14:00:14 <mwhahaha> #startmeeting tripleo
14:00:14 <mwhahaha> #topic agenda
14:00:14 <mwhahaha> * Review past action items
14:00:14 <mwhahaha> * One off agenda items
14:00:14 <mwhahaha> * Squad status
14:00:14 <openstack> Meeting started Tue May  1 14:00:14 2018 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:15 <mwhahaha> * Bugs & Blueprints
14:00:15 <mwhahaha> * Projects releases or stable backports
14:00:16 <mwhahaha> * Specs
14:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:16 <mwhahaha> * open discussion
14:00:17 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:17 <mwhahaha> Hi everyone! who is around today?
14:00:18 <openstack> The meeting name has been set to 'tripleo'
14:00:19 <beagles> o/
14:00:20 <d0ugal> o/
14:00:20 <dpeacock> o/
14:00:20 <EmilienM> o/
14:00:21 <fultonj> o/
14:00:26 <jpich> o/
14:00:27 <panda|rover> o/
14:01:11 <cdearborn> o/
14:01:13 <mriedem> o/ !
14:01:47 <slagle> hi
14:01:55 <owalsh> o/
14:02:10 <openstackgerrit> Matt Young proposed openstack/tripleo-quickstart master: Misc improvements to libvirt nodepool reproducer  https://review.openstack.org/565280
14:02:29 <jrist> o/
14:02:31 <mwhahaha> alright we got a few people, let's do this
14:02:33 <weshay|ruck> 0/
14:02:44 <mwhahaha> #topic review past action items
14:02:50 <jrist> (3 meetings at once...)
14:02:50 <mwhahaha> ci team, panda|ruck, quiquell|rover to investigate why fs021 is running on master if it's not properly containerized
14:02:52 <myoung> o/
14:03:09 <mwhahaha> jrist: pffft welcome to tuesday :D
14:03:20 <mwhahaha> weshay|ruck: did you folks look into fs021 -^
14:03:44 <weshay|ruck> not sure.. panda|rover do you have any updates?
14:04:02 <mwhahaha> i think we just needed to drop it from master/queens but i don't recall
14:04:14 <panda|rover> yes, we talked with the tempest team, and the action items there were to remove f21 from maste and create another fs for master
14:04:27 <panda|rover> squad* sorry
14:04:46 <panda|rover> not sure if they completed the move though
14:05:06 <mwhahaha> panda|rover: anyone in particular we should pin for a follow up next week?
14:05:21 <panda|rover> mwhahaha: arxcruz|pto or chandankumar
14:05:25 <weshay|ruck> ya
14:05:44 <mwhahaha> #action arxcruz|pto chandankumar  follow up on creating a containerized fs021 for master/queens
14:05:46 <mwhahaha> k
14:06:28 <mwhahaha> that's it on the past action items
14:06:58 <mwhahaha> #topic one off agenda items
14:06:58 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:07:11 <mwhahaha> (fultonj) split-control plane
14:07:18 <mwhahaha> #link https://review.openstack.org/#/c/523459
14:07:30 <fultonj> so the spec was revised into multiple phases for diff cycles
14:07:38 <fultonj> Can we land some ground work patches during Rocky to enable PoC?
14:07:50 <fultonj> e.g. https://review.openstack.org/#/q/topic:compute_only_stack2
14:07:53 <fultonj> ^ more like
14:08:23 <mwhahaha> as long as they don't cause any regressions it should be ok
14:08:32 <fultonj> ok, cool
14:08:39 <openstackgerrit> Chandan Kumar proposed openstack/tripleo-quickstart master: Added featureset052 for installing containerized UC  https://review.openstack.org/563879
14:08:43 <mwhahaha> i wouldn't necessarily want to land stuff past M2
14:08:52 <mwhahaha> so if we have some quick efforts we can accomplish that would be good
14:09:06 <fultonj> how is the spec itself handled then?
14:09:19 <mwhahaha> we'll need some folks to review it
14:09:22 <fultonj> e.g. if reviewers happy, would it merge for rocky as the scope of it is now limited?
14:09:31 <mwhahaha> and we can approve it if there aren't any objections we can continue
14:09:43 <fultonj> ok, cool.
14:09:50 <fultonj> reviews welcome
14:09:52 <fultonj> thanks mwhahaha
14:10:04 <mwhahaha> cool thanks
14:10:05 <mwhahaha> (myoung) CI Community Meeting starts immediately upon this meeting closing @ https://bluejeans.com/7050859455. All are welcome to ask/discuss $ciThings.  Add to agenda (or just join): https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:10:15 <mwhahaha> a reminder -^ more meetings
14:10:48 <mwhahaha> (beagles) neutron agent "side car" container patches https://review.openstack.org/#/q/topic:bug/1749209+(status:open) are reporting green and need more reviews - would like to get eyes on to approve ASAP
14:10:53 <openstackgerrit> Matt Riedemann proposed openstack/tripleo-docs master: Remove reference to Exact* filters  https://review.openstack.org/565511
14:11:08 <beagles> (thanks everyone for the reviews so far)
14:12:19 <beagles> Understandably a pervasive change but it addresses some critical issues/regressions with core neutron functionality in containerized deployments
14:13:25 <mwhahaha> beagles: cool so it seems only to be 2 remaining patches
14:13:55 <beagles> mwhahaha: actually this one https://review.openstack.org/#/c/537931/ is related as well but it isn't part of the core fix
14:14:05 <mwhahaha> ok
14:14:24 <beagles> it makes DVR work and we really need a CI job for it
14:14:40 <weshay|ruck> k.. FYI.. ( weshay ) would like to see  tripleo-ci-centos-7-scenario000-multinode-oooq-container-updates gating ci repos, and tripleo repos e.g. tripleo-common, tht, python-tripleoclient etc..  There were some attempts at this but voting was reverted
14:14:56 <weshay|ruck> thoughts on adding a voting update job?
14:14:56 <mwhahaha> it kept breaking
14:15:05 <mwhahaha> so figure out why it kept breaking, and fix that
14:15:14 <myoung> mwhahaha: re: community meeting, it's not a "have-to" we just want to make CI team available :)
14:15:17 <mwhahaha> missing ci, etc
14:15:23 <weshay|ruck> matbu broke the gate in tripleo-common I think
14:15:39 <mwhahaha> weshay|ruck: so has 000 been added to tripleo-common?
14:16:00 * weshay|ruck checks
14:16:22 <weshay|ruck> yes, as a check
14:16:39 <mwhahaha> k
14:16:46 <weshay|ruck> in check as of today it's running at 89% pass
14:16:55 <weshay|ruck> which is on par w/ the other jobs
14:16:58 <mwhahaha> so shouldn't we see that be higher?
14:17:02 <mwhahaha> k
14:17:04 <weshay|ruck> in check, no
14:17:11 <mwhahaha> so at the moment i'm not sure i want yet even more jobs
14:17:16 <weshay|ruck> all checks are at.. 89.3% pass
14:17:21 <mwhahaha> what specifically is that covering?
14:17:21 <weshay|ruck> hrm
14:17:42 <weshay|ruck> it's a first step in gating tripleo-upgrade which has no gates
14:18:04 <mwhahaha> we can just add that to tripleo-upgrades as voting
14:18:33 <weshay|ruck> mwhahaha, jistr had some good comments on that.. update/upgrade can easily be broken by tripleo-common, tht, ptc
14:18:44 <weshay|ruck> so his suggestion was to gate on ci + 3 tripleo repos
14:18:57 <trown> ya not really fair to add a gate on their repo that other repos are likely to break
14:19:05 <weshay|ruck> right
14:19:27 <weshay|ruck> which is exactly what happened last week
14:19:49 <mwhahaha> ok well lets check the status of the gates and we can see about adding it back to voting
14:20:28 <weshay|ruck> aye..
14:21:01 <mwhahaha> alright let's move on
14:21:08 <mwhahaha> #topic Squad status
14:21:08 <mwhahaha> ci
14:21:08 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:21:08 <mwhahaha> upgrade
14:21:08 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:21:08 <mwhahaha> containers
14:21:08 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:21:09 <mwhahaha> config-download
14:21:09 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-config-download-squad-status
14:21:10 <mwhahaha> integration
14:21:10 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:21:11 <mwhahaha> ui/cli
14:21:11 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:21:12 <mwhahaha> validations
14:21:12 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:21:13 <mwhahaha> networking
14:21:13 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:21:14 <mwhahaha> workflows
14:21:14 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:21:15 <mwhahaha> security
14:21:15 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-security-squad
14:24:02 <mwhahaha> any specific status items?
14:25:18 <slagle> i guess we'll stick with config-download
14:25:28 <slagle> we haven't had to revert (yet)
14:25:40 <fultonj> have docs been updated for that ?
14:25:44 <mwhahaha> any luck looking at the perf problems from the switch?
14:25:54 <EmilienM> slagle: we disabled voting on 3nodes, that's the only thing I'm aware of now.
14:26:16 <slagle> fultonj: more or less. not to say it's default now though
14:26:31 <EmilienM> perf problem with ceph was afik successfully addressed (thanks slagle & fultonj)
14:27:24 <fultonj> technically what is in the docs should still be true, for a certain input you get the same output
14:27:35 <fultonj> though the user experience is different
14:27:52 <slagle> yes, afaik ceph is better now.
14:27:57 <fultonj> people might wonder "why hasn't heat started yet" when it's just something different going on
14:28:05 <slagle> fultonj: i'm working on some further updates
14:28:15 <fultonj> slagle: i'm happy to help
14:28:40 <slagle> ok, we can connect
14:28:49 <fultonj> e.g. maybe some stuff from your blog which gives an overview should go in there
14:28:51 <fultonj> ack
14:28:59 <fultonj> there --> the docs
14:35:39 <mwhahaha> #topic bugs & blueprints
14:35:39 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/rocky-2
14:35:39 <mwhahaha> For Rocky we currently have 54 (+0) blueprints and about 668 (+12) open Launchpad bugs.  661 rocky-2, 7 rocky-3.  101 (+2) open Storyboard bugs.
14:35:39 <mwhahaha> #link https://storyboard.openstack.org/#!/project_group/76
14:38:16 <mwhahaha> there's one horizon bug that i wanted to raise
14:38:19 <mwhahaha> #link https://bugs.launchpad.net/tripleo/+bug/1767520
14:38:20 <openstack> Launchpad bug 1767520 in tripleo "Python-TroveClient causes Horizon to throw error 500" [High,Triaged]
14:38:47 <mwhahaha> we're getting a bunch of extra bits enabled from kolla
14:39:22 <mwhahaha> jrist: is there anyone looking at this one? i'm wondering if there's impacts elsewhere  on it -^
14:39:39 <jrist> short answer yes
14:39:57 <jrist> I don't know if there are impacts elsewhere
14:40:31 <mwhahaha> ok let us know if you need some help getting the kolla bits sorted
14:40:42 <mwhahaha> i think orange_julius mentioned cloudkitty and some other ones were being enabled as well
14:41:06 <mwhahaha> anyway, any other bugs?
14:42:29 <mwhahaha> sounds like nope
14:42:30 <mwhahaha> #topic projects releases or stable backports
14:42:48 <EmilienM> we did stable release last week
14:42:58 <EmilienM> we were talking about Newton EOL with mwhahaha  lately
14:43:09 <EmilienM> it'll probably happy during May? any thoughts on this?
14:43:23 <mwhahaha> s/happy/happen?
14:43:33 <mwhahaha> someone's a bit happy to get rid of it :D
14:43:51 <mwhahaha> is there any need to keep it open for ffu bits or are we good?
14:45:06 <mwhahaha> guess we'll want to follow up on the ml
14:45:32 <mwhahaha> as a reminder M2 is in about 5 weeks
14:45:35 <mwhahaha> so get your features landed
14:45:36 <EmilienM> it's my 7am english sorry :D
14:45:50 <mwhahaha> #topic specs
14:45:50 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:46:15 <mwhahaha> as previously talked about there is a spec for the split control plane
14:46:21 <mwhahaha> please review it when you have time
14:46:36 <mwhahaha> #topic open discussion
14:46:44 <mwhahaha> anything else?
14:48:11 <mwhahaha> sounds like nope
14:48:15 <mwhahaha> thanks everyone
14:48:17 <mwhahaha> #endmeeting