14:00:35 <mwhahaha> #startmeeting tripleo
14:00:35 <openstack> Meeting started Tue May 8 14:00:35 2018 UTC and is due to finish in 60 minutes. The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:35 <mwhahaha> #topic agenda
14:00:35 <mwhahaha> * Review past action items
14:00:35 <mwhahaha> * One off agenda items
14:00:35 <mwhahaha> * Squad status
14:00:36 <mwhahaha> * Bugs & Blueprints
14:00:36 <mwhahaha> * Projects releases or stable backports
14:00:37 <mwhahaha> * Specs
14:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:37 <mwhahaha> * open discussion
14:00:38 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:38 <mwhahaha> Hi everyone! who is around today?
14:00:39 <openstack> The meeting name has been set to 'tripleo'
14:01:00 <jpich> o/
14:01:12 <beagles> o/
14:01:13 <mwhahaha> massive turnout today :D
14:01:19 <florianf> o/
14:01:22 <marios> o/
14:01:22 <owalsh> o/
14:01:22 <jfrancoa> o/
14:01:29 <jaosorior> o/
14:02:43 <holser__> o/
14:02:53 <slagle> hi
14:02:56 <beagles> :)
14:03:12 <mwhahaha> alright let's get moving
14:03:15 <d0ugal> i/
14:03:24 <d0ugal> ahem, o/
14:03:34 <mwhahaha> #topic review past action items
14:03:34 <mwhahaha> arxcruz|pto chandankumar follow up on creating a containerized fs021 for master/queens
14:03:53 <mwhahaha> arxcruz, chandankumar: did you guys take a look at fs021 for master
14:04:19 <ccamacho> ..
14:04:35 <openstackgerrit> Florian Fuchs proposed openstack/tripleo-validations master: Fix node health validation with inventory changes https://review.openstack.org/566900
14:05:29 <jfrancoa> ccamacho: o/
14:05:48 <ccamacho> Now I can read you all o/
14:05:49 <ccamacho> :)
14:05:55 <ccamacho> thanks jfrancoa
14:06:30 <mwhahaha> i'll have to follow up with them later i guess
14:06:38 <mwhahaha> #topic one off agenda items
14:06:38 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:06:47 <mwhahaha> Just curious how moving to storyboard is going, should other squads start to consider moving to it yet? (wes)
14:07:00 <mwhahaha> weshay: is the cix tooling storyboard friendly?
14:07:03 <rasca> o/
14:07:22 <weshay> mwhahaha, not yet
14:07:24 <weshay> but can be
14:07:30 <arxcruz> mwhahaha: if i recall correct, this was moved to fs027
14:07:36 <mwhahaha> arxcruz: ok thanks
14:08:01 <mwhahaha> weshay: i'm half tempted to just cut everything over to storyboard rather than slowly doing a cut over with extended duplication
14:08:25 <weshay> mwhahaha, ok.. I can focus on that a bit today
14:08:32 <mwhahaha> weshay: can you make sure our alert bot & notification bits work with storyboard
14:08:40 <abishop> o/
14:08:42 <jpich> Having two trackers and remembering where to put what is a bit painful alright
14:08:42 <weshay> mwhahaha, are folks using it as a replacement for lp and trello?
14:08:47 <weshay> or just lp
14:09:08 <mwhahaha> it should be a replacement for both, but i think we're still using trello for some stuff
14:09:14 <mwhahaha> w/o a full cutover it's hard to push it
14:09:27 <weshay> mwhahaha, ok.. thank you
14:09:30 <mwhahaha> #action weshay & co to ensure tooling is storyboard friendly
14:09:34 <ccamacho> mwhahaha wes do we have boards for tripleo?
14:09:45 <mwhahaha> not for tripleo, but some squads
14:09:49 <ccamacho> ack
14:10:07 <mwhahaha> we're tracking some of the containerized undercloud bits in trello
14:10:13 <mwhahaha> could probably get away with a storyboard
14:10:17 <mwhahaha> but we haven't cut over
14:10:50 <mwhahaha> #aschultz mwhahaha to send a note about just cutting all of tripleo over to storyboard
14:10:57 <mwhahaha> #action mwhahaha to send a note about just cutting all of tripleo over to storyboard
14:11:00 * mwhahaha brain is broke
14:11:08 <mwhahaha> alright any other one off items?
14:11:24 <jpich> yay. It takes a bit to get used to the differences but it'll probably be easier if everything is in the same place
14:11:28 <arxcruz> https://storyboard.openstack.org/#!/board/35
14:11:31 <arxcruz> mwhahaha: weshay ^ ?
14:11:43 <mwhahaha> https://storyboard.openstack.org/#!/project_group/76
14:12:36 <ccamacho> mwhahaha also, do we need to ask to belong to a specific group, like in launchpad?
14:12:43 <mwhahaha> i don't believe so
14:12:46 <weshay> ccamacho, in storyboard, we do not
14:12:47 <weshay> yet
14:13:03 <ccamacho> weshay ack thanks
14:13:15 <weshay> well.. nothing we really use.. not sure who created board/35
14:14:50 <mwhahaha> probably emilien
14:14:58 <mwhahaha> anything else?
14:16:01 <mwhahaha> alright moving on
14:16:35 <mwhahaha> #topic Squad status
14:16:35 <mwhahaha> ci
14:16:35 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:16:35 <mwhahaha> upgrade
14:16:35 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:16:36 <mwhahaha> containers
14:16:36 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:16:37 <mwhahaha> config-download
14:16:37 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-config-download-squad-status
14:16:38 <mwhahaha> integration
14:16:38 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:16:39 <mwhahaha> ui/cli
14:16:39 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:16:40 <mwhahaha> validations
14:16:40 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:16:41 <mwhahaha> networking
14:16:41 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:16:42 <mwhahaha> workflows
14:16:42 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:16:43 <mwhahaha> security
14:16:43 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-security-squad
14:17:42 <jaosorior> Nothing much going on on the security squad size; both me and lhinds have been travelling, so it's been quite slow lately.
14:17:52 <jaosorior> My patches for public TLS by default are still pending reviews https://review.openstack.org/#/q/topic:public-tls-default+status:open
14:18:14 <mwhahaha> cool thanks jaosorior
14:19:01 <openstackgerrit> Bogdan Dobrelya proposed openstack-infra/tripleo-ci master: Alter collect heat templates dir from undercloud https://review.openstack.org/566904
14:19:09 <mwhahaha> reminder m2 is in about 4 weeks
14:19:10 <openstackgerrit> Bogdan Dobrelya proposed openstack/tripleo-quickstart-extras master: Alter collect heat templates dir from undercloud https://review.openstack.org/566905
14:19:31 <mwhahaha> any other status related items?
14:19:49 <openstackgerrit> Bogdan Dobrelya proposed openstack/python-tripleoclient master: Consume deployed t-h-t from the working output dir https://review.openstack.org/565233
14:20:26 <mwhahaha> #topic bugs & blueprints
14:20:26 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/rocky-2
14:20:26 <mwhahaha> For Rocky we currently have 54 (+0) blueprints and about 685 (+17) open Launchpad bugs. 676 rocky-2, 9 rocky-3. 101 (+0) open Storyboard bugs.
14:20:26 <mwhahaha> #link https://storyboard.openstack.org/#!/project_group/76
14:20:38 <mwhahaha> so looks like bug counts are really creeping up
14:21:38 <mwhahaha> we're up about 100 bugs from the end of queens
14:22:03 <mwhahaha> http://eavesdrop.openstack.org/meetings/tripleo/2018/tripleo.2018-02-27-14.00.log.html#l-86
14:22:24 <mwhahaha> so please take some time to review open bugs and close out any that might have been addressed
14:22:25 <mwhahaha> thanks
14:22:32 <mwhahaha> #topic projects releases or stable backports
14:22:40 <ccamacho> mwhahaha I have this big but simple patch https://review.openstack.org/#/c/549841/ Im moving the templates heat version to rocky and changing the validation as we need to force some templates to support mixed versions https://review.openstack.org/#/c/549841/10/tools/yaml-validate.py this validation change should avoid those spurious templates not with the latest version.
14:22:41 <ccamacho> I tested it locally and it works, also the CI was passing all jobs, but it prune for merge conflicts.
14:23:14 <mwhahaha> k maybe we can cut that over this week
14:23:51 <mwhahaha> as previously mentioned rocky m2 is in about 4 weeks. make sure your blueprints and patches are up to date
14:24:10 <mwhahaha> we'll be targeting a soft ff around m2 so we can bug fix
14:24:25 <mwhahaha> anyone have any backport related things?
14:24:40 <ccamacho> mwhahaha for upgrades we are still backporting lot of stuff to
14:24:45 <ccamacho> stable/queens just FYI
14:25:02 <mwhahaha> ccamacho: do you guys think you'll need to backport much else to newton? we were discussing possibly EOLing it
14:25:08 <mwhahaha> for ffu
14:26:00 <holser__> mwhahaha - yeah, we still have things we need to backport to newton
14:26:08 <mwhahaha> k
14:26:16 <mwhahaha> we'll continue to hold off on it for now
14:26:21 <ccamacho> marios ^
14:26:33 <mwhahaha> do please let us know when you think you'll be at a good point to end upstream newton stuff
14:26:48 <holser__> mwhahaha - we are really close
14:26:56 <marios> mwhahaha: aware of this one currently https://review.openstack.org/562542
14:27:10 <holser__> I'll talk to marios, jistr, lbezdick to complete a list of packages
14:27:13 <mwhahaha> k
14:28:13 <mwhahaha> cool thanks folks
14:28:24 <mwhahaha> #topic specs
14:28:24 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:28:56 <mwhahaha> looks like we've got some new specs up for review
14:29:00 <mwhahaha> please take some time to review
14:29:25 <mwhahaha> #topic open discussion
14:29:27 <mwhahaha> anything else?
14:31:18 * jrist doesn't think so
14:31:59 <mwhahaha> fair enough
14:32:00 <mwhahaha> thanks everyone
14:32:02 <mwhahaha> good chat
14:32:07 <mwhahaha> #endmeeting