14:00:11 <mwhahaha> #startmeeting tripleo
14:00:11 <mwhahaha> #topic agenda
14:00:11 <mwhahaha> * Review past action items
14:00:11 <mwhahaha> * One off agenda items
14:00:11 <mwhahaha> * Squad status
14:00:12 <mwhahaha> * Bugs & Blueprints
14:00:12 <openstack> Meeting started Tue May 15 14:00:11 2018 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <mwhahaha> * Projects releases or stable backports
14:00:13 <mwhahaha> * Specs
14:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:13 <mwhahaha> * open discussion
14:00:14 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:14 <mwhahaha> Hi everyone! who is around today?
14:00:15 <openstack> The meeting name has been set to 'tripleo'
14:00:19 <EmilienM> o/
14:00:23 <dpeacock> o7
14:00:27 <florianf> o/
14:00:34 <mwhahaha> happy tuesday
14:00:43 <marios> o/
14:00:46 <dpeacock> Happy Tuesday :-)
14:00:47 <beagles> o/
14:00:48 <chem> o/
14:01:03 <jrist> o/
14:01:08 <myoung|ruck> o/
14:01:50 <matbu> o/
14:02:07 <skramaja> hello
14:02:07 <holser___> o/
14:02:19 <mwhahaha> alright let's go
14:02:27 <mwhahaha> #topic review past action items
14:02:38 <mwhahaha> mwhahaha to send a note about just cutting all of tripleo over to storyboard - DONE
14:02:38 <mwhahaha> #link http://lists.openstack.org/pipermail/openstack-dev/2018-May/130333.html
14:02:50 <mwhahaha> not a whole lot of feedback on that one
14:03:12 <mwhahaha> if there are no objections i'm going to start working with infra to do the migration of bugs to stories
14:03:42 <EmilienM> so we stop doing squad by squad?
14:03:43 <mwhahaha> but we'll need the other action item first
14:03:45 <mwhahaha> yea
14:03:55 <EmilienM> hmm ok
14:04:03 <mwhahaha> it's not beneficial to do it that way because it doubles work
14:04:14 <mwhahaha> and it a pain trying to figure out how to wedge the squad bugs into storyboard
14:04:22 <openstackgerrit> Carlos Goncalves proposed openstack/tripleo-common master: Install Octavia amphora image if Red Hat  https://review.openstack.org/566913
14:04:46 <EmilienM> so we'll have "one" project in SB, 'tripleo' for all repos?
14:05:03 <mwhahaha> it's likely that we'll use either THT or tripleo-common
14:05:05 <mwhahaha> but yea
14:05:07 <cgoncalves> beagles, shardy, bogdando: https://review.openstack.org/#/c/566913/
14:05:12 <mwhahaha> we'll need to figure that out with the infra folks
14:06:01 <mwhahaha> anyway the other action item which is along those lines
14:06:02 <mwhahaha> weshay & co to ensure tooling is storyboard friendly
14:06:26 <weshay> 0/
14:06:26 <mwhahaha> weshay, myoung|ruck: i know ci is/was on fire, did you get a chance to look at using storyboard as the source for the CIX scripts and bots?
14:06:36 <weshay> I wish
14:06:37 <EmilienM> before the tooling we need to get humans familiar with it :D
14:06:48 <myoung|ruck> mwhahaha: what weshay said
14:06:58 <EmilienM> I'm not sure 5% of us know the syntax in commit message to close a bug (or a task/story)
14:07:16 <mwhahaha> it's been mailed out, but we can send a note
14:07:29 <Tengu> would be great for new comers :).
14:07:30 <mwhahaha> it's not that complex
14:07:42 <Tengu> either send a note, or point a wiki link
14:07:45 <mwhahaha> Story: or Task: instead of Closes-Bug:
14:07:53 <myoung|ruck> Has a quickstart / show-n-tell already been recorded?
14:07:58 <jtomasek> o/
14:08:02 <myoung|ruck> (for sb)
14:08:06 <mwhahaha> either way that's on folks need to take it upon themselves to look
14:08:06 <owalsh> o/
14:08:11 <mwhahaha> we can't force people to read
14:08:56 <Tengu> just don't forget to update https://docs.openstack.org/infra/manual/developers.html#development-workflow  - I always refer to it in case of doubt :)
14:08:58 <openstackgerrit> Harald Jensås proposed openstack/tripleo-specs master: blueprint tripleo-routed-networks-templates  https://review.openstack.org/451584
14:09:10 <Tengu> and it's already updated. so all's good
14:09:49 <mwhahaha> weshay: ok any chance on getting some eyes on the storyboard bits this week?
14:10:13 <mwhahaha> trying to nail down some dates so we can push a bit on this
14:10:24 <weshay> will try
14:10:33 <openstackgerrit> Harald Jensås proposed openstack/tripleo-specs master: blueprint tripleo-routed-networks-templates  https://review.openstack.org/451584
14:10:41 <mwhahaha> k
14:11:22 <mwhahaha> moving on
14:11:25 <mwhahaha> #topic one off agenda items
14:11:25 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:11:45 <mwhahaha> FYI open for discussion, debate other ideas regarding preflighting CentOS updates to our CI jobs
14:11:49 <mwhahaha> not sure who added that topic
14:12:00 <mwhahaha> weshay: was that you?
14:12:07 <weshay> yes
14:12:20 <weshay> so to describe this a bit
14:13:01 <weshay> I think we can have a periodic job that runs once or twice a week.. w/ the cr centos repo continuous delivery rpms that move to base
14:13:32 <bogdando> sounds like a perfect plan
14:13:43 <weshay> two jobs or so that consume that repo w/o image and container rebuild.. and a couple jobs that run after the image and containers have been rebuilt w/ the cr repo
14:13:53 <openstackgerrit> Jiri Tomasek proposed openstack/tripleo-ui master: Run undeploy_plan workflow to delete deployment  https://review.openstack.org/566366
14:13:59 <weshay> so .. I think we'd get the before and after promotion picture w/ regards to base updates
14:14:00 <EmilienM> that + humans actually watching and pro-active on this job, which means we need a process of regular surveillance for this job
14:14:06 <weshay> ya
14:14:32 <myoung|ruck> it's a (good) canary, but doesn't stop the train...so ya active monitoring
14:14:34 <EmilienM> something we check every week in our weekly meeting or in CI call or anything regular really
14:15:28 <EmilienM> stupid question: so there is a centos repo that offers cd rpms?
14:16:07 <dprince> EmilienM: testing?
14:16:22 <dprince> EmilienM: if we enabled the testing repos it might get some coverage there...
14:16:35 <weshay> EmilienM, yes.. I think I pasted into the agenda
14:16:59 <weshay> https://wiki.centos.org/AdditionalResources/Repositories/CR
14:17:18 <EmilienM> ah cool, til
14:17:53 <EmilienM> so yeah, maybe a periodic multinode + a periodic ovb might do the job
14:19:27 <mwhahaha> ok sounds like there isn't any general objection
14:19:36 <mwhahaha> weshay: is this going on the backlog for the CI squad?
14:19:43 <bogdando> even a single node undercloud deploy could prolly show if any update issues
14:20:10 <bogdando> why waste CI resources for more nodes?
14:20:37 <mwhahaha> if it's a periodic it's beneficial to get see the ovb problems
14:20:44 <bogdando> ok makes sense
14:20:56 <mwhahaha> since that's a more complete test
14:21:34 <EmilienM> the good news is we're not in hurry before next centos major upgrade
14:21:35 <mwhahaha> alright anything else on this topic?
14:21:41 <myoung|ruck> mwhahaha: bogdando: will capture this as a backlog item.  Will design / discuss / prioritize / crush with PM/UA/TC per process
14:22:03 <mwhahaha> plz make sure to also circulate plans on the ML so we can get infra input as well
14:22:13 <myoung|ruck> mwhahaha: ack and indeed.
14:22:23 <mwhahaha> cool moving on
14:22:26 <mwhahaha> Deep dive about containerized undercloud! WANTED
14:22:31 <mwhahaha> not sure who added that one either
14:22:39 <mwhahaha> put your name on things people :D
14:22:45 <bogdando> some one who wants to run it?
14:22:45 <EmilienM> yes, we should make it I agree
14:22:50 <EmilienM> when I get my voice back I can run it
14:23:07 <dprince> mwhahaha: when is the deep dive?
14:23:13 <EmilienM> there is no deep dive
14:23:20 <EmilienM> but it seems people are asking for it
14:23:30 <dprince> I can help run it
14:23:37 <dprince> if it helps
14:23:41 <EmilienM> awesome, yeah
14:23:54 <mwhahaha> #action dprince, EmilienM plan a containerized undercloud deep dive
14:23:56 <mwhahaha> tag your it
14:24:10 <dprince> mwhahaha: perhaps lets wait a week or so after summit though
14:24:15 <mwhahaha> indeed
14:24:18 <EmilienM> yes ^
14:24:38 <mwhahaha> the action item is just a plan :D so if the plan doesn't start for 3 weeks, that's fine
14:25:15 <mwhahaha> alright we'll get that going in the next few weeks
14:25:22 <mwhahaha> any other questions/issues around this?
14:27:07 <mwhahaha> ok moving on
14:27:09 <mwhahaha> CI Community Meeting starts immediately upon this meeting closing. All are welcome, Add to agenda (or just join), https://bluejeans.com/7050859455, https://etherpad.openstack.org/p/tripleo-ci-squad-meeting @L28
14:27:25 <mwhahaha> yes, ci meeting after this one. feel free to join and discuss issues
14:27:44 <mwhahaha> any questions?
14:27:54 <myoung|ruck> we don't bite
14:28:04 <mwhahaha> a likely story
14:29:45 <mwhahaha> ok moving on
14:29:51 <mwhahaha> #topic Squad status
14:29:51 <mwhahaha> ci
14:29:51 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:29:51 <mwhahaha> upgrade
14:29:51 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:29:52 <mwhahaha> containers
14:29:52 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:29:53 <mwhahaha> config-download
14:29:53 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-config-download-squad-status
14:29:54 <mwhahaha> integration
14:29:54 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:29:55 <mwhahaha> ui/cli
14:29:55 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:29:56 <mwhahaha> validations
14:29:56 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:29:57 <mwhahaha> networking
14:29:57 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:29:58 <mwhahaha> workflows
14:29:58 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:29:59 <mwhahaha> security
14:29:59 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-security-squad
14:30:06 <jrist> will update ours shortly
14:31:30 <mwhahaha> any status related items for discussion?
14:31:30 <EmilienM> ditto
14:31:43 <mwhahaha> looks like most are up to date
14:32:34 <openstackgerrit> Doug Szumski proposed openstack/diskimage-builder master: Remove duplicate GRUB command line entry  https://review.openstack.org/568600
14:33:41 <Tengu> hmm. I think I have some sound issue with bluejeans -.-
14:34:04 <mwhahaha> ok moving on
14:34:08 <Tengu> ahh
14:34:09 <mwhahaha> #topic bugs & blueprints
14:34:10 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/rocky-2
14:34:10 <mwhahaha> For Rocky we currently have 55 (+1) blueprints and about 705 (+20) open Launchpad bugs.  694 rocky-2, 11 rocky-3.  101 (+0) open Storyboard bugs.
14:34:10 <mwhahaha> #link https://storyboard.openstack.org/#!/project_group/76
14:34:30 <mwhahaha> so we've had two large increases in the bug count for the last two weeks +17 and +20
14:34:30 <EmilienM> I wanted to rise https://bugs.launchpad.net/tripleo/+bug/1771171
14:34:31 <openstack> Launchpad bug 1771171 in tripleo "ansible 2.5 takes internal role_name var seriously" [Critical,In progress] - Assigned to Emilien Macchi (emilienm)
14:34:45 <EmilienM> I'm working on it: https://review.openstack.org/#/q/topic:bug/1771171
14:35:00 <EmilienM> not sure if it's just my patches but multinode jobs are quite unstable
14:35:43 <mwhahaha> i don't think it's just your job, i think we have issues with pacemaker with the 7.5 bits
14:37:22 <mwhahaha> also looked like some container download issues
14:37:25 <mwhahaha> any other bugs?
14:37:35 <openstackgerrit> Alex Schultz proposed openstack/tripleo-common master: (cleanup) remove usage of role_name  https://review.openstack.org/568347
14:38:07 <EmilienM> just a note
14:38:23 <EmilienM> if we merge https://review.openstack.org/568443 we really need to land https://review.openstack.org/568340 at the same time
14:38:29 <EmilienM> or gate will break
14:39:22 <mwhahaha> sounds like we need to line those up carefully
14:40:03 <EmilienM> yeah, I'll sync the merges
14:40:40 <mwhahaha> alright anything else?
14:41:47 <mwhahaha> #topic projects releases or stable backports
14:42:07 <mwhahaha> EmilienM: so it was mentioned last week that we should do a tripleoclient release at some point
14:42:39 <mwhahaha> should we do it after the role name stuff lands or can we just do it now
14:44:20 <openstackgerrit> Brent Eagles proposed openstack/tripleo-heat-templates stable/queens: Add compute node L3 agent container for DVR  https://review.openstack.org/568602
14:44:47 <EmilienM> mwhahaha: yes I planned to do it after this role_name thing
14:44:50 <mwhahaha> k
14:45:01 <EmilienM> #action EmilienM to release tripleoclient after role_name bug is fixed
14:45:11 <mwhahaha> also as a reminder M2 is in ~3 weeks
14:45:44 <mwhahaha> moving on
14:45:49 <mwhahaha> #topic specs
14:45:49 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:45:53 <openstackgerrit> Steven Hardy proposed openstack/tripleo-heat-templates master: Decouple OpenShiftGlusterDisks from openshift-master.yaml  https://review.openstack.org/568603
14:46:11 <mwhahaha> we've got a handful of open specs
14:46:16 <mwhahaha> please take some time to review them
14:46:32 <mwhahaha> i'll be merging any with appropriate +2s at the end of the week if there are no objections
14:46:45 <mwhahaha> #topic open discussion
14:46:46 <mwhahaha> anything else?
14:49:26 <openstackgerrit> Merged openstack/python-tripleoclient master: Consume deployed t-h-t from the working output dir  https://review.openstack.org/565233
14:49:27 <openstackgerrit> Merged openstack/python-tripleoclient master: Use predictable name for generated hiera overrides  https://review.openstack.org/566333
14:49:29 <openstackgerrit> Merged openstack/tripleo-upgrade master: Call L3 checks before/after Role upgrade.  https://review.openstack.org/566249
14:49:30 <openstackgerrit> Merged openstack/tripleo-validations master: Add documentation links to README  https://review.openstack.org/568226
14:49:37 <openstackgerrit> Marios Andreou proposed openstack/python-tripleoclient stable/queens: Add .deployment.v1.deploy_on_servers to ffwd-upgrade prepare  https://review.openstack.org/568604
14:49:37 <mwhahaha> sounds like nope
14:49:41 <mwhahaha> thanks everyone
14:49:43 <mwhahaha> #endmeeting