14:00:43 <EmilienM> #startmeeting tripleo
14:00:44 <openstack> Meeting started Tue Jul 17 14:00:43 2018 UTC and is due to finish in 60 minutes.  The chair is EmilienM. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:48 <openstack> The meeting name has been set to 'tripleo'
14:00:51 <EmilienM> #topic agenda
14:00:53 <EmilienM> * Review past action items
14:00:56 <EmilienM> * One off agenda items
14:00:58 <EmilienM> * Squad status
14:00:59 <EmilienM> * Bugs & Blueprints
14:01:01 <EmilienM> * Projects releases or stable backports
14:01:03 <EmilienM> * Specs
14:01:05 <EmilienM> * Open discussion
14:01:08 <EmilienM> hello folks!
14:01:09 <EmilienM> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:11 <Tengu> «o/
14:01:13 <trown> o/
14:01:14 <fultonj> o/
14:01:14 <shardy_> o/
14:01:15 <rasca> o/
14:01:17 <ksambor> o/
14:01:22 <weshay> 0/
14:01:25 <marios> o/
14:01:25 <bogdando> o/
14:01:26 <holser_> o/
14:01:27 <quiquell> o/
14:01:34 <chem> o/
14:01:53 <EmilienM> oh what a nice crowd here :-)
14:01:55 <EmilienM> #topic review past action items
14:02:04 <EmilienM> mwhahaha to review current open blueprints for progress: DONE
14:02:19 <myoung> o/
14:02:21 <EmilienM> #topic one off agenda items
14:02:27 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:02:31 <EmilienM> feel free to propose topics
14:02:39 <florianf> o/
14:02:40 <dpeacock> o/
14:02:44 <EmilienM> On my side, I just wanted to remind folks about this etherpad: https://etherpad.openstack.org/p/tripleoci-ptg-stein
14:02:58 <beagles> o/
14:03:04 <EmilienM> weshay: maybe we could rename it to tripleo-ptg-stein, no?
14:03:17 <EmilienM> make it one etherpad would be easier, if you're ok with it
14:03:18 <rfolco> o/
14:03:20 <weshay> EmilienM, what ever you want man
14:03:22 <weshay> don't care
14:03:32 <EmilienM> ok I'll rename it
14:03:38 <ccamacho> heeello!
14:03:39 <jtomasek> o/
14:03:43 <Tengu> I'm working on validations, precisely on undercloud pre-deploy validations, and would require some interest on https://review.openstack.org/#/c/582917/ as a first step - more validations will come, and there's also an RFE for a good validation "framework".
14:03:45 <EmilienM> Tengu: go ahead, I think you had a topic
14:03:56 <Tengu> EmilienM: yep :). Took time to write.
14:04:17 <Tengu> so, basically, there are multiple things in the pipe: first, add a simple support in order to run ansible playbooks from the tripleoclient
14:04:19 <ccamacho> Tengu++ I have something similar but for pre-upgrade validations
14:04:30 <Tengu> second, use the validations from tripleo-validations
14:04:54 <Tengu> and do a thing allowing to run validations outside of the deploy context.
14:05:10 <Tengu> something like `openstack validators ......' - there's an opened RFE
14:05:14 <jrist> o/
14:05:17 <EmilienM> it sounds like a appealing topic and a bunch of folks already investigated, I hope we can work together :)
14:05:22 <Tengu> #link https://bugzilla.redhat.com/show_bug.cgi?id=1601739
14:05:22 <openstack> bugzilla.redhat.com bug 1601739 in python-tripleoclient "[RFE] Support listing and launching validators from the client, same as from the GUI" [High,New] - Assigned to rhos-maint
14:05:35 <Tengu> and as well as thread on the openstack-dev ML
14:06:01 <Tengu> #link http://lists.openstack.org/pipermail/openstack-dev/2018-July/132263.html
14:06:24 <Tengu> so any comment, feedback, idea... please, feel free :)
14:06:29 <chem> Tengu: ccamacho this is something which would be definitively useful for upgrade
14:06:41 <chem> Tengu: looking into it
14:06:47 <Tengu> chem: yep, there were a dedicated thread on another ML for that same topic.
14:06:57 <EmilienM> it seems to me a tripleo-specs would be useful here
14:06:59 <Tengu> chem: I jumped in it and pointed the said RFE and public ML :).
14:07:17 <Tengu> EmilienM: I can provide a first draft for that RFE, hitting Stein.
14:07:21 <EmilienM> to talk design between folks involved/interested by this effort
14:07:21 <Tengu> as well as the BP.
14:07:27 <EmilienM> Tengu: ++ awesome
14:07:41 <Tengu> #action Tengu to open a spec + BP for validation framework
14:07:47 <EmilienM> Tengu: thank you
14:07:48 <Tengu> guess I did it right :)
14:08:07 <EmilienM> if you're done, mic is on myoung :)
14:08:13 <Tengu> done :)
14:08:38 <myoung> CI Community Meeting starts immediately upon this meeting closing @ https://bluejeans.com/7050859455. All are welcome, ask/discuss anything. https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:08:51 <florianf> Tengu: One point we should probably address is how to make a good distinction between validations that need the tripleo inventory and ones that can just run with a simple local hosts file
14:09:20 <EmilienM> myoung: thanks for sharing this info.
14:09:20 <Tengu> florianf: sure thing. Please point that either in the RFE or in the ML - and we will keep that in mind in the spec.
14:09:26 <florianf> Tengu: absolutely
14:09:36 * EmilienM moving on
14:09:38 <EmilienM> #topic Squad status
14:09:44 <EmilienM> ci
14:09:46 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:09:48 <EmilienM> upgrade
14:09:50 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:09:52 <EmilienM> containers
14:09:55 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:09:56 <EmilienM> config-download
14:09:58 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-config-download-squad-status
14:10:00 <EmilienM> integration
14:10:02 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:10:04 <EmilienM> ui/cli
14:10:06 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:10:08 <EmilienM> validations
14:10:10 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:10:12 <EmilienM> networking
14:10:14 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:10:16 <EmilienM> workflows
14:10:18 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:19 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1773325
14:10:19 <openstack> Launchpad bug 1773325 in tripleo "tempest.api.object_storage.test_object_services is failing on scenario002" [Critical,Triaged] - Assigned to Arx Cruz (arxcruz)
14:10:19 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:10:20 <EmilienM> security
14:10:22 <EmilienM> #link https://etherpad.openstack.org/p/tripleo-security-squad
14:10:24 <EmilienM> please take some time to update the etherpads, I'll send a weekly owl today (after a month break)
14:10:26 <EmilienM> i know you're all waiting for the weekly owl fact... sorry for that :P
14:10:33 <EmilienM> do we have any outstanding updates from the squads?
14:10:58 <EmilienM> I have one actually, the container squad is pleased to announce that undercloud is now containerized by default, let me know any problem
14:11:04 <shardy_> nice
14:11:18 <EmilienM> it was a large team effort, thanks everyone who was involved
14:11:28 <shardy_> for integrations (openshift/ceph) I need some reviews on https://review.openstack.org/#/q/status:open+topic:alternate_plans please
14:11:41 <shardy_> it's a first step to decouple plan management for different applications
14:12:01 <EmilienM> #action team to help on reviewing https://review.openstack.org/#/q/status:open+topic:alternate_plans
14:12:19 <shardy_> thanks!
14:12:43 <EmilienM> shardy_: sounds really nice, so we could have a plan to deploy openstack , another one for ceph, another one for openshift, etc?
14:12:56 <openstackgerrit> Carlos Camacho proposed openstack/python-tripleoclient master: Integrate the pre-upgrade and post-upgrade validations in upgrades CLI  https://review.openstack.org/582088
14:13:04 <shardy_> EmilienM: exactly - that t-h-t patch is the pattern to enable that
14:13:18 <EmilienM> awesome
14:13:23 <shardy_> I'll add a CLI to select a specific plan-samples/foo, the workflow to enable that already landed
14:13:26 <EmilienM> shardy_: are we targeting Rocky?
14:13:39 <shardy_> EmilienM: yes I hope so as it's been under review for a while
14:13:46 <EmilienM> +1 to make it for Rocky, indeed
14:14:00 <EmilienM> do we have any other updates from squads?
14:14:27 <EmilienM> alright, moving on!
14:14:29 <EmilienM> #topic bugs & blueprints
14:14:34 <EmilienM> #link https://launchpad.net/tripleo/+milestone/rocky-3
14:14:35 <EmilienM> #link https://storyboard.openstack.org/#!/project_group/76
14:14:41 <EmilienM> so... Rocky Milestone 3 is next week (I know...)
14:14:54 <EmilienM> which means we'll cut the milestone 3 tag by the end of next week
14:15:05 <EmilienM> in theory, after this tag we're not supposed to land any feature code in tripleo
14:15:13 <EmilienM> unless there is FFE granted by the PTL+team
14:15:29 <EmilienM> ask for FFE in the ML, please, if you feel like your feature won't make it on time
14:15:48 <EmilienM> after milestone 3, we're in RC mode (release candidate), so bugfix + stabilization
14:15:58 <EmilienM> if any question or feedback please go ahead
14:16:04 <openstackgerrit> Carlos Camacho proposed openstack/python-tripleoclient master: Integrate the pre-upgrade and post-upgrade validations in upgrades CLI  https://review.openstack.org/582088
14:16:19 <EmilienM> we currently have one outstanding bug (in alert): https://bugs.launchpad.net/tripleo/+bug/1773325 and it seems like arxcruz got it under control
14:16:19 <openstack> Launchpad bug 1773325 in tripleo "tempest.api.object_storage.test_object_services is failing on scenario002" [Critical,Triaged] - Assigned to Arx Cruz (arxcruz)
14:16:33 <EmilienM> is there any other outstanding bug or blueprint that we should talk about this week?
14:16:43 <Tengu> ccamacho: hm, don't you want to wait a bit for a proper validation framework? :)
14:17:11 <EmilienM> alright moving on
14:17:12 <openstackgerrit> Carlos Camacho proposed openstack/python-tripleoclient master: Integrate the pre-upgrade and post-upgrade validations in upgrades CLI  https://review.openstack.org/582088
14:17:16 <EmilienM> #topic projects releases or stable backports
14:17:33 <EmilienM> we released a stable version of ocata/pike/queens last week
14:17:47 <openstackgerrit> Dan Prince proposed openstack/ansible-role-tripleo-modify-image master: Add rpm_install tasks  https://review.openstack.org/583258
14:17:51 <EmilienM> the next one is scheduled for next week, after we successfully release rocky m3
14:17:51 <Tengu> (see you guys, have to run away)
14:18:06 <EmilienM> any question about release management?
14:18:12 <ccamacho> Tengu yeah but if we wan't to run the post-upgrade validations in the overcloud we should use Mistral, right?
14:18:17 <ccamacho> we need to call them also from the UI
14:18:26 <openstackgerrit> Bogdan Dobrelya proposed openstack/tripleo-quickstart-extras master: Unify custom t-h-t install steps for UC/OC/upgrade  https://review.openstack.org/465047
14:18:28 <EmilienM> #topic specs
14:18:33 <EmilienM> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:18:51 <ccamacho> for the Undercloud case should be only Ansible **let's wait for the meeting to finish and we can keep discussing it
14:18:56 <ccamacho> Tengu++
14:19:22 <EmilienM> #action move https://review.openstack.org/#/c/566448/ to Stein (ping ayoung)
14:19:41 <openstackgerrit> Dan Prince proposed openstack/ansible-role-tripleo-modify-image master: Add rpm_install tasks  https://review.openstack.org/583258
14:19:43 <EmilienM> bfournie: are we still targeting Rocky for https://review.openstack.org/#/c/451584/ ?
14:19:43 <marios> /win 1
14:19:49 <EmilienM> bfournie: can you check with Dan maybe?
14:20:00 <EmilienM> #action investigate if https://review.openstack.org/#/c/451584/ is for rocky or stein at this point
14:20:14 <EmilienM> #action move https://review.openstack.org/#/c/567579/ to stein
14:20:36 <EmilienM> any question about specs?
14:21:24 <EmilienM> #topic open discussion
14:21:35 <EmilienM> any question or feedback can be brought here :-)
14:22:22 <trown> quick question about standalone
14:22:36 <EmilienM> trown: shoot!
14:22:48 <trown> is it intentional we dont have masquerade rules on "undercloud" or just something we missed?
14:23:22 <trown> ie. when you launch a vm on the standalone cloud... it cant ping to the internet, because there is no way to get from br-ctlplane to the external interface
14:23:22 <EmilienM> trown: I think it's intentional, as we don't need it
14:23:28 <openstackgerrit> Steven Hardy proposed openstack/tripleo-heat-templates master: Enable decoupled deployment plans e.g for OpenShift, DPDK etc  https://review.openstack.org/574753
14:23:41 <EmilienM> trown: yeah? I'll have to reverify it, the last time I deployed I could ping internet
14:23:53 <shardy_> fultonj: ^^ Hey thanks for the review, sorry but I made a silly typo in the path which should be fixed now
14:23:55 <EmilienM> but maybe it was something in my env, I'll double check, good point trown
14:23:58 <trown> EmilienM: we need it for doing openshift stuff on top of the standalone
14:24:11 <EmilienM> oh nice
14:24:14 <openstackgerrit> Ronelle Landy proposed openstack-infra/tripleo-ci master: WIP - Add Browbeat to PROJECTS  https://review.openstack.org/583261
14:24:17 <EmilienM> ok I'll look at that today and let you know
14:24:21 <trown> EmilienM: cool, I have a workaround, just wasnt sure if I should try to put up a patch for it
14:24:31 <fultonj> shardy_: ack
14:24:31 <EmilienM> #action EmilienM investigates if standalone needs masquerade iptables rules
14:24:52 <EmilienM> anything else folks?
14:25:10 <trown> EmilienM: http://paste.openstack.org/show/726114/ is my workaround btw
14:25:21 <EmilienM> trown: ack, got it
14:25:36 <EmilienM> trown: I'll investigate and let you know by today eod
14:25:40 <trown> nice
14:25:42 <openstackgerrit> Ronelle Landy proposed openstack/tripleo-quickstart-extras master: Include minimal Browbeat playbook in baremetal playbook  https://review.openstack.org/581488
14:25:55 <EmilienM> alright, thanks everyone for your time, have a great week! (and don't miss the Weekly Owl ;-))
14:25:58 <EmilienM> #endmeeting