14:00:05 <mwhahaha> #startmeeting tripleo
14:00:05 <mwhahaha> #topic agenda
14:00:05 <mwhahaha> * Review past action items
14:00:05 <mwhahaha> * One off agenda items
14:00:05 <mwhahaha> * Squad status
14:00:05 <mwhahaha> * Bugs & Blueprints
14:00:05 <mwhahaha> * Projects releases or stable backports
14:00:06 <openstack> Meeting started Tue Jul 24 14:00:05 2018 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:06 <mwhahaha> * Specs
14:00:06 <mwhahaha> * open discussion
14:00:07 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:07 <mwhahaha> Hi everyone! who is around today?
14:00:10 <openstack> The meeting name has been set to 'tripleo'
14:00:12 <Tengu> «o/
14:00:18 <jfrancoa> \o/
14:00:20 <jrist> o/
14:00:21 <ksambor> o/
14:00:25 <openstackgerrit> Dmitry Tantsur proposed openstack/tripleo-heat-templates master: undercloud: revert to using the iscsi deploy interface by default  https://review.openstack.org/585370
14:00:26 <dtantsur> shardy: ^^^
14:00:52 <ccamacho1> hi!
14:00:56 <rasca> o/
14:00:59 <fultonj> o/
14:01:00 <slagle> hi
14:01:01 <marios> o/
14:01:02 <chem> o/
14:01:21 <panda> o/
14:01:48 <owalsh> o/
14:01:58 <shardy> o/
14:02:43 <jbadiapa> hi
14:02:55 <dpeacock> o/
14:02:57 <myoung> o/
14:03:02 <mwhahaha> lets begin
14:03:08 <mwhahaha> #topic review past action items
14:03:16 <mwhahaha> Tengu to open a spec + BP for validation framework - DONE
14:03:16 <mwhahaha> #link https://review.openstack.org/#/c/583475/
14:03:32 <Tengu> now things can start ;).
14:03:41 <mwhahaha> team to help on reviewing https://review.openstack.org/#/q/status:open+topic:alternate_plans
14:03:53 <mwhahaha> shardy: looks like you -wf that one, are we skipping that for rocky?
14:05:37 <mwhahaha> we'll have to follow up on that later
14:05:38 <mwhahaha> move https://review.openstack.org/#/c/566448/ to Stein (ping ayoung)
14:05:49 <mwhahaha> not sure if that was done, I'll follow up with EmilienM
14:05:56 <mwhahaha> investigate if https://review.openstack.org/#/c/451584/ is for rocky or stein at this point
14:06:31 <mwhahaha> so the patches for -^ were in merge conflict when i checked yesterday and commented that it'll probably need to be stein
14:08:26 <mwhahaha> move https://review.openstack.org/#/c/567579/ to stein - NOT DONE
14:08:30 <shardy> mwhahaha: There are some upgrade issues I'd not anticpated so we may have to defer it
14:08:36 <mwhahaha> shardy: ok thanks
14:08:58 <shardy> mwhahaha: I'm planning to continue working on it - the issue is we combine user and t-h-t provided things in the plan-environment.yaml
14:09:38 <shardy> but Stein may be safer at this point, given we can still deploy e.g OpenShift etc with the current t-h-t
14:09:53 <mwhahaha> yea that makes more sense given the time left
14:10:08 <mwhahaha> EmilienM investigates if standalone needs masquerade iptables rules - DONE
14:10:08 <mwhahaha> #link https://review.openstack.org/#/c/583266/
14:10:13 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:14 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1782267
14:10:14 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1783055
14:10:14 <openstack> Launchpad bug 1782267 in tripleo "Stderr: u'Set Chassis Power Control to Up/On failed: Command not supported in present state\n': ProcessExecutionError: Unexpected error while running command." [Critical,Triaged]
14:10:16 <openstack> Launchpad bug 1783055 in tripleo "[master]multinode periodic promotion jobs are failing where Tempest is run in container" [Critical,In progress] - Assigned to chandan kumar (chkumar246)
14:10:37 <mwhahaha> #topic one off agenda items
14:10:37 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:10:46 <mwhahaha> (myoung) CI Community Meeting starts immediately upon this meeting closing @ https://bluejeans.com/7050859455. All are welcome, ask/discuss anything. https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:11:16 <myoung> ^^ panda has something he would like to discuss afaik
14:11:35 <panda> yep, the next item is a proposal for the community meeting
14:11:58 <mwhahaha> (gcerami) We are trying to design the move of OVB jobs to openstack infra. We need some feedback and help for the initial ideas. We can discuss more on the community meeting.
14:12:29 <panda> moving OVB jobs to openstack-infra, I wanted to start the discussion during PTG, but we are accelerating on that, we have some proposal, and I'd like to involve people to decide fi they are doable
14:12:49 <openstackgerrit> Dmitry Tantsur proposed openstack/tripleo-heat-templates master: undercloud: revert to using the iscsi deploy interface by default  https://review.openstack.org/585370
14:13:24 <panda> some proposal will ionvolve injecting changes during overcloud deploument
14:13:58 <panda> other changes after undercloud installation
14:14:18 <panda> so, I have some question about the workflow
14:14:32 <panda> if anyone is interested in this discussion please join the community meeting
14:14:51 <mwhahaha> sounds good
14:15:14 <mwhahaha> any other items?
14:16:14 <mwhahaha> sounds like nope, moving on to status
14:16:22 <mwhahaha> #topic Squad status
14:16:22 <mwhahaha> ci
14:16:22 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:16:22 <mwhahaha> upgrade
14:16:22 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:16:22 <mwhahaha> containers
14:16:22 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:16:23 <mwhahaha> config-download
14:16:23 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-config-download-squad-status
14:16:24 <mwhahaha> integration
14:16:24 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:16:25 <mwhahaha> ui/cli
14:16:25 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:16:26 <mwhahaha> validations
14:16:26 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:16:27 <mwhahaha> networking
14:16:27 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:16:28 <mwhahaha> workflows
14:16:28 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:16:29 <mwhahaha> security
14:16:29 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-security-squad
14:17:03 <mwhahaha> anything specific folks would like to highlight?
14:17:06 <Tengu> I would love a few reviews on https://review.openstack.org/#/c/584314/ (validations)
14:17:11 <jrist> config download reviews and validations reviews needed
14:17:15 <jrist> ^
14:17:44 <mwhahaha> jrist: is there a specific topic we can just to review them?
14:17:54 <jrist> yes!
14:17:54 <Tengu> main issue is: validation team is kind of decimeted.
14:18:10 <jrist> https://review.openstack.org/#/q/topic:bp/config-download-ui+(status:open+OR+status:merged)
14:18:24 <mwhahaha> dat javascript
14:18:49 <ccamacho1> Tengo ack Ill add them to my queue
14:18:55 <ccamacho1> Tengu**
14:18:57 <Tengu> ccamacho1: thank you!
14:19:13 <mwhahaha> #action team to review outstanding UI changes for config download - https://review.openstack.org/#/q/topic:bp/config-download-ui+(status:open+OR+status:merged)
14:19:33 <Tengu> and of course, reviews and feedback are needed on https://review.openstack.org/#/c/583475/ (validation framework spec)
14:19:49 <mwhahaha> sounds good
14:20:28 <mwhahaha> anything else?
14:20:33 * dpeacock chucks https://review.openstack.org/#/c/577397/ into the hat in the hope that someone from validations can +2
14:20:40 <dpeacock> would be great to see that merge
14:20:56 <Tengu> akrivoka: -^^ :)
14:21:22 <jrist> mwhahaha: yes a few more, let me find them
14:21:47 <jrist> https://review.openstack.org/581644
14:22:07 <jrist> https://review.openstack.org/#/q/status:open+project:openstack/tripleo-validations+branch:master+topic:openshift-hw-reqs
14:23:51 <mwhahaha> ok so it sounds like we need some more eyes on validations bits
14:23:54 <mwhahaha> anyway moving on
14:24:01 <mwhahaha> #topic bugs & blueprints
14:24:01 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/rocky-3
14:24:01 <mwhahaha> For Rocky we currently have 49 (-5) blueprints and about 740 (+1) open Launchpad bugs.  735 rocky-3, 5 stein-1.  102 (+0) open Storyboard bugs.
14:24:01 <mwhahaha> #link https://storyboard.openstack.org/#!/project_group/76
14:24:09 <mwhahaha> So Rocky M3 is this week.
14:24:35 <mwhahaha> if you're blueprint isn't done and doesn't have an FFE we'll be moving them out this week
14:24:50 <mwhahaha> I sent an email about the outstanding blueprints a few weeks ago
14:25:08 <mwhahaha> #link http://lists.openstack.org/pipermail/openstack-dev/2018-July/132140.html
14:25:18 <mwhahaha> so please revisit those blueprints
14:25:36 <mwhahaha> any other bugs that folks want to highlight?
14:28:04 <ccamacho1> Tengo I also added some work items to the blueprint
14:28:16 <ccamacho1> there we can agree on the CLI commands and options
14:28:22 <Tengu> ccamacho1: yep, saw that!
14:28:38 <mwhahaha> k moving on
14:28:38 <mwhahaha> #topic projects releases or stable backports
14:28:45 <mwhahaha> so as I mentioned Rocky M3 is this week
14:28:48 <Tengu> ccamacho1: shall we discuss that tomorrow? what's your TZ? seems pretty close to CET right?
14:28:54 <mwhahaha> EmilienM will be posting the patches on Thursday
14:29:00 <mwhahaha> so anything not landed before that will not be in M3
14:29:03 <ccamacho1> CET indeed, we can sync tomorrow np
14:29:11 <mwhahaha> EmilienM informed me that he will be doing a stable release next week
14:29:18 <mwhahaha> Any questions?
14:31:10 <mwhahaha> sound like nope
14:31:13 <mwhahaha> #topic specs
14:31:13 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:31:32 <mwhahaha> I previously mentioned some specs that need review
14:31:51 <mwhahaha> please review them and take some time to make sure any open specs are properly targeted for Stein at this point
14:32:01 <mwhahaha> #topic open discussion
14:32:04 <mwhahaha> anything else?
14:32:16 <mwhahaha> rasca: i saw you were adding something to the agenda, did you have something you wanted to chat about?
14:32:34 <rasca> mwhahaha, no sorry, my mistake, wrong etherpad
14:32:46 <mwhahaha> rasca: got it
14:32:51 <mwhahaha> anyone have anything else?
14:32:53 <rasca> mwhahaha, thanks for caring
14:34:52 <openstackgerrit> Jiri Stransky proposed openstack/tripleo-common stable/pike: Use ansible_queue_name only for upgrade/update  https://review.openstack.org/585380
14:35:00 <mwhahaha> sounds like nope
14:35:27 <mwhahaha> myoung, panda i'd like to join the chat about the ovb stuff in the upstream but i'm currently in another meeting. can you hold off on that discussion in the community meeting until i can join?
14:35:44 <myoung> mwhahaha: ack, and sure.  we'll cover rasca's quesrtion first
14:35:49 <mwhahaha> sounds good
14:35:52 <mwhahaha> thanks everyone
14:35:54 <mwhahaha> #endmeeting