14:00:30 <jaosorior> #startmeeting tripleo
14:00:31 <openstack> Meeting started Tue Aug 28 14:00:30 2018 UTC and is due to finish in 60 minutes.  The chair is jaosorior. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:35 <openstack> The meeting name has been set to 'tripleo'
14:00:39 <dpeacock> o/
14:00:41 <fultonj> sri_: if you want to try bluestore https://review.openstack.org/#/c/547682/
14:00:41 <ksambor> \o
14:00:42 * mwhahaha is freeeeeeeeeeeeeeeeeeeeeee
14:00:45 * mwhahaha runs away
14:00:48 <fultonj> sri_: meeting time ttyl
14:00:50 <jaosorior> #topic agenda
14:00:51 <dpeacock> lol mwhahaha
14:00:52 <jaosorior> * Review past action items
14:00:54 <jaosorior> * One off agenda items
14:00:56 <jaosorior> * Squad status
14:00:56 <EmilienM> o/
14:00:58 <jaosorior> * Bugs & Blueprints
14:01:00 <jaosorior> * Projects releases or stable backports
14:01:02 <ccamacho> hello!! o/
14:01:02 <jaosorior> * Specs
14:01:03 <beagles> o/
14:01:04 <jaosorior> * open discussion
14:01:06 <jaosorior> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:08 <jaosorior> Hey folks! who's around?
14:01:10 <jrist> o/
14:01:12 <chem> o/
14:01:15 <fultonj> o/
14:01:16 <mwhahaha> hi2u
14:01:16 <jtomasek> o/
14:01:21 <abishop> o/
14:01:25 <jfrancoa> o/
14:01:46 <rbrady> o/
14:01:53 <florianf_> o/
14:01:53 <jaosorior> \o
14:01:56 <jaosorior> Hi everyone!
14:02:12 <jaosorior> #topic review past action items
14:02:26 <owalsh> o/
14:02:35 <jaosorior> No past action items.
14:02:49 <shardy> o/
14:02:59 <jaosorior> #topic one off agenda items
14:03:05 <rascasoft> o/
14:03:05 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:03:58 <jaosorior> So, just wanted to remind folks to fill in your topics for the PTG in the etherpad
14:04:00 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-ptg-stein
14:04:08 <jaosorior> please vote on topics you're interested in
14:04:30 <jaosorior> and by the end of the week I'll send a mail with a proposed agenda
14:04:40 <jaosorior> Sent a mail to the ML too
14:04:44 <jaosorior> #link http://lists.openstack.org/pipermail/openstack-dev/2018-August/133905.html
14:05:02 <jaosorior> That's all on that side.
14:05:27 <mwhahaha> we should group some of the proposed topics together
14:05:47 <mwhahaha> in the past we've had some categories like ci or deployment or whatever that we collect the line items together under
14:05:52 <openstackgerrit> Saravanan KR proposed openstack/tripleo-heat-templates master: Mount libs directory to remove warnings in ovs-vsctl of docker-puppet container  https://review.openstack.org/597115
14:05:56 <mwhahaha> then we can schedule the time for the PTG
14:06:05 <EmilienM> yeah
14:06:19 <mwhahaha> but definitely make sure your topics of interest are listed
14:06:20 <EmilienM> also we need to look at other projects
14:06:25 <EmilienM> e.g. mistral folks want to attend tripleo workflow related topics
14:06:28 <EmilienM> so see overlaps
14:06:32 <EmilienM> it's a nice game, tbh :D
14:06:37 <mwhahaha> i'd like to get together with the osa and kolla folks around ansible role collaboration
14:06:43 <mwhahaha> so i'm trying to figure out a time to do that
14:06:51 <mwhahaha> ptg schedule is clear as mud
14:07:16 <jaosorior> so, this year the mistral team won't be able to attend. But yeah, if there are projects to have synergies with, that would be good to consider and add to the schedule.
14:07:24 <EmilienM> yeah and usually it changes until last minute
14:07:25 <jaosorior> mwhahaha: is the ansible role collaboration already in the etherpad?
14:07:31 <mwhahaha> there is a section
14:07:36 <EmilienM> at least we should provide a list of high level topics
14:07:44 <EmilienM> and build some sort of draft agenda first
14:07:46 <EmilienM> and get feedback
14:07:48 <jaosorior> OK, there we could put up the OSA and kolla times, so we can consider it.
14:07:55 <mwhahaha> the Split Out roles (ansible)
14:08:04 <EmilienM> jaosorior: so to get people together like this, send an email to these groups
14:08:05 <mwhahaha> i put (ansible) around it this morning cause we have lots of roles :D
14:08:40 <jaosorior> EmilienM: to the OSA and kolla folks?
14:08:52 <fultonj> 3 edge sessions in https://etherpad.openstack.org/p/tripleo-ptg-stein could go in a row
14:09:49 <jaosorior> EmilienM, mwhahaha: Do we have a template or something of how it was done last time? to get a better idea.
14:10:03 <mwhahaha> https://etherpad.openstack.org/p/tripleo-ptg-rocky
14:10:09 <mwhahaha> https://etherpad.openstack.org/p/tripleo-ptg-queens
14:10:13 <mwhahaha> take your pick
14:10:17 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:19 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1786764
14:10:19 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1787910
14:10:20 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1789416
14:10:20 <openstack> Launchpad bug 1786764 in tripleo "tripleo-ci-centos-7-scenario000-multinode-oooq-container-updates times out on prepare" [Critical,Triaged] - Assigned to Sorin Sbarnea (ssbarnea)
14:10:20 <openstackgerrit> Merged openstack/puppet-tripleo stable/rocky: Conditionalize rndc changes  https://review.openstack.org/596864
14:10:21 <openstack> Launchpad bug 1787910 in tripleo "OVB overcloud deploy fails on nova placement errors" [Critical,Triaged] - Assigned to Marios Andreou (marios-b)
14:10:21 <jaosorior> mwhahaha: thanks
14:10:21 <openstackgerrit> Merged openstack/tripleo-heat-templates stable/pike: snmp: listen on ctrlplane  https://review.openstack.org/597001
14:10:22 <openstack> Launchpad bug 1789416 in tripleo "stable/queens: No image with the name 'bm-deploy-kernel' found - make sure you have uploaded boot images."" [Critical,Triaged]
14:10:39 <jaosorior> mwhahaha, EmilienM: the other option is to arrange it by squads.
14:10:40 <EmilienM> also I created Google Calendars
14:10:40 <EmilienM> I think some people liked that
14:11:16 <fultonj> +1
14:11:32 <EmilienM> I'm not sure
14:11:52 <Tengu> «o/ (sorry, was working my way with podman/selinux)
14:12:15 <EmilienM> jaosorior: I would really look at how we did the previous times
14:12:22 <jaosorior> alright
14:12:33 <EmilienM> I think it worked pretty well
14:12:33 <EmilienM> https://etherpad.openstack.org/p/tripleo-ptg-pike as well
14:13:10 <openstackgerrit> wes hayutin proposed openstack/tripleo-quickstart master: set the correct config download settings for queens  https://review.openstack.org/597141
14:13:13 <jaosorior> EmilienM: thanks for the links. I'll take a look at those and probably end up poking you and mwhahaha about it tomorrow.
14:13:24 <EmilienM> poke me anytime
14:13:40 * mwhahaha pokes EmilienM
14:14:20 * EmilienM counters-poke mwhahaha
14:14:53 <jaosorior> mwhahaha: the next topic is yours
14:15:02 <openstackgerrit> wes hayutin proposed openstack/tripleo-heat-templates stable/queens: DNM, testing config-download for queens  https://review.openstack.org/597142
14:15:05 <mwhahaha> Rocky RC2 (mwhahaha)
14:15:29 <openstackgerrit> wes hayutin proposed openstack/tripleo-heat-templates stable/queens: DNM, testing config-download for queens  https://review.openstack.org/597142
14:15:37 <mwhahaha> so we're going to do an rc2 to capture a designate fix and https://review.openstack.org/#/c/596986/
14:15:44 <mwhahaha> unfortunately it looks like rocky ci is hosed at the moment
14:15:51 <mwhahaha> something about a bad package dep when building the rpm
14:15:55 <mwhahaha> so i need to look into this
14:16:06 <mwhahaha> weshay, sshnaidm: is the CI squad tracking this?
14:16:10 <fultonj> yay rc2
14:16:20 <EmilienM> :(
14:16:47 <sshnaidm> mwhahaha, need to check, weshay ?
14:16:49 <weshay> mwhahaha, all rocky jobs are down?
14:16:59 <mwhahaha> rdo package build issues
14:17:15 <mwhahaha> Error: No Package found for python-d2to1
14:17:16 <weshay> k.. I have not seen that yet
14:17:19 <weshay> k
14:17:21 <mwhahaha> http://logs.openstack.org/86/596986/1/check/tripleo-ci-centos-7-containers-multinode/eea00da/logs/delorean_logs/41/bd/41bde521e7708cedf36c860eb717ff8d873dad16_dev/rpmbuild.log.txt.gz
14:17:30 <mwhahaha> when building THT
14:17:39 <weshay> thanks
14:18:30 <mwhahaha> hopefully we can cut RC2 this week, but it might lead into next
14:18:33 <mwhahaha> depending on this
14:18:33 <weshay> ya.. k.. ssbarnea "| set fail. Delorean FAIL. |" in sova
14:18:36 <mwhahaha> that's it
14:19:11 <jaosorior> thanks mwhahaha
14:19:23 <EmilienM> how many times delorean breaks us really
14:19:31 <EmilienM> don't we have proper gating on that?
14:19:58 <mwhahaha> delorean deps always breaks us
14:20:15 <weshay> jpena, ^
14:20:21 <weshay> incoming bugs
14:20:47 <EmilienM> we could catch that if we would run tripleo jobs in distgits
14:21:01 <weshay> mwhahaha, there are several dep issues in rocky
14:21:03 <mwhahaha> EmilienM: this isn't a change in the distgit
14:21:16 <EmilienM> probably the dep missing in rocky repo
14:21:19 <jpena> DEBUG: Error: No Package found for python-d2to1
14:21:23 <mwhahaha> EmilienM: this is the missing package in deps or something, python-d2to1 has been there for some time
14:21:31 <weshay> Error: No Package found for python2-openstackdocstheme
14:21:31 <weshay> Error: No Package found for python2-sphinx
14:21:38 <weshay> http://logs.openstack.org/52/596352/1/check/tripleo-ci-centos-7-containers-multinode/66a4351/logs/delorean_logs/fc/59/fc59f07f66a77bcf7da7e19419a7ff584bc20ab8_dev/rpmbuild.log.txt.gz
14:21:47 <EmilienM> right but we wouldn't have cut RC1 if we would have seen it
14:21:50 <EmilienM> we wouldn't have merged https://review.rdoproject.org/r/#/c/15966/ Im ean
14:22:06 <mwhahaha> EmilienM: i think it was there, i think it happened as they are preping rocky release in rdo
14:22:31 <mwhahaha> it worked yesterday (tm)
14:22:59 <weshay> jpena, do you guys have a rocky job up yet?
14:23:24 <jpena> weshay: for distgits? Sure
14:23:30 <jpena> also for rdoinfo
14:23:49 <weshay> jpena, um.. point me at the rocky one for rdoinfo
14:24:42 <weshay> jpena, I don't see rocky in the list of jobs https://review.rdoproject.org/r/#/c/15620/
14:25:10 <weshay> ocata, pike, master are present
14:25:19 <jpena> weshay: ah, I see what you mean
14:26:15 <weshay> ssbarnea, ^
14:26:32 <jpena> weshay: for example, https://logs.rdoproject.org/12/15912/6/check/legacy-weirdo-validate-buildsys-tags/83c756d/job-output.txt.gz for https://review.rdoproject.org/r/#/c/15912/
14:26:34 <ssbarnea> reading...
14:26:37 <jpena> but that only includes weirdo jobs
14:26:47 <weshay> ya
14:26:55 <weshay> doesn't count :)
14:27:06 <weshay> jpena, let's get some standalone jobs running :)
14:27:13 <mwhahaha> anyway we'r emissing some deps (python-d2to1) and others
14:27:20 <mwhahaha> hopefully let's get those added back into rocky asap
14:27:43 <jaosorior> Alright, I'll bring up the next topic.
14:27:45 <mwhahaha> t-p-e also fails to build because of d2to1 http://logs.openstack.org/20/597120/1/check/tripleo-ci-centos-7-containers-multinode/ed195f6/logs/delorean_logs/df/22/df22be170eb8f722e9bb2c6f30060e034f1a4e4c_dev/rpmbuild.log.txt.gz
14:28:48 <sri_> fultonj, I will look into it, Thanks :)
14:28:53 <jaosorior> #topic Squad status
14:29:04 <jaosorior> ci
14:29:06 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:29:08 <jaosorior> upgrade
14:29:10 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:29:12 <jaosorior> containers
14:29:14 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:29:16 <jaosorior> config-download
14:29:18 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-config-download-squad-status
14:29:20 <jaosorior> integration
14:29:22 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:29:24 <jaosorior> ui/cli
14:29:26 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:29:28 <jaosorior> validations
14:29:30 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:29:32 <jaosorior> networking
14:29:34 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:29:36 <jaosorior> workflows
14:29:38 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:29:40 <jaosorior> security
14:29:42 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-security-squad
14:29:44 <jaosorior> Any squad wanting to bring up their status?
14:29:52 <mwhahaha> jaosorior: btw we dropped contig-download
14:30:03 <mwhahaha> jaosorior: and added an edge
14:30:05 <jaosorior> oh, right, and the edge squad was created
14:30:06 <mwhahaha> edge
14:30:06 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:30:07 <jaosorior> yeah
14:30:15 <jaosorior> thanks
14:30:27 <slagle> i was going to ask...where are you copying/pasting these links from?
14:30:33 <slagle> and i'll update it
14:30:45 <mwhahaha> i updated mine last week, but forgot jaosorior was talking over
14:30:57 <mwhahaha> the ptl magic .txt file :D
14:30:59 <jaosorior> slagle: updated my list now.
14:31:29 <slagle> might be nice to use the wiki for that
14:31:36 <slagle> https://wiki.openstack.org/wiki/Meetings/TripleO
14:31:44 <slagle> since that is the firt thing new comers will find
14:31:46 <slagle> first
14:31:51 <mwhahaha> too bad teh upstream wiki has been deprecated for multiple cycles
14:32:17 <slagle> it can still be updated
14:32:33 <mwhahaha> it'd probably be better to stick in tripleo-docs
14:32:40 <mwhahaha> anyway
14:32:43 <slagle> yes
14:32:47 <slagle> and then update the wiki to refer to that
14:32:59 <slagle> so that it can actually be found by humans
14:33:02 <jaosorior> Alright, I can do that
14:33:07 <jaosorior> I'll update the wiki and the docs
14:33:15 <jaosorior> #action jaosorior to update the wiki and tripleo docs to refer to the squads and their respective etherpads
14:33:27 * weshay deprecates humans
14:33:42 <Tengu> weshay: well, humans do that themselves pretty nicely already
14:33:54 * mwhahaha replaces weshay with a tiny python3 script
14:34:09 <Tengu> pyHay?
14:34:21 <weshay> lol
14:35:47 <jaosorior> #topic bugs & blueprints
14:35:48 <jaosorior> #link https://launchpad.net/tripleo/+milestone/rocky-rc2
14:35:50 <jaosorior> #link https://launchpad.net/tripleo/+milestone/stein-1
14:35:52 <jaosorior> For Rocky we currently have 1 blueprints and about 13 open Launchpad bugs. For Stein we currently have 29 blueprints open in Launchpad. Bugs: 13 rocky-rc1, 714 stein-1.  106 (-2) open Storyboard bugs.
14:35:54 <jaosorior> #link https://storyboard.openstack.org/#!/project_group/76
14:36:19 <jaosorior> Please note we are now in the RC phase so we should be working on fixing bugs
14:37:35 <weshay> FYI.. tripleo-ci community immedidately following this mtg
14:37:42 <weshay> community mtg
14:38:25 <jaosorior> #topic projects releases or stable backports
14:38:40 <mwhahaha> so as previously mentioned we're trying to do an RC2 this week
14:39:01 <mwhahaha> depending on CI and when we can land https://review.openstack.org/#/c/596986/
14:40:31 <jaosorior> #topic specs
14:40:32 <jaosorior> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:41:07 <jaosorior> With the PTG coming, please submit any specs you want to discuss over there.
14:42:04 <jaosorior> Also, please review
14:43:04 <weshay> toure, ping
14:43:14 <weshay> toure, can you join https://bluejeans.com/7050859455/
14:43:18 <weshay> for a minute
14:43:54 <weshay> EmilienM, talking about ara now
14:43:58 <jaosorior> #topic open discussion
14:44:11 <jaosorior> Anything else folks want to bring up to the meeting?
14:44:53 <florianf> I'd like to kindly ask for some review we've listed in out squad etherpad. Especially the custom validations feature that has been hanging around for a while: https://review.openstack.org/#/c/569513/
14:45:01 <ccamacho> if people have some free cycles, please reviews for https://review.openstack.org/#/c/596678/ and https://review.openstack.org/#/c/596678/ :)
14:45:13 <ccamacho> gigathanks!
14:45:37 <toure> weshay sure
14:45:46 <florianf> It's a tripleo-common patch, so we validations cores have no power there ;)
14:46:03 <florianf> greatly appreciated
14:46:06 <Tengu> if some people interested in validations could have a look here: https://review.openstack.org/589169   :)
14:47:21 <jaosorior> florianf: added to my review queue. Tengu could you also check out https://review.openstack.org/#/c/569513/ ?
14:47:40 <Tengu> cant +2 but will check.
14:48:02 <Tengu> will check that tomorrow - have to flee once this mtg is over.
14:48:03 <florianf> jaosorior: thanks a ton!
14:48:32 <florianf> Tengu: thank you! Will add another review to the spec as well
14:48:36 <Tengu> :)
14:49:50 <jaosorior> Alright folks! thanks for joining.
14:49:52 <jaosorior> #endmeeting