14:00:41 <jaosorior> #startmeeting tripleo
14:00:42 <openstack> Meeting started Tue Sep 25 14:00:41 2018 UTC and is due to finish in 60 minutes.  The chair is jaosorior. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:46 <openstack> The meeting name has been set to 'tripleo'
14:00:56 <jaosorior> #topic agenda
14:00:57 <jaosorior> * Review past action items
14:00:59 <jaosorior> * One off agenda items
14:01:01 <jaosorior> * Squad status
14:01:03 <jaosorior> * Bugs & Blueprints
14:01:05 <jaosorior> * Projects releases or stable backports
14:01:07 <jaosorior> * Specs
14:01:09 <jaosorior> * open discussion
14:01:11 <jaosorior> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:15 <jaosorior> Hey folks! who's around?
14:01:22 <marios> o/ hi
14:01:24 <shardy> o/
14:01:27 <weshay> 0/
14:01:27 <jfrancoa> o/ hola
14:01:30 <trown> o/
14:01:34 <ksambor> o/
14:01:37 <chem> o/
14:01:38 <fultonj> o/
14:01:44 <rfolco> o/
14:02:08 <mwhahaha> hi2u
14:02:14 <panda> o/
14:02:17 <Vorrtex> o/
14:02:32 <beagles> o/
14:02:40 <bogdando> o/
14:02:50 <redrobot> o/
14:02:57 <jtomasek> o/
14:03:29 <jaosorior> #topic review past action items
14:03:33 <jaosorior> None! :D
14:03:39 <jaosorior> #topic one off agenda items
14:03:45 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:04:00 <florianf> o/
14:04:01 <jaosorior> gfidente: the first one-off agenda item is yours.
14:04:22 <gfidente> jaosorior hi guys
14:04:33 <jaosorior> \o
14:04:38 <gfidente> yeah I am not sure if the one-line sentence is obvious enough but in the UC containerization
14:04:59 <gfidente> ceph-ansible got installed in the mistral executor container which we never wanted to
14:05:11 <jaosorior> For reference, this is the topic gfidente added: we want to consume ceph-ansible from the container host, not from within the container
14:05:13 <shardy> we had to do the same for openshift - it's unfortunate there's not a common install path we can bind in for $ansible roles?
14:05:15 <gfidente> instead we want to consume whatever version of the playbook is found on the container host
14:05:51 <gfidente> shardy well we just go mount in undercloud.yaml the dir where ceph-ansible installs its playbooks from baremetal
14:06:14 <bogdando> I wonder if there is an upgrade impact
14:06:25 <gfidente> see  https://review.openstack.org/#/c/604361/
14:06:25 <gfidente> https://review.openstack.org/#/c/604357/
14:06:31 <bogdando> like having validations executed against different versions of the package installed
14:06:35 <matbu> o/
14:06:45 <gfidente> bogdando an upgrade impact to what?
14:06:49 <jrist> o/
14:06:51 <jaosorior> Tengu: won't those mounts have issues with SELinux? ^^
14:06:57 <gfidente> in queens we didn't have UC containers
14:07:04 <gfidente> and rocky is not out yet
14:07:07 <Tengu> jaosorior: what mounts?
14:07:11 <bogdando> gfidente: makes sense :)
14:07:18 <Tengu> sorry, was on a patch
14:07:24 <jaosorior> Tengu: read up.
14:07:29 <fultonj> Tengu: https://review.openstack.org/#/c/604357/2/environments/undercloud.yaml
14:07:48 <Tengu> duh. probably, yeah.
14:08:00 <jaosorior> thought so, that won't work with the policy
14:08:09 <jaosorior> since it's from /usr/share/
14:08:26 <Tengu> hmm we already mount stuff from there.
14:08:31 <Tengu> it's ro, might work.
14:08:36 <jaosorior> uhm...
14:08:38 <Tengu> i.e. the puppet modules are mounted from that location.
14:08:42 <jaosorior> if we do :Z that would be fine though
14:08:58 <fultonj> good
14:09:05 <Tengu> ro,Z you mean?
14:09:09 <jaosorior> Tengu: yeah
14:09:17 <Tengu> might be good as well, if nothing else mount that location.
14:09:26 <Tengu> but I think we can't use :Z in tripleo.
14:09:33 <jaosorior> Tengu: why not?
14:09:35 <Tengu> as multiple container are launched
14:09:39 <Tengu> we already tested that.
14:09:42 <Tengu> only :z is OK.
14:09:47 <Tengu> don't you remember?
14:10:01 <jaosorior> Tengu: you're right. It would have issues with the init containers
14:10:09 <Tengu> if we had only ONE container, or keep the s0-sublevel-thing that would be OK with :Z
14:10:17 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:19 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1715374
14:10:20 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1792560
14:10:20 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1794034
14:10:20 <openstack> Launchpad bug 1715374 in tripleo "Reloading compute with SIGHUP prenvents instances to boot" [Critical,In progress] - Assigned to Bogdan Dobrelya (bogdando)
14:10:20 <Tengu> but that's not the case. so :ro,z only.
14:10:20 <bogdando> Tengu: we use :Z to share with other containers
14:10:21 <openstack> Launchpad bug 1792560 in tripleo "Upgrades in CI still using Q->master instead of R->master release" [Critical,Triaged] - Assigned to Jiří Stránský (jistr)
14:10:22 <openstack> Launchpad bug 1794034 in tripleo "Validation tasks have increase their duration" [Critical,Triaged] - Assigned to wes hayutin (weshayutin)
14:10:30 <Tengu> bogdando: minus z ;)
14:10:32 <bogdando> I think libvirt needs that?
14:10:40 <jaosorior> bogdando: it's lowercase z to share
14:10:44 <Tengu> bogdando: :Z makes it private for only one container, :z makes it sharable.
14:10:45 <jaosorior> capital case Z is private
14:10:49 <gfidente> bogdando Tengu jaosorior if it's about how we mount probably better to discuss in the review
14:10:50 <Tengu> :)
14:10:52 <jaosorior> got my selinux notes right here http://jaormx.github.io/2018/selinux-and-docker-notes/
14:10:52 <bogdando> ok :)
14:11:06 <gfidente> I mostly wanted to bring up the issue and why we want a different behavior
14:11:06 <jaosorior> gfidente: anyway... just wanted to double check. It should be fine then :D
14:11:08 * Tengu has his selinux stuff in his head for 3 weeks now
14:11:29 <fultonj> it's perfectly valid for the mistral-executor container to run external ansible packages OR for the user to run them too via "manual config download" so we should try to have consistent versions.
14:11:33 <fultonj> https://docs.openstack.org/tripleo-docs/latest/install/advanced_deployment/ansible_config_download.html#manual-config-download
14:11:37 <fultonj> so it's good we can have a way to do this
14:11:50 <fultonj> any external installer will have this issue
14:12:01 <openstackgerrit> Yurii Prokulevych proposed openstack/tripleo-upgrade master: Assert services/containers are started after reboot.  https://review.openstack.org/605084
14:12:03 <Tengu> gfidente: added a comment.
14:12:08 <gfidente> right so reviews welcomed, thanks Tengu
14:12:20 <jaosorior> gfidente: thanks for bringing it up
14:12:58 <Tengu> (so yeah I'm here ;))
14:13:00 <jaosorior> Anybody else want to shime in on gfidente's topic?
14:13:14 * gfidente left already
14:13:18 * gfidente joking
14:13:32 <Tengu> don't you dare gfidente ;)
14:13:36 <fultonj> shardy: are you going to do something similar?
14:14:09 <shardy> fultonj: we already added something IIRC but I've not found the patch
14:14:24 <shardy> will find it and ping you a link, the patches from gfidente seem fine as a workaround to me
14:14:25 <gfidente> I saw skydive there
14:14:28 <fultonj> beagles: ^
14:14:37 <gfidente> I think that has to go away from the container as well
14:14:50 <shardy> yeah, we end up bind mounting everything into the executor container, regardless of what services are enabled
14:14:59 <shardy> not very composable, but I can't think of a better approach atm
14:15:16 <gfidente> shardy well it's better than preinstalling everything in the image though
14:15:17 <gfidente> I mean
14:15:22 <shardy> yeah
14:15:34 <gfidente> but should be composable yeah
14:15:34 <shardy> containers ftw! ;)
14:15:50 <EmilienM> it's not friday :P
14:16:05 <gfidente> that was if containers aren't solving your problem yet, you're not using containers enough
14:16:24 * mwhahaha puts gfidente in a container and ships him off someplace nice
14:16:33 <shardy> yup, use more containers (that actually is how openshift solves this, ansible runs inside a container) ;)
14:16:48 <gfidente> so mwhahaha was rtight!
14:17:37 <gfidente> sorry I'll never bring up a topic to the meeting again
14:17:44 <gfidente> thanks all for helping
14:17:45 <mwhahaha> :o
14:17:48 <EmilienM> shardy: maybe out of topic but do you mind sharing how it works? we had this discussion last week
14:18:18 <EmilienM> sdoran / mwhahaha / dprince prototyped things lately, it would be interesting to comapre
14:18:42 <shardy> EmilienM: see https://review.openstack.org/#/c/583868/ - its WIP but flaper87 probably has more details
14:19:14 <fultonj> nice!
14:19:55 <shardy> Ok sounds like we're done on this topic so I'll mention https://bugs.launchpad.net/tripleo/+bug/1792613
14:19:55 <openstack> Launchpad bug 1792613 in tripleo "docker-puppet tasks can only run on the primary controller role" [High,In progress] - Assigned to Steven Hardy (shardy)
14:19:55 <jaosorior> shardy: next topic is yours
14:20:11 <shardy> I chatted with bandini at the PTG about this, and offered to take a look at how to solve it
14:20:17 <shardy> turns out it's harder than I expected ;)
14:20:26 <trown> shardy: EmilienM https://review.openstack.org/#/c/583868/ is working too ... some patches in that series dont work, but I tested the container patch by itself and it works
14:20:41 <shardy> If folks can check http://lists.openstack.org/pipermail/openstack-dev/2018-September/135045.html and provide feedback I'll spend some more time on it
14:20:42 <jaosorior> I remember we had this issue at some point when we tried to run keystone on it's own role, separate from the controller role.
14:20:51 <jaosorior> I didn't know how to fix it.
14:20:53 <shardy> basically all our bootstrap node stuff is wrong ;D
14:21:04 <gfidente> shardy I am not sure but in theory people can build their list of what needs to be mounted as it is a param
14:21:32 * flaper87 clicks
14:21:49 <shardy> gfidente: yeah but it's not easy to say if ceph is enabled add this mount
14:22:02 <shardy> the manual approach is fine, but it's not super-great for the standalone use-case
14:22:10 <shardy> Ok for undercloud though
14:22:34 <mwhahaha> it's fine for standalone cause we don't use mistral
14:22:50 <mwhahaha> so we'd be using the local version anwyay
14:23:10 <jaosorior> shardy: is there a proposed solution or approach already for the bootstrap node issue? or is that still up for discussion/solving?
14:23:11 <shardy> mwhahaha: yeah but you still have to manually build MistralExecutorExtraVolumes?
14:23:15 <shardy> oh wait
14:23:19 <mwhahaha> shardy: no mitral
14:23:20 * shardy needs more coffee :)
14:23:21 <mwhahaha> mistral
14:23:23 <mwhahaha> :D
14:24:08 <openstackgerrit> Cédric Jeanneret proposed openstack/tripleo-quickstart-extras master: Added podman support for log collection  https://review.openstack.org/605090
14:24:13 <Tengu> EmilienM: -^^
14:24:17 <shardy> Ok I'm done, feedback on the ML would be welcome, and I may have to ask for help if the implementation gets too time consuming
14:24:30 <jaosorior> shardy: thanks
14:24:36 <EmilienM> Tengu: ack will look after mtg
14:24:42 <openstackgerrit> Cédric Jeanneret proposed openstack/tripleo-quickstart-extras master: Add podman support for log collection  https://review.openstack.org/605090
14:24:43 <Tengu> sorry for the noise -.-'.
14:24:59 <jaosorior> Alright! one last reminder that this is pretty much the last day to submit topics for the Summit
14:25:06 <jaosorior> #link  Stein forum topics:
14:25:14 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-forum-stein
14:25:17 <openstackgerrit> Alex Schultz proposed openstack/tripleo-common master: Set prepare neutron_driver from NeutronMechanismDrivers  https://review.openstack.org/604953
14:25:19 <jaosorior> that's the link ^^
14:25:53 <jaosorior> although, feel free to make the proposal yourself and add it to the etherpad, like gfidente did. That was a nice idea :D
14:26:25 <gfidente> but don't mention containers in the topic
14:26:58 <jaosorior> #containers #kubernetes #cloudnative
14:27:07 <jaosorior> #servicemesh
14:27:21 <jaosorior> that'll do the trick :D
14:27:32 <jaosorior> Anyway
14:27:38 <jaosorior> Finally, a reminder from the CI team
14:27:40 <jaosorior> CI Community Meeting starts immediately upon this meeting closing in #oooq. This is our team's weekly "open office hours." All are welcome!  Ask/discuss anything, we don't bite. Agenda (add items freely) --> https://etherpad.openstack.org/p/tripleo-ci-squad-meeting.
14:28:12 <jaosorior> #topic Squad status
14:28:14 <jaosorior> ci
14:28:16 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:28:18 <jaosorior> upgrade
14:28:20 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:28:22 <jaosorior> containers
14:28:24 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:28:26 <jaosorior> integration
14:28:28 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:28:29 <openstackgerrit> Marios Andreou proposed openstack-infra/tripleo-ci master: WIP Removes EXTRA_TAGS from toci_gate_test&quickstart.sh.j2  https://review.openstack.org/604768
14:28:30 <jaosorior> ui/cli
14:28:32 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:28:34 <jaosorior> validations
14:28:36 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:28:38 <jaosorior> networking
14:28:40 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:28:42 <jaosorior> workflows
14:28:44 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:28:46 <jaosorior> security
14:28:48 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-security-squad
14:28:50 <jaosorior> edge
14:28:52 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:28:54 <jaosorior> Anything any squad wants to bring up to the weekly meeting?
14:29:39 <EmilienM> nothing outstanding in the container squad, we're still working on podman support
14:30:11 * Vorrtex is new around here... does this mean we're at Open Floor?
14:30:51 <openstackgerrit> Cédric Jeanneret proposed openstack/tripleo-quickstart-extras master: Add podman support for log collection  https://review.openstack.org/605090
14:31:22 * Vorrtex nope, sorry, retreating.
14:31:30 <rfolco> CI squad status https://etherpad.openstack.org/p/tripleo-ci-squad-meeting - L72
14:32:03 <marios> Vorrtex: open floor is usuall at the end see https://wiki.openstack.org/wiki/Meetings/TripleO
14:32:09 <jaosorior> #topic bugs & blueprints
14:32:11 <jaosorior> #link https://launchpad.net/tripleo/+milestone/rocky-rc2
14:32:13 <jaosorior> #link https://launchpad.net/tripleo/+milestone/stein-1
14:32:15 <jaosorior> For Stein we currently have 28 blueprints open in Launchpad.
14:32:17 <jaosorior> Bugs: 6 (-6) rocky-rc2, 783 (+11) stein-1.  102 (-1) open Storyboard bugs.
14:32:19 <jaosorior> #link https://storyboard.openstack.org/#!/project_group/76
14:32:26 <EmilienM> rocky-rc2 was released
14:32:41 <jaosorior> :D
14:32:42 <mwhahaha> i'll go through and move bugs out that may still be open
14:32:44 <EmilienM> mwhahaha: I guess we can do the launchpad dance
14:32:54 <mwhahaha> #action mwhahaha to move rocky-rc2 bugs out since it's been released
14:32:59 <EmilienM> I think we'll call final rocky at this point
14:33:06 <mwhahaha> it's likely that rc2 will be the ga release unless someone has serious objections
14:33:07 <openstackgerrit> James Slagle proposed openstack/tripleo-heat-templates master: check mode: docker_puppet  https://review.openstack.org/603253
14:33:08 <openstackgerrit> James Slagle proposed openstack/tripleo-heat-templates master: check mode: docker_puppet_tasks  https://review.openstack.org/603254
14:33:08 <openstackgerrit> James Slagle proposed openstack/tripleo-heat-templates master: check mode: paunch configs  https://review.openstack.org/603255
14:33:09 <openstackgerrit> James Slagle proposed openstack/tripleo-heat-templates master: Name unnamed tasks  https://review.openstack.org/604460
14:33:09 <openstackgerrit> James Slagle proposed openstack/tripleo-heat-templates master: Fix tasks in check mode  https://review.openstack.org/604461
14:34:00 <openstackgerrit> Emilien Macchi proposed openstack/tripleo-quickstart master: Switch fs027 to deploy with podman  https://review.openstack.org/600517
14:34:04 <openstackgerrit> Emilien Macchi proposed openstack/tripleo-quickstart master: Switch fs027 to deploy with podman  https://review.openstack.org/600517
14:34:40 <jaosorior> #topic projects releases or stable backports
14:34:49 <EmilienM> we released pike & queens yesterday
14:35:14 <EmilienM> nothing else to report
14:35:21 <jaosorior> thanks EmilienM
14:35:28 <jaosorior> #topic specs
14:35:30 <jaosorior> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:35:56 <EmilienM> the one about podman has 3 +2 https://review.openstack.org/#/c/602480/
14:36:08 <EmilienM> maybe we can move forward and iterate eventually?
14:37:24 <jaosorior> EmilienM: I can give it a read too. But I'm fine with that going in as well, given the 3 +2s from folks on your squad; who have better visibility on that work.
14:37:47 <EmilienM> ok. and again, happy to make changes if needed
14:37:55 <bogdando> note, we'll need one +2 from upgrades team IMO
14:37:59 <bogdando> before merging
14:38:07 <EmilienM> good idea
14:38:13 <jaosorior> bogdando: got anybody in mind that could give it a read? that is a good idea
14:38:39 <EmilienM> marios / chem
14:38:45 <EmilienM> at least
14:38:49 <EmilienM> jistr if you have time too
14:39:09 <chem> EmilienM: bogdando will look
14:39:15 <bogdando> thanks
14:39:19 <EmilienM> thx
14:39:22 <jistr> ack me too, i already skimmed through but didn't read in full yet
14:39:27 <EmilienM> ok np
14:39:33 <jaosorior> EmilienM: OK, I'll give it a read and wait for chem or jistr to read it too before merging.
14:39:36 <jaosorior> EmilienM: thanks for bringing it up.
14:40:00 <marios> EmilienM: will check
14:40:03 <EmilienM> sure, thx all for your time
14:40:04 <dtantsur> I started formally writing up the proposal of removing nova: https://review.openstack.org/604761
14:40:19 <dtantsur> WIP, but a lot of stuff to read already
14:40:19 <marios> jaosorior: this one is ready for merge i think https://review.openstack.org/579854
14:40:27 <Tengu> small note: if this review (https://review.rdoproject.org/r/#/c/16354/ ) is OK, it would be great to push https://review.openstack.org/#/c/605039/ asap - promotion blocker :).
14:40:35 <openstackgerrit> Rajini Karthik proposed openstack/puppet-tripleo master: Dell EMC SC: Add support for excluded_domain_ips  https://review.openstack.org/604444
14:41:04 <jaosorior> marios: will take a look. Thanks marios
14:41:04 <chkumar|ruck> EmilienM: Hello
14:42:02 <chkumar|ruck> EmilienM: Fs027 changes, since we are going to use podman but in fs027 tempest is runned from container which is dependent on docker that also needs to be updated otherwise tempest will fail
14:42:24 <jaosorior> Any other specs folks want to bring up?
14:43:03 <EmilienM> chkumar|ruck: right I'll work on it next no problem
14:43:14 <EmilienM> chkumar|ruck: fwiw it didn't fail since we still have docker deployed for now
14:44:23 <jaosorior> #topic open discussion
14:44:30 <Vorrtex> Hey as I mentioned earlier, I'm new around here, and have been working to get RDO multiarch.  I've made the following patch (which at first glance is ugly, but I included a comment to explain its purpose) that will help the RDO multiarch effort, if you guys could take a look.  Its quite small and digestible.
14:44:41 <Vorrtex> https://review.openstack.org/#/c/604401/
14:45:13 <chkumar|ruck> EmilienM: ok. I will take a look on podman stuff to update on tempest side also
14:45:19 <openstackgerrit> Martin Schuppert proposed openstack/tripleo-heat-templates stable/pike: Improve nova statedir ownership logic  https://review.openstack.org/587066
14:45:21 <florianf> Could I kindly ask for someone to give this backport patch a final push: https://review.openstack.org/#/c/603031/
14:45:26 <dtantsur> jaosorior: did we discuss the Forum proposals already? sorry, I had a conflicting meeting
14:45:29 <EmilienM> chkumar|ruck: we have a new oooq param undercloud_container_cli
14:45:32 <EmilienM> we could use that
14:45:38 <chkumar|ruck> EmilienM: yes
14:45:47 <jaosorior> dtantsur: I briefly did a reminder of that.
14:46:03 <dtantsur> jaosorior: do you plan to propose topics or should we propose them after talking to you?
14:46:46 <jaosorior> dtantsur: I was planning to propose them. But if you want to do it (and I know you ahve a topic in there), feel free.
14:46:59 <dtantsur> jaosorior: I'm fine with leaving it up to you :)
14:47:03 <shardy> Vorrtex: welcome, thanks for the link to the patch!
14:47:36 <jaosorior> dtantsur: if you have time already, you can submit the proposal, else I'll do it early in my time tomorrow.
14:47:43 <Vorrtex> Sure thing!  shardy thanks for the welcome :)
14:47:48 <jaosorior> Vorrtex: thanks for the patch. +2ed it.
14:47:55 <Vorrtex> jaosorior thanks much!
14:48:19 <chkumar|ruck> EmilienM: I will take a look and propose the patch for tempest tomorrow
14:48:54 <weshay> jaosorior, I should probably note that vexxhost is being investigated for 3rd party tripleo ci
14:49:19 <weshay> jaosorior, we probably want to invite nhicher and others to comment
14:49:34 <weshay> reviews on https://review.openstack.org/#/c/596432/
14:49:37 <jaosorior> weshay: will we have the same capabilities we did in RDO cloud for OVB?
14:49:49 <EmilienM> chkumar|ruck: ok
14:49:53 <weshay> jaosorior, I am poking at that
14:50:01 <openstackgerrit> Rajini Karthik proposed openstack/tripleo-heat-templates master: Dell EMC Sc: Add support for excluded_domain_ips  https://review.openstack.org/604447
14:50:10 <weshay> asking for more details to be sent out
14:50:18 <jaosorior> weshay: thanks for the info.
14:50:42 <openstackgerrit> Victor Pickard proposed openstack/tripleo-heat-templates master: Change log directory for OpenDaylight  https://review.openstack.org/603907
14:50:50 <weshay> also as usual..  CI open door immediately following this mtg
14:51:23 <openstackgerrit> Victor Pickard proposed openstack/tripleo-heat-templates master: Change log directory for OpenDaylight  https://review.openstack.org/603907
14:53:00 <jaosorior> Anything else folks want to bring up to the weekly meeting?
14:54:33 <jaosorior> #endmeeting