14:00:31 <jaosorior> #startmeeting tripleo
14:00:32 <openstack> Meeting started Tue Oct 30 14:00:31 2018 UTC and is due to finish in 60 minutes.  The chair is jaosorior. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:36 <openstack> The meeting name has been set to 'tripleo'
14:00:43 <jaosorior> #topic agenda
14:00:46 <jaosorior> * Review past action items
14:00:48 <jaosorior> * One off agenda items
14:00:50 <jaosorior> * Squad status
14:00:51 <jaosorior> * Bugs & Blueprints
14:00:54 <jaosorior> * Projects releases or stable backports
14:00:55 <jaosorior> * Specs
14:00:58 <jaosorior> * open discussion
14:00:59 <jaosorior> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:02 <jaosorior> Hey folks! who's around?
14:01:03 <EmilienM> o/ fellow humans
14:01:03 <jaosorior> It's UTC 14:00
14:01:09 <owalsh> o/
14:01:10 <beagles> o/
14:01:12 <janki> o/
14:01:14 <dpeacock> hey folks o/
14:01:16 <mwhahaha> hi2u
14:01:18 <ksambor> o/
14:01:20 <weshay> 0/
14:01:49 <fultonj> o/
14:02:01 <chandankumar> \o/
14:02:03 <marios> o/
14:02:53 <rlandy> o/
14:04:21 <jaosorior> #topic review past action items
14:04:37 <jaosorior> There was one action:
14:04:39 <jaosorior> rlandy, weshay, dtantsur to look into switching to TCP for IMPI and possibly tuning retries - postponed until next time
14:04:57 * dtantsur pings etingof
14:04:58 <weshay> k
14:05:25 <dtantsur> I know derekh looked into BMC problems
14:05:38 <dtantsur> and essentially found out that the majority of them is networking problems inside the BMCs
14:05:50 <dtantsur> if your DNS is not working well, switchign to TCP certainly won't help
14:06:15 <rlandy> we're running tests on real baremetal hardware to keep checking introspection
14:06:30 <jrist> o/
14:06:48 <panda> qo/
14:06:56 <dtantsur> rlandy: did I miss something and the CI no longer tests introspection?
14:07:08 <rlandy> dtantsur: OVB still does
14:07:12 <dtantsur> ah, good
14:07:20 <rlandy> but we're running these separate tests as well
14:07:27 <rlandy> as a second check
14:07:46 <rlandy> when the OVB envs are having issues
14:08:41 <rlandy> dtantsur: if you'd like to check any changes on the bm envs, we can help there
14:09:02 <jaosorior> well, ovb hasn't been passing for a while now :/ so, it's likely something could have gotten broken somewhere in that time
14:10:07 <weshay> and noting an rdo outtage was sent on sunday night
14:10:17 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:18 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1798195
14:10:18 <openstack> Launchpad bug 1798195 in tripleo "rdo-cloud yum repos unavailable during container updates and failing the undercloud install " [Critical,Triaged]
14:10:19 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1799786
14:10:20 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1799895
14:10:20 <openstack> Launchpad bug 1799786 in tripleo "puppet-openstack-unit-5.5-centos-7 broken due to updated puppet 5.5.7" [Critical,In progress] - Assigned to Alex Schultz (alex-schultz)
14:10:21 <weshay> the cloud was up from late friday - sunday
14:10:22 <openstack> Launchpad bug 1799895 in tripleo "CI: undercloud takes long time which causes job fail with timeout" [Critical,Triaged] - Assigned to Rafael Folco (rafaelfolco)
14:11:12 <quiquell> o/
14:12:09 <jaosorior> anything else on this action? should we follow up with the results of the checks for next week's meeting?
14:13:07 <weshay> not much we can do w/ the current state of infra
14:13:23 <jaosorior> right :/
14:13:38 <jaosorior> #topic one off agenda items
14:13:40 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:14:08 <jaosorior> There is nothing here, it seems. If folks wanted to bring something up we can discuss it in the open discussion section.
14:14:16 <jaosorior> #topic Squad status
14:14:19 <jaosorior> ci
14:14:21 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:14:22 <jaosorior> upgrade
14:14:25 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:14:27 <jaosorior> containers
14:14:29 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-containers-squad-status
14:14:31 <jaosorior> integration
14:14:32 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:14:35 <jaosorior> ui/cli
14:14:37 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:14:39 <jaosorior> validations
14:14:41 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:14:43 <jaosorior> networking
14:14:45 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:14:46 <jaosorior> workflows
14:14:49 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-workflows-squad-status
14:14:51 <jaosorior> security
14:14:51 <openstackgerrit> Merged openstack/tripleo-quickstart-extras master: Add /var/log/tripleo-container-image-prepare.log  https://review.openstack.org/613812
14:14:52 <openstackgerrit> Merged openstack/tripleo-quickstart master: fs010: switch undercloud to podman  https://review.openstack.org/611597
14:14:52 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-security-squad
14:14:53 <openstackgerrit> Merged openstack/tripleo-upgrade master: Pass stack name during minor update.  https://review.openstack.org/613935
14:14:54 <jaosorior> edge
14:14:55 <openstackgerrit> Merged openstack/tripleo-heat-templates stable/pike: Always lowercase role name  https://review.openstack.org/598588
14:14:56 <openstackgerrit> Merged openstack/os-net-config stable/rocky: Retry ovs-appctl command  https://review.openstack.org/612460
14:14:57 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:14:59 <jaosorior> Anything the squads want to bring up to the general meeting?
14:15:40 <weshay> just fyi.. couple upstream providers have some networking hiccups tracking gate failures here https://review.rdoproject.org/etherpad/p/ruckrover-sprint21
14:15:53 <weshay> atm.. mostly ovh and limestone
14:16:21 <EmilienM> sshnaidm|off: where do we collect this file?
14:16:23 <EmilienM> https://review.openstack.org/#/c/613812/
14:16:38 <EmilienM> jaosorior: some etherpads are missing updates for a while
14:16:55 <EmilienM> I'm wondering if that means we need to update the squads again?
14:17:20 <jaosorior> That's a good point. I'll check up on the squads and ask if they're active. Maybe we do need updates.
14:17:51 <jaosorior> #action jaosorior to poke the squads and check status. Based on this we might need to update the list of active squads.
14:18:03 <d0ugal> The workflow squad is no longer active
14:18:32 <jaosorior> d0ugal: alright, I'll remove it from the list
14:18:33 <EmilienM> the container squad either, I mean we still have good efforts on podman but not sure we need a squad at this point
14:18:40 <d0ugal> jaosorior: Thanks.
14:19:04 <EmilienM> bogdando, Tengu, dprince, myself, stevebaker, beagles are the main contributors on container stuff now I guess
14:19:08 <jaosorior> EmilienM: well, the work you folks are doing is kinda of a squad, except you don't update that etherpad.
14:19:15 <EmilienM> lol
14:19:17 <EmilienM> good point
14:19:30 <EmilienM> however we update our trello board: https://trello.com/b/S8TmOU0u/tripleo-podman
14:19:31 <jaosorior> EmilienM: you had a public trello, no?
14:19:44 <jaosorior> EmilienM: maybe we'll just remove that etherpad and add the trello link
14:19:52 <bogdando> +1
14:20:07 <EmilienM> jaosorior: +1
14:20:13 <Tengu> the trello should be OK
14:20:25 <openstackgerrit> Alex Schultz proposed openstack/tripleo-common stable/queens: Make ODL healthcheck IPv6 compatible  https://review.openstack.org/612243
14:20:30 <Tengu> oh. damn. meeting's already now? thanks saving time X(
14:20:32 <openstackgerrit> Merged openstack/puppet-tripleo master: Update functions to fix unit tests  https://review.openstack.org/613173
14:20:32 <openstackgerrit> Yurii Prokulevych proposed openstack/tripleo-upgrade stable/rocky: Pass stack name during minor update.  https://review.openstack.org/613958
14:20:32 <openstackgerrit> Merged openstack/puppet-tripleo master: Update parser functions to 4.x api  https://review.openstack.org/613411
14:20:33 <openstackgerrit> Merged openstack/tripleo-upgrade master: Add containers-prepare parameter to upgrade scripts.  https://review.openstack.org/613916
14:20:41 <jaosorior> Tengu: haha yeah
14:22:04 <openstackgerrit> Natal Ngétal proposed openstack/tripleo-common master: [Core] Fix the KeyError exception.  https://review.openstack.org/614225
14:22:10 <Tengu> regarding podman work :   Overcloud configuration completed.   <- 1 controller + 1 compute with podman, on podman undercloud
14:22:13 <Tengu> \o/
14:22:20 <Tengu> WITH selinux enforcing + separation
14:23:02 <jaosorior> nice!
14:23:09 <jaosorior> #topic bugs & blueprints
14:23:12 <jaosorior> #link https://launchpad.net/tripleo/+milestone/stein-1
14:23:14 <jaosorior> For Stein we currently have 28 (for stein-1) and 4 (for stein-2) blueprints open in Launchpad.
14:23:17 <jaosorior> Bugs: 761 stein-1, 8 stein2.  103 (0) open Storyboard bugs.
14:23:17 <openstack> bug 762 in libdc1394 (Ubuntu) "duplicate for #761 FTBFS: xorg include header issues" [Medium,Invalid] https://launchpad.net/bugs/762 - Assigned to MOTU (motu)
14:23:18 <jaosorior> #link https://storyboard.openstack.org/#!/project_group/76
14:25:44 <EmilienM> jaosorior: did you move blueprints to m2?
14:25:44 <etingof> pong dtantsur -- I've proposed a patch to speed up sushy up to the ipmi emulator speed -- https://review.openstack.org/#/c/612758/
14:25:46 <EmilienM> (and bugs)
14:26:04 <dtantsur> etingof: right, will put on my list
14:26:24 <jaosorior> EmilienM: I haven't yet. I'll try today
14:26:42 <EmilienM> mwhahaha has a nice script to move bugsd
14:26:48 <EmilienM> but blueprints are moved by hand usually
14:26:52 <jaosorior> he did pass it to me, just a matter of using it
14:26:57 <EmilienM> jaosorior: you need to get people doing it themselves for blueprints
14:26:58 <etingof> it seems to work in OVB though I figured that sushy should better work with VM names (like baremetal_0) as opposed to UUIDs
14:27:11 <etingof> so I am working on that ^
14:27:24 <jaosorior> EmilienM: oh, gotta start poking folks then.
14:27:26 <jaosorior> thanks
14:27:53 <jaosorior> #topic projects releases or stable backports
14:28:04 <openstackgerrit> Quique Llorente proposed openstack/tripleo-quickstart-extras master: Use dnf and python3 on platforms where these are default  https://review.openstack.org/610491
14:28:16 <jaosorior> Right, so milestone 2 was last week. Tried putting out a release, but am still having issues with zuul: https://review.openstack.org/#/c/613020/
14:28:53 <jaosorior> I'll get that sorted out though
14:29:48 <holser_> o/
14:31:28 <jaosorior> #topic specs
14:31:31 <jaosorior> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:31:40 <EmilienM> milestone 2? no milestone 1 :D
14:31:48 <jaosorior> uuh... milestone 1, yes
14:31:55 <EmilienM> don't scare us plz
14:32:02 <jaosorior> lol, sorry
14:32:05 <EmilienM> :)
14:32:36 <dtantsur> let's just straight to feature freeze
14:32:48 <dtantsur> * jump
14:33:36 <jaosorior> no features, no bugs, right? :P
14:33:56 <dtantsur> exactly!
14:34:07 <jaosorior> Anyway, folks! If you have blueprints for m1, please bump them to m2 (I'll be helping out with some of that as well)
14:34:10 <dtantsur> I'm looking forward to reducing the number of bugs in instack-undercloud on master to 0
14:34:38 <EmilienM> dtantsur: cheater
14:34:46 <dtantsur> haha
14:34:51 <EmilienM> i take instack then
14:35:35 <jaosorior> #topic open discussion
14:35:38 <jaosorior> Anything else that folks want to bring up to the meeting?
14:35:48 <marios> TripleO CI squad Community meeting after this tripleo meeting at https://bluejeans.com/5878458097 add items you would like to raise - agenda https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:36:33 <weshay> marios, thanks
14:37:25 <openstackgerrit> Harald Jensås proposed openstack/tripleo-specs master: blueprint tripleo-routed-networks-templates  https://review.openstack.org/451584
14:37:25 <jaosorior> ack
14:38:59 <hjensas> I just moved ^^ to Stein. There is several patches up for review that I'd like feedback on. :)
14:39:36 <jaosorior> hjensas: thanks
14:39:40 <hjensas> Also, to enable testing all that I have been working with bnemec on supporting routed networks in OVB. It works really well! \o/
14:40:06 <hjensas> I put some stuff here: https://github.com/hjensas/ooo-bp-tripleo-routed-networks-templates-testing if anyone wants try it out.
14:42:03 <openstackgerrit> Sorin Sbarnea proposed openstack/tripleo-quickstart master: wip: enable testing using ansible molecule  https://review.openstack.org/613672
14:42:06 <mwhahaha> if some folks have a second, please review https://review.openstack.org/#/c/613394/
14:43:21 <openstackgerrit> Sorin Sbarnea proposed openstack/tripleo-quickstart-extras master: Use dnf and python3 on platforms where these are default  https://review.openstack.org/610491
14:44:32 <openstackgerrit> Yurii Prokulevych proposed openstack/tripleo-upgrade master: Add missing bracket in jinja filter  https://review.openstack.org/614232
14:47:29 <EmilienM> mschuppert: please rebase https://review.openstack.org/#/c/614083/
14:47:44 <jaosorior> alright folks, thanks for joining!
14:47:47 <jaosorior> #endmeeting