14:00:49 <jaosorior> #startmeeting tripleo
14:00:50 <openstack> Meeting started Tue Apr 9 14:00:49 2019 UTC and is due to finish in 60 minutes. The chair is jaosorior. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:53 <openstack> The meeting name has been set to 'tripleo'
14:00:54 <jaosorior> #topic agenda
14:00:56 <mwhahaha> o/
14:00:59 <dpeacock> o/
14:01:02 <jaosorior> * Review past action items
14:01:03 <ksambor> o/
14:01:04 <jaosorior> * One off agenda items
14:01:05 <Vorrtex> o/
14:01:06 <jaosorior> * Squad status
14:01:08 <jaosorior> * Bugs & Blueprints
14:01:08 <jrist> o/
14:01:09 <jfrancoa> o/\o
14:01:10 <jaosorior> * Projects releases or stable backports
14:01:12 <jaosorior> * Specs
14:01:14 <jaosorior> * open discussion
14:01:14 <marios> o/
14:01:14 <rfolco> o/
14:01:16 <jaosorior> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:18 <jaosorior> Hey folks! who's around?
14:01:22 <beagles> o/
14:01:26 <openstackgerrit> Ronelle Landy proposed openstack-infra/tripleo-ci master: WIP: Add rocky standalone job https://review.openstack.org/651247
14:01:30 <weshay> 0/
14:01:33 <rlandy|ruck> o/
14:01:34 <zbr> o/
14:03:22 <jaosorior> #topic review past action items
14:03:26 <jaosorior> None.
14:03:31 <jaosorior> #topic one off agenda items
14:03:35 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:04:00 <jaosorior> The first topic is from beagles : working towards making scenario010-standalone (octavia) voting
14:04:16 <rh-jelabarre> o/
14:04:39 <openstackgerrit> Alex Schultz proposed openstack/tripleo-common master: Modify roles to remove unused services https://review.openstack.org/642032
14:04:39 <beagles> hi all, octavia has been around for a bit but we've not had voting CI jobs for it
14:05:08 <EmilienM> +2
14:05:27 <mwhahaha> cause they aren't passing </troll>
14:05:47 <fultonj> o/
14:05:47 <mwhahaha> let's get them green and we can switch them to voting
14:05:55 <beagles> as such things tend to get broken and unnoticed
14:06:16 <beagles> yeah. multinode probably needs to be voting as well because it is catching issues standalone is not
14:07:31 <beagles> quesitons that come to mind, do we need both - and if so, might be more of a priority to get multinode voting stable and voting first
14:07:36 <fultonj> If multinode goes back to voting it might catch things standalone doesn't, but if history is a lesson, then I think the cost would be less reliable CI.
14:07:39 <beagles> (catches more stuff)
14:08:01 <fultonj> (tripleo ci team should say though)
14:08:05 <fmount> o/
14:08:08 <mwhahaha> so the concern with adding a multinode is resources
14:08:12 <beagles> fultonj: good point
14:08:17 <weshay> we could just run the multinode against mistral projects
14:08:17 <Tengu> «o/
14:08:30 <mwhahaha> we've worked really hard to eliminate multinode as much as possible
14:09:07 <beagles> mwhahaha: I wonder if there would be advantages to be careful about what triggers what
14:10:06 <mwhahaha> maybe keep both?
14:10:14 <mwhahaha> and only run the multinode on mistral specific code
14:10:24 <weshay> +1
14:10:44 <mwhahaha> this is one of those extra services that we can kinda cover upstream but the multinode should probably be tested downstream due to resource constraints
14:11:05 <mwhahaha> since octavia is an extra and not core service i'm not sure we should use the resources upstream for it
14:12:23 <mjturek> o/
14:14:06 <jaosorior> mwhahaha: +1
14:14:20 <beagles> I've also been thinking about backports - would be good to get that up and voting as well but for that it would be multinode
14:14:33 <fultonj> mwhahaha: +1
14:14:40 <beagles> but I'm getting ahead of myself
14:14:43 <fultonj> at least that was my experience with ceph once
14:14:50 <mwhahaha> lets get the jobs fixed up and have the conversation then
14:14:55 <fultonj> e.g. a downstream testing had to catch something multinode
14:15:06 <mwhahaha> +1 to standalone version going forward being voting
14:15:08 <fultonj> not ideal but resources are limited and downstream testing was sufficient
14:15:31 <beagles> k
14:17:43 <jaosorior> the next topic is from rfolco: stein branching: we're watching tripleo channel to make sure stein jobs will run successfully.
14:18:12 <rfolco> yep, the jobs should run as soon as we branch tripleo projects, ci bits are in place
14:18:15 <weshay> did the blockers to branching get resolved, /me needs to look
14:18:27 <weshay> EmilienM mentioned a few last week
14:19:02 <mwhahaha> when do we want to branch stein? this week?
14:19:08 <EmilienM> maybe we could branch tripleoclient first
14:19:19 <EmilienM> wait to see how CI works etc
14:19:33 <EmilienM> and in few weeks we branch the rest
14:19:41 <EmilienM> that's how we do usually
14:19:52 <mwhahaha> tripleoclient or tripleo-common?
14:20:01 <marios> well they need each other
14:20:03 <EmilienM> client iirc
14:20:16 <mwhahaha> k lets get it started i guess
14:20:35 <jrist> ra ra sisk boom bah
14:21:37 <ksambor> mwhahaha, +1 we definitely need tripleo-common otherwise we will not test all changes
14:21:45 <weshay> please don't sing
14:21:55 <jrist> I was cheerleading thank you very much
14:22:16 <EmilienM> mwhahaha: you want me to propose the patch?
14:22:22 <mwhahaha> yes plz
14:22:32 <EmilienM> #action EmilienM to branch tripleoclient stable/stein this week
14:23:19 <rfolco> EmilienM, I offer support for watching jobs and making sure they run well
14:24:19 <jaosorior> #topic Squad status
14:24:24 <jaosorior> ci
14:24:26 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:24:28 <jaosorior> upgrade
14:24:30 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:24:32 <jaosorior> containers
14:24:34 <jaosorior> #link https://trello.com/b/S8TmOU0u/tripleo-podman
14:24:36 <jaosorior> integration
14:24:38 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:24:40 <jaosorior> cli
14:24:42 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-ui-cli-squad-status
14:24:44 <jaosorior> validations
14:24:46 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:24:48 <jaosorior> networking
14:24:50 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:24:52 <jaosorior> edge
14:24:54 <jaosorior> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:24:56 <jaosorior> Any squad wanting to bring up their status, or a topic for the general public?
14:25:01 <Tengu> Validations: we still need a ton of reviews.
14:25:04 <Tengu> #link https://trello.com/c/k96ySxA0/18-review-migrating-validations-playbooks-to-their-own-ansible-role
14:25:08 <Tengu> please-please-please :)
14:25:46 <weshay> please don't sing
14:25:58 <EmilienM> mwhahaha: https://review.openstack.org/651253
14:26:10 <Tengu> weshay: bah, sun's shining here.
14:26:36 <Tengu> weshay: as long as I'm not "singing under the rain", "it's alright, it's ok" :D
14:27:07 <ykarel> EmilienM, we would also need to do branching for tripleo in RDO as well
14:27:19 <mwhahaha> thought we already branched rdo?
14:27:31 <mwhahaha> or did you folks just ask about it and not do it
14:27:53 <ykarel> mwhahaha, not branched yet, current status: https://review.rdoproject.org/etherpad/p/stein-release-preparation
14:27:55 <ykarel> L 111
14:28:12 <ykarel> if you can propose branching, builds will be automatic by bot
14:28:14 <mwhahaha> k
14:29:48 <jaosorior> #topic bugs & blueprints
14:29:54 <jaosorior> #link https://launchpad.net/tripleo/+milestone/stein-rc1
14:29:56 <jaosorior> For Stein we currently have 2 (for stein-rc1) blueprints open in Launchpad.
14:29:58 <jaosorior> Bugs: 221 (+9) stein-rc1, 288 (-1) train-1 in Launchpad. 104 (0) open Storyboard bugs.
14:30:00 <jaosorior> #link https://storyboard.openstack.org/#!/project_group/76
14:30:55 <jaosorior> #topic projects releases or stable backports
14:32:20 <jaosorior> #topic specs
14:32:26 <jaosorior> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:32:28 <jaosorior> Any specs folks want to bring attention to?
14:32:37 <Tengu> yeah
14:32:49 <Tengu> we still need some reviews on https://review.openstack.org/645508 - note it's for Train already
14:33:14 <Tengu> but that one, the sooner we're OK with it, the sooner work can start. It will be long :)
14:34:05 <jaosorior> ack
14:36:01 <jaosorior> #topic open discussion
14:36:05 <jaosorior> Anything else that folks want to bring up to the meeting?
14:36:44 <mjturek> I got a quick one, baha and I uploaded this rdo patch yesterday to move our ppc64le container build job to the zuul playbooks used by tripleo-ci. If anyone can take a look at the patch we'd really appreciate some feedback. https://review.rdoproject.org/r/#/c/20031/
14:38:50 <mjturek> s/zuul playbooks/playbooks
14:41:29 <openstackgerrit> Quique Llorente proposed openstack-infra/tripleo-ci master: Make scenario000 multinode upgrades job voting https://review.openstack.org/651258
14:43:12 <jaosorior> #endmeeting