13:01:28 <cloudnull> #startmeeting tripleo
13:01:29 <openstack> Meeting started Thu Jun 20 13:01:28 2019 UTC and is due to finish in 60 minutes. The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:32 <openstack> The meeting name has been set to 'tripleo'
13:01:36 <jistr> hello
13:01:38 <ekultails> We'll be covering the agenda for today from here: https://etherpad.openstack.org/p/tripleo-ansible-agenda
13:01:45 <sshnaidm> cloudnull, just fyi, it's overlapping in CI team scrum meeting, for us with zbr
13:02:04 <cloudnull> :'(
13:02:15 <cloudnull> sorry about that.
13:02:24 <cloudnull> #topic roll
13:02:25 <ekultails> Maybe we should move to a different day?
13:02:31 <cloudnull> o/
13:02:33 <fultonj> o/
13:02:42 <ekultails> o/
13:02:42 <mnaser> bonjour
13:02:47 <zbr> also I failed to see a BJ link on the meeting
13:02:48 <sshnaidm> o/
13:03:07 <slagle> hi
13:03:18 <sshnaidm> ekultails, maybe better in different day, yeah
13:03:21 <cloudnull> zbr there's not a BJ link, this meeting was all IRC figured it'd be good to just gather folks to chat
13:03:33 <fultonj> irc++
13:03:47 <cloudnull> #topic Introductions
13:03:56 <mwhahaha> o/
13:04:09 <JqckB> hi all !
13:04:16 <cloudnull> so I guess lets get to it, basically the squad is trying to make better use of Ansible -
13:04:28 <cloudnull> as ekultails put it - Mission: TripleO services (Mistral, Puppet, Swift, Zaqar, etc.), are being deprecated in favor of Ansible automation. There is a large focus on following the best practices of Ansible content creation, adding test infrastructure for the Ansible content via Molecule, and refactoring code.
13:05:01 <cloudnull> over the past week or so there's been a lot of focus on getting tripleo-ansible into a place where we can do that
13:05:07 <cloudnull> which i think is close
13:05:08 <mnaser> (and then there's me who represents a whole bunch of already existing roles to see how we can collaborate on those) :)
13:05:58 <zbr> i can help in two areas: molecule and pre-commit (linting)
13:06:14 <cloudnull> We have a living etherpad which has a bunch of topics on it, and I'd like to have this first meeting be about what we want initially and how we can make the most impact
13:06:23 <cloudnull> #link: https://etherpad.openstack.org/p/tripleo-ansible-agenda
13:06:48 <zbr> regarding molecule, i recently managed to release pytest-molecule plugin which detects and runs molecule as pytest test. installing the plugin is enough to make pytest dicover molecule tests inside a repo.
13:07:10 <cloudnull> zbr mind dropping a link to that ?
13:07:52 <dpeacock> o/
13:07:53 <slagle> cloudnull: i like the idea of moving the existing roles from tripleo-common into tripleo-ansible to help prove out the structure, packaging, testing, etc.
13:07:57 <cloudnull> does anyone want to raise anything, talk about something, or introduce a thing?
13:08:02 <slagle> then focus on porting tasks from tht to new roles
13:08:09 <cloudnull> +1
13:08:38 <cloudnull> Regarding that, I've created a trello board
13:08:40 <cloudnull> #link https://etherpad.openstack.org/p/tripleo-ansible-agenda
13:08:46 <cloudnull> opps
13:08:49 <gfidente> cloudnull I was curious if anybody explored the possibility of reusing openstack-ansible ?
13:08:53 <cloudnull> #link https://trello.com/b/tEjJlT3k/tripleo-ansible-content-import
13:09:17 <cloudnull> gfidente good question
13:09:17 <jistr> i'd like our upgrade solution to go from "upgrade all services on node N" to "upgrade component X, and whether that happens on node-by-node or all-at-the-same-time is under control of a role for component X" if possible. We wanted rolling upgrades for a long time but not all services support it, and that has always blocked us, given how current upgrade framework is structured. I'd like to explore if the idea
13:09:19 <jistr> of per-component upgrades is compatible with the new Ansible squad work and get involved on that front.
13:09:38 <mwhahaha> we had previously talked about trying to reuse bits of opesntack-ansible as possible, but it depends on what we need to do. Since we only need the config bits, it may not make sense to use it all
13:09:46 <jistr> a fundamental refactoring of how we deploy seems like a natural opportunity for a refactoring of how we upgrade
13:09:53 <cloudnull> I've not explored that just yet, but we have mnaser here so i think its something we can look at once we have a good grasp of our existing roles
13:09:58 <fultonj> cloudnull: nice organization on that board
13:10:01 <zbr> https://github.com/pycontribs/pytest-molecule and https://review.opendev.org/#/c/645273/ (which i will fix later today, got an unexpected error over the night) -- but worked locally.
13:10:13 <cloudnull> #link https://github.com/pycontribs/pytest-molecule
13:10:21 <cloudnull> #link https://review.opendev.org/#/c/645273/
13:11:05 <cloudnull> jistr +1
13:11:06 <EmilienM> dciabrin: slagle and I are investigating why https://review.opendev.org/#/c/662472/ fails on OVB and it seems like the MySQL cluster fails to bootstrap completely
13:11:07 <mwhahaha> cloudnull: i think the perms on that board need to be opened up
13:11:15 <EmilienM> dciabrin: https://logs.rdoproject.org/72/662472/39/openstack-check/tripleo-ci-centos-7-ovb-3ctlr_1comp-featureset001/e9a20f3/logs/overcloud-controller-0/var/log/containers/mysql/mysqld.log.txt.gz
13:11:19 <slagle> gfidente: several times in the past, in different ways
13:11:19 <mwhahaha> cloudnull: i can't add myself to the board
13:11:29 <EmilienM> dciabrin: only 2 members managed to join
13:11:36 <dciabrin> EmilienM, oh... hmm looking at the logs
13:11:37 <EmilienM> dciabrin: I'm wondering if you see something wrong in the config
13:12:02 <cloudnull> I sent an invite to you mwhahaha but I will look at opening it up
13:12:07 * cloudnull thought I had
13:12:17 <slagle> gfidente: i'd personally like to try and see us make progress on migrating towards tripleo standalone roles first
13:12:55 <mnaser> yeah I'd be happy to volunteer myself to do a small poc of using OSA roles to drop configs in tripleo when the time is right
13:13:02 <slagle> then it'd be a bit easier to make progress on the collaboration with osa front
13:13:07 <zbr> some with me: unable to find any join option on the board.
13:13:09 <cloudnull> mwhahaha I made you admin on the board as well
13:13:29 <mwhahaha> k thnx
13:13:35 <fultonj> do we create a tag in the board where we can tag stuff as can-possibly-be-replated-by-openstack-ansible ?
13:13:57 <sshnaidm> cloudnull, any chance to join this board?
13:14:16 <fultonj> sshnaidm: sent you an invitation
13:14:20 <cloudnull> zbr sshnaidm invites sent
13:14:54 <cloudnull> #action cloudnull to figure out trello perms
13:15:08 <sshnaidm> cloudnull, better to do it open for all rh folks
13:15:31 <jistr> can i get an invite too please (jistr also on trello0
13:15:36 <jistr> )
13:15:45 <fultonj> jistr: done
13:15:52 <sshnaidm> you can make it open for RHOS group: https://trello.com/rhos
13:16:03 <jistr> thannks fultonj
13:16:04 <dpeacock> cloudnull: can you give me perms on the trello board please? I wanna claim something but I'm not sure if I'm permitted.
13:16:25 <JqckB> same here to cygrosjean if possible :)
13:16:35 <sshnaidm> (instead of sending invites to all :)
13:16:40 <cloudnull> dpeacock done
13:16:52 <ekultails> cloudnull was exploring the idea of using OpenStack's StoryBoard instead of Trello (it would have been easier to manage permissions for the upstream community) but it was buggy and we had issues creating and managing a new board.
13:16:58 <dpeacock> cloudnull: thank you kindly
13:17:21 <cloudnull> yea, I stuck with trello, because I like it and its easy
13:17:37 <dpeacock> trello is fine
13:17:45 <cloudnull> that said, im not married to it, if we want to move it into LP or storyboard im good with that
13:17:52 <fultonj> proposal: there's an action to make board more open, if anyone wants in before that's solved then please add your nick to etherpad so we don't clog meeting with one-off-requests
13:17:56 <openstackgerrit> yatin proposed openstack/tripleo-quickstart master: [DNM] Add CloudSIG stein release file https://review.opendev.org/665959
13:18:06 <cloudnull> fultonj +1
13:18:17 <fultonj> but are we decided on trello?
13:18:28 <fultonj> vs storyboard vs launchpad
13:18:36 <cloudnull> +1 for trello
13:19:08 <fultonj> +1 for tello
13:19:21 <dpeacock> +1 for trello
13:19:43 <EmilienM> or taiga
13:19:47 <EmilienM> or jira?
13:19:53 * EmilienM hides
13:19:55 <dpeacock> EmilienM: shush you ;-)
13:19:59 <ekultails> lol
13:20:10 <mwhahaha> carrier pigeon
13:20:18 <cloudnull> EmilienM version1 ?
13:20:21 <ekultails> We should be able to get a free Jira license since we're an open source project.
13:20:33 <mwhahaha> let's not jira
13:20:41 <cloudnull> +1 not jira
13:20:49 <mwhahaha> really we should be using lp/storyboard
13:20:59 <mwhahaha> trello has historically not been well liked in the openstack community
13:21:08 <fultonj> mwhahaha: that's a good point
13:21:10 <cloudnull> this is very true
13:21:21 <mwhahaha> i know we've used it for some stuff
13:21:25 <mnaser> I believe they recently made a change yet had affected other projects
13:21:44 <mnaser> I don't remember the details
13:21:44 <mwhahaha> i hate story board, but i think it does have a kanban dashboard thingy if you set it up right
13:21:59 <cloudnull> I'm happy to port the trello board to whatever
13:22:14 <mwhahaha> if we can't open up the trello board completely so that non-members can do stuff then we shoudl probably use storyboard (as much as i hate it)
13:22:31 <mwhahaha> you can also directly target openstack/tripleo-ansible in storyboard
13:22:31 <cloudnull> I'm good with that
13:22:36 <fultonj> i don't have strong opinions, i just saw cloudnull already put some work into trello that looked good
13:22:47 <fultonj> let's be openstack friendly though
13:23:00 <fultonj> whatever++
13:23:11 <cloudnull> its simple enough to move over.
13:23:23 <ekultails> +1 for an OpenStack friendly tool
13:23:33 <jistr> +1 for OpenStack friendly
13:23:40 <dpeacock> lol yeah whatever++
13:23:57 <gfidente> you guys take the courage to replace whatever with storyboard in your lines
13:24:00 <fultonj> so launchpad or storyboard?
13:24:06 <gfidente> :D
13:24:18 <dpeacock> omg storyboard++ can we move now lol
13:24:19 <Tengu> fultonj: why "or"? :]
13:24:22 <cloudnull> I'd rather storyboard than Launchpad but ...
13:24:40 <mwhahaha> k storyboard and lets move on with life
13:24:44 <cloudnull> #agreed port the trello board to storyboard
13:24:49 <fultonj> ++, next...
13:25:05 <cloudnull> #topic Initial plan of attack
13:25:24 <cloudnull> so far I've largely been working on getting tripleo-common ansible things into tripleo-ansible
13:25:41 <cloudnull> I'm about 50% of the way there with inflight reviews
13:26:18 <cloudnull> see "needs review" in trello, until we can port to storyboard
13:26:57 <cloudnull> a lot of the restructuring work has taken place, though I'd love folks to kick the tires, of what we've got so far.
13:27:30 <cloudnull> All of the old external roles, which we're largely just shells, have been retired
13:27:50 <openstackgerrit> Martin Mágr proposed openstack/puppet-tripleo master: Add TLS support for rsyslog https://review.opendev.org/666573
13:27:51 <ekultails> Are your patches grouped under any specific topics in Gerrit?
13:27:59 <dpeacock> cloudnull: I take it we can use your previous (merged?) patches as reference for the stragglers to follow? I blagged one so figured I'd learn from what you did previously.
13:28:05 <ekultails> I'm going to start using "molecule" for all of my Molecule related stuff.
13:28:41 <cloudnull> ekultails they're not all grouped under a single topic
13:28:47 <cloudnull> though they're dependent patches.
13:29:09 <cloudnull> #link https://review.opendev.org/#/q/topic:role-addition+(status:open+OR+status:merged)
13:29:12 <cloudnull> example ^
13:29:37 <cloudnull> dpeacock yes. the previous merged patches are a good reference
13:29:53 <cloudnull> Also
13:29:55 <cloudnull> #link https://docs.openstack.org/tripleo-ansible/latest/contributing.html
13:29:55 <openstackgerrit> Alex Schultz proposed openstack/python-tripleoclient master: Fixup sphinx requirements https://review.opendev.org/666443
13:30:02 <ekultails> Cool, thanks. Just wanted to get some visibility to folks who may not be in Trello yet.
13:30:06 <openstackgerrit> Alex Schultz proposed openstack/python-tripleoclient master: Bump keystone middleware version to 4.18 https://review.opendev.org/636849
13:30:19 <dpeacock> thanks
13:30:38 <cloudnull> we've created a very simple playbook that will create a new role, doing all of the documentation, default molecule, and zuul things for you
13:31:13 <zbr> i am in favour of using "molecule" topic to track any changes specific to molecule.
13:31:22 <openstackgerrit> Martin Mágr proposed openstack/tripleo-heat-templates master: Rsyslog composable service https://review.opendev.org/624330
13:31:29 <cloudnull> basically what I've been doing is running the playbook for a new role, and syncing the existing role content from tripleo-common into the role, then fixing all of the things that the linter complains about.
13:32:26 <cloudnull> the molecule tests that are generated will just run the role so there will be some tweaking required to make the molecule test successful
13:32:59 <cloudnull> shameless plug - I also made a blog post on creating a role from start to finish
13:33:00 <cloudnull> #link https://cloudnull.io/2019/06/creating-a-role-with-tripleo-ansible/
13:33:56 <cloudnull> zbr ekultails +1 we can set the topics accordingly
13:35:01 <cloudnull> so with all that said, I'd love help with the existing roles in tripleo-common, and I'd love for folks to help enhance the framework we're creating to make it easier to develop with the new tools.
13:36:11 <cloudnull> sshnaidm you had an item in the plan of attack for CI, mind talking a bit about it ?
13:36:37 <sshnaidm> cloudnull, yeah, I wonder how can we run regular tripleo jobs while integrating ansible roles
13:37:23 <sshnaidm> cloudnull, also do we need to build or just checkout them
13:37:40 <sshnaidm> all this is pretty much interesting for me :)
13:38:16 <sshnaidm> I mean molecule testing is great, but integration test should be done too in CI
13:38:19 <cloudnull> so once we have the package dependency restored we should be able to rely on our existing CI and then create some cross project jobs (which can be voting) to make sure we dont break anything.
13:38:30 <openstackgerrit> Francesco Pantano proposed openstack/tripleo-heat-templates master: [WIP] Add dashboard component as new ceph composable service. https://review.opendev.org/666578
13:38:36 <cloudnull> #link https://review.rdoproject.org/r/#/c/21197/
13:39:14 <cloudnull> we had an issue with conflicting files being installed between packages
13:39:22 <cloudnull> but that should not be resolved with the following set
13:39:42 <cloudnull> #link https://review.opendev.org/#/q/topic:fixup-ci+(status:open+OR+status:merged)
13:39:51 <openstackgerrit> Francesco Pantano proposed openstack/tripleo-heat-templates master: [WIP] Add dashboard component as new ceph composable service. https://review.opendev.org/666578
13:40:00 <mwhahaha> s/not/now?
13:40:42 <cloudnull> ?
13:40:44 <openstackgerrit> Francesco Pantano proposed openstack/tripleo-heat-templates master: [WIP] Add dashboard component as new ceph composable service. https://review.opendev.org/666578
13:41:00 <sshnaidm> cloudnull, mwhahaha yeah, it's "now" afaiu :)
13:41:06 <mwhahaha> "but that should not be resolved with the following set"
13:41:13 <cloudnull> oh
13:41:20 * cloudnull has bad fingers
13:41:34 <sshnaidm> cloudnull, ok, I'll look into these patches
13:42:00 <sshnaidm> will have some insights after
13:42:12 <cloudnull> but this is a good point, we're going to rapidly need to be able to spin up a full cloud to test changes in a given role
13:42:21 <cloudnull> and I'd love to figure that out
13:42:44 <cloudnull> I think we can do a lot of it with existing scenario tests as a cross repo job
13:42:55 <cloudnull> though I'm not 100% sure on how we'd wire that at this point
13:43:03 <cloudnull> thoughts?
13:44:08 <sshnaidm> cloudnull, need to test and to see how it goes..
13:44:22 <mwhahaha> test which roles?
13:44:39 <mwhahaha> i think once we get it integrated with tripleo and actually in use, the standard deployment job should suffice
13:44:53 <fultonj> +1
13:45:07 <cloudnull> sounds good to me .
13:46:34 <cloudnull> I do have a couple integrated changes I did to test things -
13:46:47 <cloudnull> #link https://review.opendev.org/#/c/664877
13:46:49 <cloudnull> #link https://review.opendev.org/#/c/664575/
13:47:12 <cloudnull> they have passed CI (in the past)
13:47:26 <fultonj> in the case of ceph i tested my role in the existin 001/004 scenario by adding a depends-on to the tripleo-ansible review
13:47:29 <fultonj> #link https://review.opendev.org/#/c/661001/17/deployment/ceph-ansible/ceph-base.yaml
13:47:59 <cloudnull> +1
13:48:25 <cloudnull> so if we can just leverage this pattern, I think we're covered?
13:48:54 <fultonj> i think so, if you're replacing one part with another it should just drop in and we'll add the molecule tests
13:49:02 <cloudnull> ++
13:49:23 <fultonj> might be nice if the larger 001 job didn't run until molecule passed
13:49:34 <sshnaidm> cloudnull, jobs fail because they try to build tripleo-ansible with dlrn, how do we build/provide it..?
13:49:35 <fultonj> i guess that's a little off topic though
13:50:15 <cloudnull> fultonj we actually could do that with a cross project job, via gate in tripleo-ansible,
13:50:26 <cloudnull> but that might be a good thing to explore at a later date
13:50:35 <zbr> fultonj: true, but lets allow the molecule job to run (mature) for 2-3 weeks before doing that.
13:51:03 <fultonj> zbr certainly
13:51:28 <cloudnull> so we got about 10 min left
13:51:30 <sshnaidm> #action sshnaidm to run regular tripleo jobs on tripleo ansible roles patches
13:51:35 <cloudnull> #topic open floor
13:51:51 <zbr> my take is to use 3 classes of jobs: thin (linters, simple unit), medium (func, molecule), fat (full deployments). and one class woudl start only when previous one passed.
13:52:34 <mwhahaha> we can do that with the zuul deps
13:52:38 <cloudnull> ++
13:52:53 <openstackgerrit> Merged openstack/ansible-role-redhat-subscription master: Rename rhsm_repository module to avoid conflict. https://review.opendev.org/666528
13:52:56 <mwhahaha> we're doing that today in tht/python-tripleoclient/tripleo-common with the unit jobs being before deployments
13:53:08 <sshnaidm> yeah, if they're not too much long
13:55:24 <cloudnull> does anyone have a good pattern to help us implement ARA with molecule? -cc dmsimard
13:55:36 <dmsimard> o/
13:55:43 <cloudnull> :)
13:55:45 <dmsimard> cloudnull: pabelanger might have something
13:55:57 <dmsimard> otherwise it's just a callback I guess ?
13:56:23 <cloudnull> #action ping pabelanger and pester dmsimard about ARA and molecule
13:56:26 <sshnaidm> cloudnull, I can look into, with help of dmsimard
13:56:30 <cloudnull> +1
13:57:04 <cloudnull> I really like what ARA provides, especially on the CI front.
13:57:26 <cloudnull> #action sshnaidm to look into ARA
13:57:49 <cloudnull> ok welp, I think we're just about out of time.
13:58:06 <cloudnull> thanks everyone! sorry for being a little all over the place but this was a great first meeting
13:58:24 <cloudnull> see you all back in the ether
13:58:27 <cloudnull> #endmeeting