14:00:10 <mwhahaha> #startmeeting tripleo
14:00:11 <mwhahaha> #topic agenda
14:00:11 <mwhahaha> * Review past action items
14:00:11 <mwhahaha> * One off agenda items
14:00:11 <mwhahaha> * Squad status
14:00:11 <mwhahaha> * Bugs & Blueprints
14:00:11 <mwhahaha> * Projects releases or stable backports
14:00:12 <mwhahaha> * Specs
14:00:12 <openstack> Meeting started Tue Jun 25 14:00:10 2019 UTC and is due to finish in 60 minutes.  The chair is mwhahaha. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <mwhahaha> * open discussion
14:00:13 <mwhahaha> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:00:13 <mwhahaha> Hi everyone! who is around today?
14:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:15 <openstack> The meeting name has been set to 'tripleo'
14:00:18 <beagles> o/
14:00:19 <dpeacock> o/
14:00:24 <Tengu> «o/
14:00:34 <rh-jelabarre> o/
14:00:36 <rlandy> o/
14:00:57 <jfrancoa> o/
14:01:02 <owalsh> o/
14:01:44 <EmilienM> hellow
14:01:46 <marios> \o/
14:02:46 <rfolco> o/
14:02:56 <sshnaidm> o/
14:03:18 <mwhahaha> we've got an assortment of people and not much on the agenda so let's go
14:03:22 <mwhahaha> #topic review past action items
14:03:23 <mwhahaha> None.
14:04:21 <mwhahaha> #topic one off agenda items
14:04:21 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:04:39 <mwhahaha> currently the agenda is empty. anyone have something they want to bring up?
14:06:31 <mwhahaha> sounds like no
14:06:45 <mwhahaha> moving
14:06:51 <mwhahaha> #topic Squad status
14:06:51 <mwhahaha> ci
14:06:51 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:06:51 <mwhahaha> upgrade
14:06:51 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:06:52 <mwhahaha> edge
14:06:52 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:06:53 <mwhahaha> integration
14:06:53 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:06:54 <mwhahaha> validations
14:06:54 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:06:55 <mwhahaha> networking
14:06:55 <mwhahaha> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:07:04 <mwhahaha> cloudnull: is there a status etherpad or something for the transition squad?
14:07:29 <cloudnull> there is, let me grab a link
14:07:47 <cloudnull> #link https://etherpad.openstack.org/p/tripleo-ansible-agenda
14:08:09 <cloudnull> that will likely change / update once we get the storyboard bits going.
14:08:21 <mwhahaha> k sure let me know
14:08:36 <cloudnull> we ran into a couple issues with storyboard itself which are being resolved within the core project
14:09:09 <mwhahaha> sounds about right
14:09:33 <cloudnull> example -
14:09:34 <cloudnull> #link https://review.opendev.org/#/c/667275/
14:09:41 <cloudnull> but things are moving along
14:11:10 <cloudnull> with that pending, I've still been working off of the trello board - https://trello.com/b/tEjJlT3k/tripleo-ansible-content-import - though I'll be closing that down as soon as possible
14:11:37 <mwhahaha> sounds good, thanks
14:11:43 <mwhahaha> any other status related items?
14:11:44 <zbr|ruck> we should still adopt the use of standardized openstack-tox-molecule template (even if we just use it for parenting)
14:12:54 <mwhahaha> is there a reason not to?
14:15:11 <cloudnull> right now we cant in tripleo-ansible, that job requires docker and we have jobs which are not running in docker due to them needing access to the host. I commented on that in https://review.opendev.org/#/c/667171
14:17:36 <cloudnull> we are using the underlying parent molecule job "tox-molecule"
14:18:14 <zbr|ruck> cloudnull: that's good!
14:19:14 <mwhahaha> cool anything else?
14:19:19 <zbr|ruck> still the tox.ini connfig does not scale up to more runs. People should be able to add new molecule scenarios without having to define new jobs, or to edit tox.ini file.
14:20:50 <zbr|ruck> one thing that I observed over the weekend was that ``pytest --collect-only` was failing to run with some exceptions caused by molecule/tests/ being recognizeded as unittest. anyway, i it is an easy fix.
14:21:19 <zbr|ruck> once done, we should be able to list all scenarios with that command, and run individual one the same way we do with normal unittests.
14:23:53 <zbr|ruck> one thing that i am not sure about is about triggering tests only when we modify the roles, based on my own experience a role can broke over night without being touched, only because some external things were updated (os images, ansible version, repo content,...). Probably we want to assure that we always run all tests at least on gate. for check we can optimize.
14:24:16 <zbr|ruck> cloudnull: what do you think?
14:24:50 <cloudnull> maybe? I think we get that with the integrated gates.
14:25:53 <cloudnull> I disagree about the scalability of the config files and would argue that running all jobs on every change would be the scalability issue. we have tooling to add items to those files and have documented what's required.
14:26:23 <cloudnull> so it should be fairly straight forward to add things to the repo
14:27:09 <cloudnull> #link https://docs.openstack.org/tripleo-ansible/latest/contributing.html
14:27:28 <cloudnull> I think we can extend those docs to contain more detail, but its a good start
14:28:08 <openstackgerrit> Alex Schultz proposed openstack/tripleo-ci master: Make tripleo-ci-fedora-28-standalone non voting  https://review.opendev.org/666834
14:28:41 <zbr|ruck> cloudnull: what will happen when we will have 30-40 roles inside? are we going to have the same number of tox environments?
14:29:07 <cloudnull> probably
14:29:47 <cloudnull> there's no limit to the number of environments we could have and its not like its unmanageable
14:30:02 <zbr|ruck> i bet openstack-infra would be very upset of seeing this number of nodes allocated by zuul, we will be forced to wait 12h before starting these jobs.
14:30:12 <cloudnull> no.
14:30:31 <cloudnull> if you look at the recent changes only the jobs impacted by a given change run
14:31:31 <cloudnull> and the current longest gate job is <15 minutes
14:32:35 <mwhahaha> i also have concerns about the number of jobs in the tripleo-ansible role
14:32:47 <zbr|ruck> cloudnull: i am trying to explain the node-number-allocaton is an issue, not the length of a single molecule job (which is very short).
14:32:54 <mwhahaha> let's have a more in depth conversation about this in the metting on thursday
14:33:16 <zbr|ruck> i may not be a problem right now, but could easily become one. just wanted to raise awareness for the moment.
14:34:32 <mwhahaha> #action cloudnull, zbr|ruck, mwhahaha, et al have further discussions around tripleo-ansible molecule CI structure @ next transformation meeting
14:35:11 <cloudnull> ++
14:35:45 <mwhahaha> alright moving on for now
14:35:53 <mwhahaha> #topic bugs & blueprints
14:35:53 <mwhahaha> #link https://launchpad.net/tripleo/+milestone/train-2
14:35:53 <mwhahaha> For Train we currently have 25 blueprints and 527 (+8) open Launchpad Bugs. 527 train-2.  109 (+6) open Storyboard bugs.
14:35:53 <mwhahaha> #link https://storyboard.openstack.org/#!/project_group/76
14:36:12 <mwhahaha> so i asked infra to nuke the tripleo-ui storyboard items but it seems like it didn't work so i'll have to follow up with them
14:36:58 <mwhahaha> any other bug/blueprint related items?
14:39:36 <mwhahaha> sounds like no, moving on
14:39:37 <mwhahaha> #topic projects releases or stable backports
14:39:47 <mwhahaha> I think we did a few stable releases last week
14:40:12 <mwhahaha> Are there any backport related issues?
14:42:20 <mwhahaha> Ok moving on
14:42:23 <mwhahaha> #topic specs
14:42:24 <mwhahaha> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:42:58 <mwhahaha> fyi i -2'd the various open specs. If you need them unblocked before the next cycle, please let me know
14:43:45 <mwhahaha> #topic open discussion
14:43:48 <mwhahaha> any other items?
14:46:00 <bogdando> there is a topic for generating pdf docs https://review.opendev.org/#/q/topic:build-pdf-docs+(status:open+OR+status:merged)
14:46:39 <bogdando> I'm looking for TeX experts to shoot possible warnings off. I'm planning to add something similar for tripleo repos
14:47:01 <mwhahaha> ok thanks
14:47:14 <bogdando> It was surprisingly low amount of warnings for the python-tripleoclient pdf :)
14:47:25 <mwhahaha> pffft docs
14:47:27 <bogdando> this prolly means we are great on writing docs!
14:47:42 <mwhahaha> a likely story
14:47:52 <mwhahaha> actually i think we dynamically generate them for tripleoclient
14:48:06 <marios> nice bogdando this is one of the community goals right
14:48:12 <bogdando> yes, we are dynamically good as well
14:48:25 <marios> "pdf docs i mean " and community goals i mean voted as summmit
14:48:31 <bogdando> yea
14:48:32 <marios> s/as/at
14:49:08 * bogdando also wonders why cp fails in the tox commands
14:49:24 <bogdando> #link https://review.opendev.org/#/c/667159/
14:50:16 <bogdando> e.g. http://logs.openstack.org/59/601659/11/check/openstack-tox-docs/9edd585/job-output.txt.gz#_2019-06-25_10_28_45_710782
14:51:56 <mwhahaha> bogdando: it's quoted? or maybe the html is missing
14:52:18 <mwhahaha> it's likely the ' though
14:52:27 <bogdando> mwhahaha: magic
14:52:28 <mwhahaha> because /bin/cp: cannot stat 'doc/build/pdf/*.pdf': No such file or director
14:53:24 <bogdando> it works in the shell...
14:53:42 <bogdando> anyway we can follow up
14:53:42 <mwhahaha> yup works in devstack
14:53:46 <bogdando> :D
14:53:50 * mwhahaha trolls his way out
14:53:59 <mwhahaha> alright, anything else?
14:56:11 <mwhahaha> Sounds like no. Thanks everyone.
14:56:17 <mwhahaha> #endmeeting