13:00:06 <cloudnull> #startmeeting tripleo
13:00:07 <openstack> Meeting started Thu Jul 25 13:00:06 2019 UTC and is due to finish in 60 minutes.  The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:10 <openstack> The meeting name has been set to 'tripleo'
13:00:22 <cloudnull> #topic rollcall
13:00:24 <cloudnull> o/
13:01:53 <sshnaidm> o/
13:03:17 <sshnaidm> we had a doodle, are there any results from it?
13:03:32 <cloudnull> give a few more minutes for folks to trickle in
13:03:44 <cloudnull> This is our etherpad
13:03:47 <cloudnull> #link https://etherpad.openstack.org/p/tripleo-ansible-agenda
13:04:01 <cloudnull> meeting minutes from last week
13:04:03 <cloudnull> #link http://eavesdrop.openstack.org/meetings/tripleo/2019/tripleo.2019-07-18-13.01.html
13:04:24 <cloudnull> sshnaidm we do have the results. I just closed the doodle this morning
13:04:25 <apetrich> o/
13:04:45 <cloudnull> so lets just jump into it
13:04:46 <cloudnull> #topic recap from past week
13:04:57 * cloudnull cloudnull to start porting hiera roles, for real this time
13:05:07 <cloudnull> this is in progress.
13:05:15 <fultonj> o/
13:05:23 <cloudnull> I dont have a review up, however I am working on the roles and will have something up later this afternoon
13:05:33 * cloudnull cloudnull to send a message to the ML w/ a doodle so we can nail down an appropriate meeting time that works for more folks
13:05:46 <cloudnull> #link https://doodle.com/poll/nkkqnkarhbgp8cxr?utm_campaign=poll_added_participant_admin&utm_medium=email&utm_source=poll_transactional&utm_content=gotopoll-cta#table
13:06:26 <cloudnull> so both Wednesday and Friday at 1400 UTC won
13:06:46 <cloudnull> so with the people here, what day will we choose ?
13:07:45 <ekultails> I know we have a handful of folks whose weekend is Friday and Saturday. Maybe Wednesday then?
13:07:52 <cloudnull> #startvote what day will we run the meeting? Wednesday, Friday
13:07:53 <openstack> Begin voting on: what day will we run the meeting? Valid vote options are Wednesday, Friday.
13:07:54 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
13:08:09 <openstackgerrit> Martin Mágr proposed openstack/tripleo-heat-templates master: Remove fluentd composable service  https://review.opendev.org/668851
13:08:13 <cloudnull> ^ everyone please vote
13:08:26 <ekultails> #vote Wednesday
13:08:29 <cloudnull> #vote Wednesday
13:08:36 <apetrich> #vote Wednesday
13:08:42 <fultonj> #vote Wednesday
13:09:13 <cloudnull> that can happen in the background through the course of the meeting, so moving on.
13:09:15 * cloudnull mnaser to see about setting up acl-y stuff for cross project thing-a-me's
13:09:43 <cloudnull> There was a thread created, any traction so far, anything you need from us ?
13:09:50 <mnaser> I sent an email to the ML with some good feedback but apparently ACLS need an actual project to be assigned on
13:10:05 <d0ugal> Hey - sorry I am late.
13:10:06 <mnaser> So I'm thinking to look at which projects we can start with to do that
13:10:13 <cloudnull> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-July/007880.html
13:10:25 <sshnaidm> #vote Wednesday
13:10:39 <d0ugal> #vote Wednesday
13:10:53 <gchamoul> #vote Wednesday
13:10:54 <cloudnull> mnaser so which projects do you want to start with?
13:11:13 <cloudnull> openstack-ansible-os_tempest, ansible-config_template ?
13:11:46 <Tengu> #vote Wednesday
13:11:49 <cloudnull> does this mean those projects would be moved out of the old ACL and into this new one?
13:11:59 <cloudnull> or can projects exist in more than one ACL?
13:12:14 * cloudnull goes to actually read the thread
13:12:15 <mnaser> They can be in more than one
13:12:39 <mnaser> So rather than a group we just have two groups asded
13:12:41 <mnaser> Added
13:14:51 <cloudnull> ok
13:14:52 <cloudnull> cool
13:15:04 <cloudnull> so where do we go from here?
13:15:06 <owalsh> o/
13:15:26 <cloudnull> something mwhahaha and you need to work on? anything we can help with ?
13:17:53 <cloudnull> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-July/007884.html
13:18:04 <owalsh> mnaser: hey, wondering what I should do with the ssh plugin. I'll get a patch ready soon for it to work with tripleo but wondering where it should live
13:18:44 <cloudnull> it looks like tripleo-ansible-core == tripleo-core, mwhahaha does that need to change?
13:19:21 <mwhahaha> I don't think it does
13:19:21 <cloudnull> moving on to our last carried action item
13:19:34 <cloudnull> OK
13:19:37 <mwhahaha> we can evaluate it later if needed
13:19:42 <cloudnull> +1
13:19:46 * cloudnull sshnaidm to look into ARA
13:20:06 <cloudnull> there was some discussion that happened post meeting last week
13:20:08 <sshnaidm> cloudnull, I think we discussed it in prev weel
13:20:33 <cloudnull> OK
13:21:19 <cloudnull> So that's all the structured topics I have
13:21:21 <cloudnull> #topic Open Discussion
13:21:29 <cloudnull> Open Reviews in need - https://review.opendev.org/#/q/project:%255Eopenstack/tripleo-ansible+status:open+label:verified%253D%252B1%252Cuser%253Dzuul
13:21:29 <cloudnull> Initial THT2TA work in need of reviews - https://review.opendev.org/#/q/topic:THT2TA+(status:open+OR+status:merged)
13:21:55 <cloudnull> work on porting things is going well ^
13:22:10 <cloudnull> if folks have time to review those things, it'd be great
13:22:27 <cloudnull> owalsh mnaser - want to talk about the connection plugin bits ?
13:22:45 <cloudnull> right now the connection plugin lives in openstack-ansible-plugins, should that change?
13:23:24 <cloudnull> #link https://opendev.org/openstack/openstack-ansible-plugins/src/branch/master/connection/ssh.py
13:23:49 <owalsh> cloudnull: yea, that's what I'm wondering. I'd rather not carry around a copy for tripleo
13:24:28 <mwhahaha> we could probably use that, but we'd just have to package it
13:24:36 <cloudnull> we could always pull in that repo / package
13:25:00 <owalsh> cloudnull: possibly, although I don't think we want/need anything else from it
13:25:39 <cloudnull> there are other plugins and filters in that repo.
13:26:11 <cloudnull> so potentially we'd have to move it outside , kinda like what we did with the config_template plugin (it used to live in the general plugins repo)
13:26:35 <cloudnull> but that's mnaser's call ^
13:26:46 <owalsh> cloudnull: where was the config_template plugin moved to?
13:26:50 <openstackgerrit> Cédric Jeanneret (Tengu) proposed openstack/tripleo-validations master: Correct "repos" validation and adds Molecule tests  https://review.opendev.org/672722
13:27:02 <mnaser> We should do that imho
13:27:09 <cloudnull> #link https://opendev.org/openstack/ansible-config_template
13:27:18 <cloudnull> ^ owalsh
13:27:18 <mnaser> I don't know if I have time to do it but
13:27:25 <mnaser> I'd be happy if someone did that
13:27:39 <cloudnull> owalsh is that something maybe you'd want to take on ?
13:27:54 <cloudnull> I'd be happy to help get it packaged.
13:28:10 <cloudnull> once infra creates the repo
13:28:14 <owalsh> cloudnull: sure, if you can point me in the right direction
13:28:23 <cloudnull> ++ happy to
13:28:49 <cloudnull> #action owalsh and cloudnull to get the osa connection plugin into a standalone repo and packaged
13:29:05 <owalsh> sweet, thanks cloudnull mnaser
13:29:52 <cloudnull> owalsh for now, until it gets moved out, if you put up your changes into openstack-ansible-plugins, and we can get them reviewed
13:30:00 <owalsh> cloudnull: ack
13:30:12 <owalsh> mnaser: oh, the issue with remote_tmp was PEBCAK... I didn't notice a typo in the yaml
13:30:15 <cloudnull> we can also pull the plugins down for test in tripleo-ansible until it gets packaged
13:30:51 <cloudnull> #link https://github.com/openstack/tripleo-ansible/blob/master/tripleo_ansible/ansible-role-requirements.yml
13:31:02 <owalsh> cloudnull: cool, it would be good to get some coverage for the tripleo env as we don't ssh as root
13:31:32 <cloudnull> so hopefully we can get it well tested for our usecases as we start the process of moving things around
13:31:51 <cloudnull> does anyone else have something they want to talk about?
13:32:06 <cloudnull> #endvote
13:32:07 <openstack> Voted on "what day will we run the meeting?" Results are
13:32:08 <openstack> Wednesday (8): fultonj, sshnaidm, Tengu, d0ugal, cloudnull, ekultails, apetrich, gchamoul
13:32:26 <sshnaidm> \o/
13:32:27 <cloudnull> ^ so the next meeting will be Wednesday at 14:00 UTC
13:32:56 <cloudnull> #action cloudnull to send a note to the ML about the new meeting itme
13:32:58 <cloudnull> **time
13:33:11 <d0ugal> 👍
13:33:37 <owalsh> cloudnull: so an hour later?
13:33:52 <fultonj> owalsh: and a day earlier
13:34:09 <owalsh> fultonj: yea, I got that :-)
13:34:10 <fultonj> relating to tripleo-ansible, requesting review of https://review.opendev.org/#/c/668294 to add molecule structure to tripleo-ceph-* roles
13:34:32 <cloudnull> ++ that would be wonderful to get in
13:35:13 <cloudnull> gets the molecule structure in for all of our ceph roles
13:36:04 <cloudnull> as a reminder - we do have quite a few stories on the board. If anyone wants to work on anything there, please help yourself :)
13:36:06 <cloudnull> #link https://storyboard.openstack.org/#!/board/174
13:36:49 <cloudnull> The bits here all could do with some review from our cores -
13:36:51 <cloudnull> #link https://storyboard.openstack.org/#!/worklist/684
13:37:40 <cloudnull> anything else folks want to talk about ?
13:38:29 <cloudnull> I've love to see this move along too, if at all possible
13:38:30 <cloudnull> #link https://review.opendev.org/#/c/671107
13:40:03 <cloudnull> OK, if there's nothing else I think we can wrap this up.
13:40:30 <cloudnull> Reminder, the next meeting will be Wednesday @ 14:00 UTC
13:40:37 <cloudnull> #endmeeting