14:01:15 <cloudnull> #startmeeting tripleo
14:01:17 <openstack> Meeting started Wed Aug 14 14:01:15 2019 UTC and is due to finish in 60 minutes. The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:20 <openstack> The meeting name has been set to 'tripleo'
14:01:23 <cloudnull> #topic rollcall
14:01:26 <cloudnull> o/
14:01:29 <owalsh> o/
14:01:48 <cloudnull> welcome everyone to another exciting wednesday meeting :)
14:01:54 <mnaser> allo
14:02:37 <ekultails> o/
14:03:00 <sshnaidm> o/
14:03:43 <cloudnull> give a minute more before diving in
14:05:29 <cloudnull> ok
14:05:30 <cloudnull> #topic Recap
14:05:37 <cloudnull> ccamacho and ekultails to sync up on creating some more general molecule documentation within integrated tripleo
14:05:42 <cloudnull> anything to report on that ?
14:07:50 <cloudnull> we'll come back to that .
14:07:54 <cloudnull> owalsh and cloudnull to get the osa connection plugin into a standalone repo and packaged
14:07:55 <ekultails> Nothing from my end, no. Let me make an Etherpad now and then we can throw ideas into there to at least get the ball rolling on it.
14:08:11 <cloudnull> ekultails thanks!
14:08:14 <cloudnull> we did pull the plugin bits out and into a stand alone repo
14:08:21 <cloudnull> #link https://github.com/cloudnull/ansible-plugin-connection
14:08:22 <cloudnull> I think we need to coordinate with mnaser on naming and getting it imported.
14:08:38 <mnaser> yeah, i thought it was a bit meh to call it that, seems super generic, but i dont have a better idea
14:08:51 * cloudnull is terrible at naming things
14:09:20 <cloudnull> I'd be happy to have it named $whatever
14:09:34 <mnaser> thinking out loud maybe
14:09:42 <mnaser> ansible-plugin-container_connection
14:09:44 <mnaser> or something nicer
14:09:53 <cloudnull> +1 from me
14:09:57 <cloudnull> owalsh ekultails ?
14:10:08 <owalsh> I'll never type that properly with mixed - and _ :-)
14:10:39 <cloudnull> ansible-plugin-container-connection ?
14:10:54 <ekultails> I'm not very creative either. :-) That works. ^
14:11:09 <owalsh> sure, if we're only using this for the ssh plugin
14:11:28 <mnaser> sure
14:11:34 <mnaser> i like ansible-plugin-container-connection
14:11:56 <cloudnull> #action cloudnull - rename stand alone connection repo for import s/ansible-plugin-connection/ansible-plugin-container-connection/
14:12:01 <cloudnull> will do
14:12:09 <mnaser> (we should totally at some point get help from the ansible team on making this stuff as collections btw)
14:12:16 <mnaser> i got the openstack_ansible namespace in galaxy :)
14:12:21 <cloudnull> nice!
14:12:36 <mnaser> so that might make it easier to consume together for the future!
14:12:43 <cloudnull> +1
14:13:11 <cloudnull> I've not used collections in anger just yet, however, I suspect they're going to help a lot.
14:13:28 <cloudnull> especially when shipping plugins
14:13:36 <ykarel|away> mwhahaha, so i checked in Fedora, env_path == 'OS::Heat::None' is working fine with python3
14:13:43 <mwhahaha> k
14:13:45 * cloudnull at least I hope they will
14:14:03 <cloudnull> mnaser so what are our next steps to getting that repo imported ?
14:14:25 <mnaser> cloudnull: i mean we can skip the github rename
14:14:35 <mnaser> and i can just get the repo imported with a new name
14:14:36 <cloudnull> already done :)
14:14:39 <cloudnull> #link https://github.com/cloudnull/ansible-plugin-container-connection
14:14:40 <mnaser> oh fair enough
14:15:36 <Tengu> thank you hjensas and mwhahaha :)
14:15:45 <mnaser> i will push up a patch now
14:15:46 <Tengu> now crossing finger - hopefully gate won't crash.
14:16:21 <cloudnull> also just to mention, I kept all of the git history surrounding that file, just created a new repo from the subdirectory. so the osa team contributions to the plugin wont be lost, and if anything goes into the original repo we can cleanly patch it
14:17:38 <openstackgerrit> Jose Luis Franco proposed openstack/tripleo-validations master: Set undercloud-connection to local by default https://review.opendev.org/653937
14:17:39 <openstackgerrit> Jose Luis Franco proposed openstack/tripleo-validations master: Add undercloud_key_file option in tripleo-ansible-inventory. https://review.opendev.org/676415
14:17:41 <cloudnull> anything else we need for that plugin ?
14:17:58 <cloudnull> I think the next steps, once imported, will be to get the CI back up and running .
14:18:10 <openstackgerrit> Luca Miccini proposed openstack/puppet-tripleo stable/rocky: Extend fencing to hosts using fence_rhevm agent. https://review.opendev.org/676416
14:18:22 <openstackgerrit> Luca Miccini proposed openstack/puppet-tripleo stable/queens: Extend fencing to hosts using fence_rhevm agent. https://review.opendev.org/676417
14:19:39 <ekultails> owalsh, cloudnull: Here are my scratch notes surrounding some generic Molecule documentation: https://etherpad.openstack.org/p/tripleo-molecule-docs
14:19:51 <ekultails> We can expand upon this and get it merged into the upstream docs over the coming weeks.
14:20:36 <cloudnull> #link https://etherpad.openstack.org/p/tripleo-molecule-docs
14:20:39 <cloudnull> ekultails thanks!
14:20:46 <cloudnull> ok moving on.
14:20:51 <cloudnull> #topic Open Discussion
14:20:57 <cloudnull> Last of the tripleo-common role import work is ready for review. There is only one change, to remove the old bits and we're out of tripleo-common.
14:21:06 <cloudnull> #link https://review.opendev.org/#/c/673366/
14:21:31 <cloudnull> if we could get some eyes on that, it'd be great.
14:22:13 <cloudnull> Open Reviews in need
14:22:13 <cloudnull> #link https://review.opendev.org/#/q/project:%255Eopenstack/tripleo-ansible+status:open+label:verified%253D%252B1%252Cuser%253Dzuul
14:22:46 <cloudnull> The THT2TA work is progressing nicely.
14:22:49 <cloudnull> THT2TA work in need of reviews
14:22:49 <cloudnull> #link https://review.opendev.org/#/q/topic:THT2TA+(status:open)
14:22:57 <openstackgerrit> Francesco Pantano proposed openstack/puppet-tripleo master: [WIP] Remove ceph_rgw_enabled dependency to keystone https://review.opendev.org/676418
14:23:00 <openstackgerrit> Francesco Pantano proposed openstack/tripleo-ansible master: [WIP] Add tripleo keystone generic resource role https://review.opendev.org/676419
14:23:38 <cloudnull> this change could use some eyes as well
14:23:39 <cloudnull> #link https://review.opendev.org/#/c/674414/
14:23:50 <openstackgerrit> Francesco Pantano proposed openstack/tripleo-heat-templates master: WIP/DNM: Create swift user for RGW in keystone without puppet-ceph https://review.opendev.org/655232
14:24:01 <cloudnull> is there anything anyone wanted to talk about?
14:24:08 <ekultails> For anyone who wants to help out with the effort I got some docs for how to convert Heat templates to Ansible roles. It's based on my experiences so far and great feedback from cloudnull. As I encounter new gotchas I keep updating the doc.
14:24:11 <ekultails> #link https://etherpad.openstack.org/p/tripleo-heat-to-ansible
14:24:21 <cloudnull> ++
14:24:50 <ekultails> I have one last thing to bring up.
14:24:57 <owalsh> cloudnull, ekultails: for the sshd role would it make sense to split the config generation from the service/pgk mgmt?
14:24:57 <cloudnull> fire away
14:25:11 <openstackgerrit> Luca Miccini proposed openstack/tripleo-common stable/queens: Enable staging-ovirt (fence_rhevm) fencing agent. https://review.opendev.org/676420
14:25:24 <mnaser> #link https://review.opendev.org/676421
14:25:54 <ekultails> cloudnull: It seems like a lot of roles depend on the upcoming tripleo-firewall role. Maybe we can get some docs on how to use that properly?
14:25:56 <ekultails> #link https://review.opendev.org/#/c/675245/
14:26:01 <mnaser> mwhahaha: ^ be nice if you wanna give a ptl +1 as a first potential collaborative repo/project
14:26:39 <mwhahaha> k
14:27:06 * mnaser just thought of a topic to add at the end of the discussion
14:27:22 <cloudnull> ekultails like so https://logs.opendev.org/45/675245/6/check/tripleo-ansible-docs/4c2a8a3/html/roles/role-tripleo-firewall.html
14:27:22 <ekultails> owalsh: I'm not exactly sure what you mean.
14:27:25 <cloudnull> or more than that?
14:28:26 <owalsh> ekultails: we will eventually need to reuse the sshd_config tasks for the nova migration container
14:28:55 <ekultails> cludnull: That looks great! Already one step ahead. ;-)
14:29:07 <ekultails> cloudnull *
14:29:43 <cloudnull> sadly those docs dont technically exist yet, the base change will need to merge before they're actually generated.
14:30:33 <owalsh> ekultails: ...once we figure out how to handle containerized services. Maybe not worth considering yet
14:30:37 <cloudnull> just for transparency, these are all the touchpoints for the firewall role - https://storyboard.openstack.org/#!/worklist/714
14:30:41 <cloudnull> #link https://storyboard.openstack.org/#!/worklist/714
14:30:58 <cloudnull> I created a storyboard worklist, which im marching though slowly.
14:31:13 <cloudnull> mnaser what's on your mind ?
14:31:58 <mnaser> so just thinking out loud in terms of governance and all, it seems like it's hard to find ownership or a "home" for the work we'll do together, its either tripleo or osa, and the projects are far from behind owned by a same ptl
14:32:11 <openstackgerrit> Francesco Pantano proposed openstack/tripleo-docs master: Fix mispelling on ceph include/exclude section https://review.opendev.org/676426
14:32:22 <mwhahaha> would be more of a working group then?
14:32:31 <mnaser> yeah
14:32:35 <mnaser> thats what i was thinking actually
14:32:41 <openstackgerrit> Francesco Pantano proposed openstack/tripleo-docs master: Fix mispelling on include/exclude list https://review.opendev.org/676426
14:32:43 <mnaser> ansible-wg or something like that
14:32:45 <openstackgerrit> Jose Luis Franco proposed openstack/python-tripleoclient master: Pass undercloud's private key to inventory used in package_update. https://review.opendev.org/676427
14:32:47 <openstackgerrit> Ronelle Landy proposed openstack/tripleo-quickstart master: DNM - Testing dlrn_base URL set to nodepool proxy https://review.opendev.org/676229
14:33:40 <ekultails> owalsh: So you'd want us to avoid installing the openssh-server package via the tripleo-ssh role? And instead only configure the sshd service? That could be reasonable, I don't believe the original Heat template even handled installing the package. Or we can make installing the package configurable.
14:33:46 <mnaser> sigs can also own repos
14:34:00 <mnaser> so a ansible-sig seems like it would be neat and would still be under governance here.. https://github.com/openstack/governance/blob/2584fec8815fdaa82fa0c49d8979ca0acd2ed996/reference/sigs-repos.yaml
14:34:03 <mnaser> with different chairs
14:35:03 <mnaser> so i could do something like propse the creation of ansible-sig inside openstack: https://github.com/openstack/governance-sigs/blob/master/sigs.yaml
14:35:16 <mwhahaha> that might make sense
14:35:51 <owalsh> ekultails: puppet *might* have handled the pkg/service stuff on baremetal (usually just for updates IIRC), but we disable all of that anyway for containerized services using puppet tags
14:36:08 <mnaser> so if it makes sense, i can take care of doing that
14:36:22 <mnaser> i can volunteer to be chair from OSA side and happy to have someone from tripleo side (dont wanna sign anyone up for work :])
14:37:07 <mnaser> we're noit limited by # of chairs so if anyone wants to get involved, that'd be better
14:37:09 <cloudnull> I'd be more than happy co-chair / help
14:37:41 <owalsh> ekultails: for containers we just want the config file, should already have the pkg from the Dockerfile build
14:37:54 <mnaser> ok i can take an action item to push up a new sig creation patch
14:38:02 <cloudnull> mnaser might be worth an ML post to get folks interested in participating?
14:38:10 <mnaser> yep ill push up the initial patch and send ML post
14:38:29 <ekultails> owalsh: Okay, thanks for the clarification. I'll get my tripleo-ssh role patches updated after this meeting to help address your concerns.
14:38:44 <mnaser> cloudnull: got a fav email for me to list down there (or preferebly the one listed at osf?)
14:39:03 <owalsh> ekultails: but maybe not worth putting any effort into this yet, till we figure out how to deal with containerized services....
14:39:16 <cloudnull> mnaser osf email works
14:39:33 <mnaser> cloudnull: which is? dont think thats available publicly :p
14:39:48 <ekultails> owalsh: The changes should be minimal so it's not a big deal.
14:40:05 <cloudnull> mnaser dm'd
14:40:28 * cloudnull doesn't need more spam in my inbox :)
14:41:41 <owalsh> ekultails: ack
14:43:02 <Vorrtex> Hey all, I got a bunch of +2's and +1's on this small docs review, was wondering if there is a waiting period to get it merged or if that can happen soon? https://review.opendev.org/#/c/675678/
14:43:30 <cloudnull> ok, anything else we want to talk about ?
14:44:02 <mnaser> fwiw: https://review.opendev.org/676428
14:44:08 <mnaser> i will email the ML too for other interested parties
14:45:27 <cloudnull> excellent !
14:45:30 <cloudnull> thanks mnaser
14:45:46 <cloudnull> welp, I think if there's nothing else, we can end here.
14:45:49 <cloudnull> thanks everyone !
14:45:52 <cloudnull> #endmeeting