14:01:12 <cloudnull> #startmeeting tripleo
14:01:13 <openstack> Meeting started Wed Sep  4 14:01:12 2019 UTC and is due to finish in 60 minutes.  The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:16 <openstack> The meeting name has been set to 'tripleo'
14:01:21 <cloudnull> Welcome everyone to the Transformation Squad weekly meeting
14:01:41 <cloudnull> Quick reminder for our useful links
14:01:41 <cloudnull> Etherpad
14:01:41 <cloudnull> #link https://etherpad.openstack.org/p/tripleo-ansible-agenda
14:01:41 <cloudnull> Work-board
14:01:41 <cloudnull> #link https://storyboard.openstack.org/#!/board/174
14:01:42 <cloudnull> Project
14:01:43 <cloudnull> #link https://storyboard.openstack.org/#!/project/openstack/tripleo-ansible
14:01:47 <cloudnull> #topic roll-call
14:01:49 <cloudnull> o/
14:01:55 <fultonj> o/
14:01:57 <dpeacock> o/
14:02:01 <Tengu> o/
14:04:31 <cloudnull> I think there's quite a few folks on PTO/AFK/or otherwise head down today, so lets just jump into it. It should be a quick one.
14:04:40 <cloudnull> #topic recap
14:04:41 <cloudnull> mnaser - Are we in a place where we can unblock this one?
14:04:42 <cloudnull> #link https://review.opendev.org/#/c/676421
14:04:54 <cloudnull> I think the Ansible-Sig work is underway
14:04:59 <cloudnull> -cc weshay
14:05:14 <cloudnull> is there anything we can help out with to get that review unblocked?
14:05:15 <weshay> aye
14:06:12 <cloudnull> I seems like there's interest between most of the folks using ansible, in openstack, so it'd be lovely if we can make that go.
14:06:16 <sshnaidm|ruck> is ansible-plugin-container-connection a wrapper for podman/docker connection plugin?
14:06:38 <cloudnull> otherwise, owalsh have you been able to get your changes into the current openstack-ansible-plugins repo ?
14:07:03 <owalsh> cloudnull: o/ no, just back from PTO
14:07:22 <cloudnull> sshnaidm|ruck yes. it allows you to run ansible native tasks in a container, as if you were connecting to the container through regular inventory means
14:07:48 <cloudnull> when using that plugin the host becomes a bastion
14:08:08 <cloudnull> owalsh no worries. just checking-in
14:08:15 <sshnaidm|ruck> cloudnull, ack
14:09:03 <cloudnull> I'm not sure mnaser is around at the moment, I'll see about taking that off-line, maybe send something to the ML as needed.
14:09:20 <cloudnull> #action cloudnull to follow up on getting the connection plugin bits into a stand-alone repo
14:09:34 <cloudnull> Open Reviews in TripleO-Ansible in need of feedback
14:09:34 <cloudnull> #link https://review.opendev.org/#/q/project:%255Eopenstack/tripleo-ansible+status:open+label:verified%253D%252B1%252Cuser%253Dzuul
14:09:34 <cloudnull> THT2TA reviews in need of feedback
14:09:34 <cloudnull> https://review.opendev.org/#/q/topic:THT2TA+(status:open)
14:09:45 <cloudnull> lots of great work has gone into tripleo-ansible recently.
14:09:53 <cloudnull> thank you everyone!
14:10:10 <cloudnull> If folks have some time to do some reviews they'd be greatly appreciated
14:10:19 <openstackgerrit> Carlos Camacho proposed openstack/tripleo-ansible master: Include the ansible role to run the backup and restore feature  https://review.opendev.org/678864
14:10:28 <cloudnull> #topic open-discussion
14:10:41 <cloudnull> anything anyone wants talk about ?
14:11:32 <owalsh> cloudnull: was wondering if tripleo-ansible is the best place for this https://review.opendev.org/676252
14:11:41 * cloudnull looking
14:12:03 <cloudnull> yes I think so
14:12:23 <fultonj> fyi for edge deployments with more than one stack unified inventory is possible with these two patches
14:12:26 <fultonj> https://review.opendev.org/#/q/topic:bp/split-control-plane-unified-inventory
14:12:31 <fultonj> #link https://review.opendev.org/#/q/topic:bp/split-control-plane-unified-inventory
14:13:09 <fultonj> How does it work? http://paste.openstack.org/show/770142/
14:13:10 <fultonj> What does the merged inventory look like? http://paste.openstack.org/show/770143/
14:13:11 <cloudnull> that module would become available to all of tripleo given the tripleo-ansible package is part of the default installation dependencies
14:14:05 <owalsh> cloudnull: ack. As it more of a day 2 ops use case I wasn't sure...
14:14:29 <cloudnull> owalsh +1 from me. I think it fits perfectly and would be well documented.
14:14:49 <owalsh> cool
14:14:56 <cloudnull> fultonj split inventory very cool !
14:15:11 <fultonj> thanks
14:15:18 * cloudnull will spend some time reviewing those things
14:17:04 <cloudnull> owalsh in case folks are wondering what the generated docs would look like - https://logs.opendev.org/52/676252/2/check/tripleo-ansible-docs/c1c3c7e/html/modules/modules-nova_image_cache.html
14:17:41 <owalsh> cloudnull: ack, I saw that. Might need to include the default too :-)
14:18:17 <owalsh> and required/not
14:18:30 <cloudnull> ++ that'd be great!
14:18:30 <EmilienM> mwhahaha: have you seen that on centos7/tripleo-master? http://paste.openstack.org/show/ipvMyRFqt6ss5h1bp24g/
14:18:45 <cloudnull> what else, anything else going on interesting on the ansible / transformation front that folks want to highlight or talk about ?
14:18:51 <mwhahaha> EmilienM: yes
14:19:04 <mwhahaha> EmilienM: how was this executed?
14:19:48 <owalsh> cloudnull: I was wondering... is there a target role to transform e.g get all of the Compute services deployed using ansible first then worry about Controllers
14:19:49 <mwhahaha> https://review.opendev.org/#/c/677296/3/tripleoclient/utils.py@1935 should prevent that error
14:20:03 <mwhahaha> EmilienM: we might jsut need to try catch/ignore the reset failure
14:20:56 <cloudnull> owalsh there's not one yet. we've been focused on the baremetal side of our deployment tooling and have not really started in on the services yet
14:20:58 <cloudnull> #link https://storyboard.openstack.org/#!/worklist/711
14:21:19 <cloudnull> that's what's left on the baremetal conversions
14:21:26 <openstackgerrit> Sagi Shnaidman proposed openstack/tripleo-quickstart master: DNM: install ceph-ansible on rhel8  https://review.opendev.org/680007
14:21:34 <cloudnull> however, if you have a role in mind, or want to create one feel free to gets started.
14:21:44 <EmilienM> mwhahaha: what do you mean how it was executed?
14:21:48 <EmilienM> I ran openstack undercloud install
14:21:57 <mwhahaha> EmilienM: did you run it via ansible, manually, magic, etc?
14:22:00 <EmilienM> ah
14:22:03 <EmilienM> no, by hand
14:22:09 <EmilienM> my dirty hands!
14:22:14 <mwhahaha> ok i haven't hit that when you run it manually
14:22:19 <cloudnull> owalsh - there's nothing stopping us from going down the path of converting other services, we've just not started it yet
14:22:23 <mwhahaha> plz file a bug and we'll just catch/ignore it. i haven't hit that
14:22:27 <mwhahaha> i hit it in CI
14:22:28 <Tengu> mwhahaha, EmilienM : probably $TERM ?
14:22:41 <mwhahaha> so we added the isatty to skip it when executed via ansible
14:22:47 <mwhahaha> which cleared that error up
14:22:51 <owalsh> cloudnull: ack, expect it will be a lot of work to convert the openstack services but the compute services might be less work with no HA etc...
14:22:59 <EmilienM> Tengu: =xterm
14:23:02 <cloudnull> owalsh ++
14:23:21 <owalsh> still have a ton of logic buried in puppet and t-h-t though
14:23:34 <cloudnull> we do indeed
14:23:54 <cloudnull> that's where a lot of time will be spent
14:24:07 <Tengu> hm.. maybe puppet has some good parts we shouldn't drop?
14:24:32 <Tengu> I'm still convinced both tools (ansible and puppet) are a good duo
14:24:44 <cloudnull> however, if folks want to start exploring what the conversion would look like / be, I think we should encourage that
14:25:05 <Tengu> if it doesn't make things more complicated...
14:25:20 <Tengu> seeing haproxy things in puppet, I'm not sure ansible would be better, for instance
14:25:22 <EmilienM> mwhahaha: I'll file a bug ok
14:25:22 <cloudnull> Tengu I think we'll be in a spot for some time where the two tools will coexist and likely compliment one another.
14:26:29 <Tengu> cloudnull: yep. I'd rather see paunch being moved to roles/playbook, right now, in fact ^^'. After the issues we got, the weird things in the code making it hard to maintain/correct...
14:26:35 <Tengu> but that's another story ;)
14:27:41 <cloudnull> thats a good example of something we didn't consider initially, which may be beneficial , and could be worth exploring.
14:27:48 <Tengu> :)
14:27:52 <cloudnull> another one is `container-puppet`
14:28:01 <Tengu> it's in my head for 2-3 weeks now, to be fair.
14:28:18 <Tengu> right, that one is probably another good candidate.
14:28:27 <Tengu> and an easier one
14:28:38 <cloudnull> I started on `container-puppet` a while back and relized I didn't have a good enough grasp of all the surrounding tooling to get it done.
14:28:40 <Tengu> there's just the tiny issue with ansible and parallel runs though
14:28:47 <cloudnull> Its something I'd like to circle back on
14:29:06 <Tengu> cloudnull: we can collaborate on it if you're OK to wait 2 weeks?
14:29:14 <cloudnull> Tengu maybe using the "free" strategy would be useful here ?
14:29:15 <openstackgerrit> Douglas Mendizábal proposed openstack/tripleo-quickstart master: Fail when $VIRTHOST is localhost  https://review.opendev.org/672075
14:29:25 <cloudnull> Tengu ++ 2 weeks is good by me
14:29:26 <Tengu> cloudnull: I'll be off the next 2 weeks, back on 22nd or something
14:29:47 <Tengu> cloudnull: nice. So we'll work together on that one.
14:29:55 <cloudnull> #action Tengu cloudnull to collaborate on playbooks and roles for some of our embedded code
14:30:08 <cloudnull> ^ just to write it down so I dont forget :)
14:30:13 <Tengu> np :)
14:30:29 <cloudnull> what else we got ?
14:30:44 <openstackgerrit> Sorin Sbarnea proposed openstack/tripleo-ci master: Remove fetch-zuul-cloner workaround  https://review.opendev.org/665994
14:30:52 <Tengu> ah, there's a thing that would require Security involvement - certmonger.
14:31:08 <cloudnull> ++
14:31:11 <Tengu> moving it to ansible instead of puppet would allow to get some really fancy features, such as "per-container service".
14:31:26 <EmilienM> mwhahaha: https://bugs.launchpad.net/tripleo/+bug/1842677
14:31:27 <openstack> Launchpad bug 1842677 in tripleo "reset failed: reset: standard error: Inappropriate ioctl for device" [High,Triaged]
14:31:27 <Tengu> I've already pushed an RFE, but it will need some love and attention.
14:31:50 <Tengu> #link https://bugzilla.redhat.com/show_bug.cgi?id=1698957
14:31:51 <openstack> bugzilla.redhat.com bug 1698957 in openstack-tripleo-heat-templates "[RFE] Manage certmonger certificate via ansible instead of puppet" [Medium,New] - Assigned to cjeanner
14:31:57 <mwhahaha> EmilienM: were you in tmate or tmux or something?
14:32:18 <cloudnull> Tengu awesome !
14:33:42 <cloudnull> OK, well I think we can call it for the day. Thanks everyone !
14:33:45 <cloudnull> #endmeeting