14:00:47 <cloudnull> #startmeeting tripleo
14:00:48 <openstack> Meeting started Wed Sep 25 14:00:47 2019 UTC and is due to finish in 60 minutes.  The chair is cloudnull. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:51 <openstack> The meeting name has been set to 'tripleo'
14:01:06 <cloudnull> welcome to another tripleo-transformation meeting
14:01:27 <cloudnull> #topic rollcall
14:01:30 <cloudnull> o/
14:01:35 <owalsh> o/
14:01:37 <cloudnull> hows not here today? :)
14:01:43 <cloudnull> **who's
14:02:23 <ekultails> I'm here today :-)
14:03:35 <Tengu> I might be here :)
14:04:31 <d0ugal> Hey
14:04:38 * d0ugal is mostly here
14:04:40 <sshnaidm> o/
14:05:09 <cloudnull> well hopefully a couple more folks join in as we go.
14:05:19 <cloudnull> #topic recap
14:05:20 <cloudnull> Etherpad
14:05:20 <cloudnull> #link https://etherpad.openstack.org/p/tripleo-ansible-agenda
14:05:20 <cloudnull> Work-board
14:05:20 <cloudnull> #link https://storyboard.openstack.org/#!/board/174
14:05:21 <cloudnull> Project
14:05:22 <cloudnull> #link https://storyboard.openstack.org/#!/project/openstack/tripleo-ansible
14:05:23 <cloudnull> Open Reviews in need
14:05:24 <cloudnull> #link https://review.opendev.org/#/q/project:%255Eopenstack/tripleo-ansible+status:open+label:verified%253D%252B1%252Cuser%253Dzuul
14:05:25 <cloudnull> THT2TA work in need of reviews
14:05:26 <cloudnull> https://review.opendev.org/#/q/topic:THT2TA+(status:open)
14:05:40 <cloudnull> as a reminder, these are some of our useful links
14:06:01 <cloudnull> much of the work-board is on hold until we get train out the door.
14:07:06 <cloudnull> lots of stabilizing changes have gone into tripleo-ansible, which has been great. there are some open reviews, if folks have time to do some reviews it'd be greatly appreciated.
14:08:41 <cloudnull> cross project collaboration with the ansible-sig has started (-cc mnaser) and while early, looks very promising.
14:09:24 <cloudnull> #topic meeting schedule
14:09:54 <cloudnull> with the cycle well underway, and as we approach the end of the year, I wanted to know if folks think we should still be having this meeting weekly ?
14:10:19 <cloudnull> or if we should just roll up into the larger tripleo meeting, like the other squads ?
14:10:39 <ekultails> +1 for meeting conslidation
14:10:42 <EmilienM> o/
14:11:17 <cloudnull> early on there was a bit more participation as we were defining things, I think we're hitting a stride, so IDK if this meeting still makes sense ?
14:11:47 <cloudnull> sshnaidm d0ugal EmilienM Tengu owalsh?
14:12:11 <mnaser> i havent been around cause i've been busy with things but i've been watching from the sidelines :<
14:12:12 <sshnaidm> maybe separate part of tripleo meeting after it, because mixing all together could be confusing
14:12:21 <owalsh> I've a ton of PTO next month so +1
14:12:22 <d0ugal> cloudnull: I have not been good enough at attending to judge - was making a active attempt at improving that :)
14:12:34 <d0ugal> cloudnull: but if it fits into the tripleo meeting that would work for me
14:13:20 <cloudnull> sshnaidm there's a squad update part in the larger tripleo meeting, maybe we could just slot in there?
14:13:35 <EmilienM> +0 (not a fan of meetings in general, i like async work)
14:14:00 <cloudnull> I know there's a lot of meetings to attend, so maybe one less to keep track of is a good thing.
14:14:03 <cloudnull> what EmilienM said :)
14:14:11 <d0ugal> +1
14:14:23 <EmilienM> I like frequent updates on ML though
14:14:26 <sshnaidm> cloudnull, I think it's just posting links to etherpads :)
14:14:35 <EmilienM> like a journal and people can comment if needed
14:15:24 <cloudnull> +1
14:15:25 <sshnaidm> cloudnull, like we have "open discussion" in tripleo mtg we can have "ansible squad discussion" maybe
14:15:40 <cloudnull> +1
14:16:09 <cloudnull> I'll take an action item to write a weekly squad update and post it to the ML
14:16:27 <cloudnull> and I think we can halt this meeting for the time being.
14:16:42 <Tengu> +1 for what EmilienM said in fact
14:16:56 <openstackgerrit> Merged openstack/tripleo-common stable/stein: Add profile_tasks to ansible runs  https://review.opendev.org/684305
14:16:58 <cloudnull> if we get to a place where we think it makes sense to start having them again, I'd be happy to facilitate that
14:17:21 <Tengu> +42
14:17:22 <EmilienM> cloudnull: thanks
14:17:33 <cloudnull> #action the tripleo-ansible squad will post weekly updates to the ML to keep folks in the loop
14:17:34 <EmilienM> or maybe we can revive the TripleO Owl :D
14:17:43 <sshnaidm> EmilienM, yay! :)
14:17:54 <EmilienM> (i stopped writing it)
14:17:54 <Tengu> EmilienM: do you have new owl facts? :]
14:18:02 <EmilienM> Tengu: i always find new facts
14:18:07 <Tengu> :D
14:18:11 <cloudnull> #topic open discussion
14:18:20 <Tengu> owls are fact-inating
14:18:29 <EmilienM> ...
14:18:36 <Tengu> maybe a bad pun? ok.
14:18:37 <Tengu> ;)
14:19:00 <sshnaidm> I submitted a patch with podman_container module: https://review.opendev.org/#/c/682458/
14:19:08 <sshnaidm> but not sure what to do with it..
14:19:16 * cloudnull looking
14:19:31 <sshnaidm> it was merged in ansible and reverted later, because no idempotency for running containers
14:19:39 <EmilienM> sshnaidm: great start. We'll need it I think if we build a plan around replacing paunch
14:19:45 <cloudnull> sshnaidm nice!
14:20:03 <cloudnull> good update to that old podman module.
14:20:06 <sshnaidm> so I'll continue to work on it to have idepmpotency in running podman containers
14:20:31 <sshnaidm> and in ideal case to have it in ansible in some point..
14:20:43 <cloudnull> we also have podman_image and podman_image_facts in there
14:21:04 <sshnaidm> cloudnull, actually facts and image are parts of ansible now, so we can drop them I think
14:21:16 <sshnaidm> cloudnull, at least from 2.8
14:21:18 <EmilienM> ++ to remove them then
14:21:26 <cloudnull> to the best of my knowledge IDK if we use any of those modules in TripleO?
14:21:31 <cloudnull> sshnaidm +1
14:21:38 <sshnaidm> cloudnull, I don't think we use them anywhere
14:21:46 <EmilienM> we don't.
14:22:27 <sshnaidm> also I started a podman_pod module for ansible and maybe it can be helpful even more with paunch
14:22:56 <sshnaidm> it allows to operate podman containers in pods, seems like nice thing to have
14:22:58 <openstackgerrit> Kevin Carter (cloudnull) proposed openstack/tripleo-ansible master: Remove modules that have been up-streamed  https://review.opendev.org/684758
14:23:06 <cloudnull> ^
14:23:31 <EmilienM> yeah for now I would not spend time on pods but rather on how we can replace paunch by calling this new module
14:23:42 <cloudnull> +1
14:23:44 <EmilienM> sshnaidm: let's work on it together, i want to help on that front
14:23:48 <cloudnull> that sounds like a great idea
14:23:52 <sshnaidm> EmilienM, sure
14:24:07 <sshnaidm> and after pods it's just little move to kubernetes..
14:24:09 <cloudnull> that said, I think the paunch module is a good intermediate step
14:24:10 * sshnaidm hides
14:24:15 <EmilienM> what I mean to say is: spend time in pods if you want the community to use the new module but in tripleoitself, it's not critical now
14:24:28 <EmilienM> cloudnull: right
14:24:34 <sshnaidm> EmilienM, yeah, agree
14:24:43 <EmilienM> sshnaidm: you said the forbidden word
14:24:53 <sshnaidm> :8
14:25:12 <Tengu> pods? :D
14:25:20 <cloudnull> if we run a little kubernetes on it, everything will be perfect
14:25:35 <cloudnull> :D
14:25:56 <sshnaidm> 50 pullups for K-word
14:26:01 <cloudnull> hahahaha
14:26:16 <cloudnull> I think that's a burpees offence
14:26:28 <sshnaidm> it was big discussion about collections in ansible fest
14:26:43 <cloudnull> ++
14:26:45 <sshnaidm> seems like this is future "packages" of roles/libs/..
14:27:15 <sshnaidm> maybe point to think if we can use this in tripleo-ansible
14:27:25 <cloudnull> tripleo-ansiible, while not setup in an "ansible-collection" currently, its not a large leap.
14:28:38 <ekultails> Could be a good goal for the U release to get that reorganized.
14:28:43 <cloudnull> I think once they iron out the spec it might be worth our while
14:28:51 <openstackgerrit> Michele Baldessari proposed openstack/puppet-pacemaker master: WIP be able to change pcmk resource op defaults  https://review.opendev.org/664606
14:29:01 <sshnaidm> yeah, it's still under heave discussion about best practices
14:29:07 <sshnaidm> as I understood
14:29:32 <cloudnull> https://galaxy.ansible.com/docs/contributing/creating_collections.html -- doesn't look like its up-to-date
14:30:52 <sshnaidm> I read here: https://docs.ansible.com/ansible/devel/user_guide/collections_using.html
14:30:53 <cloudnull> ie still references mazer, which is deprecated in 2.9 - https://github.com/ansible/mazer
14:31:25 <cloudnull> oh I guess thats more up-to-date
14:32:08 <openstackgerrit> Michele Baldessari proposed openstack/puppet-tripleo master: WIP pcs resource op defaults  https://review.opendev.org/664612
14:34:24 <cloudnull> either way I think we wait for folks to work out a little more of the details before we move to collections
14:34:30 <cloudnull> sshnaidm you at ansible fest?
14:34:39 <sshnaidm> cloudnull, virtually :)
14:35:08 <cloudnull> ah, me too :)
14:37:45 <sshnaidm> btw, ara was built as rpm today, so maybe we'll have it soon in rdo repos, and then can think about using it in product
14:38:00 <sshnaidm> kudos to dmsimard ^^
14:38:07 <cloudnull> that's awesome!
14:39:38 <dmsimard> it's only in rawhide right now, should be in f31 and f30 in the near future -- haven't looked at epel8 or rdo yet
14:39:46 <dmsimard> but yes, it's been a long journey of chasing packaging rabbitholes
14:42:41 <sshnaidm> dmsimard++
14:43:32 <cloudnull> anything else folks want to talk about. otherwise I think we can wrap this meeting up
14:47:52 <cloudnull> thanks everyone, have a great rest of your day.
14:47:55 <cloudnull> #endmeeting