14:01:04 <weshay|ruck> #startmeeting tripleo
14:01:04 <weshay|ruck> #topic agenda
14:01:04 <weshay|ruck> * Review past action items
14:01:04 <weshay|ruck> * One off agenda items
14:01:04 <weshay|ruck> * Squad status
14:01:05 <weshay|ruck> * Bugs & Blueprints
14:01:06 <openstack> Meeting started Tue Jan 14 14:01:04 2020 UTC and is due to finish in 60 minutes.  The chair is weshay|ruck. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:07 <weshay|ruck> * Projects releases or stable backports
14:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:09 <weshay|ruck> * Specs
14:01:10 <openstack> The meeting name has been set to 'tripleo'
14:01:11 <weshay|ruck> * open discussion
14:01:13 <weshay|ruck> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:13 <Tengu> weshay|ruck: you'e one minute late, sorry :)
14:01:15 <weshay|ruck> Hey folks! who's around?
14:01:17 <fultonj> o/
14:01:18 <beagles> o/
14:01:19 <ekultails> o/
14:01:19 <weshay|ruck> DOH
14:01:20 <Tengu> after time, it's not time anymore
14:01:28 <weshay|ruck> #info ptl should not be late
14:01:33 * Tengu being the Swiss Guy
14:01:38 <tkajinam> o/
14:01:41 <owalsh> o/
14:01:43 <openstackgerrit> Bogdan Dobrelya (bogdando) proposed openstack/paunch stable/queens: Fix labels to take multiple values  https://review.opendev.org/702435
14:01:45 <Tengu> :]
14:01:51 <bogdando> \o
14:01:58 <marios> o/
14:02:05 <gchamoul> o/
14:02:06 <chandankumar> \o/
14:02:23 <weshay|ruck> put your hands in the aaaairrrrrrr
14:02:35 <EmilienM> o/
14:02:58 <rfolco> o/
14:03:00 <weshay|ruck> #topic review past action items
14:03:25 <weshay|ruck> #action remind the current ptl he has to close out bugs for the milestones
14:03:30 <weshay|ruck> thanks EmilienM
14:03:38 <EmilienM> lol
14:03:42 <weshay|ruck> ok.. agenda items
14:03:50 <weshay|ruck> #topic one off agenda items
14:03:50 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:03:55 <weshay|ruck> have a few today
14:04:25 <weshay|ruck> TripleO Rocky, to build or not to build..
14:04:25 <weshay|ruck> So... the delivery team has stopped importing Rocky
14:04:37 <arxcruz> o/
14:04:43 <rlandy> o/
14:04:44 <weshay|ruck> Does tripleo need to continue to support rocky builds?
14:04:50 <openstackgerrit> Bogdan Dobrelya (bogdando) proposed openstack/paunch stable/queens: Log to a file by default, unless debugging  https://review.opendev.org/702438
14:04:52 <weshay|ruck> thoughts, opinions
14:04:54 <weshay|ruck> ?
14:05:22 <EmilienM> have we asked on the ML?
14:05:29 <EmilienM> ah you did
14:05:30 <weshay|ruck> yes
14:05:40 <weshay|ruck> jpena, will RDO continue to build rocky?
14:05:42 <EmilienM> 4 days ago, and no feedback, maybe we want a couple of days
14:05:44 <EmilienM> wait*
14:05:46 <weshay|ruck> k
14:05:56 * weshay|ruck pauses here for a second
14:05:59 <jpena> weshay|ruck: is it EOL already?
14:05:59 <zbr> o/
14:06:04 <weshay|ruck> jpena, aye
14:06:06 <bogdando> imho not to build then wait for 4 days if not new bugs reported
14:06:09 <jpena> o_O
14:06:10 <bogdando> or no one cares
14:06:23 <weshay|ruck> there are plenty of active reviews
14:06:33 <marios> that means someone on queens can't upgrade to rocky any more. they have to go ffu (v2) onto train (13..16) ?
14:06:41 <EmilienM> are they active or lazy backports?
14:06:54 <weshay|ruck> I've seen active reviews
14:06:58 <EmilienM> meh :/
14:07:04 <weshay|ruck> but.. let's move this discussion the mailing list
14:07:15 <weshay|ruck> I may perhaps.. send out a GOING ONCE... GOING TWICE
14:07:17 <jpena> weshay|ruck: on RDO Trunk, we're still building packages all the way down to Ocata. If it helps, we can keep that
14:07:19 <weshay|ruck> as I like to do
14:07:44 <weshay|ruck> jpena, k.. just trying to understand if there is a requirement I (we) may be missing
14:07:48 <weshay|ruck> ok.. moving on
14:08:05 <weshay|ruck> So.. CentOS-7 is old as dirt...  next agenda item
14:08:15 <weshay|ruck> Ironic , python2 support dropped e.g https://review.opendev.org/#/c/696669/
14:08:28 <weshay|ruck> several projects are dropping python2.. you all know this..
14:08:47 <sshnaidm> most of them stop testing of python2..
14:08:48 <weshay|ruck> the RDO team is pinning ussuri builds to older builds to properly support python2
14:08:53 <weshay|ruck> aye
14:09:18 <weshay|ruck> Any questions about how python2 support is being maintained in CentOS-7?
14:09:22 <openstackgerrit> John Fulton proposed openstack/tripleo-validations master: Add pre/post ceph validation groups  https://review.opendev.org/702433
14:09:40 <weshay|ruck> I think the latest CentOS images support python3 by default...
14:10:09 <weshay|ruck> but at this time we're still using python2.. any reason for that to change ( as we're bringing up python3 on CentOS-8 )
14:10:11 <sshnaidm> is it really default there?
14:10:23 <weshay|ruck> the very latest qcow2 it seemed to be
14:10:28 <weshay|ruck> but double check me
14:10:53 <weshay|ruck> OK.. while we're talking about it..
14:11:03 <sshnaidm> if so, would be great, if no - maybe we can ensure it is, making it default in the image
14:11:13 <weshay|ruck> CentOS-8 container builds are coming up... marios is leading that effort.. please help review
14:11:28 <weshay|ruck> in general PLEASE HELP W/ REVIEWS
14:11:38 <weshay|ruck> ok..
14:11:44 <weshay|ruck> moving on...
14:11:51 <marios> weshay|ruck: info /links there https://tree.taiga.io/project/tripleo-ci-board/us/1440
14:12:05 * weshay|ruck throws a table.. in honor of mwhahaha and his next topic
14:12:16 <weshay|ruck> (mwhahaha) Tripleo-operator-ansible efforts
14:12:16 <weshay|ruck> Tracking etherpad: https://etherpad.openstack.org/p/tripleo-operator-ansible
14:12:16 <weshay|ruck> Feel free to grab a command an push a review. I've pushed undercloud/minion/container command patches and need reviews.
14:12:25 <EmilienM> yeah if anyone is willing to help on that effort
14:12:27 <weshay|ruck> mwhahaha, has sent out several emails on the list
14:12:29 <EmilienM> there is a nice etherpad
14:12:36 <weshay|ruck> w/ the design... etc
14:12:36 <EmilienM> and a lot of work :D
14:13:02 <EmilienM> It seems we agreed on the design, now Alex is driving the implementation
14:13:08 <weshay|ruck> Yes... to refresh.. we would like to set a goal of having a first pass at everything in that etherpad by the end of ussuri
14:13:14 <Tengu> gchamoul we can probably work on the validator thing :).
14:13:15 <weshay|ruck> aye
14:13:21 <EmilienM> Tengu: thanks
14:13:29 <Tengu> EmilienM: will give it a try.
14:14:14 <weshay|ruck> EmilienM, I think we can have a running agenda item on that etherpad and it's status
14:14:18 <weshay|ruck> ack?
14:14:22 <EmilienM> ++
14:14:27 <weshay|ruck> rock on king kong
14:14:49 <weshay|ruck> #topic Squad status
14:14:49 <weshay|ruck> ci
14:14:49 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:14:49 <weshay|ruck> upgrade
14:14:49 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:14:50 <weshay|ruck> edge
14:14:52 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:14:54 <weshay|ruck> integration
14:14:56 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:15:00 <weshay|ruck> validations
14:15:02 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:15:04 <weshay|ruck> networking
14:15:06 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:15:08 <weshay|ruck> transformation
14:15:10 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-ansible-agenda
14:15:12 <weshay|ruck> Looking for squad status
14:15:27 <weshay|ruck> CI...   as I said marios is leading CentOS-8 container builds.. that's the first step..  I am hoping to refresh master today :))
14:15:50 <weshay|ruck> Thanks to the neutron team for patching a few issues that have blocked us!!!
14:16:06 <marios> weshay|ruck: panda currently running test train promotion and then if that completes re-enable promotion server
14:16:17 <weshay|ruck> Upgrades? marios ccamacho ?  how is standalone-upgrade in train?
14:16:45 <marios> weshay|ruck: you may be aware i've not worked @ upgrades for a while ppp
14:16:46 <weshay|ruck> who is on the edge squad?
14:17:01 <weshay|ruck> cloudnull, any tripleo-ansible updates?
14:17:01 <marios> weshay|ruck: "Add standalone upgrade job for train" Change-Id: I03f0171a289f42437c3c9239f05d22168f5e2e87 * https://review.opendev.org/#/c/701983/1
14:17:09 <weshay|ruck> d0ugal, apetrich any mistral updates?
14:17:16 <marios> weshay|ruck: patch from matbu
14:17:26 <marios> weshay|ruck: job wasn't running ther elast time i checked though needs revisit
14:17:34 <weshay|ruck> Tengu, any validation work to highlight?
14:17:55 <weshay|ruck> marios, think he has two .. one to get that job triggered appropriately
14:17:59 <slagle> weshay|ruck: not much going on for the edge squad tbh
14:18:05 <apetrich> weshay|ruck, we have moved into ansible runner instead of just calling ansible by hand
14:18:09 <weshay|ruck> slagle, k.. thanks :)
14:18:13 <Tengu> weshay|ruck: nope, not really, work as usual, but more is coming.
14:18:21 * fultonj wants to add a question about RDO 3rd party CI to the agenda
14:18:36 <weshay|ruck> fultonj, ok.. go for it
14:18:37 <apetrich> weshay|ruck, there are still some issues with that but we are following up on that
14:18:41 <Tengu> weshay|ruck: currently discussing about packaging in order to empower other teams to maintain and provide their own validation package.
14:18:50 <openstackgerrit> Gael Chamoulaud proposed openstack/tripleo-validations master: Add pre/post ceph validation groups  https://review.opendev.org/702433
14:18:54 <weshay|ruck> Tengu, makes sense
14:19:16 <fultonj> RDO 3rd party CI is often red. should we be re-checking to get it green before +2'ing?
14:19:32 <weshay|ruck> arxcruz, chandankumar FYI ^
14:19:55 <fultonj> (not blind rechecking)
14:19:58 <weshay|ruck> fultonj, I think the same workflow applies, but as w/ upstream.. we want to make sure those jobs are VERY stable
14:20:23 <weshay|ruck> so let's give it a week or two.. to make sure that is the case before we block patches from ceph-ansible
14:20:30 <sshnaidm> fultonj, you can recheck only 3party by "check-rdo" message
14:20:44 <weshay|ruck> FYI....  ceph-ansible and libpod in github are now checked by tripleo prior to merge
14:20:51 <EmilienM> woot!
14:20:58 <Tengu> woohoo
14:21:06 <fultonj> yay for github checks
14:21:08 <weshay|ruck> if there are other 3rd party dependencies to TripleO you would like checked... please send suggestions to the list
14:21:11 <arxcruz> fultonj: just fix the ceph-ansible jobs, should be green for now :)
14:21:17 <fultonj> arxcruz: thks.
14:21:20 <arxcruz> unless you do something wrong of course :P
14:21:30 <fultonj> i wasn't asking about another issue w/ it
14:21:50 <weshay|ruck> OK..  anything else from the squads?
14:21:55 <weshay|ruck> going once
14:22:04 <weshay|ruck> going twice
14:22:15 <weshay|ruck> We're in Ussuri-2 people :)
14:22:16 <weshay|ruck> https://launchpad.net/tripleo/+milestone/ussuri-2
14:22:20 <chandankumar> I think podman jobs are fine
14:22:28 <weshay|ruck> Blueprints:
14:22:28 <weshay|ruck> 1 Unknown, 1 Started, 1 Good progress
14:22:28 <weshay|ruck> Bugs:
14:22:28 <weshay|ruck> 5 New, 17 Incomplete, 2 Invalid, 3 Won't Fix, 5 Confirmed, 346 Triaged, 113 In Progress, 37 Fix Released
14:22:41 <openstackgerrit> Emilien Macchi proposed openstack/tripleo-ansible master: tripleo-container-image: add |list to containers_commands  https://review.opendev.org/702320
14:23:00 <fultonj> valentines day is is the week of m2
14:23:18 <weshay|ruck> EmilienM, mwhahaha do we need to setup a bug triage for tripleo bugs? Think about that.. for next time.. I think it's a bit adhoc atm
14:23:20 <EmilienM> :-)
14:23:33 <weshay|ruck> aye.. 2020-02-14
14:23:41 <weshay|ruck> send flowers to EmilienM, he loves them
14:23:55 <weshay|ruck> Storyboard bugs.
14:23:55 <weshay|ruck> #link https://storyboard.openstack.org/#!/project_group/76
14:24:26 <weshay|ruck> I have not checked on the storyboard updates, ( updates to the project itself )
14:24:43 <weshay|ruck> #topic projects releases or stable backports
14:25:15 <weshay|ruck> going once
14:25:18 <weshay|ruck> going twice
14:25:26 <weshay|ruck> #topic specs
14:25:26 <weshay|ruck> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:25:58 <weshay|ruck> new spec to highlight from ekultails https://review.opendev.org/698828
14:26:34 <weshay|ruck> apetrich, d0ugal probably should get this one reviewed and merged as work is ramping up again https://review.opendev.org/679272
14:26:48 * weshay|ruck needs to triage those
14:26:51 <openstackgerrit> Brent Eagles proposed openstack/tripleo-common stable/queens: TEST: Fix octavia cert path if trailing slash omitted  https://review.opendev.org/702441
14:27:03 <apetrich> weshay|ruck, aye
14:27:08 <weshay|ruck> thanks
14:27:11 <weshay|ruck> OK...
14:27:11 <weshay|ruck> #topic open discussion
14:27:12 <weshay|ruck> Anything else that folks want to bring up to the meeting?
14:27:19 <weshay|ruck> any open discussion???
14:27:57 <openstackgerrit> Merged openstack/tripleo-docs master: Document using validation framework with Ceph  https://review.opendev.org/694674
14:27:59 <openstackgerrit> Brent Eagles proposed openstack/tripleo-heat-templates stable/queens: WIP/DNM Configure amphora for upload and run tempest  https://review.opendev.org/692579
14:28:37 <weshay|ruck> O... keydokie
14:28:45 <weshay|ruck> #endmeeting tripleo