14:01:19 <weshay|ruck> #startmeeting tripleo
14:01:19 <weshay|ruck> #topic agenda
14:01:19 <weshay|ruck> * Review past action items
14:01:19 <weshay|ruck> * One off agenda items
14:01:19 <weshay|ruck> * Squad status
14:01:19 <weshay|ruck> * Bugs & Blueprints
14:01:20 <openstack> Meeting started Tue Jan 28 14:01:19 2020 UTC and is due to finish in 60 minutes. The chair is weshay|ruck. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:21 <weshay|ruck> * Projects releases or stable backports
14:01:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:23 <weshay|ruck> * Specs
14:01:25 <weshay|ruck> * open discussion
14:01:25 <openstack> The meeting name has been set to 'tripleo'
14:01:26 <cloudnull> o/
14:01:27 <weshay|ruck> Anyone can use the #link, #action and #info commands, not just the moderatorǃ
14:01:29 <weshay|ruck> Hey folks! who's around?
14:01:33 <weshay|ruck> \0
14:01:37 <weshay|ruck> 0|
14:01:39 <weshay|ruck> 0/
14:02:10 <rlandy> o/
14:02:10 <sshnaidm> o\
14:02:12 <rfolco> o/
14:02:12 <marios|call> o/
14:02:15 <chkumar|rover> \o/
14:02:22 <tkajinam> o/
14:02:26 <panda> o/
14:03:00 <zbr> o/
14:03:18 <weshay|ruck> waiting another minute
14:03:46 <jfrancoa> o/
14:04:00 <weshay|ruck> #topic review past action items
14:04:13 <gchamoul> o/
14:04:17 <weshay|ruck> past topics include:
14:04:35 <weshay|ruck> mistral tracking in story board .. woot
14:04:40 <weshay|ruck> and progress on CentOS-8
14:05:00 <weshay|ruck> quick update re: CentOS-8
14:05:23 <weshay|ruck> most of the containers 114-120 are building just fine.. we're missing some repos preventing the rest..
14:05:36 <weshay|ruck> email sent to openstack-discuss, for details check there
14:05:53 <weshay|ruck> we should see some of the missing repos drop in by tomorrow was the given eta
14:06:11 <weshay|ruck> #topic one off agenda items
14:06:11 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-meeting-items
14:06:29 <weshay|ruck> first topic... ansible version updates...
14:06:47 <weshay|ruck> mwhahaha, sshnaidm zbr jfrancoa there was some fall out from bumping ansible to 2.9
14:06:59 <weshay|ruck> mwhahaha, raised the topic for the mtg..
14:07:02 <weshay|ruck> comments..
14:07:05 <zbr> not as far as i know
14:07:36 <zbr> based on my experience 2.9 is an easy/safe bumping. i am afraid 2.10 will not be such.
14:07:42 <weshay|ruck> zbr, there were a lot of gate failures and gate resets caused by tripleo-upgrade failing to parse some ansible syntax due to 2.9
14:07:57 <sshnaidm> there were failures because of old deprecated syntax in tripleo-upgrade role
14:08:03 <jfrancoa> weshay|ruck: as discussed in the email, it would be useful next time to launch some former release jobs (rocky/stein/train)
14:08:03 <weshay|ruck> we are looking for process improvements to prevent failures when bumping ansible
14:08:18 <sshnaidm> that's why I wondered if they have ansible-lint running there
14:08:21 <weshay|ruck> perhaps.. tying the ansible version in ci to the ansible version that tripleo uses
14:08:29 <openstackgerrit> mathieu bultel proposed openstack/tripleo-upgrade master: Add tripleo-ansible as undercloud prerequist https://review.opendev.org/704564
14:08:30 <weshay|ruck> upper constraints ..
14:08:31 <weshay|ruck> etc
14:08:37 <sshnaidm> weshay|ruck, it doesn't save us from that
14:08:40 <zbr> sshnaidm: or what outdated version of linter/ansible mix they are running
14:08:42 <weshay|ruck> jfrancoa, aye..
14:08:44 <mwhahaha> Older versions need a cap
14:09:02 <mwhahaha> Eg queens may never actually get 2.9
14:09:17 <sshnaidm> either we lock upper version of ansible per release, but idk how to do it in Ci currently
14:09:20 <mwhahaha> We had such things in like poke where it would not get 2.6
14:09:34 <mwhahaha> s/poke/pike
14:09:54 <mwhahaha> So we need to figure out what the life cycle is for older versions
14:10:14 <weshay|ruck> agree...
14:10:16 <zbr> also check ansible lifecycle itself!
14:10:30 <mwhahaha> We don't necessarily follow that
14:10:32 <openstackgerrit> Bogdan Dobrelya (bogdando) proposed openstack/ansible-role-tripleo-modify-image master: Ensure the yum cache has at most one writer https://review.opendev.org/704335
14:10:40 <mwhahaha> We had 2.4 long after it was eol
14:10:43 <zbr> mainly if you stick to an unmaintained and unsupported version of ansible,.... you pay the price :D
14:10:56 <weshay|ruck> so.. I think this is mainly a CI task to figure out how to appropriately run a more apporiate version of ansible per branch..
14:11:08 <mwhahaha> Since we're not adding stuff to old ones I don't think that's as big a concern
14:11:15 <sshnaidm> maybe it's not only ansible, what if other py modules can break
14:11:16 <weshay|ruck> and perhaps report back some options in the next mtg?
14:11:57 <sshnaidm> seems like we need {branch}_requirements.txt
14:12:06 <weshay|ruck> aye.. so let's take a week
14:12:10 <weshay|ruck> and report back
14:12:30 <mwhahaha> This is not an ansible specific thing
14:12:37 <mwhahaha> We do this for all software
14:12:38 <weshay|ruck> #action TripleO CI team to investigate how to appropriatly pin ansible per release in CI
14:12:46 <mwhahaha> MySQL/puppet/etc
14:12:55 <mwhahaha> We're on eol versions of puppet
14:13:00 <weshay|ruck> ya
14:13:04 <sshnaidm> mwhahaha, ansible problem is Ci specific
14:13:20 <mwhahaha> The issue wasn't ci only
14:13:25 <mwhahaha> It broke tripleo
14:13:34 <weshay|ruck> it broke the upgrade roles
14:13:38 <weshay|ruck> role
14:13:45 <zbr> we may end-up with a conflict between zuul min-version of ansible requirement and our branch max-requirments
14:13:48 <mwhahaha> And tripleo-ipsec
14:13:49 <weshay|ruck> luckily jfrancoa already had a patch up :)
14:13:53 <weshay|ruck> oh really
14:13:57 <sshnaidm> it broke roles because CI used a new ansible to run these roles
14:14:27 <sshnaidm> the roles would run fine if using old ansible, afaiu
14:14:44 <weshay|ruck> mwhahaha, jfrancoa you guys comfortable with CI taking a week and making proposals to fix next week?
14:14:53 <openstackgerrit> Dougal Matthews proposed openstack/python-tripleoclient master: Remove Python 2.7 from Tox https://review.opendev.org/704576
14:15:07 <mwhahaha> Yea it just needs to not get forgotten
14:15:31 <jfrancoa> sure, fine by me
14:16:18 <weshay|ruck> mwhahaha, jfrancoa .. k.. it will not be forgotten.. thanks
14:16:21 <weshay|ruck> Next topic
14:16:36 <weshay|ruck> podman 1.6 in 3rd party CI on RHEL 8
14:17:10 <weshay|ruck> The CI team is working w/ #rdo to get updates to podman available
14:17:12 <sshnaidm> d0ugal, https://review.opendev.org/#/c/703344/
14:17:33 <d0ugal> sshnaidm: aha
14:17:44 <weshay|ruck> we'll also be touching on perhaps getting recently merged versions of podman.. now that there is tripleo ci jobs on it
14:18:01 <weshay|ruck> mwhahaha, any questions or comments ^ EmilienM ^
14:18:15 <d0ugal> sshnaidm: the tests are broken in 2.7
14:18:16 <sshnaidm> weshay|ruck, will it come to centos8 too?
14:18:33 <weshay|ruck> sshnaidm, centos8 has to be a real thing first :)
14:18:42 <weshay|ruck> deferring that conversation until then
14:19:01 <weshay|ruck> all good?
14:19:04 <weshay|ruck> k
14:19:19 <weshay|ruck> #topic Squad status
14:19:19 <weshay|ruck> ci
14:19:19 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-ci-squad-meeting
14:19:19 <weshay|ruck> upgrade
14:19:19 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-upgrade-squad-status
14:19:20 <weshay|ruck> edge
14:19:21 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:19:23 <weshay|ruck> integration
14:19:25 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-integration-squad-status
14:19:27 <weshay|ruck> validations
14:19:28 <openstackgerrit> Kevin Carter (cloudnull) proposed openstack/tripleo-common master: Remove enable_ssh_admin workflow from deployment https://review.opendev.org/704580
14:19:29 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-validations-squad-status
14:19:33 <weshay|ruck> networking
14:19:35 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-networking-squad-status
14:19:37 <weshay|ruck> transformation
14:19:39 <weshay|ruck> #link https://etherpad.openstack.org/p/tripleo-ansible-agenda
14:19:41 <weshay|ruck> Any squad wanting to bring up their status, or a topic for the general public?
14:19:57 <weshay|ruck> anything from mistral, tripleo-ansible etc.. d0ugal, apetrich, cloudnull ?
14:20:02 <openstackgerrit> Sorin Sbarnea proposed openstack/tripleo-ci master: lint: enable black https://review.opendev.org/703980
14:20:20 <openstackgerrit> Dougal Matthews proposed openstack/python-tripleoclient master: Remove the openstack overcloud plan commands https://review.opendev.org/704581
14:20:34 <d0ugal> weshay|ruck: ^ that review, I wonder if we can remove these commands :)
14:20:35 * cloudnull hands mic to d0ugal
14:21:21 <cloudnull> it would seem that non-of that is of any value any longer now that we don't have the UI ?
14:21:25 <weshay|ruck> ooh.. I suspect we can.. but let's make sure everyone see's the review first.. I have not looked
14:21:29 <d0ugal> weshay|ruck: afaik they don't make any sense without tripleo UI. but interested to see other peple input on it
14:21:53 <d0ugal> weshay|ruck: yeah, no rush it is new :) I just rushed to post it for the meeting :)
14:22:15 <fultonj> o/
14:22:24 <weshay|ruck> the question would be is if it's not properly deprecated w/ a release note.. we'll have to add that and then take two cycles to remove it
14:22:40 <weshay|ruck> unless I'm misunderstanding how that openstack policy works in this case
14:23:01 <d0ugal> weshay|ruck: yeah, so I wondered about that
14:23:14 <d0ugal> weshay|ruck: but I think it just doesn't do anything
14:23:16 <weshay|ruck> anyone here not in favor of immediately marking it as deprecated in a release note?
14:23:20 <d0ugal> weshay|ruck: we didn't do two cycles for the UI?
14:23:41 <weshay|ruck> a follow up email to opendev-discuss is a good idea
14:23:52 <d0ugal> okay, I'll do that
14:23:56 <weshay|ruck> d0ugal, k.. so let's get some more input.. maybe we have more flexiblity
14:24:18 <d0ugal> Great, I'll send the email
14:24:22 <openstackgerrit> Kevin Carter (cloudnull) proposed openstack/tripleo-common master: Remove enable_ssh_admin workflow from deployment https://review.opendev.org/704580
14:24:31 <weshay|ruck> k..
14:24:52 <weshay|ruck> cloudnull, d0ugal I will be interested in hearing how storyboard is working out for you guys at some point as well.. after some time
14:24:55 <weshay|ruck> thanks!
14:25:08 <weshay|ruck> moving on
14:25:19 <weshay|ruck> #link https://launchpad.net/tripleo/+milestone/ussuri-2
14:25:34 <weshay|ruck> Blueprints:
14:25:34 <weshay|ruck> 1 Unknown, 1 Started, 1 Good progress
14:25:35 <weshay|ruck> Bugs:
14:25:35 <weshay|ruck> 5 New, 19 Incomplete, 4 Invalid, 3 Won't Fix, 5 Confirmed, 359 Triaged, 115 In Progress, 58 Fix Released
14:26:06 <weshay|ruck> I don't think I have seen any new blueprints
14:26:21 <weshay|ruck> I think we merged d0ugal's mistral removal blueprints.. correct?
14:27:05 <weshay|ruck> yup
14:27:19 <weshay|ruck> #topic projects releases or stable backports
14:27:42 <weshay|ruck> going once
14:27:47 <weshay|ruck> going twice
14:27:58 <weshay|ruck> #topic specs
14:27:58 <weshay|ruck> #link https://review.openstack.org/#/q/project:openstack/tripleo-specs+status:open
14:28:15 <d0ugal> weshay|ruck: yup, all my specs are merged thanks
14:28:32 <weshay|ruck> great..
14:28:39 <weshay|ruck> FYI.. ekultails has a new spec up https://review.opendev.org/#/c/698828/
14:28:49 <weshay|ruck> please help him review
14:29:13 <weshay|ruck> #topic open discussion
14:29:13 <weshay|ruck> Anything else that folks want to bring up to the meeting?
14:29:17 <ekultails> Please and thank you. :-)
14:30:17 <openstackgerrit> Adriano Petrich proposed openstack/python-tripleoclient master: WIP sharing code https://review.opendev.org/704561
14:30:27 <weshay|ruck> anything anything.... bueller bueller
14:30:39 <cloudnull> shameless plug https://storyboard.openstack.org/#!/story/2007212
14:30:41 <openstackgerrit> Adriano Petrich proposed openstack/tripleo-ansible master: WIP. just sharing code. https://review.opendev.org/692363
14:30:57 <cloudnull> thiis is our first epic for mistral_to_ansible
14:31:13 <cloudnull> if folks want to help out on that, we'd greatly appreciate it :D
14:31:25 <weshay|ruck> ya.. not a small item
14:32:03 <weshay|ruck> ok... I think that is about it for today
14:32:07 <fultonj> ekultails: awx, cool
14:32:14 <weshay|ruck> will follow up re: ansible next week
14:32:24 <weshay|ruck> #endmeeting tripleo