14:01:23 <slagle> #startmeeting TripleO Edge Squad Meeting
14:01:23 <openstack> Meeting started Thu Nov  1 14:01:23 2018 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:29 <openstack> The meeting name has been set to 'tripleo_edge_squad_meeting'
14:01:32 <slagle> ping slagle, csatari, jaosorior, owalsh, fultonj, gfidente, hjensas, jtomasek,thrash, bogdando, dtantsur, rbrady, d0ugal, toure
14:01:33 <slagle> #info remove or update your nick from the Meeting Template on the etherpad if you want (or don't want) to be ping'd for the start of the meeting
14:01:35 <slagle> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:01:38 <owalsh> o/
14:01:42 <fultonj> o/
14:01:43 <slagle> Anyone can use the #link, #action, #help, #idea, #agreed, and #info commands, not just the moderatorǃ
14:01:44 <jaosorior> o/
14:01:48 <jtomasek> o/
14:01:50 <slagle> #topic Agenda
14:01:52 <slagle> * Review past action items
14:01:54 <slagle> * One off items
14:01:56 <slagle> * Goals for the week
14:02:25 <thrash> o/
14:02:30 <slagle> not sure how much we have to go over this week, so it might be quick!
14:02:30 <abishop> o/
14:02:40 <slagle> i've been totally focused and not distracted at all this week ;)
14:03:03 <slagle> #topic Review past action items
14:03:29 <slagle> fultonj make progress on split-controlplane-ci
14:03:41 <fultonj> Have automated testing in my env, will next start to apply to tripleo-ci next: https://github.com/fultonj/edge/blob/master/ansible/deploy_and_test.yml
14:03:41 <slagle> any updates?
14:03:51 <fultonj> also i have a WIP  doc update: https://review.openstack.org/#/c/614636
14:03:58 <slagle> #link https://github.com/fultonj/edge/blob/master/ansible/deploy_and_test.yml
14:04:04 <slagle> #link https://review.openstack.org/#/c/614636
14:04:04 <EmilienM> owalsh: thx for your review btw
14:04:21 <owalsh> EmilienM: np
14:04:25 <slagle> fultonj: nice progress
14:04:28 <fultonj> thanks
14:04:34 <d0ugal> o/
14:04:34 <slagle> i hadn't seen this docs patch, but i'll put it on my review queue
14:04:44 <openstackgerrit> Merged openstack/tripleo-ansible master: Add podman_image module  https://review.openstack.org/611698
14:04:49 <openstackgerrit> Sorin Sbarnea proposed openstack/tripleo-quickstart-extras master: Use dnf and python3 on platforms where these are default  https://review.openstack.org/610491
14:04:50 <slagle> #action all review https://review.openstack.org/#/c/614636
14:05:05 <fultonj> it's a little rough, spots where i dump a large env file, was thinking of making it more explanantor
14:05:12 <fultonj> explanatory*
14:06:07 <abishop> fultonj: I'll coordinate w/ you re: I have glance cache enabled and can spawn instances and attach storage in my latest PoC
14:06:17 <fultonj> abishop: sounds great
14:06:50 <owalsh> abishop: attach volumes?
14:06:56 <abishop> yep
14:07:07 <abishop> in a specified AZ
14:07:10 <owalsh> cool
14:07:25 <fultonj> yep, w/ multiple Cephs per AZ
14:07:50 <openstackgerrit> Merged openstack-infra/tripleo-ci master: Add peer and switch nodes for fedora28  https://review.openstack.org/614090
14:08:51 <slagle> ok, next item
14:08:56 <slagle> slagle to conintue on terms etherpad
14:09:08 <slagle> #link https://etherpad.openstack.org/p/tripleo-edge-terms
14:09:27 <slagle> not much change from last week
14:10:06 <slagle> i think last week it seemed there wasn't much objection to more or less adopting https://github.com/State-of-the-Edge/glossary
14:10:18 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:19 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1798195
14:10:20 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1799895
14:10:20 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1800742
14:10:21 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1801076
14:10:21 <openstack> Launchpad bug 1798195 in tripleo "rdo-cloud yum repos unavailable during container updates and failing the undercloud install " [Critical,Triaged]
14:10:22 <openstack> Launchpad bug 1799895 in tripleo "CI: undercloud takes long time which causes job fail with timeout" [Critical,Triaged]
14:10:23 <openstack> Launchpad bug 1800742 in tripleo "tempest.lib.exceptions.IdentityError: Got identity error, undercloud-containers" [Critical,Triaged] - Assigned to chandan kumar (chkumar246)
14:10:24 <openstack> Launchpad bug 1801076 in tripleo "Crane container fails to build in promotion because "No package mod_xsendfile available"" [Critical,Triaged] - Assigned to Rafael Folco (rafaelfolco)
14:10:42 <slagle> do we want to just go with that and update this etherpad to indicate such?
14:11:59 <abishop> +1
14:12:07 <openstackgerrit> Alex Schultz proposed openstack-infra/tripleo-ci master: WIP: Container build CI job  https://review.openstack.org/614392
14:12:31 <slagle> alright well, i'll tilt the etherpad in that direction and see if anyone objects
14:12:54 <fultonj> does anyone have an opinion on how we would use the terms from the glossary to refer to the split control plane scenario?
14:12:57 <slagle> #action slagle to update https://etherpad.openstack.org/p/tripleo-edge-terms around adopting https://www.stateoftheedge.com/glossary
14:13:04 <owalsh> we may also need generic terms to refer to the components in a multi tier tripleo deployment as I doubt it will be restricted to just the edge use case
14:13:45 <openstackgerrit> Emilien Macchi proposed openstack/tripleo-heat-templates master: docker-puppet: retry container run command  https://review.openstack.org/614639
14:14:10 <fultonj> Maybe "Central Data Center" for controller nodes and "Software Edge" for remote hci nodes fits?
14:14:37 <fultonj> or "infrastructure edge"
14:14:46 <slagle> or Edge Cloud
14:14:51 <fultonj> "Edge computing capability, typically in the form of one or more edge data centers, which is deployed on the operator side of the last mile network"
14:15:05 <openstackgerrit> Emilien Macchi proposed openstack/tripleo-quickstart master: Revert "(squash) disabling podman everywhere in gate"  https://review.openstack.org/614664
14:15:11 <fultonj> Yeah
14:15:20 <fultonj> edge cloud fits better
14:15:48 <fultonj> i will work them into the doc submission
14:16:00 <fultonj> reviews welcome if anyone has a better idea
14:16:06 <slagle> cool, will take a look
14:16:14 <slagle> ok, last action item from last week:
14:16:16 <slagle> fultonj docs patch for standalone edge example
14:16:21 <slagle> which we already covered :)
14:16:56 <openstackgerrit> Jiri Stransky proposed openstack/python-tripleoclient master: Always run upgrades/updates as tripleo-admin  https://review.openstack.org/614752
14:16:59 <slagle> #topic One off / Goals
14:17:08 <slagle> do we have anything new to cover?
14:18:31 <owalsh> I'm hoping to take a look at TCP windows this week
14:18:53 <owalsh> even with a local glance cache it should make populating that cache much faster
14:19:42 <fultonj> owalsh: are you testing/measuring the effects of tcp windows on "remote" computes?
14:20:19 <owalsh> fultonj: yea, larger windows are required to use bandwidth at higher latencies
14:21:24 <owalsh> or even at relatively low latencies when you get to 10gbit/s and higher
14:22:37 <fultonj> owalsh: are you still using split control plane to deploy the env for this testing?
14:23:06 <owalsh> probably not - would be a applicable to a regular deployment too
14:23:19 <fultonj> ack
14:24:08 <openstackgerrit> Emilien Macchi proposed openstack/tripleo-heat-templates master: docker-puppet: retry container run command  https://review.openstack.org/614639
14:25:52 <slagle> sounds like that's a wrap
14:25:58 <slagle> thanks everyone
14:26:02 <slagle> #endmeeting