14:02:44 <slagle> #startmeeting TripleO Edge Squad Meeting
14:02:44 <openstack> Meeting started Thu Dec 13 14:02:44 2018 UTC and is due to finish in 60 minutes. The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:46 <slagle> ping slagle, csatari, jaosorior, owalsh, fultonj, gfidente, hjensas, jtomasek, bogdando, dtantsur, rbrady, d0ugal, toure
14:02:48 <slagle> #info remove or update your nick from the Meeting Template on the etherpad if you want (or don't want) to be ping'd for the start of the meeting
14:02:48 <openstack> The meeting name has been set to 'tripleo_edge_squad_meeting'
14:02:50 <slagle> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:02:52 <slagle> Anyone can use the #link, #action, #help, #idea, #agreed, and #info commands, not just the moderatorǃ
14:02:56 <owalsh> o/
14:02:58 <fultonj> o/
14:02:59 <dtantsur> o/
14:03:05 <abishop> o/
14:03:07 <toure> o/
14:03:13 <slagle> #topic Agenda
14:03:14 <slagle> * Review past action items
14:03:16 <slagle> * Goals/action items for the week
14:03:57 <slagle> hi folks. sorry i was late
14:04:44 <slagle> here are the action items from last meeting:
14:04:46 <slagle> fultonj keep collaborating with slagle to get https://review.openstack.org/#/c/621716 + https://review.openstack.org/#/c/614636 done
14:04:48 <slagle> fultonj collab w/ slagle to get split-controlplane-standalone.yml for CI using second node
14:04:57 <fultonj> slagle did my comments in https://review.openstack.org/#/c/621716 make sense?
14:05:36 <fultonj> i'm ok with just merging it as is, but i thought they could make it a little better
14:05:52 <slagle> fultonj: yes. i need to review what 25.0 was for. i copied that from earlier up in the docs.
14:06:00 <slagle> not sure if it was for the floating ip network or not
14:06:20 <fultonj> i assumed it was your existing management network
14:06:38 <fultonj> ok, we can talk more about it post meeting if you like
14:06:58 <fultonj> as for my other doc review...
14:07:03 <fultonj> #action fultonj to update doc patch so 2nd node is called "standalone"; given it's special meaning as per https://review.openstack.org/#/c/614636/6/doc/source/install/containers_deployment/standalone.rst@729
14:07:21 <slagle> fultonj: oh i know why I added it now.
14:07:23 <fultonj> #link https://review.openstack.org/#/c/614636/6/doc/source/install/containers_deployment/standalone.rst@729
14:07:31 <fultonj> oh?
14:07:37 <slagle> fultonj: b/c the format for MasqueradeNetworks was not documented, so I wanted to show an example
14:07:56 <slagle> i'll update the patch
14:08:05 <slagle> and put the example in a comment or something
14:08:18 <fultonj> slagle: right, the example helps but assumes context reader might not have (i thougt)
14:08:21 <fultonj> sounds good
14:08:21 <fultonj> thanks
14:08:49 <fultonj> regarding "fultonj collab w/ slagle to get split-controlplane-standalone.yml for CI using second node"
14:08:52 <fultonj> rocky maintenance issues blocked me on making progress on this
14:09:15 <fultonj> i think i'll punt it to an ai for next week
14:09:37 <slagle> yea i was preoccupied as well
14:09:49 <fultonj> #action fultonj collab w/ slagle to get split-controlplane-standalone.yml for CI using second node
14:10:22 <slagle> i did make a little progress on deploying from an undercloud. got some direction from abishop on setting up the cinder AZ's
14:10:37 <slagle> going to try and make more progress on that this week
14:10:59 <slagle> #topic Goals/action items for the week
14:11:25 <slagle> i was thinking we will probably want an additional example role that is basically HCI + CinderVolume.
14:11:33 <slagle> i don't think we have that already do we?
14:11:52 <fultonj> slagle: I agree, no i don't think we have that yet
14:12:01 <abishop> I don't think we have that
14:12:09 <slagle> ok
14:12:36 <slagle> so we need to add that and document how to deploy from the undercloud with separate stacks
14:12:58 <slagle> owalsh: do we have docs on configuring AZ's for nova?
14:12:59 <fultonj> might fit under https://blueprints.launchpad.net/tripleo/+spec/split-controlplane-templates
14:13:03 <abishop> what would the role be named? maybe Edge?
14:13:28 <owalsh> slagle: I assume we do
14:13:45 <abishop> it would be good if the name were flexible enough to easily support including other storage services, such as glance-api
14:14:29 <openstackgerrit> Merged openstack/tripleo-heat-templates master: Removing the deprecated environment files for hw offloading https://review.openstack.org/573102
14:14:31 <slagle> abishop: yea not sure. seems more generic than Edge. but i'm sure we can bikeshed in the review :)
14:15:26 <abishop> sounds like a good AI (to bikeshed on something)
14:16:00 <slagle> yea :)
14:16:10 <slagle> #action slagle to submit patch for edge role with cinder-volume
14:16:40 <openstackgerrit> David Peacock proposed openstack/tripleo-heat-templates master: flatten memcached service configuration https://review.openstack.org/624712
14:16:41 <slagle> owalsh: ok, i wasn't sure we had it anywhere in tripleo. i looked briefly but did not see anything
14:16:48 <fultonj> I'll include that in the CI when it's ready (CI needs to catch up)
14:17:01 <owalsh> slagle: no, don't have tripleo support AFAIK.
14:17:30 <slagle> owalsh: is there work to support it, or it just docs to run some commands post deployment?
14:19:55 <owalsh> slagle: I'll need to take a look. Possibly some conf + post deployment commands
14:19:59 <slagle> ok
14:20:14 <owalsh> #action owalsh to investigate nova AZ config
14:20:29 <slagle> thanks
14:20:39 <slagle> anything else to highlight before we wrap up?
14:22:03 <slagle> alright thanks folks
14:22:24 <slagle> next week's meeting might be off depending on who's around, but we can decide later
14:22:28 <slagle> ttyl!
14:22:30 <slagle> #endmeeting