14:02:40 <slagle> #startmeeting TripleO Edge Squad Meeting
14:02:42 <openstack> Meeting started Thu Jan  3 14:02:40 2019 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:42 <slagle> ping slagle, csatari, jaosorior, owalsh, fultonj, gfidente, hjensas, jtomasek, bogdando, dtantsur, rbrady, d0ugal, toure
14:02:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:45 <openstack> The meeting name has been set to 'tripleo_edge_squad_meeting'
14:02:48 <owalsh> o/
14:02:51 <bogdando> o/
14:02:52 <hjensas> o/
14:02:52 <fultonj> o/
14:02:58 <slagle> oh hi :)
14:03:15 <slagle> wasn't sure if anyone would be around today or not
14:03:39 <bogdando> :D
14:03:46 <slagle> #info remove or update your nick from the Meeting Template on the etherpad if you want (or don't want) to be ping'd for the start of the meeting
14:03:46 <dtantsur> \o
14:03:48 <slagle> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:03:50 <slagle> Anyone can use the #link, #action, #help, #idea, #agreed, and #info commands, not just the moderatorǃ
14:03:52 <slagle> #topic Agenda
14:04:13 <slagle> * Review past action items
14:04:15 <slagle> * Goals/action items for the week
14:04:19 <d0ugal> o/
14:04:27 <slagle> #topic Review past action items
14:05:13 * slagle fultonj land split control plane docs patch https://review.openstack.org/#/c/614636
14:05:16 <fultonj> i had an ai for split control plane standalone doc, i think doc is ready to merge
14:05:21 <fultonj> https://review.openstack.org/#/c/614636/
14:05:42 <openstackgerrit> Alex Schultz proposed openstack/python-tripleoclient master: Expose timezone configuration  https://review.openstack.org/628015
14:06:09 <fultonj> i added all suggestions, feel free to suggest more or vote. thanks
14:06:16 <slagle> i added my +2 back
14:06:26 <slagle> owalsh: can you review this one as well?
14:06:33 <owalsh> slagle: sure
14:06:55 <bogdando> could we please use the Edge Glossary?
14:07:13 <fultonj> bogdando: ok
14:07:14 <bogdando> for https://review.openstack.org/#/c/614636
14:07:18 <bogdando> thanks
14:07:26 <fultonj> Controller --> "Centralized Data Center"
14:07:33 <fultonj> Compute --> Edge Cloud
14:07:48 <fultonj> bogdando: the docs says Controller and Compute
14:07:51 <bogdando> or Aggregation Edge Layer/ cloudlet
14:08:14 <bogdando> tho the aggregation one implies a middle layer
14:08:29 <fultonj> bogdando: s/Controller/X?
14:08:36 <fultonj> bogdando: s/Compute/Y?
14:08:37 <bogdando> yes
14:08:39 <fultonj> what's X and Y?
14:09:01 <slagle> i would keep the TripleO specific role names somewhere, b/c that's what we're actually deploying and what works
14:09:17 <slagle> no need to abstract it behind some other definition
14:09:26 <fultonj> bogdando: X="Centralized Data Center" ?
14:09:42 * dtantsur is impressed we still cannot agree on naming :-P
14:09:48 <slagle> but we can add the Edge terms as additional vocabulary
14:09:49 <bogdando> yes
14:09:58 <fultonj> derekh: that's kind of why i just said "Controller" and "Compute"
14:10:05 <fultonj> whops....
14:10:09 <fultonj> dtantsur: i mean, sorry derekh
14:10:16 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:16 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1810054
14:10:18 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1810136
14:10:18 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1810325
14:10:20 <openstack> Launchpad bug 1810054 in tripleo "mulitnode jobs failing on gathering facts from subnode-2" [Critical,Triaged] - Assigned to Ronelle Landy (rlandy)
14:10:22 <openstack> Launchpad bug 1810136 in tripleo "standalone-upgrade job failing while upgrading mariadb" [Critical,In progress] - Assigned to Jose Luis Franco (jfrancoa)
14:10:24 <openstack> Launchpad bug 1810325 in tripleo "standalone tempest fails "Exhausted all hosts available for retrying build failures for instance"" [Critical,Triaged]
14:10:51 <slagle> bogdando: maybe we can land this one since it's correct as-is, and you can submit a followup for the term discussion?
14:10:53 <dtantsur> fultonj: yeah, I'd prefer to keep these as well. my concerns are only with "far edge" and stuff, not with these ones.
14:11:00 <bogdando> sure we can
14:11:07 <fultonj> bogdando: Y="Aggregation Edge Layer/ cloudlet"
14:11:29 <fultonj> i'll use them in the doc but mention the connection in first paragph
14:11:32 <fultonj> let's see how it goes. thanks
14:11:36 <pbandark> hi cgoncalves i have just reported https://bugs.launchpad.net/ubuntu/+source/tripleo-heat-templates/+bug/1810415
14:11:36 <openstack> Launchpad bug 1810415 in tripleo-heat-templates (Ubuntu) "incorrect datatype for "OctaviaFlavorId" " [Undecided,New]
14:11:38 <slagle> ok thanks
14:11:47 <pbandark> it would be great if you can have a look
14:11:56 * slagle fultonj get help (perhaps from ci team) for ci inventory for second node for https://review.openstack.org/#/q/topic:bp/split-controlplane-ci
14:12:37 <fultonj> i still have to do that
14:12:51 <slagle> fultonj: shall we work on this task over the next week?
14:12:58 <fultonj> slagle: yes
14:13:11 <slagle> ok sounds good
14:13:30 <slagle> #action fultonj/slagle get help (perhaps from ci team) for ci inventory for second node for https://review.openstack.org/#/q/topic:bp/split-controlplane-ci
14:13:31 <openstackgerrit> Ronelle Landy proposed openstack/tripleo-quickstart master: Modify fs020 parameters to match fs001 more closely  https://review.openstack.org/628052
14:13:58 * slagle slagle to draft deployment scaling/management at the edge doc (slagle, 14:13:52)
14:14:27 <slagle> #link https://docs.google.com/document/d/12tPc4NC5fo8ytGuFZ4DSZXXyzes1x3U7oYz9neaPP_o
14:14:41 <slagle> I've started the doc, and it's ready for comments and other ideas
14:15:00 <slagle> it covers some of the existing WIP and some other new ideas
14:15:31 <slagle> there are some possible next steps documented if there are folks looking for how to get started on some things
14:15:45 <fultonj> nice
14:15:49 <bogdando> indeed
14:16:47 <slagle> i will probably send this out to the list as well
14:16:54 <slagle> #action slagle send scaling doc to ML
14:18:05 <openstackgerrit> Alex Schultz proposed openstack/python-tripleoclient master: Use cliff autodoc generation  https://review.openstack.org/523510
14:18:18 <slagle> #topic Goals/action items for the week
14:18:23 <cgoncalves> pbandark, ack. looking
14:18:50 <owalsh> slagle: think I had an action item to look into nova AZs
14:19:13 <slagle> oh right
14:19:33 <slagle> "owalsh to investigate nova AZ config"
14:19:42 <slagle> from the prior mtng
14:20:07 <cgoncalves> pbandark, pike? octavia was never tested in pike afaik. much integration work was done in queens and not backported
14:20:35 <pbandark> cgoncalves, i can see same code in the heat template for rocky
14:20:41 <owalsh> it looks reasonably straightforward,  just spinning up an env to test it out
14:20:52 <pbandark> and queens
14:21:02 <openstackgerrit> Natal Ngétal proposed openstack/paunch master: [Core] Change openstack-dev to openstack-discuss.  https://review.openstack.org/622894
14:21:23 <owalsh> backporting could take some work though
14:21:30 <slagle> owalsh: ok, is it configuration or actual client commands that need to be run?
14:21:32 <cgoncalves> pbandark, yeah, the issue would still exist in queens and rocky. I'm just saying you shouldn't be trying on pike anyway
14:21:41 <openstackgerrit> Natal Ngétal proposed openstack/paunch master: [Configuration] Add missing py37 and corrected default envlist.  https://review.openstack.org/624611
14:21:53 <cgoncalves> pbandark, will you be proposing a fix? if so, please add me as reviewer
14:22:07 <pbandark> cgoncalves, ok
14:22:28 <slagle> #action owalsh continue investigating nova AZ config
14:22:58 <owalsh> slagle: client commands
14:22:59 <slagle> also this week I'd like to document the split-controlplane deployment from a central undercloud (not using standalone)
14:23:15 <fultonj> slagle: sounds, good
14:23:16 <slagle> i'll work on that
14:23:39 <slagle> #action slagle document the split-controlplane deployment from a central undercloud (not using standalone)
14:24:28 <slagle> i'll also update https://review.openstack.org/#/c/626563/
14:24:31 <slagle> #link https://review.openstack.org/#/c/626563/
14:24:31 <fultonj> slagle: maybe it makes sense to have an edge (or similar) section in the docs?
14:24:37 <slagle> as the docs patch will need that
14:24:45 <pbandark> thanks cgoncalves psachin
14:24:50 <fultonj> e.g. so that https://docs.openstack.org/tripleo-docs/latest/ ctrl-F "edge" works?
14:24:56 <slagle> #action slagle update roles patch https://review.openstack.org/#/c/626563/
14:25:12 <slagle> fultonj: sounds good to me
14:25:23 <slagle> we can link to other sections if needed
14:25:45 <slagle> I did a similar thing for config-download. sort of along the lines of a config-download "User's Guide"
14:25:53 <slagle> could have an "Edge User's Guide"
14:26:01 <bogdando> I think until we support multiple control planes for edge it makes a little difference to have a dedicated docs
14:26:01 <fultonj> yeah, just like that
14:26:31 <bogdando> just a local vs WAN distributed single control plane, not a bug deal! :)
14:26:39 <bogdando> big*
14:27:30 <bogdando> just adding notes for scale and latency ad hoc is enought IMO
14:27:35 <slagle> i like it b/c it shows how TripleO can be used for Edge, and adds the context around Edge to our docs, which users might be looking for
14:28:14 <slagle> even if it's mostly introdcutory text, and then links to other sections. i think that's ok
14:28:27 <fultonj> that doc can then evolve to have the more advanced topics
14:28:58 <bogdando> ok, just not sure i hat would address the expectations of one opening the Edge Guide in the hope to see some real stuff and multiple control planes...
14:28:58 <fultonj> I think it's good to start with something to evolve from and get things out to people early
14:29:06 <bogdando> it would*
14:30:06 <bogdando> or rather set him/her somewhat disappointed to see the same single CP deployment but with scale/latency comments and optimizations
14:30:06 <slagle> i consider split-controlplane "real stuff" :_
14:30:08 <slagle> :)
14:30:11 <bogdando> ;)
14:30:33 <bogdando> right, split control plane worth its dedicated docs
14:31:08 <slagle> let's work on the patch and we can see how it looks. some context and level setting would be good to document IMO
14:31:18 <fultonj> +1
14:32:03 <slagle> anything else folks want to address for the upcoming week?
14:33:04 <slagle> thanks!
14:33:06 <slagle> #endmeeting