14:00:45 <slagle> #startmeeting TripleO Edge Squad Meeting
14:00:46 <openstack> Meeting started Thu Jan 17 14:00:45 2019 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:46 <openstackgerrit> Honza Pokorny proposed openstack/tripleo-quickstart master: Add new featureset for running tripleo-ui tests  https://review.openstack.org/607325
14:00:47 <slagle> ping slagle, csatari, jaosorior, owalsh, fultonj, gfidente, hjensas, jtomasek, bogdando, dtantsur, rbrady, d0ugal, toure, abishop
14:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:50 <openstack> The meeting name has been set to 'tripleo_edge_squad_meeting'
14:00:53 <bogdando> o/
14:00:55 <owalsh> o/
14:00:56 <slagle> #info remove or update your nick from the Meeting Template on the etherpad if you want (or don't want) to be ping'd for the start of the meeting
14:00:57 <slagle> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:00:59 <slagle> Anyone can use the #link, #action, #help, #idea, #agreed, and #info commands, not just the moderatorǃ
14:01:04 <jaosorior> o/
14:01:13 <slagle> hi everyone
14:01:48 <mcornea> shardy: ack, thanks. I'll add it on my list
14:01:48 <abishop> o/
14:02:11 <d0ugal> o/
14:02:36 <slagle> #topic Agenda
14:02:42 <slagle> * Review past action items
14:02:44 <slagle> * Goals/action items for the week
14:02:58 <slagle> #topic Review past action items
14:03:22 * slagle slagle send    scaling doc to ML (slagle,    14:15:14)
14:03:34 <slagle> I just sent that this morning
14:03:39 <slagle> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-January/001802.html
14:03:51 <slagle> the doc should be fully open (hopefully)
14:04:00 <slagle> so you dont need a google account
14:04:33 * slagle slagle    document the split-controlplane deployment from a central undercloud    (not using standalone) (slagle,    14:20:38)
14:04:42 <slagle> #link https://review.openstack.org/631489
14:05:05 <slagle> it's a WIP for now. but any early feedback is welcome
14:05:18 * slagle slagle/fultonj try multi-ceph deployments with    DCN (slagle,    14:20:53)
14:05:38 <slagle> i did not get to that and I know john is travelling this week
14:05:57 <slagle> #action slagle/fultonj try multi-ceph deployments with    DCN
14:06:06 * slagle abishop    document GlanceAPI at the edge for DCN
14:06:21 <abishop> yes, got it, one sec...
14:06:41 <abishop> #link https://etherpad.openstack.org/p/tripleo-edge-glance-deployment
14:07:46 <slagle> great!
14:07:53 <slagle> will need to review :)
14:08:07 <abishop> yeah, figured it would take time for folks to absorb
14:08:21 <slagle> #action review https://etherpad.openstack.org/p/tripleo-edge-glance-deployment
14:08:25 <abishop> I'm also trying to get a glance person more actively involved
14:09:04 * slagle continue    investigating glance and nova image caching status/options
14:09:53 <slagle> not sure if anyone had time to look into that
14:10:18 <bogdando> at least there is an upstream spec for glance caching
14:10:20 <ooolpbot> URGENT TRIPLEO TASKS NEED ATTENTION
14:10:20 <ooolpbot> https://bugs.launchpad.net/tripleo/+bug/1811004
14:10:26 <openstack> Launchpad bug 1811004 in tripleo "tripleo-ci-centos-7-scenario003-standalone fails tempest.scenario.test_minimum_basic.TestMinimumBasicScenario" [Critical,In progress] - Assigned to Marios Andreou (marios-b)
14:10:50 <bogdando> #link https://review.openstack.org/#/c/619638/
14:10:57 <bogdando> so we can review
14:11:24 <bogdando> as a follow-up I've sent some feedback for missing requirements identified by edge team
14:11:33 <bogdando> (the upstream Edge WG)
14:11:49 <slagle> bogdando: ok thanks
14:11:52 <bogdando> like an ability to create snapshots, requires some CRUD from glance
14:12:01 <bogdando> which cannot be done w/o having a local DB
14:12:09 <bogdando> UUIC
14:12:50 <slagle> owalsh: do you know if the image caching that is done in nova is useful for our needs at all? or it just not featureful enough?
14:13:47 <owalsh> slagle: probably some use
14:14:18 <owalsh> but if we want to ensure the images are cached we would need a shared cache and we would need to prime it *somehow*
14:14:50 <slagle> ok. right, that's what nova doesnt have afaik
14:15:03 <owalsh> or maybe could prime the cache on all computes
14:15:22 <owalsh> either way it doesn't exist right now AFAIK
14:15:42 <slagle> maybe it could be primed by just launching an instance
14:15:54 <slagle> then deleting the instance, but keeping the image around
14:16:01 <slagle> i believe there is a configuration for that
14:16:18 <owalsh> yea, that's what I was thinking of
14:16:46 <slagle> ok well i will keep this as an AI in case anyone can look at it so we dont forget
14:16:53 <owalsh> pushing the problem to the operator though
14:16:55 <slagle> #action continue    investigating glance and nova image caching status/options
14:17:30 <slagle> #topic Goals/action items for the week
14:17:55 <slagle> we have a green CI job for tripleo-ci-centos-7-split-controlplane-standalone on https://review.openstack.org/#/c/615988/
14:18:17 <slagle> i've not reviewed it thoroughly yet to see if it did what it was supposed to though :)
14:18:48 <slagle> i also switched the job to use podman since the main standalone job has been switched as wll
14:18:49 <slagle> well
14:19:27 <slagle> will keep pushing on this next week, but would appreciate any reviews on the series of CI patches
14:19:44 <slagle> #link https://review.openstack.org/#/q/topic:bp/split-controlplane-ci+(status:open+OR+status:merged)
14:19:52 <openstackgerrit> Merged openstack/puppet-tripleo master: Explicitly set certmonger's CA cert's permissions  https://review.openstack.org/631210
14:20:10 <openstackgerrit> Merged openstack/tripleo-heat-templates master: Remove with_items for 'yum/package'  https://review.openstack.org/631186
14:20:17 <slagle> anything else to bring up for next week?
14:20:35 <openstackgerrit> Juan Antonio Osorio Robles proposed openstack/puppet-tripleo stable/rocky: Explicitly set certmonger's CA cert's permissions  https://review.openstack.org/631512
14:20:49 <openstackgerrit> Juan Antonio Osorio Robles proposed openstack/puppet-tripleo stable/queens: Explicitly set certmonger's CA cert's permissions  https://review.openstack.org/631513
14:21:34 <slagle> thanks folks!
14:21:42 <slagle> #endmeeting