14:01:35 <slagle> #startmeeting TripleO Edge Squad Meeting
14:01:35 <openstack> Meeting started Thu Feb 21 14:01:35 2019 UTC and is due to finish in 60 minutes.  The chair is slagle. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:38 <slagle> ping slagle, csatari, jaosorior, owalsh, fultonj, gfidente, hjensas, jtomasek, bogdando, dtantsur, rbrady, d0ugal, toure, abishop
14:01:40 <slagle> #info remove or update your nick from the Meeting Template on the etherpad if you want (or don't want) to be ping'd for the start of the meeting
14:01:40 <openstack> The meeting name has been set to 'tripleo_edge_squad_meeting'
14:01:45 <bogdando> o/
14:01:46 <slagle> #link https://etherpad.openstack.org/p/tripleo-edge-squad-status
14:01:48 <slagle> Anyone can use the #link, #action, #help, #idea, #agreed, and #info commands, not just the moderatorǃ
14:02:05 <slagle> he edge'ers. who's around
14:02:05 <dtantsur> \o
14:02:15 <slagle> *hi
14:02:28 <fultonj> o/
14:02:33 <owalsh> o/
14:02:50 <openstackgerrit> Carlos Camacho proposed openstack/python-tripleoclient master: Add new CLI option openstack tripleo validate run  https://review.openstack.org/636930
14:02:56 <slagle> #topic Agenda
14:02:58 <slagle> * Review past action items
14:03:00 <slagle> * Goals/action items for the week
14:03:12 <slagle> #topic Review past action items
14:03:32 * slagle fultonj get glance container on compute node in split control plane ci job to talk to mysql on controller node
14:03:42 <fultonj> http://logs.openstack.org/88/615988/16/check/tripleo-ci-centos-7-split-controlplane-standalone/8b9c4e5/logs/subnode-2/home/zuul/standalone_deploy.log.txt.gz#_2019-02-21_01_19_20
14:03:55 <fultonj> i have identified the problem...
14:04:23 <fultonj> The failure [0] occurred when the compute tried to reach 192.168.24.1 because it connected to it's own 192.168.24.1 (which is not listening on port 3306), and not the controller's 192.168.24.1.
14:04:36 <fultonj> so both nodes have a 192.168.24.1 address
14:04:48 <fultonj> so the edge compute node is trying to reach mysql on itself
14:05:04 <fultonj> both nodes also have a good 192.168.24.2 and 24.3 address
14:05:14 <fultonj> the compute can connect to the controller's 192.168.24.2
14:05:21 <fultonj> can Maria on the controller listen on 0.0.0.0 or 192.168.24.2 instead of 192.168.24.1?
14:06:47 <fultonj> so i need to find a way to get maria on the controller to listen on another IP
14:06:50 <slagle> well we probably need to assign different IP's
14:06:59 <slagle> right
14:07:06 <slagle> do these nodes have just the 1 nic?
14:07:14 <jaosorior> o/
14:07:28 <fultonj> http://logs.openstack.org/88/615988/15/check/tripleo-ci-centos-7-split-controlplane-standalone/f976ed8/logs/undercloud/var/log/extra/network.txt.gz
14:07:37 <fultonj> eth0 br-ex br-ctlplane
14:07:51 <fultonj> slagle: i have IPs i can use
14:08:15 <fultonj> splitcontrol plane job assigns the desired IPs 24.2 controller and 24.3 edge (that's ok i think)
14:08:36 <fultonj> i'll just tweak the end points on the compute to reach 24.2 (not 24.1)
14:08:47 <fultonj> just need to get all services listening on 24.2 on controller
14:09:02 <fultonj> unless you think i should take a diff approach?
14:09:30 <slagle> we'll probably need to fix the duplicate ip's, as other issues will arise
14:09:58 <slagle> can we just tell the compute to use different IP's, then it should be ok to connect to 24.1?
14:10:47 <fultonj> slagle: i'll try that
14:11:00 <fultonj> i'm doing the undercloud pre set up so that's probably how it got there
14:11:20 <fultonj> i could just disable the 24.1 as a workaround to see if that will work
14:11:34 <fultonj> #ACTION fultonj to fix network on splitcontrol plane ci job
14:11:42 <owalsh> aren't 24.2 and 24.3 on the wrong network?
14:12:04 <d4c07> hi - after deploying the overcloud with network isolation should the controller node have the default gateway of the router of the external network? For some reason it looks like the default route is out via the undercloud
14:12:24 <fultonj> d4c07: we're in a meeting ATM, perhaps we can talk later
14:12:43 <d4c07> sorry just noticed that.
14:12:51 <fultonj> d4c07: np
14:13:07 <fultonj> owalsh: 24.{2,3} are what is normally used in standalone as per docs
14:13:11 <fultonj> it's just a convention
14:13:16 <fultonj> but i don't see anyting wrong with it
14:13:33 <owalsh> fultonj: but they are on br-ex
14:13:47 <fultonj> https://docs.openstack.org/tripleo-docs/latest/install/containers_deployment/standalone.html
14:13:51 <fultonj> step 6
14:14:28 <fultonj> i'm not using network isoation here, just one network for this job to reproduce scenario from doc
14:15:23 <slagle> the vxlan tunnel is setup between the nodes on br-ex. i assume you can still reach 24.1 (br-ctlplane) with that setup
14:15:28 <slagle> *from the compute node
14:15:38 <slagle> guess we'll see
14:15:41 <fultonj> slagle: yes, if only the compute node didn't also have that IP
14:15:53 <fultonj> slagle: so if i tell the compute node to not have that IP i think things should work
14:16:05 <fultonj> i'll find that out today
14:16:08 <slagle> yea so, i'd fix that first, and then see what happens. it will be easier to debug that way at least
14:16:16 <fultonj> ack
14:16:26 <owalsh> ack
14:16:30 * slagle : land https://review.openstack.org/#/c/631489 and https://review.openstack.org/#/c/632089
14:16:54 <slagle> looks like https://review.openstack.org/#/c/631489/ just needs another +2
14:17:04 <slagle> then we can land these
14:17:15 <fultonj> i'll review it today
14:17:25 <slagle> i also plan to add docs for the dcn deployment with ceph
14:17:30 <slagle> fultonj: thanks!
14:17:45 * slagle slagle/fultonj to review multiple compute+ceph deployment
14:17:52 <slagle> we did that :)
14:17:59 <slagle> owalsh: fultonj : thanks for taking a look
14:18:02 <fultonj> slagle: yeah it works
14:18:17 <slagle> fultonj: to answer your question about cinder-volume, i did mean to deploy that because I used the DistributedHCI role
14:18:36 <slagle> i think the longer term plan is also deploy etcd there to manage cinder-volume A/A
14:19:19 <slagle> so we need to add etcd to the DistributedComputeHCI role
14:19:30 <fultonj> https://docs.openstack.org/tripleo-docs/latest/install/containers_deployment/standalone.html#example-2-nodes-2-nic-using-remote-compute-with-tenant-and-provider-networks
14:19:35 <fultonj> has an example of using cinder for standalone ^
14:19:41 <fultonj> e.g. CinderRbdAvailabilityZone: edge1
14:20:16 <slagle> ok, i don't think i had that configured
14:20:23 <fultonj> slagle: with only one controller you should be ok without etcd as a first step
14:20:30 <fultonj> though i agree we should get it
14:20:40 <slagle> does that need to match the nova AZ? or does it not matter
14:20:49 <fultonj> it should match
14:20:53 <fultonj> hmmmm
14:21:06 <fultonj> i made it match not sure if you want to support non-matching, might be possible
14:21:20 * fultonj not sure about if it matters or not
14:21:24 <slagle> i'll make it match just for convention sake at this point
14:21:34 <openstackgerrit> Lukas Bezdicka proposed openstack/tripleo-heat-templates master: Add environment enabling memcached for cache and authtoken  https://review.openstack.org/638424
14:21:34 <openstackgerrit> Lukas Bezdicka proposed openstack/tripleo-heat-templates master: Use dogpile.cache.memory by default  https://review.openstack.org/638425
14:21:40 <fultonj> +1
14:21:44 <slagle> #action slagle to doc DCN deployment with ceph and cinder-volume config
14:22:03 <slagle> #topic Goals/action items for the week
14:22:30 <slagle> #action slagle look at deploying etcd for cinder-volume
14:22:39 <slagle> anything else to capture for the upcoming week?
14:23:12 <openstackgerrit> Lukas Bezdicka proposed openstack/tripleo-heat-templates master: Add environment enabling memcached for cache and authtoken  https://review.openstack.org/634505
14:23:13 <openstackgerrit> Lukas Bezdicka proposed openstack/tripleo-heat-templates master: Use dogpile.cache.memory by default  https://review.openstack.org/638425
14:23:18 <paramite> Guys, can we please merge https://review.openstack.org/#/c/638143/ to unblock gate?
14:23:55 <owalsh> fultonj, slagle: AFAIK the AZ need to match
14:24:08 <slagle> owalsh: ack, will make it so
14:25:02 <slagle> thanks folks
14:25:06 <slagle> #endmeeting