18:01:39 <hub_cap> #startmeeting trove
18:01:40 <openstack> Meeting started Wed Jan  8 18:01:39 2014 UTC and is due to finish in 60 minutes.  The chair is hub_cap. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:40 <esmute> o/
18:01:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:43 <openstack> The meeting name has been set to 'trove'
18:01:44 <denis_makogon> o/
18:01:48 <kiall> hub_cap would probably beat me if I didn't end it soon ;)
18:01:51 <amcrn> o/
18:01:52 <pdmars> o/
18:01:58 <esp> o/
18:02:02 <kevinconway> o
18:02:09 <hub_cap> kiall: not me!
18:02:10 <robertmyers> o/
18:02:14 <SlickNik> hey
18:02:23 <amytron> o/
18:02:30 <hub_cap> first meeting of the year!!
18:02:31 <imsplitbit> o/
18:02:33 <imsplitbit> o\
18:02:37 <imsplitbit> o/
18:02:41 <datsun180b> o
18:02:45 <denis_makogon> o|
18:02:49 <esmute> Happy 2014 folks!
18:02:53 <hub_cap> #topic https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:02:56 <denis_makogon> thnks
18:02:57 <datsun180b> that is yet to be evaluated
18:03:00 <cp16net> \o
18:03:06 <imsplitbit> yay the world survived another year!
18:03:09 <hub_cap> lol datsun180b
18:03:21 <vipul> o/
18:03:34 <hub_cap> ok so this isint on the list but id like to welcome amcrn to core!
18:03:43 <imsplitbit> yeah welcome
18:03:44 <cp16net> woot
18:03:46 <datsun180b> more like amcoren
18:03:50 <hub_cap> his first task, update russellb 's scripts to show hes in core!
18:03:52 <esmute> congrats amcrn!
18:03:55 <amcrn> thanks :)
18:03:56 <jimbobhickville> looking forward to all the −2s… I mean +2s
18:03:57 <imsplitbit> datsun180b: that was hub_cap quality
18:03:59 <hub_cap> datsun180b: geesus thats my caliber of jokes
18:04:17 <datsun180b> well someone's got to do your job
18:04:31 <hub_cap> datsun180b: good call, 2x bad jokes are way better than 1x
18:04:46 <hub_cap> ok so lets get to the real first topic
18:04:48 <SlickNik> heh, welcome onboard amcrn.
18:05:11 <hub_cap> #topic introduce parelastic
18:05:13 <hub_cap> #link www.parelastic.com
18:05:41 <cp16net> anyone from parelastic here?
18:05:45 <hub_cap> parelastic is a group w/ some mysql, linux, coding rockstars that is coming in to help us wiht, well ill let them talk about it. But im happy to have them joining the fold!!
18:05:47 <amrith> yes, several of s
18:05:47 <doug_shelley66> hi
18:06:00 <parstac_pete> hi there
18:06:01 <hub_cap> welcome doug_shelley66 amrith and co
18:06:01 <SlickNik> hey guys!
18:06:02 <seanGossard> yo
18:06:10 <esmute> NICE
18:06:10 <vgnbkr_1> Hi.
18:06:11 <cp16net> nice welcome :)
18:06:12 <vipul> cool! more trovesters
18:06:13 <amcrn> hola
18:06:14 <glucas> o/
18:06:15 <laurelm> hello
18:06:17 <kanzaros> howdy
18:06:20 <jimbobhickville> wow, lots of 'em.  welcome
18:06:24 <hub_cap> we just doubled in size!! this is great stuff!!
18:06:26 <imsplitbit> ok wait! are we trovians? trovesters?
18:06:28 <denis_makogon> welcome
18:06:30 <doug_shelley66> We are looking forward to getting involved in the Trove community and working with all of you
18:06:42 <imsplitbit> can we have a one hour meeting to decide this?
18:06:47 <imsplitbit> :)
18:06:48 <vipul> imsplitbit: +1
18:06:51 <vipul> i'd like clarity as well
18:06:52 <jimbobhickville> trovenites
18:06:56 <imsplitbit> yeah see
18:06:59 <SlickNik> imsplitbit: take your pick
18:07:01 <imsplitbit> we need clarity on this
18:07:04 <denis_makogon> trovers
18:07:04 <hub_cap> ive been chatting w/ doug_shelley66 and amrith for a bit about comign aboard
18:07:20 <hub_cap> lol you guys if u read this channel it loks like u want clarity about parelastic
18:07:32 <hub_cap> not the choice betwen trovester and trovian or whatever
18:07:36 <imsplitbit> SlickNik: this is python, there should be one and only one way
18:07:42 <jimbobhickville> trovellian
18:07:43 <imsplitbit> ha!
18:07:46 <imsplitbit> sorry about that
18:07:55 * imsplitbit is totally at fault for that
18:08:00 <hub_cap> so lets skip the trovester stuff and let doug_shelley66 intro the team :)
18:08:08 <imsplitbit> I gues
18:08:08 <amrith> +1 :)
18:08:10 <imsplitbit> lol
18:08:19 <denis_makogon> imsplitbit, let them speak
18:08:37 <vipul> yea imsplitbit
18:08:45 <doug_shelley66> hi there - so we have been working on DBaaS for a few years now and are very interested Trove and its direction
18:08:52 <doug_shelley66> so onto the team
18:09:20 <doug_shelley66> We are located between Toronto, Ontario and Cambridge MA
18:09:34 <doug_shelley66> I'm the head of development and will be the Internal Dev Lead
18:09:37 <esmute> Woo... fellow ONtarian here
18:09:49 <doug_shelley66> ah, from where?
18:09:56 <esmute> Ottawa.
18:10:14 <esmute> That's Canada's capital for those who dont know :-)
18:10:21 <imsplitbit> ...
18:10:22 <denis_makogon> lol
18:10:22 <doug_shelley66> say hi to Steve for me
18:10:47 <doug_shelley66> so i know most of the team said HI at the beginning of this but why don't each of just indicate your name and location
18:10:49 <esmute> Im Steve. but sure.. will do
18:10:59 <hub_cap> everyone is steve!
18:11:10 <jimbobhickville> are you a steve or a stew?
18:11:13 <hub_cap> so doug_shelley66 what do you guys intend on working on?
18:11:22 <denis_makogon> doug_shelley66, so, what the difference between Amazon RDS and parelastic ? What kind of features do you have ?
18:11:44 <doug_shelley66> let me answer hub_cap first
18:12:12 <doug_shelley66> after some discussions with hub_cap we are interested in getting involved with the Clustering and Replication projects
18:12:58 <imsplitbit> sweet, we need the help
18:13:04 <imsplitbit> so far it's me
18:13:06 <cweid> o/
18:13:08 <imsplitbit> so I'm happy
18:13:21 <denis_makogon> imsplitbit, and me (from heat side)
18:13:25 <doug_shelley66> at it's core ParElastic is a parallel database
18:13:43 <hub_cap> horray for working on clustering and replication. there is a lot of owrk that will go into that
18:13:44 <doug_shelley66> which can actually cause multiple RDS instances to look like one
18:14:09 <vipul> is it more of a front end? or a different engine underneath?
18:14:42 <doug_shelley66> we didn't implement a storage engine - it is using stock mysql
18:14:47 <doug_shelley66> (or RDS)
18:15:18 <denis_makogon> doug_shelley66, so no NoSQL ?
18:15:34 <robertmyers> double negative
18:15:48 <doug_shelley66> no not NoSQL
18:15:49 <doug_shelley66> :)
18:16:09 <doug_shelley66> we are SQL at the front end
18:16:28 <vipul> doug_shelley66: do you run parelastic in a separate instance than the mysql ?
18:16:44 <doug_shelley66> that is one possible configuration
18:17:09 <amcrn> doug_shelley66: i've read the basic whitepaper, is there another one that details how the data distribution works? the introductory whitepaper states that administrative rules handle it, but i'd be interested in knowing more.
18:17:40 <hub_cap> yes it seems like trove will have some of that logic as well amcrn  :)
18:18:04 <amcrn> (by "basic whitepaper", i'm referring to https://s3.amazonaws.com/ParElastic/ParElastic_White+Paper.pdf, so there's no confusion)
18:19:13 <doug_shelley66> amrcn - maybe we could setup a separate discussion - i don't want to side track this meeting too much?
18:19:20 <hub_cap> ++
18:19:22 <denis_makogon> ++
18:19:23 <amcrn> no problem
18:19:30 <SlickNik> That sounds like a good idea.
18:19:39 <hub_cap> i think thats a fair introduction
18:19:57 <hub_cap> parelastic team, feel free to start chatting in #openstack-trove with us w/ any questions
18:20:04 <hub_cap> welcome!
18:20:20 <doug_shelley66> Thanks - that would be great - as we are spinning up we certainly have questions
18:20:39 <seanGossard> good to be here, thanks!
18:20:51 <hub_cap> woo!
18:20:52 <hub_cap> ok movin on
18:20:59 <hub_cap> #topic mid cycle meetup
18:21:07 <hub_cap> #link https://wiki.openstack.org/wiki/Trove/IcehouseCycleMeetup
18:21:25 <amytron> doug_shelley66:  are you and your team going to the meetup?
18:21:28 <datsun180b> ugh, i'm not going downtown
18:21:32 <datsun180b> it's so far away
18:21:35 <denis_makogon> lol
18:21:36 <hub_cap> im excited about this one. other teams are doing it and i think itll be pretty nice to get together
18:21:44 <hub_cap> lol datsun180b :)
18:21:46 <imsplitbit> hub_cap: +1
18:21:46 <robertmyers> datsun180b: nice
18:22:26 <denis_makogon> sorry, but our team is not able to come due to several reasons
18:22:34 <doug_shelley66> amytron - yes we will be sending a contingent
18:22:39 <imsplitbit> awe man
18:22:45 <hub_cap> #link https://etherpad.openstack.org/p/TroveMidCycleMeetup
18:22:56 <hub_cap> denis_makogon: :(
18:23:15 <hub_cap> denis_makogon: we will find a way to get you involved, maybe a google hangout?
18:23:31 <hub_cap> ill work w/ you denis_makogon to make sure u can be there in some form, we might have to experiment a bit
18:23:54 <denis_makogon> hub_cap, thanks
18:23:55 * datsun180b googles "diy telepresence robot"
18:23:59 <SlickNik> Definitely will figure out a way to involve folks who won't be able to travel.
18:24:02 <hub_cap> plz propose sessions to the etherpad
18:24:05 <cp16net> lol
18:24:21 <imsplitbit> http://www.hizook.com/files/users/3/Texai_Robot_BigBangTheory_6.jpg
18:25:33 <hub_cap> hah ok that means its time to move on :)
18:25:37 <imsplitbit> yep
18:25:46 <hub_cap> also, if u know u are going, and havent signed up yet, plz do now
18:25:48 <hub_cap> or soon
18:26:02 <hub_cap> it helps w/ our headcount for things like lunch, u do want lunch, right?
18:26:09 <hub_cap> https://troveicehousemeetup.eventbrite.com/
18:26:09 <jimbobhickville> lunch++
18:26:13 <hub_cap> #link https://troveicehousemeetup.eventbrite.com/
18:26:14 <cweid> I expect 2 lunches
18:26:17 <kevinconway> hub_cap: i'm sold
18:26:21 <hub_cap> cweid: in 3 days? deal!
18:26:24 <vipul> will special meal requests be fulfilled
18:26:25 <SlickNik> lol
18:26:37 <hub_cap> vipul: yup, all meals will contain chicken
18:26:41 <vipul> or do i have to start eating meat now
18:26:52 <hub_cap> vipul: :)
18:26:54 <jimbobhickville> I request caviar-encrusted puffer fish for my lunch
18:27:24 <hub_cap> i know we have special requests to fufill, we will have glueten free, vegetarian, i assume (right amytron ??)
18:27:54 <datsun180b> what kind of food can't you get from a truck in downtown austin in the middle of the week
18:27:55 <esmute> will Rax be hosting a party too?
18:27:59 <amrith> Yes please. I'm flexitarian (I'll eat steak if you don't have vegan options).
18:28:08 <vipul> esmute: ++
18:28:10 <hub_cap> NICE
18:28:13 <vipul> those Rax parties are awesome
18:28:16 <imsplitbit> I'm with you vipul I need a kosher gluten free lactose free vegetarian meal
18:28:20 <amytron> yes, i think we should provide vegetarian options. we can poll the participants after everyone registers
18:28:37 <cweid> We also will serve plastic pellets.
18:28:44 <hub_cap> amytron: is our socialist expert, she will be making plans on drinkups
18:29:05 <amytron> wow, well. this is awkward
18:29:06 <amytron> :)
18:29:07 <hub_cap> HAAHAHAHAH
18:29:33 <hub_cap> we will likely be doing some drinkups in some form or fashion :)
18:29:44 <cweid> - likely
18:29:51 <imsplitbit> socialist or not
18:29:53 <jimbobhickville> will there be special drink requests?
18:29:56 <doug_shelley66> ok, i'm in
18:30:07 <hub_cap> jimbobhickville: as long as the special request is a beer, yes
18:30:11 <cweid> Whisky/
18:30:22 <datsun180b> can my special request be that you honor nobody else's special request
18:30:36 <denis_makogon> cweid, Irish bomb
18:31:28 <cweid> cweid: This sounds good.
18:31:30 <hub_cap> heh nice :)
18:31:37 <cweid> oops
18:31:39 <hub_cap> cweid: cweid you pulled a hub_cap
18:31:43 <cweid> denis_makogon: this sounds good
18:31:48 <hub_cap> ok movin on!
18:31:51 <cweid> hub_cap: hub_cap we are twins.
18:31:51 <hub_cap> to the less fun topic
18:32:02 <hub_cap> cweid: dibs on davito
18:32:06 <imsplitbit> oh jees here it comes
18:32:12 <cweid> Users...
18:32:14 <hub_cap> #topic too many open reviews
18:32:19 <hub_cap> lol no not users
18:32:31 <hub_cap> cp16net: plz link those
18:32:40 <cp16net> #link http://www.russellbryant.net/openstack-stats/trove-openreviews.html
18:32:55 <cp16net> #link https://review.openstack.org/#/mine/important/
18:33:05 <SlickNik> I'm going to have a chunk of time to work through a bunch of them today.
18:33:06 <hub_cap> so we have a lot of reviews, this is partually due to the end of year, partially due to the core team size and partially due to the core team *participation*
18:33:28 <SlickNik> And by going to have, I mean I've tried to put aside. :)
18:33:59 <vipul> i accept some of the blame... haven't been active as i'd like to be on those
18:34:43 <cp16net> sorry to be a party pooper but just wanted to bring it up since i've seen so many reviews ~70
18:35:09 <hub_cap> yes cp16net
18:35:11 <vipul> cp16net: it's a fair point.. we havn't been doing our job
18:35:35 <amcrn> if some eyes could hit the configuration-groups review and the datastore-manager to versions review in particular, that'd be great
18:35:37 <hub_cap> yes we really need to focus. im going to be putting my support behind all the datastore sint he next few days
18:35:40 <cp16net> ok i'll step off the soap box
18:36:06 <esmute> not just core reviews. Non-core can also provide valuable reviews which can speed things up (not saying that I do :-))
18:36:35 <hub_cap> we need to merge the _large_ patches too, yes amcrn config groups and datastores
18:36:36 <SlickNik> amcrn: will take a look.
18:36:40 <cp16net> esmute: i agree
18:36:47 <denis_makogon> esmute, true stroy
18:36:52 <denis_makogon> *story
18:37:21 <hub_cap> ok so, we totally know this is an issue, and i will be harping on it
18:37:30 <hub_cap> as a community, please, look at the stats
18:37:49 <hub_cap> if you see core members not doing their jobs, call them out :)
18:37:52 <denis_makogon> stats != reality
18:37:54 <hub_cap> it will help keep us in check
18:38:13 * imsplitbit ducks
18:38:15 <jimbobhickville> stats measure reality?
18:38:19 <hub_cap> denis_makogon: not sur ewhat u mean
18:38:28 <hub_cap> the stats reflect the work each person does on reviewing
18:38:35 <hub_cap> if you see a core member w/o a lot of reviews talk to them
18:38:40 <hub_cap> cuz they arent doing their job
18:38:41 <hub_cap> so
18:38:43 <hub_cap> stats = reality
18:38:44 <denis_makogon> hub_cap, if you mean review/contribution stats
18:38:49 <cweid> return true
18:38:55 <hub_cap> i mean the reviews yes
18:39:00 <imsplitbit> that would be stats == reality
18:39:07 <hub_cap> imsplitbit: shaddup
18:39:15 <kevinconway> imsplitbit: unless javascript then stats === reality
18:39:28 <cp16net> ≠≠
18:39:37 <denis_makogon> we haven't seen grapex for awhile
18:39:49 <hub_cap> denis_makogon: grapex is on vacation :)
18:39:56 <denis_makogon> hub_cap, makes sense
18:40:03 <cp16net> yup
18:40:10 <hub_cap> ill be screaming at core daily
18:40:20 <datsun180b> result = new ComparisonFactory.create(ComparisonFactory.equals)().compare(stats, reality);
18:40:54 <hub_cap> lol
18:41:39 <hub_cap> ok so i welcome ideas for makign this better
18:42:19 <hub_cap> #topic tempest integration
18:42:33 <denis_makogon> i like the idea of putting link to Russels site (open reviews section) in Open Discussion
18:42:56 <denis_makogon> it would be some sort of reminder
18:43:21 <SlickNik> Okay, so I've submitted patches to devstack-gate, and openstack-infra config to enable us to run tempest on devstack-gate.
18:43:21 <hub_cap> if u want to re-add it weekly denis_makogon im fine w/ that (i might forget)
18:43:40 <denis_makogon> SlickNik, could you share the links ?
18:44:07 <SlickNik> Yeah, hang on.
18:44:11 <denis_makogon> k
18:44:35 <hub_cap> #link https://review.openstack.org/#/c/65065/
18:44:35 <hub_cap> #link https://review.openstack.org/#/c/64913/
18:44:35 <hub_cap> #link https://review.openstack.org/#/c/65040/
18:44:36 <SlickNik> #link https://review.openstack.org/#/c/65065/
18:44:38 <hub_cap> :)
18:44:41 <hub_cap> BEEEEEET U
18:44:43 <SlickNik> thanks hub_cap
18:44:52 <hub_cap> npnp
18:45:18 <SlickNik> Also, I'm still working on cleaning up the guestagent elements and the job to build the image.
18:45:56 <SlickNik> But this will allow us to get started writing Tempest tests that test the API and parts of the taskmanager, at least.
18:46:24 <denis_makogon> so, do we plan to deprecate -integration ?
18:46:27 <SlickNik> Until that piece is in place.
18:46:54 <SlickNik> denis_makogon: eventually the integration tests parts of it, at least.
18:47:16 <SlickNik> I imagine it'll stick around until we have enough coverage in tempest.
18:47:52 <denis_makogon> i think we need pure plan for tests coverage
18:48:27 <denis_makogon> and we could split tasks between guys who works w/ tempest
18:49:01 <SlickNik> I'd love help with writing tests for tempest.
18:49:15 <SlickNik> I know some of you already started looking at it.
18:49:36 <SlickNik> denis_makogon: can you explain what you mean by "pure plan"?
18:49:40 <denis_makogon> i know that my teammate is working on list- operation
18:50:28 <denis_makogon> when we would have merged infra and devstack patches we would need to cover ReST API part
18:51:07 <denis_makogon> so we have not so many tests which involves rest
18:51:26 <denis_makogon> we could give those tests to SnowDust, as variant
18:51:34 <kevinconway> denis_makogon: are you talking about some kind of acceptance test that only uses api?
18:52:18 <denis_makogon> i mean that we need to split whole tests into separate independent groups and share them between everyone who is interested in it
18:52:29 <hub_cap> lets work on delegatging outisde this meeting
18:52:34 <denis_makogon> k
18:52:36 <hub_cap> and give some time for open discussion
18:52:59 <SlickNik> Perhaps what's needed is to meet up regarding it and to talk about who's working on which pieces.
18:53:07 <hub_cap> ++
18:53:10 <SlickNik> I can look into setting some time up for that.
18:53:32 <hub_cap> #topic open discussion
18:53:38 <hub_cap> GO GOGOGOGO
18:53:53 <datsun180b> #topic airline food: what's the deal
18:53:54 <SlickNik> #action SlickNik to organize some time to meet up and talk about who's working on what for the tempest tests.
18:54:51 <hub_cap> datsun180b: depends on the airline, when i fly i get a great eggs benedict w/ bacon instead and a spicy hollindaise
18:55:00 <hub_cap> oh wait thats airport food
18:55:03 <hub_cap> not airline food
18:55:10 * SlickNik want's to know what airline hub_cap flies
18:55:20 <hub_cap> eheh i just meant the air_port_
18:55:23 <vipul> imsplitbit: Do you have enough to push up reviews for the replication pieces you've been working on?
18:55:33 <SlickNik> ah, makes more sense.
18:55:38 <vipul> airport ramen
18:55:47 <imsplitbit> vipul not yet but I have 40% on metadata I'll be submitting soon
18:55:54 <esp> hub_cap: that sounds delicious
18:55:54 <imsplitbit> the replication will be fast follow
18:55:56 <imsplitbit> just api
18:55:58 <imsplitbit> no impl
18:55:59 <hub_cap> AIRPORT RAMEN vipul
18:56:22 <vipul> imsplitbit: Ok - we would like to help out with some of that, so whenever you have it we can look at it
18:56:34 <imsplitbit> no problem
18:56:42 <hub_cap> if nothign else, push it to a fork :)
18:56:44 <imsplitbit> parelastic seems to want to help with that too
18:56:56 <imsplitbit> so we should be able to knock it out
18:56:58 <imsplitbit> quick
18:57:13 <denis_makogon> SlickNik, could you write ML about sub-meeting (topic - tempest and trove) ?
18:57:35 <SlickNik> denis_makogon: will do.
18:57:39 <doug_shelley66> imsplitbit - maybe we can connect up and see what we can help with
18:58:08 <imsplitbit> doug_shelley66: definitely
18:58:20 <imsplitbit> I would also like to host a meeting at the meetup in austin
18:58:33 <imsplitbit> very little presentation but lots of collaboration
18:59:05 <hub_cap> ++
18:59:06 <hub_cap> :)
18:59:14 <denis_makogon> lets meet in Europe
18:59:21 <denis_makogon> suppose, Paris ?
18:59:22 <hub_cap> denis_makogon: i agree!!!
18:59:24 <denis_makogon> Madrid
18:59:26 <cp16net> +1
18:59:28 <kevinconway> denis_makogon: paris, texas
18:59:29 <robertmyers> +1
18:59:29 <cp16net> :-P
18:59:30 <denis_makogon> Moscow
18:59:33 <pdmars> denis_makogon: yes
18:59:38 <kevinconway> denis_makogon: or odessa, texas
18:59:41 <denis_makogon> London
18:59:43 <doug_shelley66> how about Sochi in a few weeks
18:59:43 <hub_cap> paris is the next one (after atlanta)
18:59:48 <denis_makogon> at Baker Street 221B
18:59:52 <hub_cap> lol
19:00:03 <hub_cap> its 11
19:00:04 <imsplitbit> good talk guys
19:00:05 <hub_cap> #endmeeting