18:00:45 <grapex> #startmeeting trove
18:00:46 <openstack> Meeting started Wed Jan 29 18:00:45 2014 UTC and is due to finish in 60 minutes.  The chair is grapex. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:49 <openstack> The meeting name has been set to 'trove'
18:00:54 <doug_shelley66> o/
18:00:56 <robertmyers> o/
18:01:00 <grapex> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:01:01 <pdmars> o/
18:01:02 <datsun180b> hello
18:01:07 <denis_makogon> o/
18:01:07 <abramley> o/
18:01:08 <kevinconway> \o/\o/\o/\o/\o/
18:01:14 <cp16net> o/
18:01:26 <kanzaros> o/
18:01:35 <esmute> o/
18:01:38 <denis_makogon> agenda ?))
18:01:49 <datsun180b> i think i had both #actions
18:01:54 <SlickNik> o/
18:01:57 <kevinconway> #agreed
18:02:01 <denis_makogon> SlickNik, hi
18:02:01 <esp> o/
18:02:03 <datsun180b> as per talking to nova's conductor peeps, no progress
18:02:15 <annashen> o/
18:02:27 <cp16net> #link http://eavesdrop.openstack.org/meetings/trove/2014/trove.2014-01-22-18.00.html
18:02:33 <SlickNik> thanks cp16net
18:02:36 <grapex> #topic action items
18:02:38 <datsun180b> oh now we're official, i'll start over
18:02:53 <ViswaV> o/
18:03:05 <grapex> #topic add sent_at table for conductor to sync messages from guests
18:03:06 <grapex> datsun180b?
18:03:39 <datsun180b> migration table built, just need to hook the models up
18:03:54 <datsun180b> review marked as WIP for now until i get that all squeaky clean
18:04:04 <grapex> datsun180b: Sounds good
18:04:27 <grapex> Up next
18:04:31 <grapex> #topic talk to nova team about their conductor sync strategy
18:04:35 <grapex> datsun180b: ^
18:04:39 <datsun180b> no progress
18:05:01 * grapex <insert a joke about hitting datsun180b with a fish or something here>
18:05:06 <datsun180b> mostly been focused on conductor work from #1 and parallel work in sneaky-pete
18:05:10 <denis_makogon> lol
18:05:25 <grapex> Ok,let's add another action item to do that next time
18:05:38 <grapex> #action datsun180b talk to nova team about their conductor sync strategy
18:05:38 <datsun180b> on it
18:05:40 <datsun180b> or you can
18:06:09 <grapex> Alright, moving on to the agenda item(s)
18:06:21 <grapex> #topic Tempest update
18:06:32 <SlickNik> That's me
18:06:32 <grapex> SlickNik: This is yours I think
18:06:58 <SlickNik> So you might have noticed that we've got tempest jobs running on the jenkins test now.
18:07:10 <denis_makogon> we're saw that now we have tempest gate - very cool)))
18:07:43 <SlickNik> You'll see something like:
18:07:44 <SlickNik> http://logs.openstack.org/29/69429/3/check/check-tempest-dsvm-trove-full/2084864 SUCCESS in 51m 25s (non-voting)
18:07:45 <esmute> SlickNik: Nice ~
18:07:53 <denis_makogon> cool
18:07:55 <datsun180b> non-voting eh
18:08:09 <SlickNik> yes, datsun180b - it's non-voting for now.
18:08:21 <SlickNik> I'm still adding trove specific tests
18:08:25 <datsun180b> sounds like fun
18:08:42 <denis_makogon> sounds like best news ever))
18:08:48 <SlickNik> The first patch of which is at: https://review.openstack.org/#/c/69501/
18:08:48 <kevinconway> SlickNik: so these are an additional gate for trove?
18:08:50 <cp16net> very cool
18:09:01 <vipul> o/
18:09:26 <SlickNik> kevinconway: yes -  and it's gonna be run using resources from upstream OpenStack CI
18:09:27 <cp16net> Ran 2030 tests in 2463.772s
18:09:33 <cp16net> that takes a while
18:09:46 <SlickNik> ~ 50 − 60 mins.
18:10:08 <denis_makogon> SlickNik, any news about image elements ?
18:10:12 <kevinconway> SlickNik: ok, so these tests won't gate nova, for example, to make sure they don't break us?
18:10:17 <esmute> our rdjenkins gate jobs take around the same time
18:10:34 <SlickNik> kevinconway: they will.
18:10:46 <SlickNik> We need to get the trove tests written for that though.
18:11:10 <SlickNik> So eventually, they will.
18:11:29 <SlickNik> So, I'm going to need help with adding more tests to the trove test suite.
18:11:52 <SlickNik> #link https://review.openstack.org/#/c/69501/
18:11:54 <grapex> SlickNik: Sounds cool
18:12:03 <esp> SlickNik: I can help write some tests
18:12:20 <kevinconway> SlickNik: will all tempest tests live in the openstack-tempest repo?
18:12:27 <SlickNik> ^^ Basic flavor API tests.
18:12:30 <kevinconway> as in are we going to remove tests from the trove repo?
18:13:10 <SlickNik> kevinconway: That's a contentious issue that we probably need to discuss. The way I see it now is that the tempest test supplement the int-tests.
18:13:24 <denis_makogon> SlickNik, according to test plan we already know who would write tests for trove, so lets ask them
18:13:37 <grapex> kevinconway: The goal of Tempest is to help gate the entire Stack as a whole
18:13:41 <SlickNik> We can't remove the int-tests until we have test coverage at par (or better than) the int-tests.
18:13:53 <denis_makogon> of course
18:13:54 <SlickNik> I hope to get there someday perhaps, but it's gonna take time.
18:14:02 <vipul> nice work SlickNik
18:14:11 <vipul> i'll help out writing the tests too
18:14:17 <denis_makogon> same as i
18:14:25 <grapex> I'm also going to make the argument at that time that there are some features of the current int tests, such as running quickly in Tox, I don't want to give up.
18:14:33 <grapex> Hopefully we can put some people on Tempest at Rax soon
18:14:45 <SlickNik> denis_makogon: I'm still working on the dib patch. Sort of needed to shift focus for a bit.
18:15:17 <denis_makogon> SlickNik, we could take care of list (HTTP GET) operation while
18:15:43 <SlickNik> yes denis_makogon: it's possible to get entire chunks of the API tested in the meanwhile.
18:15:48 <denis_makogon> then you'll become a bit free (i suppose) to take care of dib elements
18:16:15 <denis_makogon> SlickNik, i already had draft for list operations
18:16:21 <SlickNik> denis_makogon: I'll look to have something by end of this week, so we can proceed with the guest tests as well.
18:16:34 <denis_makogon> sounds amazing
18:16:47 <denis_makogon> any way, very good job SlickNik
18:17:01 <grapex> SlickNik: Awesome job.
18:17:10 <SlickNik> So, I found this very useful when coming up to speed:
18:17:13 <SlickNik> #link https://review.openstack.org/#/c/69501/
18:17:16 <SlickNik> oops
18:17:19 <SlickNik> #undo
18:17:22 <cp16net> lol
18:17:27 <SlickNik> #link http://docs.openstack.org/developer/tempest/
18:17:56 <denis_makogon> yes, very useful link
18:18:23 <SlickNik> And here's (at a high level) the list of trove functionality to write tests for:
18:18:25 <denis_makogon> there are tons of info that makes writing tests easier
18:18:27 <SlickNik> #link https://etherpad.openstack.org/p/trove-tempest-items
18:19:03 <SlickNik> I'll keep you guys updated with progress on the tests.
18:19:09 <denis_makogon> thanks
18:19:09 <SlickNik> That's pretty much all I had.
18:19:13 <denis_makogon> we'll do the same
18:19:48 <SlickNik> Thanks.
18:20:11 <SlickNik> back to you grapex
18:20:14 <denis_makogon> grapex, you are chairman
18:20:18 <denis_makogon> lead us
18:20:19 <grapex> SlickNik: Thanks for all your work on this.
18:20:43 <grapex> #topic Open discussion.
18:20:49 <grapex> Short agenda this week!
18:20:52 <denis_makogon> could i take few words ?
18:21:00 <grapex> By the way, hub_cap was sick today. He wishes us all the best. :)
18:21:10 <vipul> that's kind of him
18:21:34 <grapex> Anything anyone wants to discuss?
18:21:37 <esmute> Austin ppl, which hotels (or area) do you recommend staying at?
18:21:54 <doug_shelley66> the parelastic team is at the Intercontinental
18:22:03 <doug_shelley66> it appears to be 1 block from the meeting place
18:22:11 <grapex> esmute: Go wherever hub_cap says
18:22:12 <denis_makogon> #link https://review.openstack.org/#/c/69450/ - i'd like to heat anyone thoughts about that patch
18:22:14 <robertmyers> why not at the Omni?
18:22:14 <grapex> That's been my travel experience
18:22:29 <denis_makogon> *hear
18:22:53 <esmute> doug_shelley66: Cool.. will consider that.. and what hub_cap says
18:22:57 <doug_shelley66> hub_cap put a list on the wiki page he has for the event
18:23:03 <doug_shelley66> intercontinental was on the list
18:23:18 <cp16net> link it?
18:23:23 <SlickNik> denis_makogon: I'd not like to review specific patches during a meeting. Perhaps take it offline in openstack-trove after.
18:23:36 <doug_shelley66> https://wiki.openstack.org/wiki/Trove/IcehouseCycleMeetup#Event_Details
18:23:36 <grapex> SlickNik: Agreed
18:24:04 <SlickNik> denis_makogon: if there's a bigger issue with a patch/set of patches which needs discussion, we can bring it up as a topic.
18:24:11 <denis_makogon> SlickNik, oh, i know, i just let all of you know, that it would be good to see that one reviewd
18:24:28 <SlickNik> denis_makogon: Oh, I see. Noted.
18:24:41 <denis_makogon> thanks
18:24:59 <denis_makogon> sorry for interruption
18:25:02 <SlickNik> #link https://wiki.openstack.org/wiki/Trove/IcehouseCycleMeetup#Event_Details
18:25:28 <SlickNik> no worries,  denis_makogon ))
18:25:39 <denis_makogon> SlickNik, good
18:25:58 <denis_makogon> guys, have you received summit tickets with discount ?
18:26:08 <datsun180b> I have
18:26:35 <grapex> Quick note regarding hotel recommendations: I need to ask my wife's permission but I will be renting out my living room couch at the low, low price of $800 a night. This includes a free continental breakfast consisting of cereal and one cup of coffee.
18:26:53 <datsun180b> oh man, you get cereal!
18:27:01 <SlickNik> I think they started sending them (the ATC passes) out yesterday.
18:27:04 <datsun180b> i've been eating granola bars like a sucker
18:27:14 <SlickNik> grapex: That sounds like a steal!
18:27:22 <vgnbkr_1> what's the kick-back on that?
18:27:24 <grapex> datsun180b: It'll be either Muslix or Toasted O's (a local Cheerio imitation), subject to availability
18:27:28 <cp16net> hehe
18:27:36 <datsun180b> that first one's great, don't knock it
18:27:45 <datsun180b> just add a little honey and stir
18:28:04 <grapex> So... anything else?
18:28:18 <datsun180b> yeah, eat it before it hits room temp
18:29:10 <SlickNik> Oh one thing I'd like to mention.
18:29:17 <grapex> SlickNik: ok
18:29:38 <SlickNik> There were some issues with the new pypy gate job, and the libxml client library that the trove-client uses.
18:29:54 <SlickNik> essentially libxml is a C library that pypy doesn't support.
18:30:02 <grapex> SlickNik: Good point. It shouldn't be too hard to make that import optional
18:30:07 <SlickNik> So I've made the pypy job on the trove-client non-voting for now.
18:30:08 <grapex> or wait until XML is gone and just remove it
18:30:17 <SlickNik> We're planning to rip out xml anyhow.
18:30:38 <robertmyers> technically we can remove it from the client right now
18:30:39 <SlickNik> So I spoke to hub cap and am gonna rip it out of the client.
18:30:48 <SlickNik> And turn the job back on.
18:30:50 <robertmyers> SlickNik: good
18:30:54 <grapex> SlickNik: Sounds good to me.
18:30:57 <SlickNik> Yeah, robertmyers. That's the plan.
18:31:09 <SlickNik> Just a heads up.
18:31:13 <esmute> sorry to break it to you but my nutritionist told me that cereal is actually bad for your body... It contains sugar, carbs and other stuff.. and the bad things far outweights the good
18:31:13 <SlickNik> Thanks.
18:31:53 <imsplitbit> esmute: nutritionists are bad for your health
18:32:06 <grapex> esmute: Well my anthropomorphic cartoon tiger routinely refers to them as "great."
18:32:14 <jimbobhickville> it's ok, next year they will be telling us how all we should do is eat cereal
18:32:34 <SlickNik> And with that I'm really done.
18:32:38 <esmute> same with orange juice. Even the one that says 'Not from concentrate"
18:32:39 <grapex> Ok, cool
18:32:47 <grapex> Well, let's take it back to #openstack-trove
18:32:49 <grapex> Thanks everyone
18:32:52 <grapex> #endmeeting