18:00:50 <SlickNik> #startmeeting trove
18:00:50 <openstack> Meeting started Wed Jun 25 18:00:50 2014 UTC and is due to finish in 60 minutes. The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:54 <openstack> The meeting name has been set to 'trove'
18:01:52 <SlickNik> Agenda at:
18:01:55 <grapex> o/
18:01:57 <SlickNik> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:01:59 <amrith> 0/
18:02:30 <kevinconway> 7o7
18:02:32 <pdmars> o/
18:02:36 <schang> o/
18:02:36 <cp16net> o\
18:02:44 <abramley> o/
18:02:50 <tvoran> o/
18:03:06 <robe5515> o/
18:03:32 <peterstac> o/
18:03:53 <vgnbkr> o/
18:03:55 <SlickNik> #topic Action Items
18:03:55 <iccha1> o/
18:04:05 <SlickNik> None from last meeting, so let's move on to other topics.
18:04:23 <SlickNik> #topic Integration-tests update
18:05:02 <SlickNik> Put this into the schedule to let folks know about changes that have been made / are being made to the int-test infrastructure.
18:05:14 <dougshelley66> o/
18:05:17 <kevinconway> sounds scary
18:05:35 <grapex> SlickNik: Is this "int-test"?
18:05:42 <grapex> Or the Tempest tests?
18:05:50 <SlickNik> grapex: yes rdjenkins running int-test
18:06:47 <SlickNik> You might have noticed the trove gate running a bit faster (~1:10 instead of ~1:30)
18:07:03 <SlickNik> And the reason for that is that we're now using a cached dib image for the guestagent.
18:07:04 <cp16net> ahh yeah
18:07:19 <cp16net> bad ass
18:07:25 <grapex> SlickNik: nice
18:07:47 <SlickNik> So the image we're using is being pulled from http://tarballs.openstack.org/trove/images/ubuntu_mysql.qcow2/
18:08:32 * amrith hoists a pitcher to the person who delivered this ... cheers!
18:08:37 <SlickNik> And currently gets built as part of an experimental openstack-infra job on trove-integration.
18:08:45 <SlickNik> (where the elements are stored)
18:09:16 <grapex> SlickNik: So there's a job that's always running to update the image?
18:09:25 <cp16net> #link http://tarballs.openstack.org/trove/images/ubuntu_mysql.qcow2/
18:10:17 <peterstac> I'd assume the image is updated whenever a change is merged, no?
18:10:17 <SlickNik> grapex: currently it runs on demand when someone leaves a check-experimental comment on a trove-integration patch
18:10:30 <grapex> Nice
18:11:00 <SlickNik> I'm going to shortly fix that so it runs post a change merge to trove-integration, as peterstac mentions
18:11:14 <cp16net> yeah sounds good
18:11:34 <SlickNik> Also, there's a patch out to devstack to use the cached image during a trove install.
18:11:36 <peterstac> SlickNik: Still, better than building it each time - good work!
18:11:46 <cp16net> +1
18:11:56 <SlickNik> #link https://review.openstack.org/#/c/102455/
18:12:22 <SlickNik> Once that merges, we can start testing datastores as part of the tempest tests.
18:13:26 <kevinconway> SlickNik: so how does tempest run datastore tests?
18:13:34 <kevinconway> aren't they all trove integration tests?
18:14:21 <kevinconway> or is it that the current temptest tests will be run against multiple datastores?
18:14:21 <SlickNik> kevinconway: I meant Datastore API tests (not actual datastore guest tests just yet)
18:14:53 <grapex> SlickNik: what's the distinction between an API test and an "actual datastore guest test?"
18:15:00 <SlickNik> i.e. Test that there's a default datastore using the API, and that it has a default version.
18:15:51 <SlickNik> There's still two open items that need to be fixed before we can test spinning up an actual guest as part of the gate
18:16:40 <grapex> SlickNik: So when that happens how difficult will it be to run on a local VM?
18:17:01 <grapex> Will it be roughly the same only you'll have to build the image first and then kick it off?
18:17:48 <SlickNik> grapex: The default in trove-integration is still to build an image, and kick it off.
18:18:14 <grapex> SlickNik: Cool
18:18:35 <SlickNik> grapex: However if you specify an env var i.e. TROVE_IMAGE_DOWNLOAD_URL, it'll instead download a cached image from that location and use that instead.
18:19:02 <cp16net> thats cool
18:19:50 <SlickNik> So the outstanding issues to be able to test guest-images in the gate :
18:19:50 <SlickNik> 1. Still need figure out a way to allow the prebuilt image to pull in the trove-guestagent code (the way we do it today is schlepping down a know pub_key in authorized_keys on the host, and something similar might have to be done in devstack)
18:20:55 <SlickNik> 2. The paths where the guest code need to be rsync'ed from are different in the trove-integration, and devstack-gate cases. Still need to figure out a way to handle that issue.
18:21:06 <iccha1> as we build new processes, can we ensure they get documented? like check-experimental for tests etc
18:21:36 <SnowDust> iccha1 +1
18:22:28 <SlickNik> iccha1: That's specific step is one that will go away soon. But we should definitely update the dev-docs with this new info about things like the env-var that I just mentioned.
18:22:39 <iccha1> sweet! thanks SlickNik
18:23:10 <SlickNik> #action SlickNik to update the dev-docs with build / test process updates.
18:23:45 <SlickNik> On another front, I've been working to move our trove-int tests that run on rdjenkins to openstack-infra.
18:24:16 <SlickNik> So you guys might see a few patches to trove-integration to allow the tests to run in a devstack-gate environment.
18:24:46 <SlickNik> That's pretty much all I had.
18:25:11 * amrith hoists another pitcher to the person who delivered this ... cheers!
18:25:36 <SlickNik> Thanks amrith
18:25:48 <SnowDust> amrith :)
18:25:53 <SlickNik> Come find me if you have any question regarding any of this.
18:26:00 <SlickNik> Let's move on.
18:26:14 <SlickNik> #topic Vertica Datastore patch review
18:26:36 <amrith> i've been slogging through it
18:26:38 <SnowDust> Yes .. community .. any reasons .. not reviewing it ?
18:26:45 <amrith> there are some large-ish patch sets
18:26:46 <kevinconway> when did this pop up on the agenda?
18:26:52 <amrith> like neutron
18:26:59 <SlickNik> kevinconway: It was a late addition.
18:27:00 <amrith> and I'm actually trying to run the thing
18:27:02 <SnowDust> kevinconway : added an hour ago
18:27:04 <amrith> and it isn't trivial
18:27:22 <SlickNik> SnowDust: There are a few reasons for this.
18:27:28 <SnowDust> amrith: thanks for your effort ..
18:27:35 <SlickNik> As amrith mentions, it is a big patch-set
18:27:38 <amrith> postgres which kevinconway submitted is a whole lot easier
18:27:51 <SnowDust> amrith : i know ..
18:28:03 <SnowDust> SlickNik: ok understand ..
18:28:18 <kevinconway> amrith: thanks! someone looked at it!
18:28:19 <SlickNik> And there have been a lot of other reviews as well.
18:28:55 <SnowDust> kevinconway : ;)
18:28:56 <SlickNik> SnowDust: It would help if you could get some of the global logic folks to look at other reviews too.
18:29:19 <SnowDust> SlickNik .. we will do that .. positively now on ..
18:29:54 <SlickNik> I think denis makogon suggested breaking up the patchsets.
18:30:00 <amrith> SnowDust ... I'm assuming that you are looking for reviews on all the patch sets
18:30:04 <amrith> there are three or four
18:30:09 <SnowDust> amrith : right ..
18:30:10 <amrith> and that's a bit of a pain
18:30:28 <SnowDust> amrith: if we go by denis .. we will have more patchsets ..
18:30:36 <grapex> Ask not, what Trove can do for you... what you... can do for Trove
18:30:49 <SlickNik> That does help with making the review chunks easier, but sometimes you lose context while jumping between patchsets while reviewing .
18:31:00 <SlickNik> So there's pros and cons to that approach.
18:31:22 <SnowDust> SlickNik: thats why i got this topic in meeting
18:31:29 <SlickNik> grapex kennedy: lol, and +1 too
18:32:14 <SnowDust> I agree .. we have complete functionality to showcase .. and thats a lot of work from our side :)
18:32:17 <amrith> SnowDust ... let's not make this personal. denis had a good point and in most cases it is a good approach. IN this instance, it is a little bit more difficult to get a common context across all of them
18:32:58 <SnowDust> amrith : i value denis .. nothing personal ..
18:33:28 <SlickNik> Another reason, imo is that we don't automated tests for different datastores at the moment.
18:33:47 <SlickNik> So as amrith alluded to earlier, you end up having to do a dry-run / check by hand.
18:33:59 <SlickNik> Hopefully we can fix this soon.
18:34:20 <SnowDust> So, whats action item for me / us on this ?
18:34:37 <SnowDust> Or the team's openion ..
18:35:24 <SlickNik> SnowDust: Perhaps you can start looking at setting up some sort of automated third-party testing infrastructure for this?
18:35:30 <amrith> SlickNik, the problem I've been having is similar to both vertica and postgres and it has to do with making the guest image. so I'm struggling with a common problem on both patch sets. hopefully I'll get past that soon.
18:36:08 <SnowDust> amrith .. i will try helping u for vertica ..
18:36:35 <amrith> SnowDust, thanks. my problem is likely related to my configuration/vmware on my laptop.
18:36:44 <SlickNik> amrith: That's a good point. Perhaps building a cached image and making it available somewhere would be a good start.
18:37:08 <SnowDust> OK .. i will take that item ..
18:37:15 <SlickNik> trove-integration now supports using a pre-built cached image for guests, you know ;)
18:37:34 * amrith hoists another pitcher to the person who delivered this ... cheers!
18:37:38 <SnowDust> Yeah .. good
18:37:46 <SlickNik> Okay, thanks SnowDust.
18:37:57 <grapex> SlickNik: You may want to start flickering the lights.
18:38:01 <SlickNik> (and amrith)
18:38:04 <SlickNik> grapex: lol
18:38:09 <grapex> amrith: I think you've had enough!
18:38:17 <SnowDust> grapex: :D
18:38:23 <SlickNik> I think he just wants an excuse to imbibe :P
18:38:49 <amrith> grapex, there is no such thing as 'enough'. Anyway, I've been off the sauce for some days now.
18:38:57 <grapex> amrith: I keed, I keed
18:39:09 <SlickNik> Hopefully we can get more eyeballs and tests on these biggish "datastore" patches and get them moving soon.
18:39:27 <SlickNik> Help from all fronts is much appreciated. :)
18:39:30 <grapex> SlickNik: I'm pretty depressed the official way we test them is "run them by hand"
18:39:36 <grapex> I know you're working hard to change that
18:39:49 <SlickNik> grapex: me too :(
18:39:56 <grapex> but in my experience that just means that even if we do more work to check in more datastore code for all we know it could break shortly afterwards
18:40:27 <grapex> So the big blockers are just being able to get the guest agent code onto a server in a test environment, right?
18:41:36 <SlickNik> yup, that's the big one I'm hitting right now
18:41:36 <grapex> Not trying to be negative- I appreciate all the hard work you're done.
18:42:04 <grapex> In theory, shouldn't Tempest already be able to run in the redstack Jenkins job?
18:42:05 <amrith> grapex, for me that is. I was having trouble getting a guest agent (with mysql) to boot on my machine due to my own stupidity mostly. I'm through that now but still havign issues with pg and vertica
18:42:56 <SlickNik> grapex: Yes, I don't see why now.
18:42:57 <SlickNik> not*
18:42:57 <grapex> SlickNik: Just suggesting if we ran it there we could start at least writing Tempest tests today for these things
18:44:18 <SlickNik> grapex: THis comes back to having some sort of third party tests running for the new datastore type.
18:44:50 <grapex> SlickNik: Ok
18:45:19 <SlickNik> grapex: you actually bring up a very good point.
18:47:22 <SlickNik> SnowDust: perhaps we can make something like the "simple" test group run for Vertica on a Jenkins box somewhere?
18:47:45 <SnowDust> ok ..
18:47:48 <grapex> SlickNik: agreed. We need it already for Redis
18:47:57 <grapex> If you're talking about adding to the existing int-tests
18:48:50 <SlickNik> grapex: Yes, I figured that if we do that, it would be fairly straightforward to move to the devstack-gate infra when we have the kinks ironed out.
18:49:17 <grapex> Ok. I think that's a good idea, and we could contribute some stuff soon-ish
18:49:26 <grapex> I was thinking though of running Tempest in the redstack jenkins job
18:49:40 <grapex> Just so we could run it somewhere and get some feedback / insight as to how it works
18:51:50 <SlickNik> I think that it'd be a bigger task to get Tempest running on the rdjenkins box. I don't want to go down a path of having to invent a new, separate devstack-gate wrapper to do that.
18:52:01 <grapex> I'd love to start using Tempest internally at Rax so we could contribute new datastore specific tests back upstream. Having it run in the redstack vm would help show an example of how it works.
18:52:17 <grapex> Ok- if it's a bigger task then that makes sense.
18:52:26 <grapex> I was thinking it could run after the current int-tests
18:52:55 <grapex> but it sounds like the setup might be very expensive or complex
18:54:02 <SlickNik> Let me look into what might be the best / quickest thing to do here.
18:54:30 <SlickNik> I'll update you guys next week with what I find.
18:54:38 <SlickNik> Might have to do some digging.
18:54:53 <grapex> Cool. Thanks SlickNik!
18:55:09 <SlickNik> Thank you!
18:55:14 <SlickNik> #topic Open DIscussion
18:55:24 <amrith> SlickNik, I have two
18:55:33 <SlickNik> amrith: go for it
18:55:51 <amrith> 1. other groups are sending out an email about the midcycle meetups. I intend to do that for trove. OK?
18:56:23 <SlickNik> amrith: Sure thing, go for it.
18:56:42 <amrith> 2. there's a project doing a general cleanup of logging. I noticed a couple of change sets that were fixing logging of messages, typos and the like. I'd like to suggest that we eschew these one-of changes in favor of the project
18:57:13 <grapex> amrith: Project? Like a cross-OpenStack thing?
18:57:22 <amrith> grapex, no. trove
18:57:37 <amrith> #link https://bugs.launchpad.net/trove/+bug/1324206
18:57:38 <uvirtbot> Launchpad bug 1324206 in trove "audit logging levels" [Low,In progress]
18:57:53 <amrith> youza, what's that?
18:58:07 <SlickNik> If you link a bug, he shows up
18:58:07 <amrith> how many bots do we have in this room...
18:58:14 <cp16net> i'm a bot
18:58:21 <SlickNik> only big brother knows.
18:58:21 <grapex> amrith: This project is more bot than man!
18:58:40 <grapex> amrith: hmm... sounds like something a NON-bot would say...
18:58:45 <SlickNik> amrith: That sounds reasonable.
18:58:49 <amrith> thx
18:58:50 * grapex shifty eyes to SlickNik and cp16net
18:59:00 <amrith> that's all I had
18:59:03 <grapex> amrith: Good idea flesh-creature
18:59:06 <grapex> I mean, person
18:59:10 * cp16net has no face
18:59:42 <glucas> it's bots all the way down
18:59:45 * amrith wonders how someone without a face would grin
18:59:49 <cp16net> done?
18:59:55 <amrith> done
19:00:03 <SlickNik> Cool, anything else?
19:00:07 <cp16net> time
19:00:12 <SlickNik> #endmeeting