18:02:15 <SlickNik> #startmeeting trove
18:02:16 <openstack> Meeting started Wed Oct  8 18:02:15 2014 UTC and is due to finish in 60 minutes.  The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:20 <openstack> The meeting name has been set to 'trove'
18:02:23 <denis_makogon> o/
18:02:31 <ramashri> o/
18:02:39 <SlickNik> Giving folks a few minutes to trickle in.
18:02:40 <esmute> o/
18:02:48 <amcrn> o/
18:02:57 <schang> o/
18:03:12 <amrith> ./
18:04:08 <SlickNik> Agenda at:
18:04:10 <SlickNik> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:04:32 <dougshelley66> o/
18:04:38 <kevincon_> o/
18:05:12 <SlickNik> #Topic rdservers related logic change
18:05:36 <SlickNik> rumale, around?
18:05:40 <mattgriffin> o/
18:05:43 <ramashri> yep
18:05:53 <ramashri> so all, feel free to peruse the text in https://bugs.launchpad.net/trove/+bug/1376525
18:05:55 <uvirtbot> Launchpad bug 1376525 in trove "mgmt-show reports server as null" [Undecided,In progress]
18:06:50 <ramashri> to give some context for this bug, we wanted the compute instance id back as part of trove mgmt-show for debugging purposes... turns out we already have server information as part of the schema thats coming back as null... some digging into the bug revealed that though the server information was retrieved correctly the attributes of the server that were being accessed was not present on the devstack deployment. After fixing the bug in
18:06:50 <ramashri> which we check for presence of attributes before accessing them... Auston brought it to my attention that this might change the logic for those who are counting on the attribute access throwing an exception and being caught in the exception bloc below
18:07:29 <ramashri> counting on exception to drive the logic is not the most obvious flow imo... anyway would like folks to chime in if the fix might affect them negatively
18:07:34 <amcrn> i.e. if you're using rdservers as a backdoor, this might have implications for you.
18:09:15 <sgotliv> o/
18:09:18 <SlickNik> amcrn: I don't think HP is doing anything like that with rdservers, so I don't think this will affect HP.
18:09:47 <SlickNik> And I don't see any rackers around.
18:09:48 <amrith> do we want to wait for a confirmation from rax
18:09:51 <amrith> before moving forward?
18:10:33 <SlickNik> ramashri: Can you follow up with folks from rax offline? I think they might be at a conference that overlaps with this meeting.
18:10:47 <ramashri> gotcha... ok
18:11:32 <SlickNik> Okay, anything else?
18:11:50 <SlickNik> sounds like not.
18:11:53 <SlickNik> #topic FOSS Outreach Program Projects
18:11:59 <amrith> iccha is out and won't be able to attend the meeting tomorrow, so I'm bringing this up on her behalf.
18:11:59 <amrith> The deadline for applications for GNOME OPW is Octoebr 22nd. In order for the applicants to submit their applications, they need to include a description of the project taht they will be working on.
18:11:59 <amrith> There are currently a few possible applicants.
18:11:59 <amrith> What we (as a community) owe them is a commitment of a project or projects that they will be working on.
18:12:00 <amrith> there are a couple of bp's that are currently in the queue for Kilo that could be candidates.
18:12:03 <amrith> The goal is to get projects that are clearly defined, and well contained. The deliverable is that they will work on this project in a 3 month period Dec 9 to March 9.
18:12:08 <amrith> Iccha will be the mentor for these individuals.
18:12:10 <amrith> I would like to fast track the decision of what project(s) we would like these individuals to work on. Ideally, if we can pick up a couple of blueprints and assign them to Iccha, it would be her responsibility to get the BP's finished, reviewed and implemented.
18:12:40 <SlickNik> #link http://gnome.org/opw/
18:12:41 <amrith> I'll wait for y'all to read ...
18:13:16 <denis_makogon> i've got few suggestions about actual BPs
18:13:18 <kevinconway> amrith: iccha is aware that we're dumping this responsibility on her correct?
18:13:32 <amrith> kevinconway, yes. I spoke with her about this yesterday
18:13:46 <SlickNik> kevinconway: yup, iccha brought it up with me as well.
18:13:49 <amrith> and she had some suggestions for bp's as well.
18:14:11 <SlickNik> I'd suggest we get an etherpad / wiki page started with project BP ideas.
18:14:18 <denis_makogon> not so long ago i've talked to her about what can we do for her, and i came into conclusion that we can suggest to take over configuration groups for other datastores
18:14:33 <grapex> >-o<
18:14:54 <amrith> in speaking with her yesterday
18:15:02 <amrith> given the scope of the project and the time available
18:15:25 <amrith> the two that came up were retreiving logs from guests and the ceilometer integration.
18:15:38 <SlickNik> #link https://etherpad.openstack.org/p/trove-opw-projects-kilo
18:16:54 <denis_makogon> i think ceilo integration can work well for her
18:17:20 <SlickNik> amrith: I agree — both of those seem pretty self contained and relevant to Trove.
18:18:11 <SlickNik> iccha / amrith: I'll brainstorm some additional project ideas and add it to that etherpad page.
18:18:33 <SlickNik> Do you guys know if there is a deadline we're working with?
18:18:39 <amrith> sounds good, let's take this offline on the etherpad.
18:18:44 <denis_makogon> #link https://review.openstack.org/#/c/124717/ - spec for logs
18:18:44 <amrith> the deadline is pretty close
18:18:50 <amrith> oct 20th for the applications.
18:19:00 <amrith> and that's the current forcing function
18:19:20 <amrith> so if we can get an answer to iccha before the end of the week, she'll at least be able to communicate that with applicants
18:19:41 <denis_makogon> i would say that we should end up with a concrete decision by the next meeting (wed. 15)
18:20:17 <SlickNik> denis_makogon: From the sound of it that will be too late; we need it earlier than that.
18:20:40 <SlickNik> I'll try and put in some more ideas by tomorrow / Fri at the latest.
18:20:57 <denis_makogon> sounds like a plan
18:21:10 <SlickNik> Will follow up with iccha and amrith when I've done so.
18:21:45 <SlickNik> #action SlickNik to add BP candidates to https://etherpad.openstack.org/p/trove-opw-projects-kilo for OPW
18:22:25 <SlickNik> Anything else you want to add amrith?
18:22:33 <amrith> nope, thanks all
18:22:43 <amrith> I was trying to see if iccha is around
18:22:49 <amrith> but didn't get anything back from her.
18:22:54 <amrith> so, sounds like a plan for now.
18:23:24 <SlickNik> amrith: cool, thanks!
18:23:30 <SlickNik> #topic Open Discussion
18:23:51 <denis_makogon> i've got one
18:24:00 <SlickNik> I have one too.
18:24:03 <SlickNik> denis_makogon: go ahead
18:24:07 <denis_makogon> thanks
18:25:10 <denis_makogon> just want to remind to all that since Kilo is opened it would be great so see some activity around reveiwing specs
18:25:58 <amrith> SlickNik, I have one too.
18:26:57 <SlickNik> denis_makogon: good point. I had sent spec links in my last email. Would be good to get eyeballs on those when folks have a chance.
18:27:57 <SlickNik> amrith: go for it.
18:28:31 <amrith> SlickNik, I will pass.
18:28:41 <amrith> Having a sidebar conversation about it
18:28:49 <amrith> so it is premature to have a conversation here.
18:28:50 <amrith> sorry
18:29:06 <SlickNik> np
18:29:10 <amrith> I will bring it up in next meeting (relates to oslo.messaging)
18:29:26 <SlickNik> I have a comment about rdjenkins.
18:29:49 <SlickNik> So it looks like the HP 1.0 environment that it was running on has been sunset.
18:30:02 <SlickNik> And so it lives no more.
18:30:32 <denis_makogon> SlickNik, oh
18:30:43 <denis_makogon> sound bad =/
18:30:57 <vipul> so we have no CI :D
18:31:15 <denis_makogon> vipul, fake would be enough =)
18:31:23 <grapex> SlickNik: Wow, that is really bad
18:31:24 <denis_makogon> *fake CI
18:31:29 <grapex> Like is it dead already?
18:31:31 <vipul> denis_makogon: i'm not so sure ;)
18:31:36 <grapex> Or just dead in mobster terms
18:31:41 <denis_makogon> unfortunately i have nothing to report on investigating dsvm-gate
18:31:45 <grapex> like "eh, there's a dead guy walking there!"
18:31:57 <denis_makogon> at least yet
18:32:17 <SlickNik> So I see two options:
18:32:17 <SlickNik> 1. We can bring up a new rdjenkins in the new HP environment
18:32:18 <SlickNik> 2. We've been wanting to move to OpenStack CI, and we're close, just need to figure out a couple of issues — this is a good forcing function
18:32:46 <denis_makogon> 2nd sound like a plan
18:32:50 <SlickNik> I'm leaning towards putting in the elbow grease for 2.
18:32:55 <denis_makogon> but woudn't it block development?
18:33:05 <cp16net> yeah sounds like a plan
18:33:12 <SlickNik> Nope, it would only block merging of code.
18:33:19 <grapex> SlickNik: So are the raptor fences off right now?
18:34:02 <SlickNik> denis_makogon: You can still run your own int-tests (like we have been doing all along :))
18:34:16 <denis_makogon> yeah, true
18:35:00 <SlickNik> grapex: Oh the dinosaurs are alive and thriving.
18:35:04 <denis_makogon> FYI, i've wrote small script to run dsvm gate localy, would be nice to hear any feedback for it https://gist.github.com/denismakogon/10eaaafaa69df801cb9b
18:35:11 <grapex> SlickNik: Honestly, fake mode with Tox in the gate blocks a pretty large number of bugs.
18:35:17 <grapex> But I think RdJenkins improved quality a lot
18:35:23 <grapex> we had fewer regressions as it improved
18:35:53 <SlickNik> grapex: I'm planning to have the exact same int-tests run in OpenStack CI
18:36:07 <grapex> SlickNik: I knew you would. :) <3
18:36:54 <denis_makogon> so, any help with getting new CI running would be appreciated
18:37:19 <SlickNik> denis_makogon: That looks very much like what the trove-functional-test gate is doing.
18:38:03 <SlickNik> Anyhow, I will send out more details once I have a path forward. Will keep you guys updated.
18:38:11 <grapex> Thanks SlickNik
18:38:44 <denis_makogon> correct, but that job is still experimental due to several issues, just wanted to reduce manual operations
18:39:35 <SlickNik> Okay, that's all I had on that.
18:39:44 <SlickNik> Anything else for open-discussion?
18:41:01 <SlickNik> .
18:41:05 <SlickNik> #endmeeting