18:01:41 <SlickNik> #startmeeting trove
18:01:43 <openstack> Meeting started Wed Oct 22 18:01:41 2014 UTC and is due to finish in 60 minutes.  The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:46 <openstack> The meeting name has been set to 'trove'
18:02:15 <denis_makogon> o/
18:02:16 <robertmyers> o/
18:02:18 <SlickNik> Agenda at:
18:02:19 <georgelorch> o/
18:02:20 <iccha1> o/
18:02:21 <SlickNik> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:02:27 <cp16net> teamo/
18:02:29 <cp16net> o/
18:02:30 <amrith> ./
18:02:33 <schang> o/
18:02:41 <grapex_> o/
18:02:43 <amcrn> o/
18:02:45 <atomic77> o/
18:02:57 <AJaeger_> o/
18:03:24 <SlickNik> #Topic Trove design summit sessions
18:03:39 <SlickNik> #link https://etherpad.openstack.org/p/kilo-trove-summit-topics
18:03:56 <kevinconway> o/
18:04:28 <SlickNik> So we need to finalize on the list of sessions for the design summit by end of this week.
18:04:44 <SlickNik> It looks like we'll have 4 session slots, and a half day of meetup time
18:05:14 <SlickNik> I've taken a first stab at proposing some sessions at https://etherpad.openstack.org/p/kilo-trove-summit-topics
18:06:05 <SlickNik> If there's something that you'd really like to see in a session, definitely propose it! :)
18:06:43 <SlickNik> Also if there are sessions that you're interested in, either participating or leading, please go ahead and put your name in the appropriate list.
18:07:39 <SlickNik> Looks like most of you have already started doing this — awesome. :)
18:07:59 <iccha1> thanks SlickNik
18:08:21 <dougshelley66> o/
18:08:45 <vgnbkr> o/
18:09:48 <SlickNik> We have some time until Friday to do this — after that, I'll have to collect the results so that they can be published to the design summit schedule in time.
18:10:28 <denis_makogon> SlickNik, are there any priorities for Kilo?
18:10:55 <denis_makogon> and how topics would be picked from given list?
18:12:47 <SlickNik> My top priorities for kilo are
18:12:48 <SlickNik> 1. Continuing the replication, and clustering work that we've started on in Juno, and
18:12:48 <SlickNik> 2. Focusing on testing and quality.
18:13:18 <SlickNik> Apart from that, I'll be looking at interest levels, and what most folks are keen to discuss, and talk about.
18:15:46 <SlickNik> Okay, I'll let folks update that etherpad out of band.
18:16:16 <SlickNik> I'll send out a reminder email again tomorrow, and will look at collecting the results by the end of this week.
18:16:42 <SlickNik> Let's move on to the next topic, in the interest of time.
18:17:21 <SlickNik> (Please let me know if you have any questions!)
18:17:51 <SlickNik> #Topic Bug Importance
18:18:01 <SlickNik> #link https://wiki.openstack.org/wiki/Bugs#Importance
18:18:38 <amcrn> just a quick comment on this: if folks wouldn't mind taking a look at their bugs, looking at the importance chart, and making changes where necessary, that'd be great.
18:19:22 <amcrn> at the moment it's a bit difficult to find actual bugs in behavior vs. minor enhancements, etc.
18:20:07 <denis_makogon> i have concrete proposal, i'd to make trove-bugs group closed on launchpad and allow only cores and PTL to review bugs (once per week if it's possible)
18:20:27 <denis_makogon> i'd suggest =)
18:21:05 <johnma> who assigns the bug importance - is it the person who opens the bug or the cores?
18:21:29 <iccha1> cores i think
18:21:35 <denis_makogon> johnma, a person who's in trove-bugs group
18:21:45 <SlickNik> johnma: There's a "trove-bugs" group in LaunchPad whose members can change the importance.
18:22:01 <johnma> ok , great. thanks
18:22:02 <SlickNik> And currently any trove-dev can be part of that group
18:22:36 <denis_makogon> #link https://launchpad.net/~trove-bugs
18:22:51 <SlickNik> denis_makogon: I'm afraid that with the amount of review load, and other items that cores are trying to tackle, making yet another thing "core only" would cause more slowdowns.
18:23:08 <amrith> Looking at other projects, review of bugs is an open responsibility
18:23:12 <amrith> as it is in trove right now.
18:23:14 <denis_makogon> SlickNik, agreed, it was just a proposal
18:23:37 <amrith> i.e. there aren't 114 core team members for Nova.
18:23:43 <iccha1> +1
18:23:58 <SlickNik> There was some discussion around having a bug czar on the mailing list earlier — perhaps what we need is someone who can drive triaging and making sure bugs are aptly marked (importance, milestone, etc).
18:24:21 <denis_makogon> but we still need to find out suitable way to review bugs (thanks for amcrn for rising this question)
18:24:39 <denis_makogon> czar may work, at least we can try it out
18:24:42 <vgnbkr> If there is an issue, the trove-bugs could be a PTL appointment for non-cores, but has there been an issue that is raising the question?
18:25:32 <amcrn> SlickNik: i can take a stab at a one time clean up for now,.
18:25:49 <amrith> amcrn, if you'd like I'll split with you (and others who volunteer)
18:26:01 <amcrn> amrith: sure
18:26:04 <amcrn> thanks
18:26:17 <amrith> amcrn, maybe we can stick around after the meeting and divvy up the work
18:26:19 <denis_makogon> if you wouldn't mind i would liket to help too
18:26:34 <SlickNik> amcrn / amrith: thanks!
18:26:38 <amrith> vgnbkr, I don't believe there's a specific issue now
18:26:42 <amrith> except that there's a lot of bugs
18:26:49 <amrith> and it hasn't been a priority to sanitize LP
18:26:56 <amrith> after all, stackalytics doesn't track that ;)
18:27:01 <SlickNik> maybe you guys can come up with a recommendation for an ongoing plan as well.
18:27:19 <SlickNik> That would be so sweet! :)
18:27:34 <amcrn> SlickNik: now you're asking too much ;)
18:27:38 <amrith> vgnbkr, I think the issue now is just that we need to clean up the bug lists ... so that when we're trying to prioritize bugs, it is less of a workload
18:27:50 <SlickNik> lol, I knew I could count on you amcrn.
18:27:57 <AJaeger_> Some projects - like infra and docs - do regular bug days.
18:28:01 <AJaeger_> Maybe something for trove?
18:28:12 <denis_makogon> AJaeger_, good point
18:28:24 <vgnbkr> amrith: Sure, I was referring to the recommendation to close the list.  I thought there might be an issue I hadn't heard of.
18:28:27 <AJaeger_> A whole day where everybody goes through the open bugs to make the list as small as possible.
18:28:30 <denis_makogon> we can do the same, bug-day is perfect thing for us =)
18:28:40 <AJaeger_> Fixing obvious bugs but also categorizing them and discussing how to move forward
18:29:01 <denis_makogon> +1 to bug-day
18:29:02 <amrith> vgnbkr, I don't believe there is a strong reason (that I know of or would support at this time) to close the list
18:29:24 <amcrn> AJaeger_: let's brew on that and hash out some ideas next week. i think it'd be a great idea.
18:29:51 <AJaeger_> before you do it, check http://status.openstack.org/bugday/
18:29:52 <cp16net> +1
18:30:00 * amrith volunteers amcrn
18:30:08 <SlickNik> AJaeger_: I like the idea
18:30:15 <cp16net> 2nd amcrn
18:30:17 <AJaeger_> and get trove added to the link so that you can monitor your progress ;)
18:30:18 <cp16net> :_p
18:30:32 <amcrn> AJaeger_: accountability? pfft.
18:30:36 <SlickNik> AJaeger_: nice!
18:30:36 <iccha1> and it could be done at a regular cadence
18:30:37 <amcrn> ;)
18:30:46 <iccha1> so if u cant make it to this one, make it to the next one
18:33:01 <SlickNik> Okay, all good ideas.
18:33:37 <SlickNik> #action amcrn, amrith to initially clean up bug list
18:33:46 <amrith> ok
18:34:01 <SlickNik> #action SlickNik to look into getting bugday going with a regular cadence
18:34:34 <SlickNik> Let's move on.
18:35:05 <SlickNik> #topic Enable H301
18:35:22 <cp16net> #define H301
18:35:42 <denis_makogon> cp16net, import only module
18:35:43 <AJaeger_> cp16net this is one of the hacking rules which is currently disabled
18:35:58 <SlickNik> cp16net: no preprocessor directives in python, please :)
18:36:00 <AJaeger_> "H301: Do not import more than one module per line (*)"
18:36:13 <AJaeger_> but with disable H301, we also disable a few others like 304 and 306
18:36:22 <AJaeger_> "[H304] Do not make relative imports"
18:36:25 <cp16net> that kinda sucks for the tests tho
18:36:30 <SlickNik> AJaeger_ / amrith: feel free to jump in and explain.
18:36:31 <AJaeger_> "H305 H306 H307] Organize your imports according to the Import order template and Real-world Import Order Examples below."
18:36:36 <kevinconway> what's wrong with preprocessor directives?
18:36:56 <SlickNik> kevinconway: absolutely nothing
18:36:57 <iccha1> http://docs.openstack.org/developer/hacking/
18:37:02 <iccha1> if that is still relevant
18:37:04 <AJaeger_> SlickNik: amrith invited me since I send a patch that fixes H301
18:37:16 <amrith> maybe some context would be good. AJaeger started working on a fix and I wanted to ensure that he didn't waste a bunch of time
18:37:17 <AJaeger_> and the question was how to continue with it
18:37:23 <amrith> only to be told, thanks but no thanks.
18:37:28 <robertmyers> I guess my take is that imports do not effect the quality of our software
18:37:35 <robertmyers> so I vote no
18:37:36 <amrith> I'd like us to speak with him about what it is that he is going to implement
18:37:45 <amrith> and make sure that he and the review team are in sync
18:37:47 <vgnbkr> robertmyers: ++
18:37:50 <amrith> before he spends time.
18:37:57 <AJaeger_> This is one of the global OpenStack hacking rules and hacking is defined as "general accepted best practices"
18:38:06 <AJaeger_> Still a project is fine to ignore it.
18:38:22 <robertmyers> So we can follow it in practice but not gate on it
18:38:36 <AJaeger_> robertmyers: that does not make sense.
18:38:41 <robertmyers> I hate ridge rules
18:38:45 <AJaeger_> Fix all issues and then enable it
18:38:50 <robertmyers> no
18:38:52 <AJaeger_> or leave it
18:39:04 <robertmyers> leave it
18:39:26 <robertmyers> don't fix the issues
18:39:34 <AJaeger_> If there's an agreement of leaving it, I will send a patch to document this.
18:39:39 <robertmyers> just use it as a guideline
18:39:51 <iccha1> honestly I am fine either ways
18:40:09 <AJaeger_> Most projects document which violations are disabled on purpose - and which ones are disabled because nobody cleaned up yet.
18:40:19 <AJaeger_> Right now trove does not say either of it.
18:40:27 <robertmyers> as a general rule we should follow this, but don't change a bunch of code to fix a non-bug
18:40:33 <AJaeger_> which meant to me: You ignore since you never cleaned up ;)
18:40:40 <robertmyers> yes
18:40:41 <cp16net> i dont think it matters beyond aesthetics of the code
18:40:53 <cp16net> which is on par with what robertmyers is saying
18:40:54 <cp16net> +1
18:41:30 <AJaeger_> cp16net: I agree, this is more a style issue and not to prevent any bugs - like other hacking checks
18:41:33 <amcrn> +1 to leave as-is
18:42:00 <SlickNik> Same here, I'm trying to read to figure out if there are other implications of leaving this disabled.
18:42:03 <grapex_> AJaeger_: I think it makes sense to clean this up, but I honestly feel like there have been so many commits over the last two years that were just changing order of imports and stuff like that. I think there may be some collective exhaustion in some of the long-time Trovers about it.
18:42:08 <cp16net> only time i've seen an issue with multiple imports is conflicting names but thats a runtime error
18:42:17 <cp16net> maybe unused ones
18:42:21 <cp16net> but thats a pip error
18:42:49 <amcrn> grapex_: read my mind, and i'm not even an old-timer.
18:42:50 <cp16net> i dont care for the importing  * but some cases its alright
18:43:00 <amrith> just to test the waters, may I have a quick show of hands. How many people want to move forward with enabling new rules as proposed in hacking and how many would like to remain as is.
18:43:07 <AJaeger_> grapex_: once the cleanup is in, it might be easier since you have a defined order on the imports
18:43:22 <cp16net> #vote?
18:43:32 <amrith> sure, just want to see how wide the moat is
18:43:36 <SlickNik> So AJaeger_, what I'm hearing is that we'd be amenable to a patchset that explicitly states that we have this check disabled in Trove.
18:43:36 <amrith> or how broad the split is
18:43:40 <robertmyers> lets vote
18:43:40 <AJaeger_> note that I'm volunteering myself to enable some of these after fixing them - but still need friendly reviewers.
18:43:41 <SlickNik> cp16net: sure
18:44:13 <AJaeger_> SlickNik: Yes, that's my feeling as well - and I will send such a patch similar to what other projects do.
18:44:26 <AJaeger_> unless there's another vote ;)
18:44:27 <amrith> AJaeger_, I'm volunteering to help with the review as well.
18:44:36 <SlickNik> #vote Enable H301? Yes, No, Indifferent
18:44:41 * cp16net waits for SlickNik to find the docs for voting...
18:44:42 <AJaeger_> #vote yes
18:44:42 <cp16net> :-P
18:44:42 <SushilKM_> enabling 301 is gonna be huge task and big review
18:44:54 <SlickNik> clearly I don't remember the syntax for #vote
18:44:56 <AJaeger_> SushilKM_: https://review.openstack.org/#/c/129624/
18:44:57 <amcrn> hrm, is the bot broken?
18:45:01 <AJaeger_> SushilKM_: done ;)
18:45:03 <kevinconway> startvote?
18:45:09 <grapex_> I want to vote indifferent, but feel like if I see a bunch of people voting yes I'll want to vote no. :p
18:45:12 <SlickNik> #startvote Enable H301? Yes, No, Indifferent
18:45:12 <openstack> Begin voting on: Enable H301? Valid vote options are Yes, No, Indifferent.
18:45:13 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
18:45:24 <AJaeger_> #vote Yes
18:45:29 <amcrn> #vote No
18:45:30 <robertmyers> #vote No
18:45:35 <iccha1> #vote Indifferent
18:45:35 <dougshelley66> #vote No
18:45:35 <SushilKM_> #vote Yes
18:45:36 <vgnbkr> #vote No
18:45:39 <amrith> #vote no
18:45:41 <cp16net> #vote No
18:45:41 <grapex_> #vote No
18:45:43 <tomblank> #vote No
18:45:54 <schang> #vote no
18:46:12 <amrith> I demand a recount
18:46:20 <cp16net> LOL
18:46:25 <SlickNik> #vote Yes
18:46:25 <cp16net> hanging chad?
18:46:35 <SlickNik> Anyone else?
18:46:46 <johnma> Yes
18:46:46 <SlickNik> #endvote
18:46:46 <openstack> Voted on "Enable H301?" Results are
18:46:47 <openstack> Yes (3): AJaeger_, SushilKM_, SlickNik
18:46:48 <openstack> Indifferent (1): iccha1
18:46:49 <openstack> No (9): schang, tomblank, robertmyers, amrith, vgnbkr, amcrn, cp16net, grapex_, dougshelley66
18:47:14 <grapex_> SlickNik: You will have those Trove t-shirts that say "The Bad Boys of OpenStack" ready at the summit, right?
18:47:22 <cp16net> lol
18:47:23 <amcrn> LOL
18:47:33 <SlickNik> grapex_: heh
18:47:39 <SlickNik> there's an idea :)
18:47:39 <iccha1> lol
18:47:40 <AJaeger_> Tell me when you all wear it, I want a photo ;)
18:47:43 <amrith> What me Hacking?
18:47:48 <dougshelley66> i could always use a new tshirt
18:47:50 <grapex_> amrith: lol!
18:47:53 <amrith> with an Al Newmann cartoon on the front
18:48:11 <SlickNik> Okay, I think we have a way forward, and it's as I suspected.
18:48:11 <AJaeger_> ok, will abandon my patch and send a documentation patch for tox.ini
18:48:21 <SlickNik> Thanks AJaeger_!
18:48:37 <SlickNik> #Topic Open Discussion
18:48:39 <AJaeger_> Thanks for discussing it openly here - better a NO now than kicking you over the next half year ;)
18:49:01 <amrith> AJaeger_, thanks much
18:49:42 <schang> There is one more agenda item, I added it this morning. Do we have time for it today?
18:49:58 <SlickNik> Oh, I missed it. Let me refresh
18:50:02 <SlickNik> Sure, we have some time.
18:50:10 <schang> It's about the guestagent refactoring.
18:51:07 <SlickNik> schang: You bring up a good topic.
18:51:14 <SlickNik> To touch on the gate issue.
18:51:50 <SlickNik> So finally the environment that rdjenkins runs on was decommissioned.
18:52:04 <SlickNik> Which has been causing the "quota issues" in the gate.
18:52:28 <SlickNik> Still working on a way forward to gate against the integration tests.
18:53:26 <SlickNik> Will keep all of you updated on the gate.
18:53:44 <SlickNik> But hope to have a solution in place fairly soon (hopefully by the end of the week).
18:53:55 <amcrn> thanks SlickNik
18:54:08 <schang> Thanks SlickNik
18:54:12 <schang> So robertmyers, what should be the next step for the guestagent refactoring?
18:54:16 <grapex_> SlickNik: Thanks for all your work on this. It's greatly appreciated.
18:54:50 <robertmyers> schang: After it is merged, then we need to cut ties with trove
18:54:51 <schang> Other than the gate -1, it pretty much passed the tests.
18:55:46 <schang> robertmyers: Did you say there could be some pending commits for the guestagent?
18:56:01 <schang> ... that we should merge before cutting the ties?
18:56:15 <robertmyers> no
18:56:40 <robertmyers> schang: basically we want everything to merge that is a higher priority
18:56:54 <robertmyers> then this refactor
18:57:09 <robertmyers> to cut down on rebases all aroung
18:57:12 <robertmyers> around
18:57:28 <amrith> robertmyers, what we discussed last week
18:57:36 <robertmyers> amrith yes
18:57:40 <amrith> would give you a clear time to chkin
18:57:46 <amrith> without other merges coming along
18:57:49 <amrith> and muddying the water
18:57:52 <robertmyers> yes
18:57:58 <amrith> that's still the plan, I think.
18:58:11 <robertmyers> so we are just pingin the world to say we are ready
18:58:14 <amrith> except that someone (me) has been wreaking havoc in the builds.
18:58:43 <schang> And for me ... I'll leave this review the way it is, letting it to collect more feedback.
18:58:54 <SlickNik> robertmyers: yup, once the gate is back up, and the tests pass — let's look into triaging the reviews, and merging this if there's nothing else that more important.
18:58:55 <amcrn> robertmyers schang: looking forward to the new world, thanks for the great work.
18:59:03 <SlickNik> that's*
18:59:26 <SlickNik> robertmyers: yes, thanks for this! It's been coming a while.
18:59:30 <robertmyers> SlickNik: cool thanks!
18:59:45 <robertmyers> thank schang
18:59:57 <robertmyers> he did it all, I'm just a supervisor
19:00:01 <schang> thanks robertmyers
19:00:23 <SlickNik> Thanks schang!
19:00:24 <grapex_> robertmyers: You're the associate producer
19:00:28 <amrith> thanks schang and robertmyers
19:00:43 <SlickNik> Okay, that's time.
19:00:51 <schang> thanks SlickNik and amrith
19:00:52 <SlickNik> Thanks all!
19:00:56 <amrith> thanks SlickNik
19:00:57 <SlickNik> #endmeeting