17:59:08 <SlickNik> #startmeeting trove
17:59:08 <openstack> Meeting started Wed Dec  3 17:59:08 2014 UTC and is due to finish in 60 minutes.  The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:59:12 <openstack> The meeting name has been set to 'trove'
17:59:44 <SlickNik> Giving folks a few minutes to trickle in.
18:00:09 <SlickNik> The meeting agenda is at:
18:00:24 <SlickNik> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:00:36 <amrith> ./
18:00:39 <sgotliv_> ./
18:00:49 <amrith> oh crap, he showed up.
18:01:03 <esmute> 0/
18:01:08 <schang> o/
18:01:29 <sgotliv_> amrith, I didn't see that ;-)
18:01:42 <amrith> sgotliv_, I was counting on that.
18:01:56 <vgnbkr> o/
18:01:59 <peterstac> o/
18:02:09 <dougshelley66> o/
18:02:24 <edmondk> o/
18:02:39 <SlickNik> #topic Discuss merge order for various OSLO related patches
18:02:48 <kanzaros> o/
18:02:54 <amrith> sounds like mine.
18:03:07 <SlickNik> amrith:  go for it
18:03:10 <abramley> o/
18:03:10 <amrith> so, I'd like to discuss with the group the order in which we get these large oslo patches in.
18:03:13 <amrith> I have several.
18:03:20 <amrith> Sergey has RPC messaging.
18:03:21 <georgelorch> o/
18:03:29 <amrith> Mine are simple (largely changes to requirements.txt)
18:03:45 <amrith> gated behind my changes are 3 sets of changes
18:03:53 <amrith> 1. processutils -> oslo.serialization
18:03:59 <amrith> 2. resynch oslo incubator
18:04:09 <amrith> 3. some security related changes which didn't make it to juno
18:04:24 <amrith> I would like to get the deprecated modules changes done
18:04:29 <amrith> so I can move forward.
18:04:34 <amrith> I need core reviewers
18:04:49 <amrith> to +2 and wf +1
18:04:59 <amrith> the earlier decision was to wait for rpc messaging
18:05:05 <amrith> but that seems to be also not moving.
18:05:05 <SlickNik> So at the summit we decided we'd push oslo.messaging through first since that was the biggest and riskiest change.
18:05:12 <amrith> so I'm raising the general issue of how we move forward.
18:05:35 <amrith> SlickNik, yes, I know that. two questions. should we revisit that, or should we put some urgency on merging oslo.messaging.
18:05:41 <amrith> I don't care about the order.
18:05:56 <esmute> ALL: THe fire alarm just went off here in the Seattle office...
18:05:57 <amrith> but I know which would be easier (for me).
18:06:07 <amrith> that's the oslo.messaging patch.
18:06:10 <amrith> sometimes it does that
18:06:11 <esmute> if you talk to us and we dont respond, we are not ignoring you
18:06:19 <amrith> well, try recheck
18:06:23 <amrith> it works sometimes.
18:06:48 <amrith> sgotliv_, you've got to address the issue of oslo.messaging patch setting off the fire alarm.
18:06:51 <SlickNik> Well, we were waiting on an updated spec which was updated yesterday.
18:08:06 <SlickNik> And amrith when I talked with you yesterday, you said you were still in the process of pulling down the oslo.messaging changes and going through them.
18:08:23 <amrith> I am
18:08:26 <amrith> and it is taking time.
18:08:31 <amrith> I have to do that, no matter the merge order.
18:08:54 <SlickNik> There's also an issue of them making the int-tests run slower, which is pushing the dsvm job past its time limit.
18:08:57 <amrith> at issue now is the question not of whether oslo.messaging must merge or not but rather whether it should hold up other things that are ready.
18:10:06 <amrith> the deprecated modules changes had (no longer) spec dependencies. we opted to go for the bug instead.
18:10:16 <amrith> the code itself is (largely) updates to requirements.txt
18:10:21 <amrith> hence my request to change the order.
18:10:34 <sgotliv_> I have no problem with the order
18:11:21 <sgotliv_> I just want to understand messaging status
18:11:43 <amrith> SlickNik, if we don't want to change the order, that's fine too. could I get the changes +2'ed and pending a WF change.
18:12:04 <amrith> it would be ideal to merge
18:12:07 <sgotliv_> amrith, your changes are very important
18:12:16 <sgotliv_> they close several issues
18:12:18 <amrith> because that would make the oslo-incubator rebase easier to handle
18:13:38 <SlickNik> I'm fine with changing the order — someone would have to take on the job of rebasing the oslo.messaging patch (again).
18:13:49 <sgotliv_> I will do that
18:14:02 <amrith> I will help
18:14:06 <amrith> in any way I can
18:14:25 <amrith> including doing that rebase if required; the intersection is small.
18:15:33 <SlickNik> Okay, then. Let's move forward with that plan.
18:15:42 <SlickNik> sgotliv_: Right now for status — I'm good with the messaging changes and spec — just trying to understand why they cause the int-tests to run slower and fail in the given time limit, or see if we can extend that.
18:15:56 <SlickNik> I'll work on getting that piece ironed out.
18:16:13 <sgotliv_> SlickNik, can I help?
18:16:25 <sgotliv_> I didn't realize that there is a problem
18:17:00 <amrith> SlickNik, is that the reason for the gate failures on the messaging change?
18:17:37 <SlickNik> amrith / sgotliv_: The dsvm-functional tests seem to be timing out on every patchset.
18:17:49 <SlickNik> eg: http://logs.openstack.org/84/94484/46/check/gate-trove-functional-dsvm-mysql/d53d0fd/console.html.gz
18:18:13 <SlickNik> if you scroll to the very bottom you'll see it.
18:18:26 <sgotliv_> I will take a look
18:18:42 <amrith> ah, 95 minute deadline
18:18:51 <amrith> should see how close to it we are without the messaging patch
18:19:29 <sgotliv_> i see 30minutes gap between last test result and the next line
18:19:38 <sgotliv_> looks weird
18:19:52 <SlickNik> It's usually 70-85 mins depending on how slow the node is.
18:19:54 <peterstac> What test is it trying to run that times out?
18:20:05 <amrith> the one after detach replica
18:20:08 <amrith> there is a test
18:20:11 <peterstac> (i.e. waht comes after test_slave_is_not_read_only?)
18:20:13 <amrith> that I saw the review for yesterday
18:20:19 <amrith> that didn't have a timeout
18:20:24 <amrith> it had a poll_until
18:20:26 <amrith> with no timeout
18:20:39 <amrith> mariam had a comment on the review questioning whether a timeout should be added
18:20:55 <amrith> yes, had to do with slave readonly
18:21:08 <amrith> or was the test immediately after that
18:21:15 <SlickNik> So perhaps that test is always failing for the oslo.messaging patch.
18:21:19 <SlickNik> I saw that as well.
18:21:30 <peterstac> The read_only one seems to pass pretty quickly (4.22 s)
18:22:15 <SlickNik> it's     def test_slave_user_removed(self):
18:23:00 <peterstac> That shouldn't take long - think there's a bug in the test?
18:23:17 <sgotliv_> usually when tests stuck means Trove try to reach out to the real queue
18:23:29 <sgotliv_> I have to check mocks
18:23:50 <SlickNik> sgotliv_: There's no mocks in the int-tests.
18:23:55 <sgotliv_> oh
18:23:57 <amrith> https://review.openstack.org/#/c/135398/2/trove/tests/api/replication.py,cm
18:24:01 <SlickNik> (in real mode)
18:24:01 <peterstac> This test looks like it was doing real work
18:24:18 <amrith> test_slave_user_removed
18:24:23 <amrith> that's the test in question
18:24:27 <peterstac> But still shouldn't take long (removing a user should be pretty quick)
18:24:41 <amrith> shouldn't but it sure appears that it is.
18:24:58 <SlickNik> peterstac: possibly something else going on here with the message?
18:25:50 <sgotliv_> I suggest to discuss it in the main room later
18:25:57 <amrith> ok
18:26:11 <SlickNik> Anyway, that's probably the last issue to look into before the merge — all the other tests pass, and that's one of the last few tests to run
18:26:15 <amrith> so popping stack, on the present topic.
18:26:24 <SlickNik> Thanks sgotliv_
18:26:48 <amrith> are we ok with merging decrepit and geriatric oslo-incubator modules change first?
18:27:05 <amrith> it was called something else but I can't remember what it was
18:27:59 <SlickNik> Yes, let's do that.
18:28:03 <amrith> obsolete and deprecated, that's what it was.
18:28:09 <amrith> ok, thanks.
18:28:53 <SlickNik> anything else on this before we move on?
18:29:25 <SlickNik> .
18:29:31 <SlickNik> #topic Discuss status of moving guest agent to its own repository patch set
18:29:46 <amrith> I put this on the agenda as well because it is a significant change
18:30:00 <amrith> and we discussed some (several) weeks ago that we should queiesce the tree
18:30:06 <amrith> when we want this to merge.
18:30:25 <amrith> I wanted to get a sense of where we are with this change and how it impacts other (potentially large) changes that are in the pipe.
18:31:10 <schang> amrith, other then the occasional rebase, I haven't don't anything else on it.
18:31:26 <schang> amrith, it's waiting for more feedback.
18:31:48 <amrith> ok.
18:31:55 <sgotliv_> it definitely has a huge impact on messaging patch
18:32:16 <amrith> yup
18:32:33 <vgnbkr> Is this about moving the guest agent to it's own git repo, or just the refactoring?
18:32:50 <SlickNik> vgnbkr: just the refactoring — in the same repo
18:32:56 <schang> fyi, https://review.openstack.org/#/c/119425/
18:33:03 <vgnbkr> ok, great.
18:33:14 <SlickNik> Also this needs to be reviewed first https://review.openstack.org/#/c/136918/
18:33:24 <SlickNik> i.e. the corresponding spec
18:33:40 <amrith> sgotliv_, why is there a large overlap with o.m?
18:33:57 <amrith> should be small to non-existant, I thought.
18:33:59 <amrith> let me check
18:34:49 <SlickNik> amrith: I would think it changes the guest RPC endpoints for every datastore.
18:34:55 <SlickNik> (i.e. all the managers)
18:35:55 <amrith> ok, I'll look later but I recall at a previous meeting where it was discussed and the consensus (or statment) was that the overlap would be small.
18:36:01 <amrith> given that the overlap may be large
18:36:04 <sgotliv_> amrith, try to rebase messaging patch on top of that one
18:36:18 <amrith> it may not make sense for one of the two parties to continually rebase code now, until the other major change is merged.
18:36:23 <amrith> we need to pick the ordering
18:36:31 <amrith> what do we want to do?
18:37:16 <SlickNik> So it looks like we need more feedback / reviews on this — and oslo.messaging seems to be farther along.
18:38:04 <SlickNik> So I'd recommend merging that one first, while we get more reviews on this, and then rebasing this on top of that and merging it.
18:38:42 <amrith> as I recall there was some urgency at RAX to get this one done
18:38:46 <amrith> is that no longer the case
18:38:50 <amrith> anyone at rax here?
18:38:53 <sgotliv_> SlickNik, you propose to merge messaging after that patch?
18:39:23 <SlickNik> sgotliv_: other way round. merge oslo.messaging first.
18:39:32 <sgotliv_> thanks you!!!!
18:40:38 <amrith> phew
18:40:51 <sgotliv_> amrith, I am not sure that reason is valid!
18:40:56 <amrith> the sigh that sergey let out was so loud that it was detected by seismometers all over the world.
18:41:27 <sgotliv_> we don't represent companies upstream
18:41:31 <sgotliv_> remember?
18:41:37 <SlickNik> amrith: Don't get me wrong, it's still an important patch to merge
18:42:59 <SlickNik> So we should look into reviews + feedback.
18:43:46 <SlickNik> and merging it soon.
18:43:50 <amrith> SlickNik, fine with me. The last time when this was discussed some from RAX (maybe robert myers but also others) had expressed an interest in merging soon.
18:44:54 <amrith> I think we're set with this
18:45:33 <SlickNik> Sounds good. Any other questions wrt this?
18:45:46 <amrith> so the conclusion was that the order would be
18:45:48 <SlickNik> .
18:45:50 <amrith> 1. obsolete modules
18:45:52 <amrith> 2. messaging
18:45:56 <amrith> 3. split guest agent
18:46:07 <amrith> thx
18:47:03 <SlickNik> more like:
18:47:03 <SlickNik> 1. obsolete modules
18:47:03 <SlickNik> 1. messaging
18:47:03 <SlickNik> 3. split guest agent
18:48:57 <SlickNik> Since we're saying that we'll let the obsolete modules merge — but if oslo.messaging makes in in after some of them while others are still in review, that's okay since there isn't an implicit ordering between those.
18:49:00 <amrith> ok, I'm confused. but that's fine.
18:49:57 <SlickNik> i.e. we're allowing obsolete modules to merge before oslo.messaging, but not requiring it.
18:50:09 <amrith> ok
18:50:50 <SlickNik> #topic Open Discussion
18:50:54 <dougshelley66> i have one
18:51:12 <SlickNik> dougshelley66: go for it
18:51:30 <dougshelley66> just wanted to introduce Nirav Shah (nshah) - he joined our community this week
18:51:48 <dougshelley66> (Note to sgotliv_ - notice i didn't say he joined Tesora :) )
18:51:48 <SlickNik> Welcome nshah!
18:52:16 <sgotliv_> welcome nshah!
18:52:49 <sgotliv_> dougshelley66, I have a feeling you will say it in the future :-)
18:52:53 <edmondk> welcome!
18:53:03 <dougshelley66> sgotliv_, have to eat....
18:53:14 <SlickNik> Feel free to hit me (or any of the others) up in #openstack-trove if you have any questions.
18:53:28 <nshah> Thanks all!
18:54:06 <SlickNik> On the same note — I'd like you all to meet danritchie as well
18:54:24 <dougshelley66> welcome danritchie!
18:54:48 <esmute> Welcome danritchie!
18:54:56 <sgotliv_> wellcome
18:54:57 <schang> hello danritchie
18:55:04 <SlickNik> He's ramping up on trove, and is hoping to have his first contribution in soon. :)
18:55:07 <peterstac> hi danritchie!
18:55:14 <amrith> hello! welcome to trove!
18:55:54 <amrith> while we are doing intros, and before sergey says it ... please also welcome vkmc to the trove community. Welcome Victoria!
18:56:12 <danritchie> Thanks all!  Cheers...
18:56:30 <edmondk> Welcome Victoria!
18:56:38 <SlickNik> vkmc: Welcome aboard. :)
18:56:44 <SlickNik> Wow so many new faces.
18:56:56 <vkmc> o/
18:56:56 <schang> vkmc: hello :)
18:56:56 <SlickNik> Good to see it.
18:56:56 <esmute> Welcome vkmc
18:56:59 <vkmc> thanks all :)
18:57:21 <dougshelley66> SlickNik, do we still have that policy where the new people have to buy drinks at mid-cycle?
18:57:24 <esmute> @SlickNik Any update about the mid-cyle meetup?
18:57:48 <peterstac> Yeah, like the policy dougshelley66 is talking about ;)
18:57:54 <SlickNik> esmute: confirmed to be Feb 3-5
18:57:55 <esmute> dougshelley66: And tell a joke too
18:57:56 <amrith> dougshelley66, yes, that is the policy. VKMC bought drinks in Paris.
18:58:14 <vkmc> haha :)
18:59:09 <amrith> SlickNik, any updates on hotes
18:59:13 <amrith> hotels
18:59:13 <SlickNik> esmute: Good reminder that I need to update the wiki with this info.
18:59:17 <amrith> and block rates
18:59:43 <SlickNik> amrith: Haven't heard back yet :(. I need to follow up.
18:59:56 <amrith> need a hand?
19:00:13 <SlickNik> #action Slicknik to follow up on hotels and block rates for mid-cycle. And update the wiki.
19:00:28 <sgotliv_> Guys, I apologize, but I have to go. Have a nice day.
19:00:37 <SlickNik> amrith: I'll ping you if I do, thanks!
19:00:49 <SlickNik> Anything else?
19:01:25 <SlickNik> .
19:01:30 <SlickNik> #endmeeting