18:01:27 <SlickNik> #startmeeting trove
18:01:27 <openstack> Meeting started Wed Apr 22 18:01:27 2015 UTC and is due to finish in 60 minutes.  The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:31 <openstack> The meeting name has been set to 'trove'
18:01:50 <peterstac> o/
18:01:52 <SlickNik> Giving folks a few minutes to trickle in.
18:01:56 <atomic77> o/
18:01:58 <sushilkm> Hello all
18:02:00 <nshah> o/
18:02:17 <pmalik> (o_o)/
18:02:21 <SlickNik> Meeting agenda at:
18:02:23 <SlickNik> #link https://wiki.openstack.org/Meetings/TroveMeeting
18:02:30 <ashleighfarnham> o/
18:02:37 <edmondk> o/
18:03:01 <dougshelley66> o/
18:03:34 <SlickNik> #topic Trove pulse update
18:03:47 <SlickNik> #link https://etherpad.openstack.org/p/trove-pulse-update
18:04:47 <vgnbkr> o/
18:05:32 <vkmc> o/
18:05:43 <edmondk> almost double the amount of reviews compared to two weeks ago
18:05:50 <mvandijk> \0/
18:06:21 <SlickNik> Yeah — doing pretty well on momentum.
18:06:59 <SlickNik> Lots more reviews happening :)
18:07:13 <SlickNik> And across the board, not just core — which is good to see.
18:07:18 <sushilkm> yeah thats awesome, i first thought if it was 2 weeks ;)
18:07:29 <georgelorch> o/
18:07:42 <edmondk> cores also went from 33 to 70
18:07:50 <dougshelley66> slicknik - why did the "**" disappear from cores?
18:07:50 <edmondk> to 77 I mean
18:08:05 <dougshelley66> seems to have stopped after March 11th
18:08:11 <SlickNik> yeah, awesome — keep up the good work all around!
18:08:54 <mvandijk> new changes : changes merged+abandoned is still ~ 2:1 though
18:09:35 <SlickNik> dougshelley66: I've been cleaning that up, I can leave that in there if folks find it interesting.
18:09:56 <dougshelley66> SlickNik, no worries - just wondered why that changed
18:10:16 <SlickNik> dougshelley66: I missed doing that week of March 11.
18:11:42 <SlickNik> mvandijk: good point, but given that development for liberty just opened - that might not necessarily be a bad thing.
18:12:40 <SlickNik> Okay — let's move on.
18:12:49 <SlickNik> #topic Liberty Design Summit sessions
18:12:50 <peterstac> As long as the 'merged' number doesn't dip too much, we're doing ok ;)
18:13:55 <SlickNik> So this is _the_ week where I need input from folks as to what summit sessions they would want to drive / participate in for the design summit.
18:14:25 <SlickNik> I've started adding a few sessions that I think will be important / interesting at https://etherpad.openstack.org/p/trove-liberty-proposed-sessions
18:14:57 <SlickNik> But I need others to step up with suggestions and options too.
18:15:32 <edmondk> was going to say the cluster one
18:15:33 <edmondk> but you already ahve it
18:16:25 <SlickNik> edmondk: Yes, I put that one in already based on the discussions we've had so far.
18:17:40 <SlickNik> In fact, maybe we should take a few minutes time after this meeting to go flesh that out.
18:18:18 <SlickNik> If you'd like to discuss / participate in a session feel free to put in just a line / two for the title and goal.
18:18:37 <SlickNik> Others and myself can add in discussion points.
18:20:51 <SlickNik> Any ideas folks want to propose? Or any other questions regarding this?
18:22:04 <SlickNik> .
18:22:28 <SlickNik> Okay, let's move on.
18:22:39 <SlickNik> #topic Implement dangling mock detector for unittests (and recommended mocking guidelines - see the below spec for more details)
18:22:46 <pmalik> I am looking for some feedback on the proposed mocking strategy.
18:22:46 <pmalik> I think it would be helpful to have a set of general guidelines on which
18:22:46 <pmalik> approach (see 'Recommended Mocking Patterns') to use when.
18:22:46 <pmalik> If we got an agreement I would submit my detector code together with a
18:22:46 <pmalik> sample usage and fix for review and set up an Etherpad page where people
18:22:47 <pmalik> could sign for modules they'd like to cleanup.
18:23:03 <SlickNik> #link https://review.openstack.org/#/c/176158/
18:24:07 <SlickNik> pmalik: I like the idea — we've had a lot of random failures in unit tests because of incorrect mocking.
18:24:25 <pmalik> I also think that we should cleanup all test cases as a part of this project as oposed to just fixing the leaked mocks.
18:24:46 <peterstac> I agree, it's a good excuse to do some overdue housekeeping
18:24:47 <sushilkm> yeah, and many-a-times it creates some problem while writing other tests too, have been a victim
18:25:13 <pmalik> It would be good if we all followe the same mocking style.
18:25:41 <pmalik> I tried to propose something in the spec, but of course it is not hard solid...
18:26:41 <peterstac> Have people had a chance to review the suggestions?
18:26:43 <edmondk> we should prefer to inject items into classes vs mocking out globals as well
18:26:44 <SlickNik> pmalik: "fixing all tests" doesn't seem specifically actionable.
18:26:51 <peterstac> (I have and tend to agree with them)
18:27:11 <SlickNik> pmalik: without having a plan as to what we are actually fixing.
18:27:53 <pmalik> The tests are in packages. Many packages contain only a couple of files.
18:28:02 <peterstac> SlickNik: I think he means to do away with the 'orig=method  method=mock  method=orig' type used in the past
18:28:06 <pmalik> We need to fix leaked mocks for sure.
18:28:16 <edmondk> yeah we do need to fix them
18:28:19 <peterstac> SlickNik: as part of the cleanup
18:28:42 <pmalik> but I was also thinking about cleanup existing mocking - see peter's comment.
18:29:20 <pmalik> We should really be using the .start(), .stop() methods for those.
18:29:40 <pmalik> Or context manager/decorators for smaller scopes.
18:30:11 <SlickNik> pmalik: Do you have a link for the .start() and .stop() methods?
18:30:21 <SlickNik> (some sort of doc)
18:30:30 <peterstac> SlickNik: I think there's an example in the spec
18:30:54 <peterstac> Under 'Recommended Mocking Patterns'
18:31:05 <pmalik> see 26.4.3.5. in https://docs.python.org/3/library/unittest.mock.html
18:32:25 <SlickNik> Does this exist in 2.7 as well?
18:32:48 <SlickNik> (That doc link is for version 3.3)
18:32:58 <SlickNik> #link https://docs.python.org/3/library/unittest.mock.html
18:33:36 <pmalik> I've been using it in 2.7. I believe it's the same mock library...
18:34:08 <SlickNik> Frankly, I'm less excited about going back and fixing all of the 'orig=method  method=mock  method=orig' style used in the past.
18:34:26 <pmalik> https://pypi.python.org/pypi/mock
18:35:57 <SlickNik> Because it's unit tests that already work, and there is a lot of other feature work in Trove that could use effort.
18:36:36 <sushilkm> +1
18:36:51 <sushilkm> there are better areas to use the effort
18:37:03 <pmalik> ok, so, you suggest using the proposed guideline for new ones only?
18:37:40 <dougshelley66> I tend to agree with SlickNik and sushilkm - we should fix the broken ones and move on. Establish the new standard going forward
18:37:50 <vgnbkr> And I would suggest that reviews require modified tests to be converted as well.
18:38:00 <SlickNik> pmalik: yes that would be my preference.
18:38:32 <sushilkm> i wud agree on using the guideline for new-comers in testing
18:38:50 <sushilkm> new-comers=new-unit-tests
18:38:59 <SlickNik> pmalik: can we get the info that's in the spec on to a wiki page?
18:39:15 <SlickNik> Or into the trove dev docs.
18:39:23 <SlickNik> Actually the latter would be better.
18:39:33 <pmalik> sure, why not
18:40:42 <SlickNik> Sounds good.
18:40:43 <pmalik> ok, I will submit a review with the proposed implementation then.
18:41:13 <SlickNik> pmalik: want to action yourself?
18:41:52 <SlickNik> #action pmalik submit a review with the proposed mocking implementation.
18:41:58 <pmalik> ok thanks
18:42:12 <SlickNik> Thank you!
18:42:25 <SlickNik> #topic Open Discussion
18:42:54 <SlickNik> Any items for open discussion?
18:44:12 <SlickNik> Looks like we can end a bit early.
18:45:04 <SlickNik> #action Everyone please fill out Design summit session suggestions at https://etherpad.openstack.org/p/trove-liberty-proposed-sessions
18:45:26 <SlickNik> ^^ reminder — please take a few minutes to do that today.
18:45:31 <SlickNik> #endmeeting