17:59:00 <SlickNik> #startmeeting trove
17:59:00 <openstack> Meeting started Wed Jun 10 17:59:00 2015 UTC and is due to finish in 60 minutes. The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:59:03 <openstack> The meeting name has been set to 'trove'
17:59:16 <cp16net> hello yall
17:59:22 <SlickNik> hey cp16net!
17:59:32 <sushilkm> hello SlickNik, cp16net
17:59:34 <SlickNik> Giving folks a few minutes to trickle in.
17:59:42 <vkmc> o/
17:59:46 <peterstac> hey everyone
17:59:47 <vkmc> hi hi
18:00:02 <SlickNik> Meeting agenda is at:
18:00:06 <SlickNik> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:00:10 <danritchie> o/
18:00:37 <vgnbkr> o/
18:00:40 <mvandijk> o/
18:01:04 <johnma> Hello
18:01:22 <SlickNik> Okay, let's get started.
18:01:25 <ashleighfarnham> o/
18:01:32 <SlickNik> #topic Trove pulse update
18:01:41 <SlickNik> #link https://etherpad.openstack.org/p/trove-pulse-update
18:01:57 <dougshelley66> o/
18:04:22 <cp16net> i was close to being up there...
18:04:36 <cp16net> challenge accepted
18:04:40 <SlickNik> cp16net: gotta try harder next time :P
18:04:46 <pmalik> ?/
18:04:50 <SlickNik> Total velocity still around ~200 reviews this week
18:05:16 <SlickNik> which is about what our average velocity has been like.
18:05:31 <SlickNik> So nothing new here.
18:05:51 <SlickNik> I did have an action item from last week to follow up on the auto-abandon job and what happened to it.
18:05:56 <sushilkm> we added 4 more reviewers this week upto 25 from 21 last time
18:06:58 <SlickNik> sushilkm: That's because folks from other projects were reviewing the "Protected instance support" spec.
18:07:12 <sushilkm> :)
18:07:25 <cp16net> ah that makes sense
18:07:31 <SlickNik> I wouldn't necessarily count on them to be Trove reviewers.
18:07:32 <dougshelley66> i assume the core team size should have shrunk to 8?
18:08:05 <cp16net> might need to take an action item on that SlickNik
18:08:38 <SlickNik> dougshelley66 / cp16net: did we lose someone else from core?
18:09:04 <dougshelley66> while i hate to have seen Vipul leave, he did resign from Trove Core, no?
18:09:15 <SlickNik> Ah yes - of course.
18:09:35 <cp16net> what is the link to the trove core group in launchpad?
18:09:44 <cp16net> maybe i'm overlooking it
18:09:52 <SlickNik> #action SlickNik to submit patch to revirewstats to remove vipul from core.
18:09:55 <vipul> :P
18:10:10 <SlickNik> cp16net: We're using gerrit groups now, so it's not associated with LaunchPad any longer.
18:10:19 <cp16net> OH....
18:11:12 <SlickNik> I've removed vipul from the gerrit group — haven't done it from reviewstats yet, so the numbers aren't reflected.
18:11:36 <SlickNik> Will do that.
18:11:58 <SlickNik> Back to the auto-abandon job.
18:12:52 <SlickNik> The OpenStack infra team explicitly stopped running that.
18:13:11 <SlickNik> More context of the discussion at:
18:13:13 <SlickNik> #link http://lists.openstack.org/pipermail/openstack-dev/2015-March/058104.html
18:14:29 <SlickNik> Basically they found that the negative impact of the job outweighed the positive impact, and that folks had other tools to prioritize looking at reviews — so they killed the job.
18:16:32 <SlickNik> That explains why we haven't seen it running for a while.
18:16:40 <SlickNik> Any questions regarding any of this?
18:16:59 <SlickNik> .
18:17:01 <ashleighfarnham> Sounds though like we still wanted a solution to the view issue
18:17:20 <dougshelley66> so that means that over time our backlog of reviews will just grow?
18:17:23 <ashleighfarnham> we might want to look into some of the tools that were mentioned
18:17:31 <dougshelley66> i.e. if there are reviews that just get virtually abandoned?
18:17:51 <SlickNik> dougshelley66: yes. that's the case — you will have crufty reviews in the system.
18:18:29 <ashleighfarnham> you also run across the issue of crufty reviews that don't make any sense based on where trove has moved since they became idle
18:18:43 <SlickNik> ashleighfarnham: ++ I can talk to the infra folks to figure out how to get a view to the reviews that can filter out some of this cruft.
18:19:02 <cp16net> might be able to run a crazy query to find some of them
18:19:33 <cp16net> i just saw something about gertty and seeing how it works
18:19:46 <SlickNik> cp16net: We did have some crazy queries that I had set up before — but I think there is now support for native gerrit dashboards that you can set up, so we should probably look into that.
18:20:11 <cp16net> oh yeah they were moving to the templates or something right?
18:20:23 <dougshelley66> I think more improved views are a good thing but if we are using those weekly reviewstats to monitor our progress...
18:20:33 <dougshelley66> views won't clean that up
18:21:48 <cp16net> yeah but if we can tell that a review is not been touched and not going to be touched again as core we can abandon it
18:22:17 <SlickNik> dougshelley66: Some stats will probably not be useful to monitor (eg. wait times for open reviews) but it would still make sense to track review and merge velocity.
18:22:17 <cp16net> if that was a mistake it can be reverted.
18:22:52 <dougshelley66> SlickNik, cp16net sounds good
18:23:42 <cp16net> so if slick can find a view of that we can quickly go over which reviews are still valid and prune the list
18:24:43 <cp16net> i *assume* that other teams might do something similar
18:25:12 <SlickNik> cp16net: I think the idea (if you read that mail thread closely) is that we shouldn't be abandoning other folks' changes just because they're out of date since it's a pretty strong thing to do, and can have negative consequences.
18:25:52 <SlickNik> I'll try to get us a good dashboard that will filter old changes out, so that it doesn't affect our workflow as reviewers.
18:26:04 <cp16net> ahhh yeah true
18:26:12 <vkmc> what if we contact them? it would be a lot of work... but still
18:26:29 <SlickNik> vkmc — it's okay to get them to abandon their own changes.
18:26:53 <vkmc> cool
18:26:57 <cp16net> or even take over the changeset if it still applies
18:27:04 <vkmc> that would be a decent solution so we can have a more representative stats
18:27:47 <sushilkm> +1 for take over of changeset which are overdue and waiting for long
18:28:23 <dougshelley66> presumably you should communicate with the owner to take over a changeset
18:28:44 <SlickNik> sushilkm: Of course, but please talk to the folks you're taking over from so that you don't end up duplicating work / stepping on each other's toes.
18:28:54 <vkmc> SlickNik++
18:29:02 <cp16net> true
18:29:09 <cp16net> #agree
18:29:13 <SlickNik> Okay — Let's move on.
18:29:32 <pmalik> SlickNik: I dont agree. If somebody does not touch a patch set for a month or so we should abandon it. You cannot just take it. If they want to proceed working on it they can always restore it.
18:29:48 <sushilkm> LGTM a requirement for take-over :)
18:31:00 <SlickNik> pmalik: Have you looked at http://lists.openstack.org/pipermail/openstack-dev/2015-March/058104.html
18:31:35 <SlickNik> That lays out some very good reasons why one shouldn't simply just abandon someone else's review just because it's been sitting for a while.
18:32:03 <pmalik> Well, it does not mean they are right...
18:33:05 <SlickNik> Well, the only reasons I've seen for abandoning it so far is that it affects some of the stats we measure — and I have to admit the reasons in that thread seem far more compelling to me than that.
18:34:13 <cp16net> yeah there are some good points in it
18:35:22 <SlickNik> We can have more of this discussion offline pmalik - let's move on with the meeting agenda.
18:35:55 <SlickNik> #topic Open Horizon Reviews
18:36:37 <SlickNik> So dougshelley66, shayneburgess and a few others noted a couple of days ago that we have quite a few Trove related changes in horizon seem to be making slow progress with reviews.
18:37:29 <SlickNik> #link https://etherpad.openstack.org/p/trove-reviews-in-horizon
18:37:51 <cp16net> yeah i think some of these should have been in since the beginning like the database/user calls
18:38:15 <SlickNik> One of the reasons for this — talking to horizon folks — is that many of them don't have context into whether some of these changes are correct from a trove perspective.
18:38:35 <johnma> I can pass this list to couple of horizon cores and see if they can help. I can also work with them to view these patches if it helps
18:38:56 <SlickNik> So I'd like to start getting some more trove folks to start looking at these patchsets, and +1 them if they look good from a trove perspective.
18:38:57 <dougshelley66> johnma, thanks!
18:39:03 <cp16net> so we should review them for validity at least it sounds like
18:39:07 <SlickNik> johnma: that would be super helpful — thanks!
18:39:12 <SlickNik> cp16net: yes ++
18:39:14 <peterstac> SlickNik: Sounds reasonable
18:39:28 <johnma> sure, that sounds like a plan. I can help with it
18:39:48 <david-lyle> yes please review them from the trove standpoint
18:40:23 <david-lyle> working on a model in horizon where trove reviews could go through with less review overhead from horizon
18:40:44 <david-lyle> basically trove reviewers worth one +2 and horizon core the other +2
18:40:57 <david-lyle> hopefully decreasing the bottleneck
18:40:58 <cp16net> i think i can help as well but i dont have much exp with the horizon pieces
18:41:12 <dougshelley66> david-lyle would that be to have the trove dashboard external to the horizon repo as a plugin?
18:41:19 <dougshelley66> or some such
18:41:34 <peterstac> david-lyle: The new model sounds interesting - you have an eta on that?
18:41:37 <david-lyle> dougshelley66: that may be a long term solution, but testing becomes more difficult
18:41:39 <johnma> do we know whether these patches involve ny angular changes as well or is it mostly django
18:41:56 <SlickNik> david-lyle: ++
18:42:15 <david-lyle> right now working on moving trove and sahara to a contrib directory as a first step
18:42:30 <david-lyle> the review model can work that way now
18:42:38 <SlickNik> I can follow up with you to figure out how to ease the bottleneck with reviews
18:43:02 <SlickNik> johnma: it's mostly django — I haven't seen any angular based reviews yet.
18:43:19 <david-lyle> so please just validate the correctness from the trove interaction standpoint and the horizon reviewer will tackle the horizon part
18:44:07 <SlickNik> david-lyle: To me that sounds like a good, workable plan for the near term.
18:44:13 <johnma> thats good. I think I can handle the Django part, havent been up-to-date with the angular changes happening. THanks SlickNIk
18:44:14 <david-lyle> we just don't have enough trove expertise to properly validate that side
18:44:30 <cp16net> makes sense to me
18:44:31 <david-lyle> great, I'd really like things to get in a lot faster
18:44:52 <SlickNik> Awesome, thanks david-lyle!
18:45:19 <dougshelley66> david-lyle thanks for the info and help
18:45:29 <SlickNik> #topic Open Discussion
18:45:39 <pmalik> Just a little suggestion for open discussion. I think the project description on Launchpad (https://launchpad.net/trove) should be updated to reflect the fact Trove now supports other datastores too.
18:46:05 <SlickNik> pmalik: ++
18:46:07 <dougshelley66> maybe it should have the current mission statment?
18:46:11 <dougshelley66> who can update that
18:46:13 <SlickNik> I can update that with the mission statement
18:46:21 <dougshelley66> slicknik ++
18:47:16 <SlickNik> #action SlickNik to figure out how to update LaunchPad Trove messaging to be current and update it with Trove's mission statement
18:47:56 <SlickNik> Other items for open discussion?
18:48:43 <cp16net> i'd like to catch up on clustering that was chatted about at the summit but that doesnt have to be here.
18:49:02 <SlickNik> cp16net: Let's catch up on that after the meeting.
18:49:08 <cp16net> we can catch up in #trove after the meeting
18:49:10 <cp16net> ok
18:49:23 <SlickNik> Looks like we're all done for the meeting.
18:49:24 <SlickNik> Thanks all!
18:49:27 <SlickNik> #endmeeting