18:01:24 <SlickNik> #startmeeting trove
18:01:25 <openstack> Meeting started Wed Jun 17 18:01:24 2015 UTC and is due to finish in 60 minutes.  The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:29 <openstack> The meeting name has been set to 'trove'
18:01:31 <amrith> ./
18:01:40 <mvandijk> 0/
18:01:47 <SlickNik> hello all
18:01:47 <vgnbkr> o/
18:01:48 <ashleighfarnham> o/
18:01:49 <sushilkm> o/
18:02:10 <peterstac> \o
18:02:23 <dloi> o/
18:02:40 <pmalik> -o-
18:03:02 <amrith> \_(*)_/
18:03:03 <cp16net> hi yall
18:03:15 <cp16net> |.|
18:03:24 <SlickNik> Meeting agenda at:
18:03:26 <SlickNik> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:03:37 <atomic77> *|
18:03:37 <dougshelley66> o/
18:03:48 <cp16net> looks sparse
18:03:51 <shayneburgess> ——o—-
18:03:56 <bhunter71> o
18:04:24 <SlickNik> Let's get started
18:04:30 <SlickNik> #topic Trove Pulse Update
18:04:44 <SlickNik> #link https://etherpad.openstack.org/p/trove-pulse-update
18:05:39 <SlickNik> Slightly fewer reviews this week — down from the last week, but things are  still moving.
18:06:04 <SlickNik> You will notice that core-reviewer team size is now accurately reflected. :)
18:06:30 <SlickNik> reviewstats actually took a change to pull the team directly from the gerrit-group using the gerrit HTTP API.
18:07:16 <cp16net> SlickNik: how do you pull this info?
18:07:39 <dougshelley66> openstack-infra/reviewstats
18:07:42 <SlickNik> To follow up on last weeks conversation — no auto-abandon job, but I'm working on a custom gerrit dashboard for us.
18:07:52 <SlickNik> cp16net: what dougshelley66 said
18:07:59 <cp16net> k
18:08:11 <SlickNik> #link https://github.com/openstack-infra/reviewstats
18:08:59 <cp16net> nice
18:09:02 <SlickNik> Any other questions regarding this?
18:09:47 <SlickNik> #action SlickNik — figure out custom dash in gerrit for Trove
18:10:14 <SlickNik> Okay, let's move on.
18:10:29 <cp16net> SlickNik: let me know if i can help out with that
18:11:01 <SlickNik> cp16net: awesome — let's talk offline about that
18:11:04 <SlickNik> #topic Liberty-1 cut next week
18:11:05 <cp16net> k
18:11:19 <SlickNik> This is more of an FYI than anything else.
18:11:43 <SlickNik> We'll be cutting liberty-1 next week, so I'll be triaging bps and bugs that won't make it in over the next couple of days.
18:12:21 <SlickNik> If there's something that folks definitely want in liberty-1, please reach out to me so we can figure out a timeline for landing it before next week.
18:13:01 <SlickNik> FYI the current liberty-1 page is at:
18:13:02 <SlickNik> #link https://bugs.launchpad.net/trove/+milestone/liberty-1
18:13:55 <SlickNik> Any questions regarding this?
18:14:24 <SlickNik> .
18:14:44 <cp16net> *crickets*
18:14:53 <SlickNik> #topic Moving to semantic versioning
18:15:33 <SlickNik> Many of you are probably aware that all of the OpenStack integrated release projects moving to semantic versioning.
18:16:02 <SlickNik> Trove being one of them, is also being moved.
18:16:37 <SlickNik> Wanted to call this out, as this has (upgrade) implications for folks who package trove
18:16:52 <SlickNik> So folks are aware of this.
18:17:00 <cp16net> so this is new to me but what is the version now then?
18:17:54 <SlickNik> We move from date based versioning (eg. 2015.1) to semantic versioning (4.0.0.0)
18:18:38 <cp16net> oh man that could realy impact someone if you dont have the version close to the date
18:18:45 <SlickNik> 4 is chosen for trove since liberty will be the 4th trove release as part of the OpenStack integration projects.
18:19:16 <SlickNik> cp16net: Yes, in fact the upgrade will not work unless you rev the epoch, since 4.x.x.x < 201x.x
18:19:26 <cp16net> yup
18:20:09 <shayneburgess> are they not standardizing the version numbers across projects?
18:20:15 <SlickNik> They are.
18:20:35 <SlickNik> shayneburgess: https://review.openstack.org/#/q/topic:+semver-releases,n,z
18:21:08 <shayneburgess> so nova will be version 12 and we will be version 4?
18:21:10 <SlickNik> They're not keeping the same version — but standardizing semantics.
18:21:14 <SlickNik> shayneburgess: yes
18:21:18 <shayneburgess> *ugh* ok
18:21:25 <amrith> that sucks
18:21:30 <cp16net> yeah that doesnt make much sense
18:21:38 <amrith> it was nice when all releases were like 2015,1
18:21:41 <amrith> or 2015,2
18:21:45 <shayneburgess> welcome to needing a spreadsheet to find out what is in Liberty
18:21:45 <cp16net> sounds like thats just going to confuse people more
18:21:56 <amrith> *more*
18:22:54 <shayneburgess> i don't think we can anything about it here
18:22:59 <shayneburgess> or at all :)
18:23:08 <cp16net> maybe if all the gates continue to fail it wont go in :-P
18:23:10 <cp16net> j/k
18:23:14 <shayneburgess> +1
18:23:18 <SlickNik> shayneburgess: We do because it has upgrade implications.
18:23:31 <SlickNik> Moving from 2015.x to 4.x is not natural :)
18:23:45 <SlickNik> So just wanted to make sure folks are aware.
18:23:46 <shayneburgess> agreed
18:24:03 <cp16net> i'm aware and not happy that i know now...
18:24:08 <cp16net> :)
18:24:10 <SlickNik> Apart from that, there's a discussion about this on the mailing list.
18:24:56 <SlickNik> I guess part of the reason is that it gives teams ability to release on a schedule decoupled with the integrated release if they choose to do so.
18:25:15 <SlickNik> Let me find a link to the ML discussion
18:26:06 <SlickNik> #link http://lists.openstack.org/pipermail/openstack-dev/2015-May/065211.html
18:27:35 <SlickNik> ^^ that explains some of the motivations for choosing to go the semver route.
18:28:46 <SlickNik> That's all I had for this topic — questions?
18:29:15 <SlickNik> .
18:29:18 <SlickNik> Let's move on then.
18:29:28 <SlickNik> #topic Open Discussion
18:29:46 <SlickNik> I had a follow up action from last meeting's agenda.
18:30:15 <SlickNik> You'll notice that https://launchpad.net/trove/ now has the summary information updated.
18:30:27 <SlickNik> With the current Mission Statement and summary.
18:31:06 <dougshelley66> SlickNik cool thanks!
18:31:18 <SlickNik> Np.
18:31:26 <SlickNik> Any other topics for open discussion?
18:31:39 <peterstac> I had a quick one
18:32:20 <peterstac> we've got a lot of specs coming down the pipe and it would be good to get the 'spec validation' patchset in
18:32:39 <peterstac> if people could review it and see if everyone agrees with what's there
18:32:42 <peterstac> #link https://launchpad.net/trove/
18:32:45 <SlickNik> peterstac: ++
18:32:55 <peterstac> sorry
18:33:00 <peterstac> #link https://review.openstack.org/#/c/158617/
18:33:29 <peterstac> that's it :)
18:33:43 <cp16net> i'll look at it
18:34:13 <SlickNik> I authored the initial changes, so probably not good to review it myself. peterstac your updates look good to me so I've +1'd.
18:34:22 <SlickNik> cp16net: that would be awesome.
18:35:02 <SlickNik> Any other items for open discussion?
18:35:28 <peterstac> SlickNik: Same here, I'm leaving it for someone else to approve ;)
18:36:40 <SlickNik> Looks like we're good for now.
18:36:41 <SlickNik> Folks can have some of the time back.
18:36:45 <SlickNik> Thanks all!
18:36:50 <SlickNik> #endmeeting