18:00:31 <cp16net> #startmeeting trove
18:00:32 <openstack> Meeting started Wed Sep 30 18:00:31 2015 UTC and is due to finish in 60 minutes. The chair is cp16net. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:35 <openstack> The meeting name has been set to 'trove'
18:00:40 <amrith> ./
18:00:47 <cp16net> howdy everyone
18:00:55 <amrith> howdy cp16net ...
18:00:59 <amrith> just you and me for now
18:01:03 <SlickNik> hey — 'sup people!
18:01:04 <amrith> quick, let's make some decisions
18:01:31 <cp16net> i'll give a little time for people to trickle in
18:02:07 <amrith> we should start charging for tardiness
18:02:57 <cp16net> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:03:11 <peterstac> o/
18:03:27 <edmondk> o/
18:03:27 <dougshelley66> o/
18:03:28 <dloi> o/
18:03:38 <schang> o/
18:03:42 <danritchie> \o/
18:03:44 <vgnbkr> o/
18:04:07 <cp16net> #topic Trove pulse update
18:04:16 <cp16net> #link https://etherpad.openstack.org/p/trove-pulse-update
18:05:08 <cp16net> reviews are pretty steady for the last 3 weeks between 70-80
18:05:26 <vkmc> o/
18:05:28 <atomic77> o/
18:06:27 <cp16net> any other comments around this?
18:06:54 <peterstac> I'm still working on the graph - should have something by the end of the meeting ;)
18:07:13 <cp16net> peterstac: awesome that leads to the next topic i have
18:07:17 <cp16net> #Action items
18:07:23 <cp16net> #topic Action items
18:07:37 <cp16net> - cp16net look into troveclient tempest gate failures
18:07:54 <cp16net> i got the gate working again for troveclient
18:08:01 <peterstac> ah, cool
18:08:29 <cp16net> it wasnt hard but it was similar to the saharaclient issues
18:08:41 <cp16net> so it was pretty easy to resolve
18:08:49 <cp16net> - peterstac put together a graph for week over week
18:09:19 <cp16net> sounds like peterstac may have something to show off by the end of the meeting:-D
18:09:44 <cp16net> moving along...
18:09:53 <cp16net> #topic Bugs that could be back ported for Liberty
18:10:22 <cp16net> so i've identified a few bugs that could be backported to liberty
18:10:50 <cp16net> - [trove] Fix promote for Redis datastore
18:11:01 <cp16net> #link https://review.openstack.org/#/c/226075/
18:11:17 <cp16net> so this is a fix redis
18:11:36 <peterstac> Yeah, I dropped the ball on that one - I should have mentioned it last week when SlickNik asked about potential candidates ...
18:11:46 <cp16net> is there any concerns around proposing this one to liberty?
18:12:22 <peterstac> It involves promote leaving the slaves in a detached state, because the redis python client doesn't interpret None as none
18:12:36 <peterstac> (you need to set it to '')
18:12:56 <dougshelley66> looks like no concerns
18:12:59 <peterstac> I think it should go in liberty :D
18:13:16 <cp16net> ok with overwhelming majority we'll get that one in
18:13:28 <cp16net> - [trove] Fix publish_exists_event authentication exception
18:13:38 <cp16net> #link https://review.openstack.org/#/c/228696/
18:13:55 <cp16net> i thought about this one as well after dougshelley66 was working on it
18:14:12 <dougshelley66> i'm fine with that - no one has posted a review on it
18:14:15 <cp16net> (i'm still working on testing it)
18:14:25 <dougshelley66> in the end, it turned out to be a pretty simple fix
18:14:36 <amrith> looks good to me
18:14:40 <dougshelley66> in novaclient - project_id is for the tenant_name
18:14:46 <dougshelley66> so we shouldn't use that
18:14:55 <cp16net> yeah this will allow deployers to get the events we send out
18:15:07 <cp16net> so i think this should be a high priority
18:15:11 <peterstac> looks good to me too
18:15:19 <edmondk> yeah I think it's fine as well
18:15:23 <cp16net> next one...
18:15:26 <cp16net> - [troveclient] Accepting network and availability zone for instances in cluster
18:15:33 <cp16net> #link https://review.openstack.org/#/c/184349/
18:15:47 <cp16net> this isnt a trove fix but to the troveclient
18:17:05 <SlickNik> cp16net: The client release schedule is not tied to the openstack release schedule.
18:17:07 <cp16net> i believe that we can make a new version of the client to get this out that shouldnt nessearily require a backport to the stable/liberty branch
18:17:27 <cp16net> SlickNik: right i thought that was the case
18:17:28 <SlickNik> So perhaps we just cut a new client release after that bug is fixed.
18:18:20 <cp16net> alright so are there any other bugs found that should be added to this list?
18:18:25 <SlickNik> yup — I don't think we'll need a backport for this.
18:18:55 <peterstac> SlickNik +1
18:19:01 <cp16net> dougshelley66: i noticed there were a few other ones that you mentioned that maybe related to the notifications.
18:19:02 <SlickNik> cp16net: we usually do an updated release of translations as well if we are going to cut a new RC>
18:19:18 <SlickNik> So we might want to do that.
18:19:37 <SlickNik> Other than think — that set of bugs looks reasonable.
18:19:39 <cp16net> SlickNik: ok
18:20:20 <dougshelley66> cp16net yes there are two other but i don't think we should push back to liberty. One has a workaround
18:20:37 <cp16net> dougshelley66: ok great
18:21:19 <cp16net> if there are any other bugs found that affect liberty let me know
18:21:29 <cp16net> alright next....
18:21:42 <cp16net> #topic Mitaka Summit Design Sessions
18:21:49 <cp16net> #link https://etherpad.openstack.org/p/mitaka-trove-summit
18:22:18 <cp16net> we have some topic proposed here
18:22:20 <cp16net> awesome!
18:23:15 <cp16net> i'm not sure if there is a deadline to have these published at least for the fishbowl sessions
18:23:15 <vkmc> :D
18:23:22 <cp16net> i need to find that out
18:23:37 <dougshelley66> so on Mitaka summit - who is going?
18:23:51 <cp16net> o/
18:23:54 <dougshelley66> o/
18:24:03 <amrith> ./
18:24:14 <dougshelley66> ah good we need someone to buy beer
18:24:20 <vkmc> o/
18:24:21 <imandhan> o/
18:24:23 <atomic77> o/
18:24:33 <peterstac> o/
18:25:13 <schang> o/
18:25:21 <cp16net> edmondk: and SlickNik will be there
18:25:35 <edmondk> o/
18:25:37 <edmondk> will be there
18:25:52 <amrith> vipul said he'd be there. he offered to buy beers.
18:26:01 <dougshelley66> it's about time....
18:26:01 <SlickNik> cp16net: There is a deadline, but we have another 1-2 weeks I think.
18:26:09 <cp16net> #action cp16net find out if there is a deadline for fishbowl sessions
18:26:10 <SlickNik> I'll totally be there.
18:26:13 <cp16net> :)
18:27:14 <cp16net> alright excited to see all your faces again
18:27:32 <cp16net> moving along...
18:27:38 <cp16net> #topic Assert follows standard deprication
18:27:54 <dougshelley66> s/deprication/deprecation/
18:28:04 * amrith doesn't understand what that means.
18:28:23 <cp16net> so there is a new tag that we can decide to follow or not
18:28:44 <cp16net> this will verify that config parameters are depricated in a standard fashion
18:28:53 <amrith> http://governance.openstack.org/reference/tags/assert_follows-standard-deprecation.html
18:28:57 <amrith> #link http://governance.openstack.org/reference/tags/assert_follows-standard-deprecation.html
18:28:58 <cp16net> forgive my speeling
18:29:10 <cp16net> amrith: thanks for the link
18:29:11 <amrith> for-given
18:29:14 <dougshelley66> so are we following these requirements now?
18:29:35 <cp16net> i think we've done a great job so far following this
18:29:51 <cp16net> mainly beacuse we only add and dont change the meaning of the configs
18:30:06 <amrith> have we ever actually deprecated anything?
18:30:33 <cp16net> amrith: maybe one config a long time ago in a galaxy far far away
18:30:39 <cp16net> :-P
18:30:43 <dougshelley66> what about having an automated test to for fwd compat of config files?
18:31:08 <amrith> cp16net, I have seen us move things in a config file from [DEFAULT] to a better place but we've never actually (that I know of) deprecated the old one.
18:31:10 <cp16net> applying this tag would gate on this from happening
18:31:15 <SlickNik> amrith: We've removed some internal APIs that were deprecated more than a couple of releases, I think.
18:31:37 <amrith> SlickNik, thanks, wasn't aware of that.
18:31:45 <cp16net> thats a good point moving the configs around may be a violation of this
18:31:49 <amrith> if we're compliant with this, is there a downside in asserting the tag?
18:31:53 <SlickNik> cp16net: I think we have some work to be done here if we want to apply this tag
18:32:01 <SlickNik> specifically reading -
18:32:05 <SlickNik> 'It uses an automated test to verify that configuration files are forward-compatible from release to release and that this policy is not accidentally broken (for example, a gating grenade test)."
18:32:18 <SlickNik> I don't think we have anything like this yet.
18:32:35 <cp16net> yeah i agree its something to think about
18:33:15 <cp16net> this is meant help with deployers during an upgrade
18:33:37 <SlickNik> We've been following this tag in spirit, but we would need to author upgrade test jobs to actually verify this.
18:34:11 <SlickNik> How new is this tag?
18:34:22 <cp16net> i saw it this past week
18:34:36 <cp16net> Note: No projects are using assert:follows-standard-deprecation, yet.
18:34:58 <cp16net> something we could talk/think about for the future
18:35:22 <cp16net> ok thats all i had on that topic
18:35:33 <cp16net> more for info
18:35:49 <amrith> what are the next steps on this?
18:36:11 <cp16net> we need to look more into this
18:36:26 <amrith> I'm proposing a session at mid-cycle as we speak
18:36:27 <cp16net> and determine what the steps are
18:36:30 <amrith> my speeling isn't all that good
18:36:31 <vkmc> is there a place with a listing of the new tags?
18:36:59 <cp16net> vkmc: i just saw this on the mailing list
18:37:12 <vkmc> cp16net, fair enough
18:37:31 <cp16net> #link http://governance.openstack.org/reference/tags/
18:37:31 <amrith> vkmc: http://governance.openstack.org/reference/tags/index.html
18:37:34 <cp16net> that looks like more
18:38:15 <cp16net> i have not personally looked into them yet just sharing
18:38:32 <cp16net> alright moving on....
18:38:39 <amrith> we should at least assert http://governance.openstack.org/reference/tags/release_has-stable-branches.html
18:38:41 <vkmc> amrith, thx!
18:38:43 <amrith> has-stable-branches ;)
18:38:54 <amrith> oh, sorry, we do
18:39:00 <amrith> not an alphabetical list ;(
18:39:17 <cp16net> hah yeap
18:39:23 <cp16net> #topic Open Discussion
18:39:32 <cp16net> anyone have anything else to add?
18:39:35 <amrith> cp16net, I'd like to know whether it is ok to put in a shameless plug for my candidacy for election to the TC [https://review.openstack.org/#/c/229073/] here? Yes/No?
18:39:49 <cp16net> to late.
18:39:50 <cp16net> :-P
18:40:03 <amrith> is that a yes?
18:40:08 <cp16net> sure
18:40:11 <amrith> OK thanks, here's a shameless plug for my candidacy for election to the TC [https://review.openstack.org/#/c/229073/]. Election is Oct 2 to Oct 9th.
18:40:18 <amrith> ;)
18:40:22 <SlickNik> ++
18:40:41 <edmondk> ^ thats a broken link
18:40:45 <amrith> I think the TC could do with some more representation from the non-core projects
18:40:49 <cp16net> remove the ] at the end
18:40:51 <edmondk> or nm I dont have permissino to view this page
18:40:57 <SlickNik> works for me
18:41:00 <amrith> https://review.openstack.org/#/c/229073/
18:41:14 <amrith> "As OpenStack evolves, so too should the Technical Committee. I believe
18:41:15 <amrith> that the Technical Committee has a very high representation from the
18:41:15 <amrith> core (nova, cinder, swift, glance, neutron, ...) projects, and there
18:41:15 <amrith> needs to be more representation of the other projects in OpenStack
18:41:15 <amrith> that are not part of this core (trove, sahara, ...). I believe that
18:41:16 <amrith> the future success of OpenStack depends heavily on the successful
18:41:17 <amrith> integration of these non-core projects, and the ease with which people
18:41:19 <amrith> can deploy the core and non-core components of OpenStack."
18:41:34 <amrith> </shameless-plug>
18:42:04 <cp16net> awesome amrith
18:42:13 <amrith> Thanks cp16net
18:42:36 <cp16net> anyone have anything else?
18:42:48 <cp16net> peterstac: have something to show off? :-?
18:43:29 <peterstac> I have some graphs - where should I put them?
18:43:45 <cp16net> whats easiest for you for now
18:44:20 * amrith takes a deep breath and doesn't swing at the softball from peterstac
18:44:48 * cp16net imagines peterstac is running around like a crazy person right now :-P
18:45:09 <pmalik> cp16net, he is actually sitting...
18:45:44 <cp16net> lol but in my head hes running around his chair in circles getting dizzy
18:45:59 <cp16net> :)
18:46:27 <cp16net> i guess if there is nothing else we can call this meeting
18:46:34 <pmalik> Was just wondering if it would be possible to get few more eyes on the last three remaining int-test patch sets?
18:46:34 <pmalik> It would be great if ppl could actually start using them. :-)
18:46:58 <cp16net> peterstac: can show us in the the trove channel.
18:47:12 <amrith> can we share images in IRC?
18:47:18 <peterstac> Well, I have some .jpg files - if there's nowhere to put them ...
18:47:42 <cp16net> you can link them
18:47:52 <vkmc> you can upload them to imgur?
18:47:56 * amrith takes deep breath and counts to 10
18:47:56 <cp16net> some clients show them and others can click them
18:47:58 <peterstac> to my hard drive ? ;)
18:48:12 <SlickNik> amrith: not easily
18:48:31 <SlickNik> many clients support sending images to specific people via DCC
18:48:45 <SlickNik> I guess you could imgur it and post a link.
18:49:03 <peterstac> #link http://imgur.com/a/YS2m7
18:49:04 <amrith> ok, peterstac what about just putting them on the agenda page for this meeting?
18:49:09 <amrith> or that ;)
18:49:12 <cp16net> cool
18:49:14 <cp16net> thanks peterstac
18:49:21 <peterstac> amrith, I tried that, couldn't figure it out quickly
18:49:28 <vkmc> nice graphics
18:49:38 <cp16net> thanks everyone
18:49:48 <cp16net> #endmeeting