18:00:19 <cp16net> #startmeeting trove
18:00:20 <openstack> Meeting started Wed Jan 20 18:00:19 2016 UTC and is due to finish in 60 minutes.  The chair is cp16net. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:23 <openstack> The meeting name has been set to 'trove'
18:00:47 <cp16net> howdy trove team
18:01:24 <imandhan> o/
18:01:57 <vkmc> o/
18:01:58 <cp16net> i'll give everyone a few minutes to join
18:02:51 <johnma> o/
18:03:11 <atomic77> trove create atomic77
18:03:21 <cp16net> nice atomic77
18:03:37 <atomic77> gotta change it up from time to time :)
18:03:39 <amrith> ./
18:03:45 <cp16net> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:03:53 <amrith> hi all, sorry I got double booked. I'm on another phone call as well ;(
18:04:05 <cp16net> #topic pulse update
18:04:15 <cp16net> #linkhttp://bit.ly/1VQyg00
18:04:16 <dougshelley66> o/
18:04:18 <cp16net> #link http://bit.ly/1VQyg00
18:04:37 <cp16net> went down this week
18:06:05 <cp16net> :-/
18:06:49 <cp16net> there should be lots of code for blueprints landing so we will need to keep up with them
18:07:24 <cp16net> i dont have much more on the pulse
18:07:53 <cp16net> #topic announcements
18:07:54 <peterstac> o/
18:08:05 <bhaskarduvvuri> o/
18:08:08 <cp16net> i have a few announcements i'd like to get out of the way
18:08:36 <cp16net> #info trove mid cycle meeting (Feb 9-11)
18:08:44 <cp16net> #link https://etherpad.openstack.org/p/mitaka-trove-midcycle-rsvp
18:09:35 <cp16net> we will be discussing the current road map for mitaka and going over features and code
18:09:55 <cp16net> please sign up if you can make it
18:11:06 <dougshelley66> cp16net will an agenda be drafted?
18:11:14 <cp16net> yes sir
18:11:21 <cp16net> that reminds me...
18:11:28 <cp16net> #action cp16net draft agenda
18:11:30 <cp16net> :-P
18:15:29 <Ravikiran_K__> o/
18:16:30 <mvandijk> ./
18:16:55 <dougshelley66> cp16net are you still out there?
18:17:21 <cp16net_> hello?
18:17:30 <atomic77> ack
18:17:39 <cp16net_> hmm
18:17:44 <cp16net_> i think i got booted
18:17:50 <dougshelley66> that can't be good
18:17:53 <SlickNik> welcome back
18:18:09 <cp16net_> well shoot
18:18:11 <atomic77> did you listen to that kid that had a cool hacking tool you could use against 127.0.0.1 ?
18:18:35 <cp16net_> brb
18:19:48 <cp16net_> how inconvient
18:19:59 <pmalik> ./
18:20:41 <cp16net> got it
18:21:12 <cp16net> i dunno what the last thing was that you guys saw
18:21:48 <cp16net> ping
18:21:50 <bhaskarduvvuri> action cp16net draft agenda
18:21:56 <bhaskarduvvuri> this was what we saw
18:21:57 <atomic77> ack
18:22:12 <cp16net> ok
18:22:18 <tosky> aaand a netsplit, nice
18:22:36 <dougshelley66> is this the left or right side of the brain?
18:22:45 <cp16net> yeah talk about timing of the netsplit... ;-P
18:22:53 <cp16net> ok...
18:23:01 <cp16net> so mitaka-2 will be cut this week
18:23:16 <cp16net> #link http://docs.openstack.org/releases/schedules/mitaka.html
18:24:07 <cp16net> we are entering the last period  and we need to keep up with the reviews
18:24:31 <cp16net> we have basically another month to get code in and then the feature freeze will have
18:24:37 <cp16net> s/have/happen
18:24:59 <cp16net> ok
18:25:21 <cp16net> ping
18:25:33 <johnma> yes
18:25:54 <cp16net> checking to see if i'm still online
18:26:00 <atomic77> ack
18:26:03 <cp16net> thx
18:26:05 <johnma> :) you are
18:26:20 <cp16net> ok thats all the announcements i have
18:26:33 <cp16net> moving on
18:26:42 <cp16net> #topic python 3 support in trove
18:26:54 <cp16net> i dunno who aded this
18:27:10 <cp16net> bueller?
18:28:42 <peterstac> The final line of the agenda instructions says: Please make sure to include your own name in the first line of the agenda item,
18:29:10 <cp16net> well i guess i'll go over what they added
18:29:36 <cp16net> there are a bunch of patches that are being added to trove to support python 3
18:30:03 <cp16net> there was a blueprint that was created but no spec
18:30:05 <cp16net> #linkhttps://blueprints.launchpad.net/trove/+spec/trove-python3
18:30:07 <cp16net> #link https://blueprints.launchpad.net/trove/+spec/trove-python3
18:30:40 <cp16net> this is a wiki page that outlines getting support for python 3 in all the projects in openstack
18:30:43 <cp16net> #link https://wiki.openstack.org/wiki/Python3
18:30:53 <amrith> cp16net, I added that ...
18:31:27 <cp16net> amrith: care to continue ? or still busy?
18:31:54 <amrith> tied up with a patent examiner, sorry
18:32:05 <cp16net> ok nbp
18:32:51 <cp16net> this is asking if trove intends on supporting python 3 in the mitaka release
18:33:45 <vgnbkr> I have been +1'ing changes that are small in scope, telling cross-file changes that they should wait for N.
18:34:21 <cp16net> while i think py3 would be great
18:35:07 <cp16net> i think this adds burden to the m-3 period
18:35:11 <johnma> I think one of the point made in some of the reviews was whether this work should have started early in the release rather than this late with mitaka-2 ending this week
18:35:14 <johnma> right
18:35:30 <dougshelley66> cp16net i agree
18:35:36 <cp16net> my pov is to hold off on it
18:35:42 <dougshelley66> maybe a goal would be to get these things in at the start of N
18:35:54 <cp16net> i agree with that dougshelley66
18:35:57 <vgnbkr> cp16net, Are you talking about actually switching to Python3 in Mitaka.  Yeah, that would be a huge risk.
18:35:59 <dougshelley66> which is what vgnbkr is saying
18:36:00 <cp16net> and johnma
18:36:14 <cp16net> vgnbkr: switching?
18:36:14 <cp16net> no
18:36:18 <cp16net> supporting
18:36:24 <cp16net> is all i'm talking about
18:36:37 <amrith> OK, I'm freed up
18:36:38 <dougshelley66> right so we would still have py27 and be adding py34
18:36:40 <dougshelley66> i believe
18:36:47 <cp16net> but adding py3 to the tests does not seem like a good idea either
18:37:03 <dougshelley66> but i think the review bandwidth comment that cp16net made is very valid
18:37:03 <amrith> cp16net, I believe that making changes that will benefit py3 at this stage seems risky
18:37:08 <amrith> whether they are tests or executed code
18:37:17 <tosky> cp16net: even as non-voting test?
18:37:19 <amrith> I would rather we treat this like all other projects and try and get the code in earlier
18:37:28 <amrith> yes
18:37:30 <vgnbkr> I think it's probably OK to accept small changes that are limited in scope during Mitaka, but anything that is likely to cause testing issues or rebase issues should be pushed to the next cycle.
18:37:32 <amrith> all tests take time to run
18:37:55 <amrith> and at the end of the cycle, time is of the essence
18:38:15 <cp16net> i dunno what thats all about^^
18:38:16 <amrith> and whether it is voting or not voting you are also making non-voting test changes
18:38:18 <cp16net> lol
18:38:32 <amrith> such as six.this and six.that
18:38:59 <amrith> so I am advocating that we hold py3 beyond the m3 timeline and then treat them as part of the n release.
18:39:46 <cp16net> yeah i think the piority of this isnt as high as other features that are already in progress for some time
18:40:11 <cp16net> amrith: #agreed
18:40:40 <amrith> I agree cp16net but I'd like to try and clearly undnerstand what the process will be in N
18:40:49 <amrith> I'm not sure we need a trove-spec
18:41:06 <cp16net> amrith: i dont really think so either
18:41:13 <amrith> I'd actually say this is one of those cross project things that has a bp but need not have a trove spec (unless others feel that it should for some reason).
18:41:21 <cp16net> that wiki page outlines everything pretty clearly as it is already
18:41:34 <amrith> And I'd like to have all the changes related to py3 either marked dependent or otherwise identified so we can review and merge them as such.
18:41:37 <cp16net> i think refering to it will be good enough for the bp
18:42:23 <amrith> and we coudl take them all early in the N timeframe and be on our merry way
18:42:32 <cp16net> amrith: if they are linked to the bp that would be good
18:42:53 <cp16net> #link https://review.openstack.org/#/q/topic:bp/trove-python3
18:42:59 <cp16net> like that list
18:43:04 <amrith> it would save us time on reviews (now), and if we don't have them gating other merges for things we want (no matter how inconsequential the merge may be), I think we'd all be better off.
18:43:17 <amrith> that's all you get for 2c
18:43:18 <amrith> ;)
18:43:47 <dougshelley66> must have been 2 Canadian cents .. .:)
18:43:52 <amrith> and apologies for not putting my name on the agenda item
18:44:01 <amrith> are we all agreed?
18:44:08 <cp16net> ok so to summarize
18:44:30 <cp16net> i've not heard anything for pushing forward on py3 in M cycle
18:44:46 <cp16net> and we all mentioned the risk of it for now
18:45:23 <cp16net> so we will be pushing this bp out to N and be one of the first things merged in the N release
18:45:42 <cp16net> alright
18:45:45 <cp16net> moving on
18:45:59 <cp16net> #topic open discussion
18:46:05 <dougshelley66> i have one
18:46:20 <cp16net> dougshelley66: go ahead
18:46:27 <dougshelley66> i'm assuming everyone has noticed they various check failures today
18:46:46 <dougshelley66> just wondering if anyone has a sense for what/when the correction is?
18:46:49 <dougshelley66> do we need to do something?
18:48:00 <amrith> abramley, has some background about it
18:48:06 <amrith> I'll gather it and post on #openstack-trove
18:48:13 <amrith> we (he and I) talked about it early this morning
18:48:23 <amrith> and it appears to be something outside of trove
18:49:01 <dougshelley66> this asimov dude won't leave us alone...
18:49:02 <cp16net> i was having some trouble myself with devstack but i'm not sure if its related
18:49:20 <dougshelley66> we've seen devstack setup failures and kick-start failures
18:49:20 <amrith> yes, if you get pip 8, then you are going to be waiting a long time
18:49:25 <amrith> devstack won't come up
18:49:52 <cp16net> i've had many strange errors
18:50:19 <amrith> well, you live near Roswell, NM, correct?
18:50:44 <cp16net> lol
18:51:01 <cp16net> ok any other topics
18:51:02 <cp16net> ?
18:51:03 <dougshelley66> it seems related to a bunch of tooling upgrades overnight
18:51:08 <dougshelley66> like virtualenv, pip etc
18:51:31 <dougshelley66> just trying to understand if this will just magically get fixed or we need to actively do something about it
18:51:33 <cp16net> yeah its possible and if its a devstack related issue i'm sure we are not the only ones feeling the pain
18:51:44 <cp16net> but havtn looked into it much further
18:51:51 <cp16net> just trying to run some tests myself
18:51:59 <abramley> I saw a fix for devstack - but there are still issues in things like diskimage-builder
18:52:28 <cp16net> alright
18:52:53 <abramley> and right now there are a bunch of reviews for removing argparse from requirements.txt across all projects - I believe that is a symptom but not the cause of the problem
18:53:25 <cp16net> ok
18:53:40 <cp16net> anything else for discussion
18:53:46 <cp16net> dougshelley66: thanks for bringing this up
18:53:51 <dougshelley66> cp16net np
18:54:22 <cp16net> alright if not i'll end the meeting
18:54:30 <cp16net> #endmeeting