18:00:14 <cp16net> #startmeeting trove
18:00:15 <openstack> Meeting started Wed Jan 27 18:00:14 2016 UTC and is due to finish in 60 minutes.  The chair is cp16net. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:18 <openstack> The meeting name has been set to 'trove'
18:00:25 <amrith> ./
18:00:34 <tosky> hi
18:00:38 <egafford> Hi all!
18:00:39 <cp16net> howdy everyone
18:01:08 <imandhan> o/
18:01:10 <cp16net> egafford: welcome
18:01:30 <vgnbkr> o/
18:01:45 <egafford> cp16net: Thanks! (This is Ethan from the Sahara team; I'm hoping to serve as a Sahara liaison for when/if that might be useful.)
18:02:14 <cp16net> awesome
18:02:22 <cp16net> lets get this party started
18:02:26 <egafford> And, you know, to Trove, because Trove. :)
18:02:26 <cp16net> #topic pulse update
18:02:41 <cp16net> #link http://bit.ly/1VQyg00
18:02:54 <cp16net> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:03:27 <vkmc> o/
18:04:10 <cp16net> we've got more reviews
18:04:37 <cp16net> one stat i added what on the others tab for reviews
18:05:01 <cp16net> tracking total vs core vs other reviews
18:05:11 <pmackinn> o/
18:06:12 <cp16net> that can be helpful to see if we have community support reviewing
18:07:24 <cp16net> it looks like we've done some work here but a bit more goto
18:07:48 <cp16net> thanks for everyone reviewing!
18:07:56 <cp16net> its very helpful
18:08:11 <cp16net> not much else from me on this
18:08:29 <cp16net> moving along
18:08:37 <cp16net> #topic announcements
18:08:53 <cp16net> we got the gate issue resolved last week
18:09:00 <cp16net> after much fun with pip issues
18:09:16 <cp16net> and there was an issue with the elements
18:10:30 <cp16net> thanks for the help from abramley we got it all resolved
18:10:46 <cp16net> #info fixed gate issues
18:11:14 <cp16net> #info trove midcycle meetup is 2 weeks away (feb 9-11)
18:11:30 <cp16net> #link https://etherpad.openstack.org/p/mitaka-trove-midcycle-rsvp
18:11:36 <pmackinn> WHAAAAT???
18:11:40 <cp16net> #link https://wiki.openstack.org/wiki/Sprints/TroveMitakaSprint
18:11:59 <cp16net> pmackinn: i hope thats a joke :-P
18:12:16 * pmackinn counts 6 participants officially
18:12:35 * amrith bites his tongue
18:12:36 <pmackinn> i aw awaiting news of the marriott rates
18:12:45 <cp16net> i created the eventbright and i'll get the numbers on that later
18:12:57 <cp16net> i think its been duplicates of the members on the list
18:13:06 <pmackinn> who has flights atm?
18:13:19 <amrith> ./
18:13:24 <amrith> sorry, you said flights
18:13:28 <amrith> I thought you said fights
18:13:36 <pmackinn> actually 4 rsvp
18:13:44 <pmackinn> for the live fights
18:14:47 <amrith> goody
18:14:58 <cp16net> please signup if you plan on being there
18:15:18 <cp16net> it will help with food situation and planning
18:15:24 <pmackinn> cp16net, +1
18:15:55 <cp16net> a few other announcements i have
18:16:15 <cp16net> #info [release news]  mitaka-2 was released
18:16:23 <cp16net> #link http://docs.openstack.org/releases/releases/mitaka.html#mitaka-trove
18:17:03 <cp16net> #info [release news]  mitaka-3 is planned for March 1-3
18:17:14 <cp16net> #link http://docs.openstack.org/releases/schedules/mitaka.html
18:17:36 <cp16net> this means we need the code for the features in asap
18:17:57 <cp16net> to get reviewed and updated before the rush
18:19:07 <cp16net> #info [release news]  trove-dashboard was tagged with 6.0.0.0b2
18:19:36 <cp16net> it had no tags before and zigo pointed this out last night
18:20:04 <cp16net> this version was chosen because trove has been in horizon since havana
18:20:34 <cp16net> i tagged the head of master with this version last night
18:20:41 <cp16net> fyi
18:21:05 <cp16net> anything i missed?
18:21:57 <cp16net> alright well i guess we'll move to open discussion
18:21:59 <amrith> only other thing I can think of is that zigo has other issues with trove (not dashboard).
18:22:07 <amrith> and he's reported some bugs on them.
18:22:46 <cp16net> amrith: yeah i bet its because he is using the same vm to build all the packages across OS
18:23:10 <cp16net> #topic open discussion
18:23:36 <cp16net> anything anyone wants to bring up?
18:23:48 <pmackinn> redstack/devstack clean this week? noticed some floating ip weirdness yesterday from a fresh install
18:24:03 * pmackinn phishs
18:24:22 <cp16net> i havnt messed with floating ips on devstack so i'm not sure
18:24:29 <tosky> just a request to push some of the test-related backports on stable/liberty - I see that there are only two core reviewers for the stable branches, so it could be easy to miss
18:24:39 <amrith> haven't noticed any recently pmackinn
18:24:55 <amrith> tosky, got some #'s
18:25:17 <amrith> you can send them later in #openstack-trove
18:25:22 <amrith> no need to hold everyone up now
18:25:25 <amrith> am looking for them
18:25:32 <cp16net> tosky: yeah there are a few and i think slicknik -1 asking why we were pushing test changes in stable
18:26:37 <cp16net> something i noticed another team doing in their meeting was a weekly update topic from everyone
18:27:07 <tosky> amrith: thanks; the two you pushed and also https://review.openstack.org/#/c/262289/
18:27:09 <amrith> I could do one right now if you want ;)
18:27:15 <cp16net> everyone just gives a 1 sentence of what or where they are with their tasks
18:27:23 <amrith> cp16net, we need a good bug scrub
18:27:29 <amrith> I've been doing it adhoc for some days
18:27:36 <amrith> and there are 261 oldy moldy bugs
18:27:43 <amrith> and some are no longer relevant
18:27:55 <cp16net> i was thinking this would be really helpful with the release coming up
18:27:55 <amrith> and some important ones are buried in the weeds
18:28:04 <amrith> so fair warning to all
18:28:09 <amrith> I'm going to be running through lp
18:28:23 <amrith> and posting comments around bugs that have been growing old.
18:28:36 <amrith> and fixing up status; such as change in-progress if the chagne is abandoned
18:28:52 <amrith> But, I'd like people's view on unassigning bugs from people who aren't active in the project any longer.
18:28:56 <amrith> that's a touchy subject
18:28:57 <cp16net> amrith: yeah that should be done a little before m-3 release so that we know whats left we can work on in the m-4 time frame
18:29:23 <pmackinn> no bug yet, but am dusting off fedora in redstack (f23) in advance of pending mariadb feature set
18:29:46 <cp16net> amrith: i think if there is no review for the bug up then we dont know what the progress is
18:30:11 <amrith> pmackinn, there's a bug to get redstack/devstack for trove completely working for fedora
18:30:14 <amrith> I entered it a while ago
18:30:18 <amrith> currently assigned to vkmc.
18:30:40 <amrith> 1419089
18:30:40 <pmackinn> "completely"
18:30:50 <amrith> https://bugs.launchpad.net/trove/+bug/1419089
18:30:52 <openstack> Launchpad bug 1419089 in Trove "Get redstack working completely with fedora" [High,Triaged] - Assigned to Victoria Martinez de la Cruz (vkmc)
18:31:23 <amrith> you pushed some of the trove-integration stuff
18:31:27 <amrith> a while ago
18:31:39 <vkmc> working on that certainly, still hitting a lot of bugs related to hard wired Ubuntu paths
18:31:44 <vkmc> we are almost there I'm dare to say though
18:32:02 <amrith> is there a change or set of changes to converge to a complete solution?
18:32:11 <pmackinn> i think the trove project should be removed from that bug imho
18:32:16 <pmackinn> long march
18:32:19 <cp16net> so my update is the pxc review of grow/shrink(working on getting current networks on instances in the cluster) and root-enable(ready for review).
18:32:50 <vkmc> probably a set of changes is going to be needed, I'll submit the ones I have in my queue this week
18:33:20 <cp16net> that would be great vkmc
18:33:26 <vkmc> :)
18:33:59 <cp16net> if you can squash the changes together for the bug that would be good
18:34:21 <vkmc> k k, will do
18:34:30 <cp16net> unless its across projects then create bugs for them across the projects and link them in lp
18:34:51 <amrith> #action amrith to chat with pmackinn about removing trove as an affected project from 1419089
18:35:12 <cp16net> +cp16net to that convo
18:36:09 <amrith> ok, right after this mtg? #openstack-trove?
18:36:20 <cp16net> oh one thing i forgot to mention there was an ask for a liason for cross-project issues by default its me but curious if anyone else was interested in helping out?
18:36:54 <cp16net> if you are interested let me know.
18:37:06 <tosky> my status: I'm playing with the integration tests, even if more on the liberty branch (but with an eye on mitaka) on RHEL platforms
18:37:18 <egafford> https://wiki.openstack.org/wiki/CrossProjectLiaisons describes the full set of liaisons it's nice to have.
18:37:22 <amrith> cp16net, was that a per-project issue?
18:37:30 <amrith> I'm supposed to be one oslo
18:37:47 <cp16net> there is the cross project effort as well
18:37:50 * egafford politely suggests that one person would be hard-pressed to fill all these roles for any one project.
18:38:01 <cp16net> #agrees
18:38:18 <vgnbkr> cp16net, I thought Peter was the cross-project contact.
18:38:36 <amrith> actually, I've been the contact for a while now ;)
18:38:42 <cp16net> vgnbkr: no this is relatively new
18:38:53 <amrith> for oslo that is.
18:39:16 <vgnbkr> cp16net, maybe that was just for the incubator stuff or something
18:39:19 <amrith> Ok, timeout!
18:39:30 <cp16net> if you are interested in helping out this would be helpful! :)
18:39:31 <amrith> What is this effort you're talking about cp16net ?
18:39:51 <amrith> egafford sent a link to a page with many liaisons already identified.
18:39:52 <cp16net> The OpenStack project relies on the cross-project spec liaisons from each participating project to help with coordination and cross-project spec related tasks. See full set of responsibilities The liaison defaults to the PTL, but the PTL can also delegate the responsibilities to someone else on the team by updating this tableː
18:39:56 <amrith> are you talking about the same thing?
18:40:05 <cp16net> look at the bottom on the list of liasons
18:40:25 <cp16net> if interested let me know
18:40:39 <cp16net> thats all i have
18:40:44 <dalees> I just wanted to say hi to all. I'm Dale Smith from Catalyst IT and I'm starting to look at existing trove single tenant features and how I can help improve these. (with a view to address https://bugs.launchpad.net/trove/+bug/1445295).
18:40:45 <openstack> Launchpad bug 1445295 in Trove "Guestagent config leaks rabbit password" [Undecided,New] - Assigned to Amrith (amrith)
18:40:45 <amrith> Ok cp16net
18:40:51 <amrith> that's the SPEC liaison
18:40:57 <amrith> liaison
18:41:05 <amrith> specifically cross project specs.
18:41:21 <amrith> Happy to help with that.
18:41:27 <cp16net> amrith: sorry yeah thats what i meant
18:41:29 <cp16net> :-P
18:41:43 <peterstac> vgnbkr, I'm the API liason (FWIW)
18:41:52 <cp16net> dalees: welcome and we appreciate your help
18:42:01 <egafford> Looks like Trove is missing Product WG and Logging WG liaisons as well at the moment.
18:42:04 <vgnbkr> peterstac, Ah, I knew there was something :-)
18:42:06 <amrith> And since I'm the guy who started the mail thread that prompted a Sahara/Trove liaison, I'll volunteer for the Trove sie.
18:42:08 <cp16net> i see amrith was assigned that bug but not sure where he is on that
18:42:17 <cp16net> so it might be good to chat with him about it
18:42:29 <egafford> amrith: o/
18:42:49 <cp16net> egafford: it all defaults to me if no one picks it up but yea there are a few openings
18:42:53 <amrith> cp16net, I had a couple of conversations with Bruno on that bug
18:43:12 <egafford> cp16net: Indeed; just noting. :)
18:43:15 <amrith> and it seemed like there was (at the time) a disconnect between the capabilities of OSLO and what Catalyst wanted to propose.
18:43:17 <cp16net> true!
18:43:39 <amrith> So, one thing at a time.
18:43:49 <amrith> with your permission cp16net I will add myself as Trove/Sahara liaison
18:43:50 <amrith> ok?
18:44:01 <cp16net> sounds good to me
18:44:06 <amrith> Thx
18:44:12 <pmackinn> amrith, so many hats?
18:44:26 <cp16net> but none of them are red...
18:44:27 <cp16net> :-P
18:44:32 <amrith> enough to talk through
18:44:54 <cp16net> anyone have anything else?
18:44:59 <vgnbkr> o/
18:45:04 <peterstac> just a quick question for tosky
18:45:13 * amrith waits for vgnbkr to finish
18:45:18 <peterstac> you go first vgnbkr
18:45:24 <vgnbkr> OK.
18:45:38 * amrith graciously allows peterstac to go next
18:45:49 <vgnbkr> We've had ongoing issues and misunderstanding with API versioning between the Trove components.
18:46:23 <vgnbkr> I would like to propose a spec outlining a method for dealing with these issue, but would want some level of buyin before making the effort.
18:46:45 <vgnbkr> Do people think it worthwhile formalizing the method for changing APIs?
18:47:12 <vgnbkr> anyone? ...
18:47:32 <cp16net> vgnbkr: there is a method to it but its not documented really so it might be helpful to layout the path
18:47:43 <cp16net> for trove that is
18:48:02 <amrith> vgnbkr, I think it would be a worthwhile spec and think it makes sense to get some agreement on the approach
18:48:05 <amrith> before writing the spec.
18:48:16 <peterstac> vgnbkr, sounds like you're proposing a document not a 'spec' - rihgt?
18:48:24 <amrith> I think it would be very good to formalize the method for changing the API.
18:48:44 <vgnbkr> My proposal would basically be that every API destination have a preceeding block comment that it never be changed (the destination).
18:48:50 <amrith> peterstac, vgnbkr, cp16net ... would a short email to the ML make sense?
18:49:26 <cp16net> getting an abstract of the details before diving to far in would be good
18:49:33 <peterstac> I thought the ML was where ideas went to get shot down ... ;)
18:50:41 <amrith> vgnbkr, that proposal seems to make a lot of sense
18:50:44 <amrith> the block comment
18:50:44 <cp16net> vgnbkr: write up an abstract on the process you envision and we can discuss
18:50:54 <vgnbkr> Then a method for how a new API destination would be named to show its relationship to the previous version (say reset(foo) => resetMOD2(foo, bar)).
18:51:03 <cp16net> we could bring it up next meeting
18:51:28 <vgnbkr> I'm not doing to spend the time writing a document if the basic idea isn't what people are looking to do.
18:51:48 <cp16net> i think there is some value to it
18:51:49 <amrith> if we go that route vgnbkr we could also add a test that would check the method signature and barf it was changed ;)
18:52:08 <vgnbkr> amrith, yes, I was going to propose that as well.
18:52:24 <amrith> I think it is a good thing to do vgnbkr
18:52:31 <cp16net> i agree
18:52:37 <amrith> and if I can help write it or the spec, you know where to find me.
18:52:57 <cp16net> alright peterstac had something/
18:53:08 <vgnbkr> And you agree with the basic idea of naming methods (reset(foo) => resetMOD2(foo, bar))?
18:53:22 <amrith> devil meet details
18:53:22 <vgnbkr> (of course, the MOD2 part is open to discussion)
18:53:56 <cp16net> makes sense
18:54:35 <vgnbkr> OK, I'll write something up.  A Wiki doc rather than a spec, then?
18:54:37 <peterstac> I just had a question for tosky (if vgnbkr is done ;) )
18:54:42 <tosky> peterstac: sure :)
18:54:50 <vgnbkr> go ahead
18:55:24 <peterstac> tosky, you're trying to get some tests backported to liberty, but from what I can see, these are all 'scenario' tests
18:55:44 <tosky> peterstac: yes, they are
18:56:11 <peterstac> These tests don't run in the gate yet (never have) and definitely weren't stable in liberty
18:56:21 <peterstac> (some aren't stable yet in mitaka)
18:56:34 <cp16net> peterstac: tru!
18:56:35 <tosky> peterstac: I understand that, but they were partially backported already; with the few missing bits, they should be able to work properly in a still-supported branch
18:56:39 <peterstac> just curious what the motivation is
18:57:30 <peterstac> but that's my point - they don't run in the stable branches - never have
18:57:48 <peterstac> (still don't, in fact)
18:58:06 <cp16net> yeah they were a work in progress in the last stable branches
18:58:25 <tosky> yes, but from the discussion on the channel it seemed that at least with two backports (the one going in now) at least they were not totally broken
18:58:36 <tosky> and from my testing I can say that they are mostly working
18:58:39 <cp16net> the int-tests that we have that tested mysql thoroughly were stable
18:59:15 <tosky> right, but between spending time with the old ones and adapt them to mariadb vs using the new ones, I invested my time in the new one
18:59:25 <tosky> hopefully it's something that will be visible on RDO soon(ish)
19:00:45 <peterstac> tosky, ok, just curious (since we have limited bandwidth and lots of stuff to do for mitaka)
19:00:52 <tosky> I was going to ask for few more small backports (of patches I did) but it the direction is to reduce their usage, I won't ask for that
19:01:41 <amrith> are we there yet?
19:01:49 <peterstac> tosky, you've submitted changesets for the scenario tests? (must have missed them - will go look)
19:01:59 <peterstac> oops - out of time ...
19:02:12 <cp16net> alright times up
19:02:26 <amrith> cp16net, pmackinn regroup in #openstack-trove?
19:02:27 <cp16net> #endmeeting