18:00:37 <cp16net> #startmeeting trove
18:00:38 <openstack> Meeting started Wed Feb  3 18:00:37 2016 UTC and is due to finish in 60 minutes.  The chair is cp16net. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:42 <openstack> The meeting name has been set to 'trove'
18:00:51 <pmackinn> o/
18:00:59 <cp16net> hello everyone
18:01:04 <nshah> o/
18:01:39 <cp16net> hi and welcome nshah
18:01:45 <dougshelley66> o/
18:02:23 <pbelamge> o/
18:02:48 <pmalik> sudo rm -rf /
18:03:06 <peterstac-m> o/
18:03:20 <pmackinn> oh my
18:03:23 <atomic77_> o/
18:03:36 <cp16net> someone gives up... :-P
18:03:39 <pmackinn> lol
18:04:09 <cp16net> #topic  Trove pulse update
18:04:21 <cp16net> #link http://bit.ly/1VQyg00
18:04:49 <cp16net> we've kept up the momentum
18:05:22 <cp16net> i'm happy with the results
18:06:26 <cp16net> not much else from me on that
18:06:43 <cp16net> #topic Announcements
18:06:53 <cp16net> #info Trove Mid Cycle Meetup (Feb 9-11) Next week!
18:07:01 <cp16net> #link https://wiki.openstack.org/wiki/Sprints/TroveMitakaSprint
18:07:02 <pmackinn> yes indeed
18:07:33 <cp16net> from the looks it sounds like there will be a decent turn out
18:07:38 <pmackinn> cp16net, would like contact emails for attendees so i can request meal preferences etc.
18:07:40 <cp16net> last count i had was 11
18:08:03 <cp16net> #action cp16net get list together for attendees
18:08:09 <cp16net> pmackinn: ok i'll do that today
18:08:22 <pmackinn> anyone heartbroken if no t-shirts?
18:08:45 <dougshelley66> certianly
18:08:51 <dougshelley66> red hat can't afford t-shirts?
18:08:54 <vgnbkr> o/
18:08:55 * pmackinn can't outdo the la laker uniforms of last meetup
18:09:11 * peterstac-m shakes his head
18:09:15 <vkmc> o/
18:09:25 <cp16net> sad panda :-P
18:09:56 <cp16net> #info put ideas to talk about on the etherpad at the midcycle
18:10:04 <cp16net> #link https://etherpad.openstack.org/p/liberty-trove-midcycle
18:10:34 <dougshelley66> cp16net i think vkmc put up a link that was for mitaka
18:10:43 <dougshelley66> given this isn't the liberty midcycle
18:10:55 <vkmc> #link https://etherpad.openstack.org/p/mitaka-trove-midcycle
18:11:05 <vkmc> same content
18:11:13 <dougshelley66> we should probably use that one
18:11:17 <cp16net> oh crap i'm terrible
18:11:20 <cp16net> yeah
18:11:28 <cp16net> good call
18:11:46 <cp16net> thanks vkmc
18:11:53 <vkmc> np
18:12:06 <cp16net> #info use the mitaka url for the etherpad
18:12:31 <cp16net> #info we will cancel next weeks meeting since everyone will be at the midcycle
18:13:07 <cp16net> #info reminder that m-3 is March 1-3
18:13:39 <cp16net> the bp are more important than the bugs to review
18:13:52 <cp16net> so please help out with those
18:14:27 <cp16net> alright thats all the announcements i have
18:14:36 <amrith> ./
18:14:39 <amrith> sorry, am late
18:14:43 <amrith> (fashionably)
18:14:48 <cp16net> #topic open discussion
18:15:28 <pmackinn> config groups...is the long term goal to have that for all datastores?
18:16:07 <cp16net> pmackinn: if the datastore can be configured i think it makes sense
18:16:36 <pmackinn> any reason it wouldn't make sense for say mysql or mariadb?
18:16:50 <cp16net> this allows for a bit more flexibility for the user
18:17:50 <cp16net> pmackinn: no because some configuration requires root and or restart of the service
18:18:34 <dougshelley66> pmackinn config groups are already implemented for mysql and maria
18:18:50 <cp16net> yeah its there
18:18:56 <cp16net> i wrote it originally for mysql
18:19:09 * pmackinn defers to meetup
18:19:11 <dougshelley66> i believe we also have it for mongo/redis
18:19:21 <dougshelley66> and cassandra is en route
18:19:25 <cp16net> yup
18:19:35 <amrith> pmackinn, what were you getting at?
18:20:30 <pmackinn> amrith, postgresql templates got reworked as part of config groups so problematic paths *seemed* to go away
18:20:40 <pmackinn> trying to understand the bigger scope
18:21:21 <cp16net> ok
18:21:34 <dougshelley66> pmackinn you should talk to atomic77_
18:21:57 <pmackinn> k
18:22:43 <dougshelley66> and/or pmackinn
18:22:45 <dougshelley66> sorry
18:22:47 <dougshelley66> pmalik
18:24:19 <cp16net> we have a few specs that need to be reviewed if they are planning to be in Mitaka
18:25:26 <cp16net> also for those that are here can we get a sense of how comfortable you are with the specs you have to be code complete and merged by the end of Feb?
18:26:34 <cp16net> #info pxc-grow-shrink and pxc-root-enable are waiting review
18:26:41 <peterstac-m> I should be good
18:26:46 <pmalik> Well config groups are not enabled for Maria...
18:27:08 <pmalik> https://bugs.launchpad.net/trove/+bug/1532256
18:27:09 <openstack> Launchpad bug 1532256 in Trove "Configuration groups not supported on Mariadb" [Medium,Confirmed]
18:27:12 <imandhan> I have a couchdb user and db operations spec in review and I'm working on the code but I will be fine on the timeline
18:27:32 <atomic77_> all is good on my side
18:27:55 <johnma> I have one for couchdb backup & restore thats waiting for reviews
18:27:56 <cp16net> peterstac-m: thanks
18:27:58 <cp16net> imandhan: thanks
18:28:05 <cp16net> atomic77_: great
18:28:35 <cp16net> johnma: thanks
18:28:44 <johnma> and I have another one for couchdb replication. I have the code ready, can push it up for review today/tomorrow but the spec also needs reviews
18:28:56 <johnma> its master-master replication
18:29:01 <vgnbkr> I'm comfortable my stuff will be pushed up.
18:29:23 <cp16net> vgnbkr: sounds good
18:30:40 <cp16net> thanks for everyones status its helpful to know everything is going well
18:30:51 <cp16net> does anyone have any blockers that i can help with?
18:31:42 <imandhan> has anyone run redstack install lately? wondering if things are buggy or not at the moment
18:31:53 <cp16net> imandhan: i've run it last night
18:32:00 <cp16net> no problems that i saw
18:32:14 <cp16net> when i was testing the cassandra patches
18:32:21 <imandhan> okay, great! thanks cp16net :)
18:32:24 <cp16net> np
18:32:45 <cp16net> imandhan: if you have issues let me know and we can get them worked out
18:33:00 <imandhan> okay, I'll be trying it out in a bit today
18:33:06 <cp16net> ok
18:33:11 <cp16net> thats all i have for today
18:33:21 <cp16net> anyone have anything else they'd like to bring up
18:34:51 <cp16net> alright if nothing else.. have a great week
18:34:57 <johnma> Thanks cp16net
18:34:57 <cp16net> safe travels
18:35:19 <cp16net> #endmeeting