18:00:34 <amrith> #startmeeting trove
18:00:35 <openstack> Meeting started Wed Apr 13 18:00:34 2016 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:38 <openstack> The meeting name has been set to 'trove'
18:00:56 <dougshelley66> o/
18:00:58 <SlickNik> o/
18:01:00 <pmackinn_> o/
18:01:01 <amrith> ./
18:01:05 <amrith> hello folks
18:01:07 <pmalik_> ☺/
18:01:21 <tosky> o/
18:01:27 <abramley> o/
18:01:39 <mvandijk> ./
18:01:40 <johnma> o/
18:01:45 <amrith> johnma told me that she wouldn't be able to make it to the meeting
18:02:03 <SlickNik> and yet here she is :)
18:02:09 <peterstac> o/
18:02:09 <johnma> i am here though :)
18:02:09 <amrith> i know
18:02:15 <johnma> just for the meeting
18:02:21 <amrith> cool, thanks johnma
18:02:30 <amrith> let's get started.
18:02:35 <dloi> o/
18:02:41 <vgnbkr> o/
18:02:43 <amrith> meeting agenda is at https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:02:45 <amrith> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:02:53 <amrith> #topic Trove pulse update
18:03:00 <amrith> #link http://bit.ly/1VQyg00
18:03:11 <amrith> I'll let everyone look at the graph and collect their thoughts
18:03:22 <vkmc> o/
18:03:28 <haypo> _o/
18:03:39 <amrith> we have had a significant drop in the number of reviews
18:03:46 <amrith> and the queue has grown a bit
18:04:02 <amrith> the only reason it didn't grow more is likely because we abandoned a bunch of changes
18:04:03 <schang> o/
18:04:21 <amrith> but we've got to pick up the pace on reviews; especially of the specs which we are considering for newton
18:04:42 <amrith> otherwise there's a very real possibility that we'll get closer to the N-1 deadline and have a rush of code and specs
18:05:05 <amrith> so, I'm going to request everyone to take some time and catch up on reviewing the code and specs taht are out there.
18:05:34 <amrith> if you have code that has a number of comments, please either push up a new change set, or indicate when you plan to.
18:06:13 <amrith> anyone have anything else to add?
18:06:26 <dougshelley66> It would definitely be helpful to get the pace of review back to where is was in mitaka
18:06:40 <dougshelley66> i think there are some "low hanging fruit" reviews that we can get thru
18:07:05 <dougshelley66> but definitely getting specs reviewed before N-1 is important
18:07:13 <haypo> amrith: another option is to recruit new core reviewer in most active contributors ;) (i'm not interested to become a core, it's just a suggestion)
18:07:22 <amrith> haypo, we need reviews
18:07:33 <amrith> I think monikers like core are a different thing altogether
18:07:48 <amrith> or are you suggesting that making someone a core reviewer somehow increases the number of reviews they do?
18:07:53 <amrith> we have 6 core reviewers.
18:08:05 <amrith> five of who are here at this meeting
18:08:23 <pmackinn> amrith, is workflow same between spec and bug for +2?
18:08:32 <amrith> yes pmackinn
18:09:03 <amrith> do others have thoughts, suggestions?
18:09:10 <amrith> SlickNik, peterstac, johnma, vkmc
18:09:38 <pmalik_> Maybe we should put top 10 list back. It did seem to make difference...
18:10:07 <amrith> good idea
18:10:11 <pmackinn> so # of reviews per item leads to more focus/+2?
18:10:12 <johnma> amrith, I certainly like the idea of having a list of reviews that we are focusing on - like we did in Mitaka
18:10:15 <pmackinn> in theory?
18:10:38 <amrith> a couple of good thoughts there
18:10:43 <amrith> a focus on specific reviews
18:10:50 <amrith> putting back the list of top reviewers
18:11:14 <amrith> pmackinn, I think an active discussion about a topic will lead to more people reviewing, and +2's, I think.
18:11:18 <vkmc> yeah, agree that having a focus could help
18:12:40 <amrith> any other thoughts?
18:12:57 <vkmc> other than that... I've seen in some projects that the number of reviews decrease weeks after the summit
18:13:00 <tellesnobrega> o/
18:13:09 <vkmc> I think this happened in Trove in the past too
18:14:02 <amrith> so, here's a list I've been using
18:14:19 <amrith> https://review.openstack.org/#/q/%28project:openstack/trove+OR+project:openstack/trove-integration+OR+project:openstack/trove-specs+OR+project:openstack/trove-dashboard+OR+project:openstack/python-troveclient%29+AND+status:open+AND+branch:master+and+is:mergeable
18:14:23 <amrith> #link https://review.openstack.org/#/q/%28project:openstack/trove+OR+project:openstack/trove-integration+OR+project:openstack/trove-specs+OR+project:openstack/trove-dashboard+OR+project:openstack/python-troveclient%29+AND+status:open+AND+branch:master+and+is:mergeable
18:15:12 <amrith> there are several changes that I think we should be able to quickly approve
18:15:13 <amrith> https://review.openstack.org/304316
18:15:21 <amrith> https://review.openstack.org/286317
18:15:29 <amrith> https://review.openstack.org/221480
18:15:48 <amrith> there are specs that we need to get agreement on quickly
18:15:49 <amrith> lie
18:15:51 <amrith> like
18:15:58 <amrith> https://review.openstack.org/294213
18:16:07 <amrith> https://review.openstack.org/302416
18:16:14 <amrith> https://review.openstack.org/295274
18:16:25 <amrith> there are the changes for python3
18:16:38 <amrith> now, when you say "focus", what are you looking for?
18:16:45 <amrith> a 'starred' list?
18:16:47 <amrith> a dashboard?
18:16:55 <amrith> an email from time to time?
18:17:49 <SlickNik> I wonder if something like having some known set time for code reviews (every week) where we can help drive focus will be helpful? Something like code-review office hours?
18:18:18 <johnma> a dashboard is what I was thinking and I know flavio was working on something along that line
18:19:06 <amrith> SlickNik, I'm open to the idea and would like to give it a shot.
18:19:11 <johnma> that is also a good idea SlickNik.
18:19:16 <amrith> is there a specific time that we could set aside for this?
18:19:36 <dougshelley66> SlickNik time scheduling multiple timezones is usually tricky
18:20:11 <peterstac> If we put the 'top 10' list back, then by definition it'll become Tuesday afternoon ;)
18:20:27 <SlickNik> dougshelley66: agreed — maybe doesn't need to be a time when everyone is available.
18:20:47 <dougshelley66> Slicknik how about 9am ET? :)
18:21:24 <SlickNik> Maybe have a web-page for example I can publish what time I'll be doing reviews (weekly).
18:21:31 <SlickNik> and others can do the same.
18:22:02 <johnma> Maybe we could have 2 different days/times a week and people could join either times
18:22:22 <amrith> ok, let's give that a shot
18:22:29 <SlickNik> Not 100% sure — just brainstorming ideas :)
18:22:30 <amrith> #action Amrith to add back the top-10 list
18:22:48 <amrith> #action [amrith] figure out a way to communicate priority for reviews
18:23:14 <johnma> top-10 list for what? just curious
18:23:15 <amrith> #action [all] think more about the idea of review timings and see if we can get some way to move that forward.
18:23:29 <amrith> johnma, there used to be a time when we published who the top-10 reviewers were
18:23:42 <amrith> like: <name> <n-reviews>
18:24:09 <johnma> oh ok, I remember that. we stopped doing that for some reason, not sure
18:24:11 <amrith> and Heisenburg's theory of management said ...
18:24:45 <amrith> ok, we have a couple of action items
18:24:55 <amrith> if others have thoughts, let's keep talking on #openstack-trove
18:25:14 <amrith> anyone else have anything else, let's move along
18:25:30 <amrith> #topic Announcements
18:25:33 <amrith> python-troveclient v2.2.0 has been released and is now on pypi. For newton, g-r and u-c have been set to v2.2.0
18:25:48 <amrith> just wanted to pass that word along to all.
18:26:02 <amrith> For newton, we'll be using at least 2.2.0 for the client
18:26:21 <amrith> currently we're enforcing upper-constraints.txt so it'll 2.2.0 for now
18:26:31 <amrith> anyone have questions about this?
18:27:23 <amrith> ok, moving along
18:27:27 <amrith> #topic Proposals for review
18:27:40 <amrith> I have two proposals that I'd like to put to the meeting and discuss today
18:27:56 <amrith> I propose that changes from the proposal bot (requirements, translations) can be approved on master by a single +2
18:28:16 <amrith> I believe that these are (at this point) purely procedural
18:28:16 <dougshelley66> +1 makes sense to me
18:28:24 <pmalik> +1
18:28:26 <amrith> and some of them have been hanging out for a while
18:28:42 <johnma> +1, I agree
18:28:46 <amrith> so, I'd like to put this to a vote ... but before I do that, I'd like to know if anyone objects.
18:28:46 <SlickNik> ++
18:29:32 <amrith> hearing no objections ...
18:29:34 <peterstac> +1, but I don't think the bot reviews was ever much of a problem ...
18:29:38 <amrith> #agreed that changes from the proposal bot (requirements, translations) can be approved on master by a single +2
18:29:58 <amrith> Ok, on to the next one.
18:29:59 <amrith> I propose that we approve https://review.openstack.org/#/c/304030/
18:29:59 <amrith> This change would make python34 a gating job
18:30:37 <tosky> does it require a vote? Wasn't it part of the spec, which was approved time ago?
18:30:44 <haypo> +1 it's part the (approved) python3 blueprint https://blueprints.launchpad.net/trove/+spec/trove-python3 ;)
18:31:20 <haypo> tosky: i would also prefer to avoid having meetings and use the regular reviews on gerrit ;)
18:31:55 <SlickNik> +1 on the python34 gating job
18:31:56 <amrith> does anyone object to this change being merged?
18:31:57 <haypo> but i understood that amrith wanted to "warn" all dev that py3 is serisouly becoming "mandatory" for new changes
18:32:08 <amrith> at this time ...
18:32:10 <dougshelley66> sounds like the right thing to do - guess we just need reviews on the project-config change
18:32:16 <amrith> I'm sure we have to do python3 before long
18:32:30 <haypo> amrith: i'm available for any question specific to python3 ;)
18:32:35 <amrith> but ... I wanted to make sure everyone knew and we had a chance to discuss and decide it quickly.
18:32:46 <haypo> i mean, if some dev start to have py3 questions for new changes
18:32:49 <amrith> haypo, tosky decisions in a review can take much longer (if there is contention)
18:33:08 <peterstac> right now, only specific tests are run in the job, so the risks are low
18:33:15 <amrith> ok, hearing no objectons
18:33:18 <pmalik> +1
18:33:23 <cp16net> i made it
18:33:23 <johnma> +1
18:33:25 <amrith> #agreed that we agree to https://review.openstack.org/#/c/304030/
18:33:31 <vkmc> +1
18:33:42 <haypo> i just removed the WIP status of https://review.openstack.org/#/c/304030/ -- go there to put your +1 ;-) andreas already voted +2
18:34:36 <amrith> haypo, done
18:34:47 <amrith> #topic Clearing up the review backlog
18:34:55 <haypo> amrith: thx ;)
18:34:56 <amrith> we started talking about this already (earlier)
18:35:05 <amrith> and now we have some action items that I'll follow up on
18:37:07 <peterstac> I think the reno addition to troveclient is good to go
18:37:12 <peterstac> #link https://review.openstack.org/#/c/301894/
18:40:02 <pmackinn> oops
18:40:08 <tosky> netsplit :/
18:40:30 <tosky> the openstack bot seems to be here
18:40:53 <dougshelley66> i think we lost our PTL...
18:41:16 <tellesnobrega> indeed
18:41:39 <vkmc> seems so
18:41:54 <dougshelley66> amrith is telling me what to type...
18:42:04 <pmackinn> you puppet
18:42:04 <dougshelley66> anyone have any project updates?
18:42:10 <vkmc> do not let the netsplit affect our meeting
18:42:20 <dougshelley66> pmackinn but i'm a really good puppet
18:42:35 <pmackinn> dougshelley66, no doubt!
18:43:04 <peterstac> dougshelley66, either he needs to speak faster or you need to type faster ... ;)
18:43:18 <pmackinn> SlickNik, any thoughts on those SuperConductor notes? am i way off base?
18:43:19 <dougshelley66> well, i'm waiting for project updates
18:43:20 <johnma> :)
18:44:01 <pmackinn> dougshelley66, image builder spec at patch set 6; assume it will land in top 10 list
18:44:03 <SlickNik> pmackinn: I had a chance to look over it — it seems pretty on point. I had a couple of minor notes that I'm in the process of writing up, will send it to you.
18:44:10 <dougshelley66> pmackinn thx
18:44:12 <amrith> #topic Ongoing review of projects.
18:44:17 <amrith> I'm back
18:44:18 <dougshelley66> HE'S BACK!
18:44:19 <amrith> ok ...
18:44:21 <pmackinn> dammit
18:44:26 <amrith> so I should add superconductor to the list
18:44:41 <amrith> #action [amrith] add superconductor to the list
18:44:46 <amrith> pmackinn, you have notes?
18:44:52 <amrith> great ...
18:44:54 <amrith> let's chat
18:44:59 <amrith> any word on trove image build?
18:45:19 <dougshelley66> <pmackinn>	dougshelley66, image builder spec at patch set 6; assume it will land in top 10 list
18:45:24 <haypo> for the "Port crypto_utils to Python 3" review, i suggest to wait until the 2 other python 3 changes are merged, and peterstac gives its feedback ;)
18:45:33 <pmackinn> amrith, just level setting with SlickNik on SC; he has some pending notes
18:46:00 <amrith> ok, anything new on CEPH? tellesnobrega is that still a project you'll be working on or should we strike it?
18:46:10 <amrith> #link https://review.openstack.org/#/c/256057/
18:46:22 <dougshelley66> I believe there is a BP/Spec for image upgrade now - the agenda can be updated
18:46:23 <amrith> vkmc, is sonali going to do the couchdb stuff or is she gone?
18:46:26 <tellesnobrega> amrith, nothing new on that now, but im still working on it
18:46:41 <vkmc> amrith, she is gone, I'll be taking where she left
18:46:42 <amrith> tellesnobrega, working on it <which>? CEPH or cinder snapshot?
18:47:04 <amrith> thanks vkmc
18:47:08 <vkmc> np
18:47:17 <tellesnobrega> amrith, im rushing to get cinder snapshot spec up this week, but I hope to get back to ceph soon, so we can discuss better in austin
18:47:27 <johnma> amrith, I am going to abandon the couchdb replication work for now.
18:47:37 <amrith> johnma, ok.
18:48:21 <amrith> we have a number of other projects including locality for cluster, couchbase clusters, upgrade (which now has a spec), postgresql replication and incr b&r, volume-type and datastore association, multi-region support and so on
18:48:31 <amrith> could everyone please take a look at these specs as a priority
18:48:43 <amrith> and make sure that you provide feedback tat you have as soon as possible and before summit
18:48:50 <amrith> so the conversations at summit can reflect that feedback.
18:49:10 <vkmc> +1
18:49:31 <amrith> I will include a list of specs in the email that follows this meeting
18:49:40 <amrith> #action amrith include list of reviews in meeting notes email
18:49:51 <amrith> any other updates on projects ...
18:49:52 <tellesnobrega> +1
18:50:25 <amrith> #topic Summit planning
18:50:35 <amrith> session list is now at http://bit.ly/trove-newton-design-summit
18:50:37 <amrith> #link http://bit.ly/trove-newton-design-summit
18:50:55 <amrith> please mark your calendars and update etherpads for sessions that you are leading
18:51:14 <amrith> SlickNik, amrith, dougshelley66 https://www.google.com/url?q=https://etherpad.openstack.org/p/trove-newton-summit-management-client&sa=D&ust=1460577036050000&usg=AFQjCNEbK_j9z1PYj5PovQ6EukcxNY_czg
18:51:29 <amrith> sorry, bad link https://etherpad.openstack.org/p/trove-newton-summit-management-client
18:51:31 <haypo> oh, i expected that we would discuss each "Ongoing review". anyway, my two python 3 patches are waiting for your review ;) https://review.openstack.org/279119 & https://review.openstack.org/298952 but there is no urgency ;)
18:51:41 <amrith> haypo, go ahead
18:52:16 <amrith> haypo, I'll look at those two reviews but it is also important that others in the trove team review them.
18:53:05 <amrith> anyone have anything to add about summit sessions ...
18:53:07 <haypo> amrith: i don't have anything to say about my changes, just review them ;) (if you have questions, ask them directly on the reviews)
18:53:23 <haypo> amrith: you asked me to talk about python3, but i don't see exactly what do you expect
18:53:44 <haypo> amrith: the plan is quite simple. pick an unit test, port it to py3, send a patch, wait for the review, then move to the next test ;)
18:54:10 <amrith> haypo, nothing specific now. at summit, I have the notes from Abhishek that I'll share with the team ahead of time
18:54:27 <haypo> amrith: do you have a specific question? the status is also quite simple: a few unit tests pass, we are at the beginning of the port (i would say a random 20%)
18:54:34 <amrith> there's nothing more that I'd expect in an update, just that if people have questions they'd know how to get in touch with you.
18:54:36 <haypo> amrith: ok, nice
18:54:54 <amrith> to be clear haypo ... python3 is a little different from the other projects.
18:55:02 <amrith> I think it is on a very clear path.
18:55:10 <amrith> and if people have questions they know to get in touch with you.
18:55:34 <haypo> ok, cool
18:55:52 <amrith> that's all I had for the meeting today
18:56:02 <amrith> but I want to leave time for any other things that people may want to talk about
18:56:07 <amrith> #topic open discussion
18:58:22 <amrith> anyone have anything to add?
18:58:51 <amrith> going once ...
18:59:22 <amrith> going twice ...
18:59:46 <amrith> #endmeeting