18:01:06 <amrith> #startmeeting trove
18:01:07 <openstack> Meeting started Wed Apr 20 18:01:06 2016 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:09 <peterstac> o/
18:01:11 <openstack> The meeting name has been set to 'trove'
18:01:13 <tellesnobrega> o/
18:01:16 <amrith> ./
18:01:24 <tosky> o/
18:01:27 <mvandijk> 0/
18:01:37 <dougshelley66> o/
18:01:44 <amrith> Agenda is at https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:01:44 <amrith> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:01:44 <amrith> Let's give folks a couple of minutes to come in
18:01:45 <twm2016> o/
18:03:08 <SlickNik> o/
18:03:15 <dloi> o/
18:03:16 <amrith> OK, let's get going
18:03:29 <amrith> hello everyone
18:03:30 <amrith> #topic Action Items from Last Meeting
18:03:31 <amrith> None outstanding
18:03:54 <amrith> I had taken one but I guess it didn't show up on the minutes last week. that was to send out a trove dashboard. I've done that.
18:03:59 * amrith runs to find a link
18:04:38 <amrith> #link http://openstack.markmail.org/thread/nw4a2mtcdwd2vxue
18:04:46 <amrith> has anyone tried this out?
18:04:54 <cp16net> ./
18:05:03 <cp16net> hello
18:05:08 <amrith> hello cp16net
18:05:14 <tellesnobrega> amrith, did, looks pretty good
18:05:20 <vgnbkr> o/
18:05:22 <amrith> thx tellesnobrega
18:05:35 <SlickNik> I tried it out as well — looks pretty good to me!
18:05:40 <tellesnobrega> at this point don't see anything missing on that
18:05:44 <SlickNik> Thanks Amrith!
18:05:47 <amrith> flaper87's not here. as I said in my email, thx to him for pointing me to the dashboard creator
18:06:03 <cp16net> i've made a dashboard before
18:06:11 <amrith> there were a couple of kinks as I went through and used it; the latest review as pushed into the repo looks stable to me.
18:06:13 <cp16net> its pretty awesome
18:06:26 <amrith> so I like a lot about it; there are things I DON'T like
18:06:30 <cp16net> a really long link
18:06:31 <amrith> I can't change the sort order
18:06:51 <amrith> well, the long link is easy to get around, since you generate it once and then put it in the settings so it is just a menu link to me
18:06:57 <amrith> see my email :)
18:07:04 <amrith> #link http://openstack.markmail.org/thread/nw4a2mtcdwd2vxue
18:07:06 <cp16net> yup
18:07:11 <pmalik> ./
18:07:13 <amrith> the sort order bugs me
18:07:20 <amrith> also, the foreach is a nusiance
18:07:25 <johnma> o/
18:07:25 <amrith> for me at least
18:07:29 <amrith> this is a trove dashboard
18:07:37 <amrith> so it makes sense to have a foreach that lists the trove projects
18:07:42 <amrith> but I watch about 23 projects all told
18:07:46 <amrith> so I can't have a single dashboard
18:07:51 <amrith> without having projects in each query
18:07:59 <amrith> which makes for a VERY VERY VERY long link
18:07:59 <amrith> :(
18:08:04 <amrith> other than that, great tool
18:08:18 <amrith> and more importantly we all now should have a single priroity list of reviews
18:08:40 <amrith> I suggest that we use this for a couple of weeks (say a month) and then revisit
18:08:42 <amrith> and improve
18:08:45 <amrith> thoughts?
18:08:47 <vkmc> o/
18:08:57 <tellesnobrega> +1 amrith
18:09:22 <johnma> amrith: I have been using it and I find it very useful to look at that list and prioritize. Thank you for putting it together
18:09:57 <SlickNik> Yeah, I remember I hit a 2083 URL char limit at some point because the URL was too long — so that's something to be aware of.
18:10:11 <amrith> thx johnma
18:10:16 <amrith> 2083 char limit eh?
18:10:20 <amrith> where?
18:10:30 <amrith> is that a gerrit-dash-creator limit or a gerrit UI limit?
18:10:33 <SlickNik> Yeah, it was on the client — I was using chrome.
18:10:59 <cp16net> lol
18:11:07 <johnma> I couldnt get the link you posted in the mail to work. So I just went to the gerrit-dashboard and got the link for Trove-Dashboard from there and used it in my settings. That worked
18:11:24 <amrith> so SlickNik I got around that by pushing it into my menu
18:11:28 <amrith> johnma, sorry about that
18:11:35 <amrith> you mean the link in the gist didn't work?
18:11:54 <amrith> I'll go and check that out.
18:11:56 <SlickNik> The link in the gist is well under 2083 chars, and is fine. :)
18:12:01 <johnma> oh ,no worries. Just wanted to bring it up in case someone else had a problem.
18:12:10 <johnma> right, the link in gist
18:12:21 <amrith> cool. so let's keep a list of things we'd like to see improved and revisit in a month
18:12:26 <tellesnobrega> the link worked nicely for me
18:12:28 <SlickNik> ++
18:12:35 <amrith> #action Amrith to add agenda item in a month to revisit this and iterate.
18:12:46 <johnma> could very much be something wrong on my side
18:12:46 <amrith> ok ... that's out of the way for now.
18:12:54 <amrith> #topic Trove Pulse Update
18:12:54 <amrith> #link http://bit.ly/1VQyg00
18:13:15 <amrith> Significant uptick since last week, great job folks. The number of changes merged was up, the number of open patches went down. All good trends. What do others think?
18:13:39 <johnma> good news
18:15:10 <cp16net> yeah i think there are still a few low hanging reviews that could make that better
18:15:20 <cp16net> but overall its great!
18:15:55 <amrith> yes, that's what I thought.
18:16:51 <amrith> anyone else have thoughts on the #'s
18:17:03 <amrith> #link https://gist.github.com/amrith/42a6772ff4ce22243381153596ef1a30
18:17:03 <amrith> Top reviewers for the past week. Thanks folks, let's keep the momentum going in the coming week
18:17:26 <amrith> last week we said we'd bring back the top-N list ...
18:17:29 <amrith> so there you have it.
18:18:10 <amrith> I'm still trying to get a good understanding of the disagreements numbers
18:18:13 <amrith> but, ...
18:18:41 <amrith> I think they say that Peter disagrees more than me. I don't know if that's good or bad.
18:18:44 <amrith> ;)
18:19:01 <amrith> johnma, I fixed the link in the gist; it should work now.
18:19:08 <dougshelley66> amrith don't know if it is good or bad but don't know if i believe it :)
18:19:29 <peterstac> I see the disagreements all at 0%, so I'm not sure how they're calculated
18:19:31 <amrith> well, I read the documentation and here's is what it said
18:19:42 <johnma> I think there was a discussion past week about what this topic - regarding disagreements
18:19:44 <amrith> "Disagreements is a reflection of how disagreeable the reviewer is".
18:19:54 <amrith> now I don't know whether more is better or less is better :)
18:20:03 <amrith> so is 100% disagreeable better or 80% ? :)
18:20:13 <amrith> seriously though, there was some chatter about this in the ML
18:20:19 <amrith> in the past two weeks
18:20:21 <johnma> I think it means, if someone +1/+2 a change and a core puts a -1 on it - thats a disagreement
18:20:25 <dougshelley66> it isn't better or worse - this is if you +1 a review and core -1s it
18:20:32 <dougshelley66> for example
18:20:32 <amrith> dims brought it up (thread was about gaming stackalytics)
18:20:51 <johnma> right
18:21:08 <cp16net> yeah johnma thats how i understand it
18:21:22 <cp16net> or the opposite case as well
18:21:23 <amrith> yeah, I dont know what that is good for :)
18:21:39 <amrith> I don't think core reviewers are "better" or "worse", just that they have the ability to +2 stuff.
18:21:42 <cp16net> maybe to see how negative someone can be?
18:21:45 <cp16net> j/k
18:22:08 <amrith> anyway
18:22:11 <amrith> good momemtun
18:22:15 <amrith> the number of reviews is up
18:22:22 <amrith> the number of patch sets is healthy
18:22:25 <amrith> new and merged
18:22:29 <amrith> nothing was abandoned
18:22:32 <amrith> all goodness
18:22:33 <amrith> Anyone have anything else to add on this topic?
18:23:00 <amrith> OK, chugging along.
18:23:01 <amrith> #topic announcements
18:23:01 <amrith> None that I know of
18:23:01 <amrith> Anyone have any?
18:23:01 <amrith> Babies, new pets, travel plans :)
18:23:14 <johnma> :)
18:23:19 <amrith> anyone going to this thing in Austin?
18:23:21 <amrith> next week?
18:23:40 <cp16net> i'm here
18:23:44 <johnma> +1
18:23:45 <cp16net> come join me
18:23:50 <cp16net> and johnma
18:24:08 <amrith> cp16net, I'll be there Sunday afternoon. have a couple of meetings Sunday, then the WOO thing that evening.
18:24:42 <cp16net> do you rsvps
18:24:49 <cp16net> your*
18:25:18 <amrith> ok, no announcements ...
18:25:30 <amrith> #topic Proposals for review
18:25:31 <amrith> I have none
18:25:36 <amrith> anyone else have any?
18:25:42 <pmalik> Hi.
18:25:42 <pmalik> I pushed a long-overdue patch to the cfg.py
18:25:42 <pmalik> I would just like to draw attention to it.
18:25:42 <pmalik> You can read the commit message and comment on the
18:25:43 <pmalik> review.
18:25:44 <pmalik> If we decide this is the way we want it it will just
18:25:45 <pmalik> have to go ASAP or it's going to stall forever in merge conflicts.
18:25:47 <pmalik> https://review.openstack.org/#/c/308126/
18:25:49 <pmalik> Thx.
18:26:14 <amrith> thanks pmalik I've starred it
18:26:24 <amrith> so it should popup on people's dashboards ...
18:26:28 <pmalik> thx :)
18:26:59 <amrith> back to the agenda ... anything in the form of a proposal that ppl want to put out there for review?
18:27:18 <amrith> ok, let's move along
18:27:24 <amrith> #topic update on projects
18:27:29 <amrith> pmackinn, yt?
18:27:49 <amrith> are you going to be pushing any code for the trove image build thing before summit?
18:28:12 <amrith> tellesnobrega, I've updated the session in the schedule, the etherpads and so on; now it is snapshot as a backup strategy
18:28:18 <amrith> I will update the agenda for next week
18:28:32 <amrith> as for the ceph spec, do you want to abandon it for now and revive it when you plan to work on it again?
18:28:35 <tellesnobrega> amrith, I saw that, thanks
18:28:45 <amrith> vkmc, any update on the sonali projects
18:28:53 <pmackinn> amrith, push where?
18:29:06 <vkmc> amrith, updated the spec yesterday, will update the code today
18:29:06 <tellesnobrega> amrith, I can do that, so it is not on the review list yes
18:29:09 * amrith resists the urge to fall for that :)
18:29:20 <amrith> pmackinn, I was wondering if you would be putting up any code for review before summit
18:29:26 <amrith> the spec has been out there for a while
18:29:48 <amrith> I've stopped +1'ing it; I agree with the course in general but would like to see more details
18:30:09 <pmackinn> amrith, code required for the spec? talking about bash scripts and libguestfs cli
18:30:21 <amrith> yes, that kind of stuff
18:30:31 <amrith> so ...
18:30:40 <amrith> if you look at other specs, some have a full API definition
18:30:45 <amrith> or a detailed API specification
18:30:52 <amrith> or look at my spec https://review.openstack.org/302952
18:30:57 <pmackinn> amrith, what API applies here?
18:31:03 <amrith> I don't believe that it has enough information in it for a +2 in a review
18:31:18 <pmackinn> amrith, vkmc +2 it :-)
18:31:27 <amrith> it is an outline, a high level description, so I don't see anyone being willing to +2 it.
18:31:42 <amrith> pmackinn, I'm talking about the spec I put up for storage things
18:31:54 <amrith> I was wondering whether you'd be providing more details before summit
18:32:27 <vkmc> what kind of details are you expecting to see outlined in the spec amrith?
18:32:38 <pmackinn> amrith, you mean the trove image builder spec, right? i can or we could walk through it next week
18:32:48 <amrith> vkmc, not in the spec per se, but before we meet and discuss next week
18:33:03 <amrith> if there's more stuff one can read ahead of time, there's more value to the conversation there
18:33:13 <amrith> as it is, all I have been able to do is play with the tools
18:33:21 <amrith> and familiarize myself with what they can and cannot do
18:33:35 <amrith> and I modified some existing images using those tools (well, I've been doing that for some time)
18:33:38 <vkmc> this has been discussed during the on Tokyo summit and during the midcycle as well, I'm ok with discuss this on the Austin summit as well
18:34:00 <vkmc> but I don't see why nobody would be willing to +2 that spec
18:34:30 <amrith> Well, I'm not in a position to +2 it because I'm not sure what the end deliverable looks like
18:34:55 <amrith> let me ask you the question this way, is there enough detail in https://review.openstack.org/302952 for you to +2 it?
18:35:00 <vkmc> that is something that ends up being defined with the code, once the proposal has been merged
18:35:10 <pmackinn> amrith, ? what spec provides a full implementation in code for review?
18:35:13 <vkmc> last time I check that was the procedure we were following with the rest of the features we have in Trove
18:35:19 <amrith> pmackinn, not full code
18:35:39 <amrith> but sufficient detail on what the API would be, for example (we have more specs like that so I go back to that example).
18:35:59 <amrith> vkmc, what's that procedure? what we've always done that I can recall is that the code and the specs merge together.
18:36:01 <tosky> so the output of the command --help ?
18:36:35 <amrith> hard to say tosky because I don't know exactly what the shape of the things that will be delivered are.
18:36:49 <tosky> amrith: it's a tool, so a program
18:36:56 <amrith> anyway, let's discuss next week
18:37:35 <amrith> vkmc, I guess my question then is this; there are a number of specs out there, do you feel that we should be merging them before the code is written?
18:37:42 <amrith> I don't believe that we've done that before
18:37:47 <amrith> and I'm certainly not advocating that.
18:38:12 <vkmc> amrith, I don't think we should postpone merging an spec because the code is not there yet
18:38:36 <vkmc> amrith, more in the case of this feature in particular that is depending on the creation of a repository under Trove umbrella
18:38:55 <amrith> we can create the repository anytime we want
18:38:58 <vkmc> amrith, usually the process is blueprint registration -> spec -> code
18:39:01 <amrith> doesn't need a spec to merge for that
18:39:26 <amrith> SlickNik, cp16net you've been doing this longer than I have, what do you think?
18:39:30 <tellesnobrega> I believe merging spec than code is the common procedure on other projects
18:39:43 <tellesnobrega> then*
18:40:07 <cp16net> usually we approve the spec
18:40:10 <tellesnobrega> they don't need to coexist on the same time frame for the spec to be merged
18:40:23 <cp16net> that allows us to know what the impl will be
18:40:30 <johnma> amrith: it was my understanding that we can merge the spec before the code as long as everyone agrees with the details in the spec
18:40:38 <cp16net> and have the acceptance crtiera for it
18:40:57 <egafford> In Sahara, we do occasionally need to submit patches to modify existing specs when the impls have to deviate, but that's just an extra patch set.
18:41:02 <SlickNik> I don't think we need code for a spec to merge — we should be okay to merge the spec as long as the spec makes sense, and has sufficient detail regarding the design.
18:41:07 <vkmc> johnma++
18:41:59 <amrith> ok, so here's the list of specs out there now. https://review.openstack.org/#/q/project:openstack/trove-specs+status:open
18:42:08 <amrith> could we get reviews on them done
18:42:12 <amrith> and feedback provided
18:42:21 <amrith> and if you agree with the spec, put a +1 or +2 on it ...
18:42:33 <amrith> I currently see few specs that have this kind of review
18:42:59 <amrith> Take https://review.openstack.org/#/c/294213/
18:43:06 <amrith> well, maybe not that one
18:43:08 <amrith> it is WF-1
18:43:21 <amrith> https://review.openstack.org/302952
18:43:34 <amrith> could we get this reviewed and +1'ed if you agree?
18:44:11 <amrith> anyway, I think we've spent a lot of time on this, we can discuss next week in detail
18:44:27 <amrith> if the process we want to follow is that specs get merged ahead of the code, let's do that.
18:44:39 <mvandijk> amrith - what is that second spec about?
18:44:52 <amrith> click on it ...
18:44:54 <mvandijk> the commit message doesn't really say :)
18:45:43 <amrith> ok, if no one else has anything to add, let's discuss next week
18:46:01 <amrith> #topic Work on branches other than master
18:46:10 <amrith> There are a number of patches outstanding for Mitaka and Liberty
18:46:21 <amrith> if folks have cycles, I'd request you push up backports
18:46:38 <amrith> we've had some new folks (brandon is one) who have pushed up some of these
18:47:38 <amrith> Looking down the agenda, most of the rest of what we have is procedural. Please update your etherpads for summit.
18:47:48 <amrith> pmackinn, SlickNik we have one for superconductor that we should update
18:48:26 <pmackinn> amrith, SlickNik: i put what i could in that etherpad
18:48:30 <amrith> Also, at raleigh we had talk about the idea of multiple datastores with a single manager
18:48:41 <SlickNik> pmackinn: I still have the note  — I'll update the etherpad with them this afternoon.
18:48:48 <amrith> if you could look over that and make sure it reflects what we discussedin raleigh that'd be great.
18:48:54 <amrith> I've updated the etherpads I had.
18:49:10 <tellesnobrega> updating mine this afternoon as well
18:49:11 <amrith> SlickNik, you and I have a couple; mgmt API, openstack CLI, and so on
18:49:15 <amrith> thx tellesnobrega
18:49:22 <tellesnobrega> np
18:49:25 <amrith> maybe we can chat about that before next week
18:49:33 <amrith> so we have the requisite info in there.
18:49:34 <SlickNik> amrith: yes, I will spend some time this afternoon updating the etherpad.
18:50:16 <amrith> pmackinn, yours on images needs to be updated
18:50:22 <amrith> I see that flaper87 has done his
18:50:43 <amrith> dougshelley66, vgnbkr you have a couple
18:51:36 <amrith> unfortunately neither victor nor abhishek will be at summit so I'll post a quick update on python3
18:51:42 <amrith> we may not have a lot to discuss about that
18:51:53 <dougshelley66> guest instance upgrade is up in review - willl be on the docket for design summit
18:52:14 <amrith> mvandijk, peterstac, pmalik you have a couple of etherpads to update
18:52:19 <pmackinn> amrith, ack
18:52:41 <amrith> that's mostly all I had
18:52:48 <amrith> #topic Open Discussion
18:52:55 <dougshelley66> amrith - sorry, right the design summit etherpads, got it
18:54:28 <mvandijk> amrith: what etherpad sry?
18:54:50 <dougshelley66> mvandijk i'll fill you in
18:55:27 <twm2016> When the etherpads are complete, maybe they can be put on this page for others to easily view? https://wiki.openstack.org/wiki/Design_Summit/Newton/Etherpads#Trove
18:55:52 <twm2016> - if its design summit related.
18:56:18 <amrith> twm2016, doing it now
18:56:37 <amrith> done
18:56:38 <twm2016> awesome, thanks.
18:57:18 <pmackinn> newton sessions http://bit.ly/22Oklpy
18:58:28 <amrith> actually this may look better now
18:58:49 <amrith> anything else?
18:58:55 <amrith> 2m to go ...
18:59:45 <johnma> I am assuming Trove meeting is cancelled for next week
18:59:59 <amrith> yup
19:00:40 <amrith> going once
19:01:11 <amrith> Well, I guess we're out of time :)
19:01:13 <amrith> #endmeeting