18:00:20 <amrith> #startmeeting trove
18:00:21 <openstack> Meeting started Wed May 25 18:00:20 2016 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:25 <openstack> The meeting name has been set to 'trove'
18:00:43 <peterstac> o/
18:00:52 <amrith> hello peterstac
18:00:55 <tellesnobrega> o/
18:01:03 <amrith> hello tellesnobrega
18:01:48 <cp16net> howdy yall
18:01:56 <SlickNik> o/
18:01:59 <amrith> hello cp16net
18:02:05 <SlickNik> howdy cp16net
18:02:12 <amrith> hello SlickNik
18:02:27 * cp16net tips hat
18:02:30 <SlickNik> hi hi
18:02:43 <stewie925> hi amrith
18:02:53 <tellesnobrega> hi amrith
18:03:07 <amrith> hi stewie925
18:03:12 <dougshelley66> o/
18:03:15 <twm2016> o/
18:03:22 <amrith> hello dougshelley66 twm2016
18:03:30 <vgnbkr> o/
18:03:54 <amrith> hello vgnbkr
18:03:58 <amrith> let's get started
18:04:05 <amrith> #agenda https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:04:16 <amrith> #topic Action items from last week's meeting
18:04:30 <amrith> We had one last week, to review https://review.openstack.org/#/c/298994/5
18:04:39 <amrith> unfortunately, it remains undone
18:04:53 <amrith> #action [all] review https://review.openstack.org/#/c/298994/5
18:05:04 <amrith> nothing else from last week
18:05:43 <pmalik> ./
18:06:01 <amrith> anyone have anything else to add re: last weeks action items
18:06:07 <peterstac> amrith, 298994 merged
18:06:37 <amrith> good morning ... time to wake up
18:06:41 <amrith> what day is it today?
18:06:47 <amrith> sorry, not sure what I was looking at
18:07:04 <amrith> so it merged, great ...
18:07:13 <amrith> anything else to add re: action items
18:07:27 <amrith> #topic Trove pulse update
18:07:28 <peterstac> with the /5 on the end it takes you to a 'not current' page (something I don't really like about gerrit)
18:07:44 <amrith> aha, that's what it was
18:07:51 <amrith> ok, thanks for clearing that up
18:07:54 <amrith> #link http://bit.ly/1VQyg00
18:08:10 <amrith> #link https://gist.github.com/amrith/7d0f3122b0132d30f6a4fa912c1e9a31
18:08:30 <amrith> so, the momentum we had on reviews seemed to go away last week
18:08:45 <amrith> the queue dropped but that's largely because there were not many new changes
18:08:53 <amrith> (fewer)
18:09:10 <amrith> we have a number of open pages that could benefit from reviews
18:09:22 <amrith> One area to focus is specs
18:09:24 <amrith> #link https://review.openstack.org/#/q/project:openstack/trove-specs+NOT+label:Workflow%253C%253D-1++NOT+label:Verified%253C%253D-1%252Cjenkins+NOT+label:Code-Review%253C%253D-2+status:open++%28project:openstack/trove+OR+project:openstack/trove-integration+OR+project:openstack/trove-specs+OR+project:openstack/python-troveclient+OR+project:openstack/trove-dashboard%29
18:10:11 <amrith> anyone have anything to add on the subject of momentum, reviews,
18:10:43 <amrith> Ok, moving along
18:10:45 <amrith> #topic https://review.openstack.org/#/q/project:openstack/trove-specs+NOT+label:Workflow%253C%253D-1++NOT+label:Verified%253C%253D-1%252Cjenkins+NOT+label:Code-Review%253C%253D-2+status:open++%28project:openstack/trove+OR+project:openstack/trove-integration+OR+project:openstack/trove-specs+OR+project:openstack/python-troveclient+OR+project:openstack/trove-dashboard%29
18:10:51 <amrith> #topic Announcements
18:11:00 * amrith damn cut and paste gone wild
18:11:26 <amrith> reminder: we have a spec proposal deadline in a couple of weeks
18:11:28 <amrith> R-16
18:11:32 <amrith> June 13-17
18:11:47 <amrith> does anyone else have specs that you'll be submitting (not yet up for review)
18:12:52 <amrith> OK, next announcement
18:13:04 <amrith> Please take a look at the email about mentoring that hit the ML earlier today
18:13:10 <amrith> http://markmail.org/message/nec7ez6ocgjcjxxf
18:13:50 <amrith> That's all I had for announcements
18:13:56 <amrith> anyone else have anything?
18:15:15 <amrith> ok, moving along
18:15:22 <amrith> there's nothing else on the agenda
18:15:25 <amrith> so let's move to
18:15:29 <amrith> #topic open discussion
18:15:50 <amrith> stewie925, you had a question earlier
18:15:58 <amrith> was it about rebase?
18:16:19 <stewie925> hi amrith  - yes it is about rebase  - https://review.openstack.org/#/c/312611/5
18:16:43 <stewie925> patch 4 was a rebase showing dependencies to another gerrit
18:17:07 <stewie925> but when I submitted patch 5, it seems the dependency is gone
18:17:59 <amrith> stewie925, what do you mean by 'dependency to another gerrit'?
18:18:29 <amrith> I'm not seeing any dependencies called out in the commit message
18:19:07 <stewie925> if you look at patch 4  https://review.openstack.org/#/c/312611/4   it shows a parent id that points to a code fix in gerrit #308707
18:19:41 <amrith> I think that just lists related changes
18:19:54 <amrith> wait a second, you said parent id
18:20:14 <stewie925> yes parent id
18:20:26 <stewie925> pmalik helped me with it yesterday
18:20:54 <amrith> pmalik, yt?
18:21:29 <pmalik> yes
18:21:38 <stewie925> hi pmalik, I have made the mocking changes you suggested for the guest_id
18:21:48 <pmalik> I think you somehow detached yourself from the parent patch set. :/
18:22:08 <amrith> pmalik, is there a need for this change to be dependent on the other?
18:22:10 <pmalik> We can look at it offline.
18:22:18 <pmalik> Yes. It need it.
18:22:27 <pmalik> He needs to mock a config property.
18:22:29 <stewie925> yeah good idea, pmalik, thank you appreciate it
18:22:40 <amrith> ok, in that case the two of you can chat about it in #openstack-trove
18:22:46 <stewie925> thank you amrith
18:22:46 <amrith> anything else of open discussion
18:22:48 <SlickNik> Looks like there was a rebase that (maybe) got rid of the dependent change?
18:22:48 <amrith> ?
18:23:08 <SlickNik> Not from me.
18:23:17 <amrith> cp16net, anything?
18:23:21 <amrith> peterstac?
18:23:35 <amrith> vgnbkr, tellesnobrega, dougshelley66, pmalik anything to add?
18:23:39 <tellesnobrega> i have the cinder snapshot spec up for review, would be good to get some eyes there, as well as a API change patch, so we can agree on the structure, if you guys can take a look
18:23:54 <amrith> tellesnobrega, I have it on my list for today
18:23:55 <SlickNik> #link https://review.openstack.org/#/c/320512/
18:24:03 <tellesnobrega> amrith, awesome
18:24:13 <pmackinn> seeing some problems from the mysql systemd vendor packages; anyone else been down this path?
18:24:39 <cp16net> i could bring up when i thought about earlier
18:24:40 <amrith> what problem(s) pmackinn
18:25:34 <amrith> also, what vendor?
18:25:43 <pmackinn> mysqld seems to start up again in the prepare before the new conf has been set
18:25:43 <amrith> I know that I've had no trouble with the percona packages
18:25:57 <pmackinn> thus writing a new db to /var/lib/mysql
18:26:21 <pmackinn> but we've already copied the original to /mnt/volume/data
18:26:51 <amrith> don't you mount /mnt/volume/data to /var/lib/mysql
18:27:24 <pmackinn> that indeed happens
18:27:28 <cp16net> we copy it first tho
18:27:47 <cp16net> the database should be stopped at that point
18:27:51 <pmackinn> but before that mysqld runs again with datadir still at /var/lib/mysql
18:28:00 <cp16net> but if systemd magically starts it again
18:28:05 <pmackinn> hilarity ensues
18:28:21 <amrith> so is restart set in systemd?
18:28:34 <cp16net> might need to set a configuration to not auto restart?
18:28:35 <amrith> i.e. the watchman in systemd potentially treating it as a down mysql?
18:28:43 * amrith is guessing
18:28:47 <cp16net> sounds like it
18:29:05 <pmackinn> yes but if we've stopped via systemctl it shouldn't restart
18:29:16 <pmackinn> on its own
18:29:36 <amrith> and yet it is?
18:29:49 <pmackinn> trove is restarting it
18:29:55 <pmackinn> its in the logs
18:30:15 <pmackinn> percona btw
18:30:31 <pmackinn> anywho, will keep digging
18:30:33 <cp16net> this is before we mount the volume to /var/lib/mysql?
18:30:38 <cp16net> that shouldnt be the case
18:31:11 <pmackinn> after but before the tmp conf has come back in with datadir=/var/lib/mysql/data
18:31:31 <cp16net> oh...
18:31:42 <cp16net> i c now
18:33:13 <amrith> sounds bad, very bad
18:33:32 <pmackinn> makes me mad, very mad
18:33:38 <cp16net> https://github.com/openstack/trove/blob/master/trove/guestagent/datastore/mysql_common/manager.py#L229
18:33:49 <amrith> pmackinn, in that case it is a feature
18:34:25 * pmackinn can't wait for SUPERCONDUCTOR
18:34:41 <amrith> cp16net, the mount happens earlier https://github.com/openstack/trove/blob/master/trove/guestagent/datastore/mysql_common/manager.py#L218
18:34:56 <amrith> and the datadir is reset https://github.com/openstack/trove/blob/master/trove/guestagent/datastore/mysql_common/manager.py#L228
18:35:00 <cp16net> right but thats after the mount happened it restarts
18:35:06 <cp16net> without the updates configs
18:35:37 <cp16net> one way we could "fix" this is in the image set the mysql dir to /var/lib/mysql/data
18:36:01 <amrith> but wait, this works ...
18:36:10 <amrith> we set datadir
18:36:13 <amrith> that's the important part
18:36:18 <amrith> before restarting
18:36:23 <amrith> or I'm missing something
18:36:59 <pmackinn> i can assure you that it restarts with the old config
18:37:00 <cp16net> oh yeah i see what you mean
18:37:17 <pmackinn> old == original
18:37:26 <amrith> like coke
18:38:10 <pmackinn> baking /var/lib/mysql/data into the image CAN work but it leaves a mark
18:38:18 <cp16net> yeah
18:38:23 <pmackinn> /var/lib/mysql/data/data
18:38:51 <cp16net> app.set_data_dir(mount_point + '/data')
18:39:08 <cp16net> shoudl set the dir right before we start it again
18:39:27 <cp16net> any logs aroudn that?
18:39:41 <cp16net> might be helpful
18:39:47 <pmackinn> you and your logs...jas
18:40:13 <cp16net> anyways its something to look into
18:40:39 <pmackinn> meh, that instance is gone...i'll hit the channel up later
18:40:42 * amrith TIMECHECK
18:40:44 <cp16net> k
18:40:52 <amrith> so is this something we can pick up in #openstack-trove
18:41:00 <amrith> right after we adjourn here?
18:41:11 <pmackinn> thx all for the input!
18:41:19 <amrith> does anyone else have any other things for open discussion ...
18:41:32 <amrith> #action pmalik and stewie925 to look into the rebase issue
18:41:33 <cp16net> i could bring up what this lead me back to thinking about
18:41:50 <amrith> #action amrith pmackinn cp16net to see what this mysql issue is
18:41:54 <amrith> anything else?
18:42:19 <cp16net> so in pxc i had some weird issue that i hacked around
18:42:30 <cp16net> https://github.com/openstack/trove/blob/master/trove/guestagent/datastore/experimental/pxc/service.py#L70
18:42:30 <amrith> #action review https://review.openstack.org/#/c/320512/ ( tellesnobrega's spec on cinder snapshots )
18:43:00 <amrith> go ahead cp16net we have about 18m here before the bot kicks us out
18:43:04 <tellesnobrega> amrith, this one is not the spec, this is the API structure change
18:43:06 <amrith> we're done for the meeting it appears.
18:43:13 <cp16net> since we have never seen this issue with single instances and only in pxc cluster
18:43:24 <tellesnobrega> amrith, https://review.openstack.org/#/c/306620/ this one is the spec
18:43:44 <amrith> tellesnobrega, thanks for clarification
18:43:45 <amrith> yes
18:43:50 <tellesnobrega> np
18:44:23 <cp16net> my theory is maybe we cant set the admin password until the cluster has quarum
18:44:45 <cp16net> and the sync state is up.
18:45:11 <cp16net> wondered if working on maria clustering or others if anyone saw this same issue?
18:45:55 <pmackinn> cp16net, haven't seen that but sounds plausible
18:46:45 <cp16net> yeah because writes are not allowed until quarum is reached i believe
18:47:06 <cp16net> it was an idea i had after talking with pmackinn about his issue
18:47:23 <cp16net> i thought they might be related but it doesnt seem like it now
18:48:04 * pmackinn has pxc working with systemd btw, ugly but working
18:48:18 <cp16net> i just wanted to throw that idea out there and see if it sticks
18:48:29 <cp16net> thats all i had
18:48:38 <amrith> ok
18:48:54 <amrith> let's take our stuff and mosey over to #openstack-trove and continue there
18:48:58 <amrith> last call ...
18:49:05 <amrith> anybody have anything for the meeting?
18:49:14 <amrith> objections to #endmeeting speak now
18:49:47 <amrith> #endmeeting