18:00:09 <amrith> #startmeeting trove
18:00:10 <openstack> Meeting started Wed Jun  8 18:00:09 2016 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:14 <openstack> The meeting name has been set to 'trove'
18:01:27 <cp16net> hello
18:01:35 <amrith> hey craig
18:01:37 <peterstac-m> Hi
18:01:44 <amrith> was getting a bit lonely here
18:01:51 <amrith> hi peterstac-m
18:01:55 <amrith> what's the -m?
18:01:57 <dougshelley66> \_o_/
18:02:19 <peterstac-m> Mobile
18:02:22 <amrith> ah
18:03:14 <amrith> courtesy reminder for johnma, SlickNik
18:03:27 <SlickNik> o/
18:03:32 <pmalik> ?
18:03:37 <SlickNik> hey folks!
18:03:37 <pmalik> ?/
18:03:51 <amrith> let's get started; hi SlickNik
18:03:54 <amrith> we have a quorum
18:04:16 <amrith> I spoke with johnma this morning, she said she'd be here; maybe got tied up in something
18:04:23 <amrith> Here's the agenda
18:04:29 <amrith> #agenda https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:04:38 <amrith> #topic Action items from last week
18:04:43 <amrith> I don't have any
18:04:54 <amrith> We didn't have a meeting last week
18:05:02 <amrith> and the week before that we finished all our action items
18:05:10 <amrith> so unless someone else has something, ...
18:05:57 <amrith> moving on ...
18:06:00 <amrith> #topic Trove pulse update
18:06:08 <amrith> #link http://bit.ly/1VQyg00
18:06:51 <amrith> the pace has slowed a bit
18:07:10 <amrith> but we didn't get many new changes last week
18:07:18 <amrith> and the queue growth was small
18:07:28 <amrith> the backlog is, however, quite significant
18:08:13 <amrith> hmm, I forgot to fill some columns; I'll fix that later today
18:08:21 <amrith> the last 3 columns
18:09:26 <amrith> there ... fixed that
18:10:06 <amrith> also https://gist.github.com/amrith/3454ca929bf58d783e00c70746e7c5f0
18:10:29 <amrith> I fell a bit behind this week, have to pick up again this week
18:10:45 <amrith> anyone have anything else to add ...
18:11:18 <johnma> does the open reviews signify the backlog?
18:11:37 <amrith> looking
18:12:12 <amrith> it is column N
18:12:18 <amrith> which is the number of reviews in backlog
18:12:20 <amrith> johnma, yes
18:12:50 <johnma> ok, thanks amrith. I need to pick up the pace as well. will do that
18:13:04 <amrith> thanks johnma we all have to
18:13:18 <SlickNik> ++ Looks like we all need to pick up the pace on reviews. :)
18:13:24 <amrith> yup
18:13:36 <amrith> so, with that
18:13:42 <amrith> moving on to
18:13:46 <amrith> #topic Announcements
18:14:02 <amrith> So, the first is something that isn't on the agenda.
18:14:11 <amrith> Last week (June 2nd I believe)
18:14:17 <amrith> was the deadline for Newton 1 release
18:14:21 <amrith> it is a drop for a beta
18:14:26 <amrith> I missed that drop
18:14:56 <amrith> i misread the email from dhellmann and interpreted the text in the release schedule page to imply that we could release it with our proposed freeze of specs
18:14:58 <amrith> apparently not
18:15:13 <amrith> So, I will keep a closer eye on that and make sure we do the newton b2 drop
18:15:33 <amrith> we are a release:cycle-with-milestones project
18:15:39 <amrith> and should've done a June 2 drop
18:15:46 <amrith> anyway, newton-2 is July 12-14
18:15:50 <amrith> I'll make sure to do that
18:16:06 <amrith> The other is something that I did put on the agenda
18:16:22 <amrith> Jun 13-17, R-16 is the trove spec proposal deadline
18:16:35 <amrith> that's next week
18:16:46 <amrith> this is the proposal deadline, not the review and close deadline
18:16:47 <SlickNik> #link http://releases.openstack.org/newton/schedule.html
18:16:52 <amrith> thanks SlickNik
18:16:54 <amrith> should've done that
18:17:07 <amrith> I'm refering to http://releases.openstack.org/newton/schedule.html#n-trove-spec-prop
18:17:27 <amrith> and the one after that is R-12 which has
18:17:34 <amrith> #link http://releases.openstack.org/newton/schedule.html#n-2
18:17:41 <amrith> #link http://releases.openstack.org/newton/schedule.html#n-trove-spec-freeze
18:17:56 <amrith> is there anyone who has to still put in a spec for something?
18:18:08 <johnma> I have 2 specs amrith
18:18:21 <johnma> 1 will go in today
18:18:31 <amrith> thx johnma what are these for?
18:18:48 <johnma> both are pretty straight forward - db2 online backups & configuration management
18:18:56 <amrith> cool, thanks!
18:19:10 <johnma> I may/ may not do one for couchdb clustering - 2.0 has been released which has clustering support
18:19:18 <johnma> but 2 for sure
18:19:33 <amrith> ok, thanks.
18:19:35 <amrith> anyone else?
18:19:59 <SlickNik> Nothing else from my side.
18:20:16 <cp16net> nope
18:20:29 <amrith> before moving on to the next thing; I'll assume that everyone saw the email from vkmc yesterday.
18:20:31 <amrith> #link http://markmail.org/thread/ddobuj25eitqweyq
18:20:50 <amrith> we should therefore figure out what we want to do with RPC API Versioning
18:21:09 <amrith> as the upgrade issue(s) are something that would be good to deal with
18:22:07 <amrith> thx SlickNik cp16net
18:22:18 <amrith> dougshelley66, peterstac-m any other specs that you know of that are still to come?
18:22:51 <amrith> I'd like to propose that at next week's meeting we try and get a firm handle on the actual things we feel we can get into Newton
18:23:03 <amrith> factoring new features + bug fixes + backlog
18:23:25 <amrith> so could everyone please think about that and be prepared to discuss at next weeks meeting
18:23:39 <amrith> #action prepare for next weeks meeting; things that we can get into Newton
18:25:18 <johnma> will do
18:25:21 <amrith> ok, I'll follow up with both of them offline
18:25:38 <peterstac-m> I don't think I have anything else
18:26:02 <peterstac-m> amrith ^^^  specs that is
18:26:15 <amrith> ok
18:26:15 <amrith> thx
18:26:27 <amrith> so, moving along (unless anyone else has other announcements)
18:26:53 <cp16net> vkmc: thanks for your contributions to trove :)
18:27:10 <pmackinn> +1
18:27:42 <amrith> #topic open discussion
18:27:44 <johnma> ++a big thanks to vkmc
18:28:19 <SlickNik> vkmc — it's been a pleasure and an honor! We will miss you :)
18:29:05 <cp16net> amrith: i have a small comment about the utc timezone patch you have
18:29:07 <peterstac-m> vkmc Yes, thanks!!
18:29:36 <amrith> cp16net, go ahead
18:29:52 * amrith hands baton to cp16net
18:30:20 <cp16net> i just want to make sure you and others know why we use the 'Z' at the end of the times in the api responses
18:30:23 <amrith> and yes, thanks vkmc for your contribution to trove
18:30:39 <dougshelley66> ha
18:30:46 <dougshelley66> sorry
18:30:48 <amrith> the Z
18:31:08 <dougshelley66> i meant to say - what is the issue with the "Z"
18:31:09 <cp16net> this was a requirement that horizon needed to make sure to have a standard time format so that it could display these times
18:31:21 <amrith> yes I think it would be good for everyone to understand that
18:31:33 <amrith> Z is Zulu time
18:31:42 <amrith> and when referencing times UTC
18:31:43 <dougshelley66> right so that is being deprecated?
18:31:51 <amrith> it is often the case that you refer to it as
18:32:01 <cp16net> zulu/gmt/any other strange name you want to call the +/-0 timezone
18:32:03 <amrith> YYYY-MM-DDTHH:MM:SS+00:00
18:32:16 <amrith> or YYYY-MM-DDTHH:MM:SSZ
18:32:23 <amrith> Z is ~ +00:00
18:32:33 <amrith> Z ~ +00
18:32:42 <amrith> it is NOT the same as GMT
18:32:44 <cp16net> i wasnt sure from reading over the change if that was removed or now
18:32:48 <cp16net> s/now/not/
18:32:50 <amrith> GMT has a daylight savings adjustment
18:32:57 <amrith> UTC and Z do not
18:33:09 <cp16net> amrith: oh i didnt realize that.. but that makes sense.
18:33:12 <amrith> So strictly speaking, GMT (Greenwich Mean Time) does have a DST
18:34:04 <cp16net> amrith: so you werent changing that in the patch right?
18:34:06 <amrith> so Historically, pre 1972, GMT had no DST
18:34:28 <amrith> After 1972, GMT ~ does have a daylight savings adjustment and UTC does not
18:34:35 <amrith> TO answer your specific question cp16net
18:34:38 <amrith> YES, I retain the Z
18:34:59 <cp16net> i assume if the example generating tests are still running then it would not be affected :)
18:35:09 <amrith> See: https://review.openstack.org/#/c/326655/2/trove/common/timeutils.py
18:35:11 <cp16net> ok
18:35:11 <amrith> line 79
18:35:20 <amrith> Yes, the example tests work
18:35:29 <amrith> also there are new unit tests proposed that ensure taht we retain the Z
18:35:38 <amrith> See: https://review.openstack.org/#/c/326655/2/trove/tests/unittests/common/test_timeutils.py
18:36:10 <cp16net> k
18:36:12 <cp16net> sounds good
18:36:18 <cp16net> thats the only comment i wanted to make
18:36:25 <amrith> cp16net, would you like me to add a clarification about that?
18:38:34 <amrith> cp16net, ^^
18:39:01 <cp16net> i dont think so
18:39:14 <cp16net> unless you think it warrants a clarifications
18:39:20 <amrith> ok, does it look good otherwise?
18:39:52 <cp16net> i just remember discussions that required the Z at the end wanted to share that info
18:39:56 <cp16net> i think so
18:40:35 <amrith> I have to rebase anyway (there's now a merge conflict) so I'll add a blurb about it in the commit message and near the new code.
18:40:38 <amrith> thx cp16net
18:40:45 <cp16net> np
18:41:20 <amrith> SlickNik, did you see the comments from kevinfox re: ssh and superconductor?
18:42:33 <SlickNik> I saw that he had replied, but haven't had a chance to look into it as yet.
18:42:57 <SlickNik> Actually looking into it as we speak :)
18:43:41 <amrith> maybe we can discuss later
18:44:52 <amrith> that's all I had for the meeting
18:44:58 <amrith> anyone have anything else ...
18:47:21 <amrith> ... a motion to adjourn? ...
18:47:38 <johnma> I think so
18:47:45 <amrith> #endmeeting