18:00:04 <amrith> #startmeeting trove
18:00:05 <openstack> Meeting started Wed Jul 13 18:00:04 2016 UTC and is due to finish in 60 minutes. The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:08 <openstack> The meeting name has been set to 'trove'
18:00:51 <mvandijk> ./
18:01:01 <aliadil> ./
18:01:01 <amrith> hi matt
18:01:26 <schang> o/
18:01:39 <amrith> hi ali, simon
18:01:51 <amrith> lets give folks a couple of minutes to trickle in
18:01:57 <peterstac> o/
18:02:56 <amrith> hi peter
18:02:59 <johnma> hello
18:03:01 <amrith> let's get started
18:03:03 <amrith> hi mariam
18:03:11 <johnma> hi amrith
18:03:20 <amrith> #agenda https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:03:34 <pmalik> 😝/
18:03:38 <amrith> #topic Action items from last week's meeting
18:03:55 <amrith> all three of them are for me, I've started on them but have not been able to finish them
18:04:03 <amrith> will get them done by next week
18:04:08 <amrith> hi pmalik
18:04:26 <amrith> as for the redis scenario tests, they seem to fail sporadically
18:04:30 <amrith> could not find a specific pattern.
18:04:39 <amrith> so:
18:04:42 <amrith> #action [amrith] review logstash to see how the redis scenario tests perform
18:04:58 <amrith> as for 237710, I think a reasoable solution has been proposed
18:05:15 <amrith> SlickNik, are you around
18:05:20 <amrith> would you be able to take a look at it
18:05:32 <pmalik> amrith I don't remember seeing redis failing. :/
18:05:41 <amrith> #action merge https://review.openstack.org/#/c/237710/
18:05:51 <amrith> pmalik, that's why I still have this on my list
18:05:57 <peterstac> yeah, I thought that redis was fairly stable - do you have a link for that?
18:06:02 <amrith> I will get more details before next week
18:06:09 <amrith> peterstac, it is a logstash query
18:06:15 <amrith> have to figure out how to get you a link for that
18:06:23 <amrith> hence the 'next week'
18:06:40 <amrith> finally, I sent a question to infra about the machines; have to follow up and get details
18:06:48 <amrith> so
18:06:51 <amrith> #action [amrith] review what kind(s) of machines we get in the gate and see if we can get some more beefy horses ...
18:07:06 <amrith> peterstac, pmalik I'll get details about redis to you
18:07:13 <peterstac> ok, thx
18:07:30 <amrith> or go to logstash, it is not the easiest interface but you get used to it
18:07:50 <amrith> and if you want you can take the action item :)
18:07:58 <amrith> I won't resist
18:08:23 <peterstac> do you have a link to the changeset where redis was failing?
18:08:42 <amrith> not handy now
18:08:59 <peterstac> ok, I'll follow up with you (I can take that action if you like ;) )
18:09:23 <amrith> OK, moving along then
18:09:25 <amrith> #topic Trove pulse update
18:09:41 <amrith> #link http://bit.ly/1VQyg00
18:09:48 <amrith> #link https://gist.github.com/amrith/0a1acb6de826d6ca2b21b92323bd7db9
18:10:11 <amrith> I think last week was a little light on reviews, have to (and I have to as well) pick up the pace a bit
18:10:14 <amrith> the backlog is building
18:10:30 <amrith> peterstac, I spoke briefly with pmackinn this morning
18:10:43 <amrith> he has pushed up a new change set for the trove-integration fedora/centos elements
18:11:06 <amrith> you'd asked some quesitons about that if I recall correctly
18:11:11 <amrith> or maybe it was someone else
18:11:24 <peterstac> I had some questions, but they were minor
18:11:39 <amrith> fyi: there are a lot of changes currently waiting for submitter
18:11:56 <amrith> so if you have reviews out there please take a look and make sure that they are not in need of tlc
18:12:22 <amrith> any questions, thoughts, comments ...
18:12:59 <amrith> ok ...
18:13:06 <amrith> #topic Call for topics for mid-cycle
18:13:14 <amrith> recall that this is a virtual mid-cycle
18:13:20 <amrith> thanks johnma for the topic re: tempest
18:13:43 <johnma> np
18:13:43 <amrith> I want to also add a couple of more to that list, but wanted to quickly start the conversation here.
18:15:09 <amrith> topic #1 the first was around grenade testing
18:15:30 <amrith> has anyone taken a look at this recently?
18:16:36 <amrith> topic #2 do we have any straggler oslo-incubator code hanging around in trove?
18:16:47 <amrith> and can we get a plan together to get rid of it
18:17:34 <amrith> does anyone have any thoughts about these?
18:17:45 <amrith> I've just added them to the agenda now
18:18:09 <amrith> anyone have anything else to add?
18:19:01 <amrith> also re: midcycle, I've contacted masaki and kengo (they came to the mid-cycle in Raleigh) and asked if they had any topics they'd like discussed at the mid-cycle. we may have to pick some sessions at a time that work for them.
18:20:06 <amrith> is there anybody out there?
18:20:18 <trevormc> hi amrith :)
18:20:36 <amrith> hi trevormc ... looks like everyone else left.
18:21:00 * georgelorch waves across the smoke filled room at amrith
18:21:11 <trevormc> Sorry for being late, I just got back from a town hall with John Donovan.
18:21:11 <amrith> hi george
18:22:24 <amrith> well mvandijk schang aliadil peterstac johnma trevormc pmalik ... is there anything else to add? are we done here?
18:23:16 <amrith> well, I guess not.
18:23:21 <johnma> amrith: I am wondering whether we want to also include status of python 3.4 work
18:23:24 <peterstac> I'll give it some thought
18:24:26 <peterstac> johnma, that's probably a good one. It looks to me as if switching the tests to run in parallel doesn't work so well for 3.4
18:24:47 <peterstac> Might be worth a discussion
18:25:53 <amrith> ok, would one of you add it to the list then plz
18:26:08 <johnma> sure
18:26:21 <amrith> Anything else re: mid cycle or should we move along
18:28:58 <amrith> OK, if there's nothing else, we should likely just move to open discussion
18:29:01 <amrith> #topic open discussion
18:29:05 <pmalik> 😶/
18:29:12 <pmalik> Just wanted to draw attention to this because it has been breaking our (non-voting)
18:29:12 <pmalik> tests.
18:29:13 <pmalik> Change I65e8a8d5dc251a8b00529cdfb1a6ada3d5720f68 has switched from MySQL-python to PyMySQL.
18:29:13 <pmalik> This change surfaced an issue in the current implementation of configuration groups.
18:29:13 <pmalik> The issue occurs on configuration detach and is currently reproduced in MySQL scenario tests
18:29:14 <pmalik> (old API tests only detach non-dynamic configuration and hence don't uncover the issue).
18:29:15 <pmalik> This happens because we convert all template values get converted to strings.
18:29:17 <pmalik> MySQL does not accept string values for numeric variables. The old
18:29:19 <pmalik> client library had a way around it.
18:29:21 <pmalik> I pushed up a patch set to the ini codec to preserve types.
18:29:23 <pmalik> https://review.openstack.org/#/c/338662/
18:30:58 <johnma> will look at it pmalik
18:31:17 <trevormc> Hey that's cool, I'll look at it later :) What was the client library way around it?
18:32:20 <peterstac> pmalik, I'll take a look as well
18:32:21 <pmalik> I guess they just converted the types at runtime (I verified the issue goes away when the change is reverted).
18:33:21 <amrith> cool, anything else ...
18:33:27 <johnma> amrith: is the spec approval deadline tomorrow?
18:33:32 <amrith> I'll let y'all read through the agenda thing about the mascot
18:33:37 <amrith> and the spec approval deadline
18:33:43 <johnma> right
18:33:46 <amrith> if there are specs that need to be approved; let's get that done
18:34:01 <peterstac> I put 4 links in the agenda
18:34:15 <peterstac> not to say that those are the only specs that people want in ...
18:34:39 <peterstac> maybe others can add to that if they still have ones outstanding they'd like to see make it into newton
18:35:04 <trevormc> I really like how openstack is making all projects have mascots. Great discussions take place on that topic.
18:35:56 <amrith> johnma, any specs to add to the list that peterstac put in the agenda?
18:37:00 <johnma> mine is in that list. so I think I am good from that perspective. Apart from that, I would like to help complete the one related to CouchDB configuration groups
18:37:10 <johnma> but that spec is already approved
18:37:19 <peterstac> Also, I added a couple links to reviews I'd like to see go in this week (they're from the last set, but didn't make it due to forced rebases)
18:37:57 <johnma> will go through them peterstac
18:38:11 <peterstac> johnma, great, thx!
18:38:32 <amrith> anybody have ideas about the mascot ...
18:38:56 <trevormc> I was going to add an idea to the etherpad for next week
18:39:13 <amrith> ok, we'll take a vote next week and send in the top 3 or so to the foundation.
18:39:59 <amrith> anyone have other things to discuss
18:40:04 <amrith> ...
18:40:14 <peterstac> we've been talking about some ideas in our office - if we come up with anything concrete we'll post it on the wiki :)
18:40:26 <trevormc> I had a question about the config option for a list of udp and tcp ports we use for our datastores.
18:40:42 <trevormc> Take a look at this patch I uploaded to oslo https://review.openstack.org/#/c/339787/
18:41:15 <amrith> thx peterstac
18:41:26 <trevormc> I got a review to suggest about separating port ranges with '..' instead of '-' is there a preference?
18:43:30 <amrith> trevormc, the general convetion has been either '-' or ':' for a range of ports. never seen '..'.
18:44:21 <amrith> iptables uses a list delimited by ',' where each element is either an integer or a range, and a range is integer:bigger-integer
18:44:22 <trevormc> amrith, the '..' is based on the python convention in lists already. Ok, I just want to make sure what I submit to oslo can still be used to fix improve port option validation.
18:45:08 <amrith> ok
18:45:48 <amrith> anyone want to discuss anything else (either on the agenda or otherwise) ... speak now.
18:46:07 <amrith> or till next week ...
18:46:39 <peterstac> I don't have anything else .
18:46:40 <amrith> going once
18:46:48 <amrith> has everyone got their summit talks in?
18:46:59 <amrith> deadline is today, yes?
18:47:05 <peterstac> I believe so, yes
18:47:06 <johnma> yes that deadline is tonight
18:47:21 <amrith> "The Call for Presentations deadline is July 13 at 11:59pm PT / July 14 6:59 UTC."
18:47:38 <amrith> So you have about 12 hours.
18:48:14 <amrith> ok, going twice ...
18:48:47 <amrith> please review/approve all specs by end of week. that's the deadline.
18:48:50 <amrith> #endmeeting