18:00:46 <amrith> #startmeeting trove
18:00:46 <openstack> Meeting started Wed Aug 10 18:00:46 2016 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:51 <openstack> The meeting name has been set to 'trove'
18:00:53 <amrith> ./
18:00:55 <peterstac> \o/
18:01:01 <aliadil> o/
18:01:28 <amrith> should be a quick meeting, I think
18:01:29 <amrith> #agenda https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:01:37 <amrith> let's give folks a couple of minutes to come in
18:01:49 <pmalik> 😜/
18:02:00 <mvandijk> ./
18:02:01 <schang> o/
18:03:34 <amrith> courtesy ping for dougshelley66 johnma cp16net slicknik
18:03:40 <amrith> let's get started
18:03:50 <amrith> #topic Action items from last week's meeting
18:04:03 <amrith> the only outstanding one is ongoing, I'm working on it.
18:04:17 <amrith> but from the mid-cycle, I took some notes
18:04:25 <amrith> and converted them into action items
18:04:35 <amrith> peterstac,  What's the status of adding the additional scenario tests to the gate?
18:04:35 <amrith> What's the status of flipping the existing (mysql and redis) to voting in the gate?
18:05:09 <amrith> peterstac ^^
18:05:16 <peterstac> I unabandoned the changeset last night and it already merged
18:05:28 <amrith> ok, cool
18:05:29 <peterstac> so they're now voting/run in the gate
18:05:43 <amrith> what about additional tests?
18:05:51 <peterstac> unfortunately due to changes in the requests module that means the gate is now broken :(
18:06:07 <peterstac> pmalik has a fix for it though
18:06:16 <pmalik> #link https://review.openstack.org/#/c/353625/
18:06:52 <peterstac> I was thinking of making MariaDB, PostgreSQL and possible PXC as new non-voting scenario jobs
18:07:24 <peterstac> (also setting up the remaining ones under 'check experimental' if they're not there yet)
18:07:29 <amrith> ok, so as soon as pmalik's change passes the CI, we should try and get it merged?
18:07:32 <peterstac> any objections to that?
18:07:45 <pmalik> Cassandra should be ok as well, but it may have higher HW requirements. We may still want to make it experimental (and maybe the others as well so that we can run it).
18:07:46 <amrith> no objections to that from me.
18:07:47 <peterstac> amrith, yes - it'
18:07:52 <peterstac> s a pretty simple fix
18:08:11 <pmalik> i.e. everything other than Vertica and DB2
18:08:24 <pmalik> Those need to have a 3rd party package...
18:08:40 <peterstac> pmalik, right - DB2 and Vertica would require 3rd party CI's
18:09:22 <amrith> #action peterstac to propose changes to add non-voting jobs for mariadb, postgresql, pxc, and cassandra
18:09:48 <amrith> ok, next item on the list
18:09:50 <amrith> Is someone able to take a look at the python35 job and why it is failing?
18:09:52 <pmalik> Amrith: Any change we can get say extra 4GB on gate RAME?
18:09:54 <pmalik> RAM
18:10:04 <amrith> pmalik, am working on it
18:10:09 <pmalik> We could probably safely trade it for 4 vCPUs...
18:10:20 <peterstac> amrith, I'll take a look at the py35 failure
18:10:28 <pmalik> Current machines seem to have 8CPUs +8GB RAM
18:10:43 <amrith> #action amrith to see if we can get (specifically) 4gb machines on the gate
18:10:52 <amrith> #action peterstack to review py35 failure
18:11:16 <amrith> finally, any word on the templest plugin issue? johnma's fix went in but apparently something broke again
18:11:19 <pmalik> We could probably even trade for py27 CPUs
18:11:49 <pmalik> We don't really need more than 1CPU and say 4GB for unittests...
18:12:53 <amrith> any word on the tempest plugin ...
18:13:04 <amrith> pmalik, would you like to work with infra about it
18:13:11 <amrith> i'm happy to pass it along to you
18:14:06 <pmalik> I can email with them. Do we have any particular contact to them?
18:14:41 <amrith> #openstack-infra is a good starting point
18:14:49 <peterstac> johnma was going to find out more info on the tempest job - but I don't see her here
18:15:14 <amrith> peterstac, yes, I pinged her ahead of the meeting but have not heard back.
18:15:19 <amrith> will check with her.
18:15:32 <peterstac> I'd be good if we could get that working
18:15:36 <amrith> #undo
18:15:37 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7f5bc0869510>
18:15:41 <amrith> #undo
18:15:42 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7f5bc06f8210>
18:16:00 <amrith> #action pmalik to work with infra to see if we can get different machines for gate
18:16:07 <amrith> #action peterstack to review py35 failure
18:16:23 <amrith> ok, anything else
18:16:25 <amrith> ?
18:18:42 <amrith> #topic #action peterstack to review py35 failure
18:19:01 <amrith> #topic Trove pulse update
18:19:17 <amrith> I've updated the numbers on the table
18:20:23 <amrith> some movement over the past couple of days, but we could always use more
18:21:04 <amrith> I have nothing significant to add to this, if anyone does ...
18:21:34 <peterstac> nope - looks like a light week
18:22:02 <amrith> yes, a somewhat light week
18:23:25 <amrith> anything else?
18:24:17 <peterstac> nothing here
18:24:48 <amrith> #topic Reviews that can be merged
18:25:03 <amrith> This (in the agenda) is a list of reviews, that I believe can be merged.
18:25:15 <amrith> peterstac, I removed #noqa change from that list
18:25:28 <peterstac> ah, good - thx
18:25:54 <peterstac> I've looked at a couple from the list, will get to the rest today/tomorrow
18:25:55 <amrith> I didn't notice that it was a quoted string
18:26:31 <amrith> and unless something negative shows up, I'll plan on merging those Friday
18:28:04 <amrith> ok ...
18:28:17 <amrith> #topic Reviews that will be abandoned
18:28:45 <amrith> Similarly, a list of reviews that will be abandoned by end of the week if I don't see any action. I see that some have already been abandoned.
18:29:07 <amrith> If you want that the change not be abandoned, then identify that it is still actively being worked, or that you will be taking ownership for the change.
18:31:03 <amrith> anyone have anything to add ...
18:31:32 <amrith> #topic Discuss review 352355
18:31:35 <amrith> #link https://review.openstack.org/#/c/352355/
18:31:39 <amrith> I'd wanted to discuss this
18:31:45 <ShaikApsar_> amrith: https://review.openstack.org/#/c/340022/ is also need to review
18:31:53 <amrith> and see if anytone had comments or thoughts about it
18:32:22 <amrith> peterstac, have you had a chance to look at the latest version of this change for u-c
18:32:43 <amrith> I'm not able to find a good way to test it other than to merge it and then test a trove change with some requirements change.
18:33:12 <peterstac> I'm ok with that
18:33:16 <amrith> the trove change would cause a clone of trove-integration with this new code and hopefully we'll get a proper test with u-c being reflected in both the controller and the guest.
18:33:39 <peterstac> did you still want the 'pip freeze' messages in it?
18:33:49 <amrith> yes, I did want that for the following reason(s).
18:34:07 <amrith> assume that something doesn't work now, we don't easily know what version(s) were running in the guest.
18:34:13 <amrith> and I think that in general this is a good to have.
18:34:25 <peterstac> sure, sounds reasonable
18:34:28 <amrith> I found it useful while seeing what the CI was doing with this change
18:34:33 <amrith> so I'm inclined to leave it in.
18:34:44 <amrith> but if there's a better way to handle it, I'm all ears.
18:35:10 <peterstac> nope - gave it a +2
18:35:54 <amrith> ok, I'll wait a respectable amount of time and then if no one else objects, I'll merge it.
18:36:07 <amrith> #topic Open Discussion
18:36:18 <amrith> ShaikApsar_, wants to discuss  https://review.openstack.org/#/c/340022/
18:36:22 <amrith> go ahead ShaikApsar_
18:36:27 <amrith> the floor is yours
18:37:19 <ShaikApsar_> amrith: this change to fix the issue with publish_quota_notifications in taskmanager
18:37:58 <ShaikApsar_> amrith: eariler the code is trying to get tenant list from novaclient
18:38:57 <amrith> that's fine, I'm not sure why that should fail.
18:39:12 <ShaikApsar_> that was wrong and i have made changes to use keystoneclient to get the tenant list and i don;t see any error, 'Fix for 'Client' object has no attribute 'tenants''
18:39:22 <amrith> why is it wrong?
18:39:36 <amrith> is nova_client.tenants.list() not a valid API call?
18:39:48 <ShaikApsar_> amrith: i don;t think we can get tenant list from nova api
18:41:09 <amrith> so this would never have worked?
18:42:30 <ShaikApsar_> amrith: I'm not sure that eariler results
18:42:49 <ShaikApsar_> amrith: I don;t see any thing above tenant action in nova https://github.com/openstack/python-novaclient/blob/master/novaclient/v2/client.py
18:43:39 <ShaikApsar_> amrith: https://github.com/openstack/python-novaclient/tree/master/novaclient/v2   don;t have tenant specific actions
18:44:52 <amrith> ok, I will review it.
18:45:12 <amrith> anybody have any other questions for ShaikApsar_
18:45:19 <ShaikApsar_> amrith: thank you amrith
18:46:13 <amrith> anyone have anything else for the meeting?
18:46:17 <amrith> going once
18:46:59 <amrith> going twice
18:47:28 <amrith> #endmeeting