18:02:54 <amrith> #startmeeting trove
18:02:55 <openstack> Meeting started Wed Aug 17 18:02:54 2016 UTC and is due to finish in 60 minutes. The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:58 <openstack> The meeting name has been set to 'trove'
18:03:09 <peterstac> o/
18:03:09 <johnma> o/
18:03:14 <amrith> sorry I'm late folks
18:03:23 <amrith> thanks for the reminder peterstac
18:03:29 <peterstac> np ;)
18:03:39 <amrith> #agenda https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:03:49 <trevormc> o/
18:03:55 <spilla> o/
18:03:57 <vgnbkr> o/
18:05:14 <amrith> having issues with agenda, one second
18:05:26 <pmalik> 😏/
18:05:54 <mvandijk> ./
18:06:07 <amrith> ok, sorry for that, just had a quick update to the agenda
18:06:14 <amrith> and had to reconcile mine with Peter's recent edit
18:06:18 <amrith> #topic Action Items
18:06:33 <amrith> peterstac, yours was "peterstac to propose changes to add non-voting jobs for mariadb, postgresql, pxc, and cassandra"
18:06:38 <amrith> I think that's been proposed, yes?
18:06:52 <peterstac> yes, but it's just sitting there
18:07:01 <peterstac> I may have to poke someone in infra
18:07:14 <amrith> they are a bit busy today
18:07:26 <amrith> lots of stuff seems to have started to let out magic smoke
18:08:02 <amrith> you can ping them.
18:08:13 <amrith> pmalik had "pmalik to work with infra to see if we can get different machines for gate"
18:08:21 <amrith> pmalik ... have you?
18:08:53 <amrith> let's skip over that one if pmalik isn't around
18:08:56 <amrith> peterstac, "peterstac to review py35 failure"
18:09:11 <pmalik> I am waiting for the above patch set to merge first to have something in hand before going to them.
18:09:28 <amrith> ok
18:09:32 <peterstac> I haven't have much time to look at that (py35) - I'll see if I can get to it this week
18:09:42 <amrith> #action peterstac to review py35 failure
18:09:48 <amrith> #action pmalik to work with infra to see if we can get different machines for gate
18:10:06 <amrith> #action amrith and peterstac to ping infra re: https://review.openstack.org/#/c/354881/3
18:10:16 <amrith> sounds good
18:10:18 <amrith> #topic Trove pulse update
18:10:24 <amrith> I've updated the numbers
18:10:34 <amrith> still a backlog but the cleanup from last week helped a bit.
18:10:40 <amrith> #link https://docs.google.com/spreadsheets/d/1vJxNaoR3VVNS1Cpiz7U--1zyJRZ6ybMxzJoayrjdduo/edit#gid=1104331956
18:11:11 <amrith> we've seen a spurt of new patches (#noqa, ...)
18:11:20 <amrith> over the past couple of days.
18:11:31 <amrith> that's skewing the numbers a bit.
18:11:48 <amrith> to those who've not had a chance to do any reviews
18:11:50 <amrith> #link https://gist.github.com/anonymous/1513fafa647403c9d8d494d2c42ac57f
18:11:58 <amrith> the help would be appreciated ...
18:12:23 <amrith> anyone have anything to add?
18:13:42 <trevormc> We should be seeing a new type from oslo soon that we can use to validate our tcp/udp lists in cfg.py :)
18:13:54 <amrith> #topic Newton release schedule
18:14:13 <amrith> hi trevormc
18:14:18 <amrith> go ahead
18:14:19 <mvandijk> we dont use oslo's tip though do we?
18:14:34 <mvandijk> we would only see that next release
18:14:44 <mvandijk> or am I mistaken... (amrith, you should know this)
18:14:48 <amrith> could we hold that conversation till open discussion please ...
18:15:02 <amrith> #link http://releases.openstack.org/newton/schedule.html
18:15:06 <amrith> I will be marking a test client branch tomorrow, and once next week. The absolute deadline for all client changes is week R-5. After that, no new features, no bug fixes till AFTER Newton is cut. So it is important that ALL changes that must go into python-troveclient make it by Wednesday of week R-5. The release team wants clients tagged by Thursday.
18:15:13 <amrith> everybody OK with this ...
18:15:23 <amrith> well, there's not a lot I can do if you aren't ok with it.
18:15:56 <peterstac> I've put a list of all the client changes that I think still need to go in
18:16:07 <peterstac> If anyone wants to add to the list, feel free
18:16:15 <peterstac> (it's in the agenda)
18:16:16 <amrith> #topic Client reviews that need to be merged
18:16:23 <amrith> good introduction to that topic
18:16:26 <amrith> peterstac, all yours ...
18:16:29 <peterstac> and there we are :D
18:17:20 <peterstac> Those six reviews are ones that I found that I think need to go into Newton
18:17:58 <peterstac> I didn't add the one for backup scheduling, but it should probably be there too
18:20:05 <peterstac> A couple of them still need some TLC, but I'd be good if we could get them reviewed before Friday in case they need tweaking
18:20:22 <johnma> sure, will help with reviews
18:20:23 <peterstac> (for example release notes)
18:20:32 <amrith> yup, will review today
18:21:36 <amrith> so there are some others on the list
18:21:48 <peterstac> I've put a note on the ones without release notes - will bug the authors to get those up today
18:21:53 <amrith> I assume we're not going to hold our breaths for https://review.openstack.org/356293
18:22:13 <amrith> I'll try and get to https://review.openstack.org/296667
18:22:19 <amrith> as soon as I finish api-ref
18:22:55 <peterstac> I'll add that to the list if you like amrith
18:23:09 <amrith> I'm hoping not
18:23:12 <amrith> let's focus on these ones
18:23:25 <peterstac> ok
18:23:28 <amrith> if we get the others to the point where we can get them working, let's add later
18:23:31 <amrith> if that works for all.
18:24:13 <peterstac> sure
18:24:20 <amrith> ok, ready to move on?
18:24:30 <peterstac> (I added sched backups to the list though, since it'd be good to have that in)
18:24:31 <amrith> johnma, ...
18:24:37 <amrith> ok, thx peterstac
18:24:39 <peterstac> yep, I'm good
18:24:40 <johnma> yes amrith
18:24:55 <amrith> #topic Open Discussion
18:24:58 <amrith> I had one on there
18:25:04 <amrith> and I know trevormc has something
18:25:11 <amrith> trevormc, go ahead
18:25:18 <trevormc> Hey sorry for speaking out of turn.
18:25:23 <amrith> no such thing :)
18:25:30 <trevormc> Range type is making good progress in oslo now
18:25:31 <trevormc> https://review.openstack.org/#/c/339787/
18:26:00 <amrith> so to mvandijk's question, yes
18:26:03 <amrith> once this merges in oslo
18:26:08 <trevormc> It's being co-authored by a core and it looks like it will be merged now. It converts integers like 1-8 to a python range(1, 8)
18:26:14 <amrith> it'll be the next release before we get to see this in the wild
18:26:25 <amrith> it'll be Ocata before we get to see this
18:26:30 <amrith> requirements are now frozen
18:26:56 <amrith> well, maybe not
18:27:03 <amrith> Final release for non client libs is R-6
18:27:13 <amrith> if oslo pulls this one out of a hat next week, it may make it to newton
18:27:25 <amrith> so trevormc did they give any indication when they'd merge this?
18:27:39 <trevormc> ahh ok, I'm not familiar with they're cycles. This is just an update because one of the bugs I'm working on is dependent on this.
18:28:08 <trevormc> As for when they will merge it, I said soon because of the activity from the core and a previous +2 I think they're just doing some finishing touches
18:28:20 <trevormc> so I really don't know exactly when
18:28:28 <amrith> I just asked harlowja on #openstack-oslo
18:28:45 <amrith> he's in this room as well, so if he sees this, he may respond here.
18:28:51 <amrith> anyway, good deal trevormc
18:28:54 <amrith> nice work!
18:29:05 <amrith> mvandijk, did that answer your question (at least in principle)
18:29:28 <amrith> I'll assume that this is a yes ...
18:29:30 <mvandijk> yes
18:29:38 <amrith> OK, I wanted to also bring up https://review.openstack.org/#/c/316381/
18:29:57 <amrith> and now https://review.openstack.org/#/c/356631/ which has replaced that one.
18:30:10 <amrith> finally got it patched to the point where the failing tests were all fixed
18:30:13 <amrith> but it is messy
18:30:21 <amrith> hence the respin https://review.openstack.org/#/c/356631/
18:30:28 <amrith> that one is a little cleaner
18:30:38 <amrith> but it just failed py27, have to see why. it'll be something silly.
18:30:46 <amrith> but we have to get this merged in the next couple of days.
18:30:55 <amrith> will need some help once the gate passes.
18:31:15 <amrith> that's all I had
18:31:28 <amrith> anyone have anything else they want to discuss ...
18:31:49 <peterstac> nothing from me
18:31:53 <amrith> trevormc, harlowja just said the change could merge (on #openstack-oslo)
18:31:58 <johnma> about the tempest tests
18:32:06 <amrith> johnma, yes please go ahead
18:32:11 <amrith> EmilienM, mentioned that
18:32:18 <amrith> and yes, I said I'd discuss at the meeting today
18:32:20 <amrith> he pushed up a change.
18:32:26 <johnma> sorry I was on vacation last week, so couldnt attend the meeting
18:32:38 <peterstac> #link https://review.openstack.org/#/c/356587/
18:32:47 <amrith> yup
18:32:50 <amrith> that one
18:32:54 <amrith> hope you had a good vacation
18:33:29 <EmilienM> hello !
18:33:31 <johnma> right, that one is different from why the gate-tempest-trove job is still failing
18:33:52 <EmilienM> we (puppet) are testing trove and our jobs are failing
18:34:10 <EmilienM> I think my patch might help though I haven't tested it yet, I'm working on it
18:35:18 <johnma> right. we need to update the devstak-gate.yaml and update the job definition to include the Trove tempest plugin is installed in the tempest venv. Matthew pointed me to how we could do this.
18:36:20 <johnma> so I am going to put out a patch for it today. its going to be a patch under openstack-infra, and not trove
18:37:57 <amrith> thx johnma
18:38:08 <johnma> so Emilien, the gate-tempest-dsvm-trove is not detecting any trove tests to run and looks like this is because the Trove tempest plugin is not getting installed in the tempest venv
18:38:30 <johnma> once thats fixed, along with Emilien's change all the tests should pass
18:38:37 <EmilienM> ok, puppet CI doesn't have the same error
18:38:45 <EmilienM> but yeah 2 changes are required I guess :)
18:39:34 <amrith> #action johnma to push infra change to enable tempest plugin install ...
18:39:43 <johnma> I will put out a patch today itself and we will try to get this resolved for you EmilienM.
18:39:56 <EmilienM> awesome thx folks
18:40:01 <johnma> right. Thanks for your patience EmilienM
18:40:19 <amrith> thx EmilienM
18:40:52 <amrith> anything else folks?
18:41:42 <amrith> going once ...
18:41:54 <amrith> going twice
18:42:04 <amrith> enjoy the extra 15m
18:42:06 <amrith> #endmeeting