18:00:27 <peterstac> #startmeeting Trove
18:00:28 <openstack> Meeting started Wed Aug 24 18:00:27 2016 UTC and is due to finish in 60 minutes.  The chair is peterstac. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:30 <mvandijk_> ./
18:00:31 <openstack> The meeting name has been set to 'trove'
18:00:38 <aliadil_> ./
18:01:00 <peterstac> #agenda https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:01:35 <peterstac> Waiting a bit for people to join ...
18:02:41 <peterstac> amrith and johnma both are unavailable, so we don't need to wait for them ;)
18:03:46 <vgnbkr> o/
18:04:08 <peterstac> ok, let's get started
18:04:27 <peterstac> There's not too much on the agenda so it may be a short meeting
18:05:19 <pmalik_> 😂/
18:05:27 <peterstac> #topic Action items from last week's meeting
18:05:45 <peterstac> First one: peterstac to review py35 failure
18:06:04 <peterstac> I pushed up a changereq that should get the py35 tests to pass
18:06:13 <peterstac> #link https://review.openstack.org/#/c/359446/
18:07:00 <peterstac> Turns out the tests were running the same command as the py27 tests (i.e. fake tests & generate_samples)
18:07:14 <peterstac> and these don't seem to work yet in python3
18:07:35 <peterstac> so for now I think we'll just have them run the same set as the py34 tests
18:08:28 <peterstac> I don't expect there to be too many comments on that - if so you can make them on the changereq :)
18:08:43 <peterstac> Next: pmalik to work with infra to see if we can get different machines for gate
18:08:56 <peterstac> pmalik_, floor is yours
18:10:29 <pmalik_> The current non-voting jobs seem to be ok. We will need to run check experimental first to see how we stand with resources.
18:11:14 <peterstac> so hold off on talking with infra right now?
18:11:56 <pmalik_> I think we should first try to make the new non-voting jobs passing. :/
18:12:40 <pmalik_> Yeah, I would say let's go to infra once we have concrete results (failures) in hand...
18:12:41 <peterstac> ok, so once they pass we can evaluate again if we need more resources
18:12:55 <peterstac> pass or fail :)
18:13:09 <peterstac> ok, sounds good
18:14:00 <peterstac> #action get new non-voting jobs to pass
18:14:18 <peterstac> Next: amrith and peterstac to ping infra re: https://review.openstack.org/#/c/354881
18:14:33 <peterstac> #link https://review.openstack.org/#/c/354881
18:14:59 <peterstac> That patchset merged this morning so we can now see the results for quite a few different datastores
18:15:44 <peterstac> mariadb, pxc and postgresql now run in the check (you'll need to run 'check experimental' to see the others)
18:16:10 <peterstac> Next: johnma to push infra change to enable tempest plugin install ...
18:16:23 <peterstac> She's not here, but the changereq is up
18:16:35 <peterstac> #link https://review.openstack.org/#/c/356999/
18:16:51 <peterstac> If people could review that, it'd be great
18:17:14 <peterstac> #topic Trove pulse update
18:17:29 <peterstac> #link https://docs.google.com/spreadsheets/d/1vJxNaoR3VVNS1Cpiz7U--1zyJRZ6ybMxzJoayrjdduo/edit?pref=2&pli=1#gid=1104331956
18:17:38 <peterstac> #link https://gist.github.com/anonymous/ac2e4a74aa53bc2b56719988d01e232d
18:18:45 <peterstac> looks like the stats are similar to last week
18:18:54 <peterstac> we could probably use some improvement there
18:19:21 <peterstac> and moving on ...
18:19:25 <peterstac> #topic Newton release schedule
18:19:39 <peterstac> #link https://releases.openstack.org/newton/schedule.html
18:19:58 <peterstac> any questions about the release schedule?
18:21:26 <peterstac> aliadil, dloi are there any dashboard pieces that need to get in this week?
18:21:45 <peterstac> (we have client and horizon freezes coming due this week)
18:22:22 <aliadil_> #link https://review.openstack.org/#/c/286159/
18:23:09 <peterstac> ok, maybe we can get some eyes on that?
18:24:16 * peterstac looks around to see if anyone's awake ;)
18:24:41 <peterstac> moving on then
18:24:44 <peterstac> #topic Client reviews that need to be merged
18:24:54 <peterstac> We also have client freeze coming up
18:25:20 <peterstac> There are 6 reviews that I'd like to merge by end-of-day today, if there are no objections
18:25:29 <peterstac> (see the agenda)
18:25:57 <peterstac> most already have 2 +2's
18:26:20 <peterstac> There's one more though that might warrant a bit of discussion
18:26:34 <peterstac> #link https://review.openstack.org/#/c/329160/
18:26:40 <peterstac> Implement scheduled backups
18:27:12 <peterstac> There seemed to be an issue with credentials when Mistral kicked off the backup
18:27:33 <peterstac> I tried running the mistral commands through their client and got the same results
18:27:54 <peterstac> so it almost looks as if there's a mistral bug
18:28:27 <peterstac> so the question is: do we merge the client piece and hope mistral fixes their end, or do we wait?
18:28:42 <peterstac> vgnbkr, do you have any opinion?
18:29:32 <vgnbkr> It worked for me when I did it, but that was a long time ago.  I'm looking into it now to see if I can reproduce your issue.
18:30:22 <peterstac> ok, maybe we'll follow that on the changereq then - we'll have to decide soon if we want it to ship in Newton though
18:31:02 <peterstac> any other people want to chime in?
18:31:27 <shaikapsar> Regarding backup mistral workflow
18:31:30 <peterstac> ok, moving on then
18:31:41 <peterstac> oops, go ahead shaikapsar
18:32:19 <shaikapsar> We are seeing authentication issue when we add workflow as cron job
18:32:51 <shaikapsar> We have bug for that and we are working on it
18:33:07 <peterstac> yeah, that's the same issue I saw (and reported on the changereq for trove sched backups)
18:33:16 <peterstac> so is that a mistral issue?
18:33:22 <shaikapsar> Yes
18:33:46 <shaikapsar> Let me share the bug id
18:34:04 <peterstac> ok, maybe going with option 'a' is ok then (merging the trove code and hoping that mistral gets fixed in time)
18:34:07 <peterstac> sure
18:35:18 <shaikapsar> bug/1607788
18:35:31 <shaikapsar> On mistral project
18:36:20 <peterstac> #link https://bugs.launchpad.net/mistral/+bug/1607788
18:36:20 <openstack> Launchpad bug 1607788 in Mistral "Cron Trigger failed to get openstack service authenticaton" [Undecided,New] - Assigned to Bhaskar Duvvuri (bhaskar-duvvuri)
18:37:11 <peterstac> any time frame on a potential fix?
18:37:20 <ApsarShaik> https://bugs.launchpad.net/mistral/+bug/1607788
18:37:20 <openstack> Launchpad bug 1607788 in Mistral "Cron Trigger failed to get openstack service authenticaton" [Undecided,New] - Assigned to Bhaskar Duvvuri (bhaskar-duvvuri)
18:37:32 <ApsarShaik> It will fail for all the openstack client api calls
18:37:53 <ApsarShaik> I will check with mistral team on that
18:38:15 <peterstac> ok thanks
18:38:40 <peterstac> #action ApsarShaik to follow up with mistral on bug/1607788
18:38:53 <peterstac> moving on then
18:39:02 <peterstac> #topic Other reviews that look to be ready to merge
18:39:33 <peterstac> There are a few reviews that I'd like to see merged by the end of the week
18:39:35 <ApsarShaik> please review the change https://review.openstack.org/#/c/340022/
18:40:29 <peterstac> ApsarShaik, is that part of the mistral fix?
18:41:09 <ApsarShaik> peterstac: No, It's trove related patch for "Client' object has no attribute 'tenants"
18:41:48 <peterstac> ah yes, I seem to recall this from last week
18:42:21 <peterstac> I'll see if I can get around to testing it this week
18:42:38 <ApsarShaik> peterstac: thanks
18:42:41 <peterstac> np
18:43:04 <peterstac> As for the ones on the agenda, most of them are fairly simple fixes that should be easy to review
18:44:09 <peterstac> #topic Open Discussion
18:44:20 <peterstac> anything else people would like to discuss?
18:45:29 <peterstac> The only thing I've got is that our feature freeze is next week so we'll have to move on that quickly once the client changes merge
18:46:18 <peterstac> I'll create an agenda item for next week's meeting where people can list the reviews that they think should still make it into Newton
18:46:36 <peterstac> (for example the server code for all the client changes :) )
18:46:54 <peterstac> anything else?
18:47:13 <peterstac> going once ...
18:47:25 <peterstac> going twice ...
18:47:33 <peterstac> Thanks everyone!
18:47:37 <peterstac> #endmeeting