18:00:28 <amrith> #startmeeting trove
18:00:28 <openstack> Meeting started Wed Oct  5 18:00:28 2016 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:31 <openstack> The meeting name has been set to 'trove'
18:00:56 <vgnbkr> o/
18:01:00 <aliadil_> o/
18:01:03 <amrith> anyone here for trove meeting say aye!
18:01:07 <amrith> hello vgnbkr aliadil_
18:01:22 <aliadil_> hi amrith
18:01:23 <spilla> o/
18:01:42 <amrith> hi spilla
18:01:49 <spilla> hi amrith
18:01:51 <amrith> lets give folks a couple of minutes
18:01:57 <amrith> this may be a short meeting
18:02:43 <peterstac> o/
18:02:49 <amrith> hi peter
18:02:59 <amrith> I don't have much for the meeting today
18:02:59 <peterstac> hi amrith
18:03:07 <amrith> there were no action items from last time
18:03:11 <johnma> hi amrith
18:03:13 <peterstac> that's ok by me :)
18:03:19 <amrith> #topic Newton release schedule
18:03:22 <amrith> hi johnma
18:03:30 <amrith> tomorrow the newton release will be cut
18:03:46 <amrith> there is one translation for dashboard that came in too late
18:03:52 <amrith> it'll make the next release for newton
18:04:03 <amrith> don't have anything further to add about that
18:04:37 <amrith> #topic Open Discussion
18:05:17 <amrith> an email went out to all PTL's asking to confirm whether our respective teams would participate in the PTG in Atlanta.
18:05:23 <amrith> I confirmed that Trove would attend.
18:05:35 <amrith> we now have an idea of the room allocations for Barcelona.
18:05:52 <amrith> #link https://docs.google.com/spreadsheets/d/1TQ-RSlbiBBEclkonIbfUP7R1ExZSJylF1uiEKV2G_Cw/pubhtml?gid=1107826458&single=true
18:06:04 <johnma> I was about to ask about barcelona summit. thanks amrith
18:06:05 <amrith> you'll see the rooms that we have ... (they are marked Trove)
18:07:21 <amrith> we need to make our schedule for the design session, I'll be working on that. An etherpad is at https://etherpad.openstack.org/p/trove-barcelona-design-summit-sessions
18:07:25 <amrith> please propose topics there.
18:07:53 <amrith> Some of us have presentations at Barcelona that we have to prepare for.
18:07:59 <amrith> I know that johnma and I have one
18:08:08 <amrith> dougshelley66 has some
18:08:12 <amrith> not sure who else
18:08:42 <amrith> That's about all I had for Open Discussion
18:09:02 <amrith> We have several large change sets that are still in need of reviews
18:09:14 <dougshelley66> Emily has a presentation
18:09:31 <amrith> I've been working on a couple; get rid of trove-integration and redstack, and one I've been workign with along with vgnbkr on API versioning.
18:09:42 <amrith> mvandijk_ has a couple
18:09:50 <amrith> vgnbkr has some specs that are in need of review
18:10:11 <johnma> I am testing Matt's changes and Petr's right now. hopefully will be done before end of day today
18:10:11 <amrith> thx dougshelley66 yes. forgot that one.
18:10:28 <johnma> Petr's related to postgresql
18:10:37 <amrith> johnma, thanks for the comments and change on trove-image-builder
18:10:51 <amrith> I'm trying to get the next one behind that (dsvm tests) and having some challenges.
18:12:19 <amrith> that's all I've got.
18:12:40 <trevormc> I remember discussion about this at the last summit but... what about supporting multiple versions of the same datastore? Running both mysql 5.5 and 5.6.
18:13:05 <trevormc> I think we concluded storing different versions of config for the different datastore would be a challenging task.
18:13:55 <amrith> trevormc, I don't know that anyone has signed up to do that (for ocata)
18:14:00 <amrith> I may be wrong
18:14:04 <amrith> but I don't think so
18:14:19 <amrith> dougshelley66, is that on your list?
18:14:36 <dougshelley66> amrith not presently
18:14:40 <amrith> thx
18:15:11 <amrith> #action [amrith] publish the ocata plan/list of things
18:15:21 <amrith> I have a list, I have to publish it ...
18:16:01 <amrith> trevormc, you'd asked earlier about projects to work on. here's one that has been around for a while and is in need of an owner.
18:16:04 <amrith> Get rid of schema downgrade code https://bugs.launchpad.net/trove/+bug/1434103
18:16:06 <openstack> Launchpad bug 1434103 in OpenStack DBaaS (Trove) "SQL schema downgrades are no longer supported" [Medium,Triaged] - Assigned to Nikhil Manchanda (slicknik)
18:16:29 <amrith> There has been discussion about this off and on, but we never did conclude one way or the other.
18:16:32 <amrith> that I can recall.
18:16:50 <amrith> Does anyone have strong objections to this project?
18:18:40 <trevormc> amrith: Ok I will work on getting rid of the schema downgrade code, seems like there are implementations I can use as a reference.
18:19:10 <amrith> yes
18:19:21 <amrith> peterstac, johnma, ... others ... OK with this?
18:19:54 <johnma> amrith: I am sorry but I got disconnected in between. So I missed the earlier messages
18:20:19 <amrith> >> trevormc, you'd asked earlier about projects to work on. here's one that has been around for a while and is in need of an owner.
18:20:24 <amrith> >> Get rid of schema downgrade code https://bugs.launchpad.net/trove/+bug/1434103
18:20:26 <openstack> Launchpad bug 1434103 in OpenStack DBaaS (Trove) "SQL schema downgrades are no longer supported" [Medium,Triaged] - Assigned to Trevor McCasland (twm2016)
18:20:34 <amrith> >> There has been discussion about this off and on, but we never did conclude one way or the other.
18:20:39 <amrith> >> that I can recall.
18:20:43 <amrith> >> Does anyone have strong objections to this project?
18:21:11 * amrith waits for johnma
18:21:55 <johnma> I am fine with trevormc looking at this.
18:21:59 <peterstac> I'm ok with that
18:22:28 <peterstac> Maybe it can be done in two steps - right now we have checks that insist there's a downgrade path
18:22:45 <peterstac> so even though we don't care any more, we still have to add it to new changes
18:23:02 <peterstac> maybe we can get rid of that first, and then rip out the rest?
18:23:44 <amrith> sounds good, thx peterstac, johnma.
18:23:59 <amrith> #action [trevormc] to look at Get rid of schema downgrade code https://bugs.launchpad.net/trove/+bug/1434103
18:24:00 <openstack> Launchpad bug 1434103 in OpenStack DBaaS (Trove) "SQL schema downgrades are no longer supported" [Medium,Triaged] - Assigned to Trevor McCasland (twm2016)
18:24:16 <amrith> There is one other review that may be worth talking about
18:24:18 <amrith> #link https://review.openstack.org/#/c/379317/
18:24:30 <amrith> This review tries to deal with hacking rule H301
18:24:34 <amrith> history:
18:24:53 <amrith> this was discussed a long time ago
18:25:03 <amrith> 2014-10-22 to be precise
18:25:12 <amrith> and the feeling then was overwhelmingly negative to the change
18:25:29 <amrith> 18:46:47 <openstack> Yes (3): AJaeger_, SushilKM_, SlickNik 18:46:48 <openstack> Indifferent (1): iccha1 18:46:49 <openstack> No (9): schang, tomblank, robertmyers, amrith, vgnbkr, amcrn, cp16net, grapex_, dougshelley66
18:25:37 <amrith> The cast of characters is now very different
18:25:48 <amrith> so I'd like to at least see what the sense of the team is
18:26:08 <amrith> The change would make many changes (as you can see from the review)
18:26:30 <amrith> and generally be a nusiance to merge as it juggles import lines
18:26:30 <peterstac> My only point would be if we decide to do it, it has to go in now
18:26:42 <peterstac> otherwise we'll spend too much time rebasing
18:26:48 <amrith> i agree
18:27:29 <amrith> i've seen the following here today, johnma peterstac vgnbkr spilla aliadil_ dougshelley66 trevormc
18:27:33 <amrith> what do y'all think?
18:27:52 <amrith> my vote is -1
18:28:21 <vgnbkr> Unless someone can explain to me how this would make the product more correct or easier to understand, let's concentrate on useful things.
18:28:35 <amrith> vgnbkr, that sounds like +1? :)
18:29:03 <trevormc> so +1 is yes and -1 is no?
18:29:17 <amrith> oh, ok.
18:29:22 <amrith> let's make this a regular vote
18:29:27 <vgnbkr> But what do yes and no mean?  The question was "what do you think"?
18:29:47 <trevormc> yes to merge no is not to merge
18:30:22 <vgnbkr> Then how would my comment above be taken as a yes/+1?
18:30:47 <trevormc> I like hacking rules so I would vote yes, but the importance is low so I move my vote to Indifferent. That's how I feel about it.
18:31:00 <amrith> #startvote Should we go ahead with this project of H301. Yes, No, Maybe
18:31:00 <openstack> Unable to parse vote topic and options.
18:31:16 <peterstac> I'm indifferent too (but I'm almost finished reviewing it nontheless)
18:31:23 <trevormc> #vote Maybe
18:31:37 <amrith> #startvote Should we go ahead with this project of H301 Yes, No, Maybe
18:31:38 <openstack> Unable to parse vote topic and options.
18:31:44 <peterstac> #vote maybe
18:31:54 <amrith> well, I can't seem to get the vote to work
18:32:01 <amrith> Should we go ahead with this project?
18:32:03 <amrith> Yes,
18:32:04 <amrith> No,
18:32:06 <amrith> Maybe?
18:32:19 <vgnbkr> No
18:32:37 <peterstac> Maybe
18:32:40 <amrith> amrith: no
18:32:43 <trevormc> Maybe
18:32:48 <johnma> No (I don't see any value)
18:34:43 <amrith> Ok, sounds like no one is saying Yes
18:35:12 <amrith> so I am inclined to say no
18:36:37 <amrith> #decided I will update the review and say we are not doing this.
18:37:15 <amrith> #agreed [amrith] update https://review.openstack.org/#/c/379317 with the decision to not take this change
18:37:57 <amrith> does anyone else have anything they'd like to discuss
18:38:51 <trevormc> I just wanted to bring attention to this review: https://review.openstack.org/#/c/340022/
18:38:58 <amrith> hearing none, ... time to adjourn?
18:39:31 <trevormc> this is someone from my org and he has asked for help getting this patch merged, I left a review and told him to add unit tests.
18:40:16 <amrith> it seems like it is marked with WF-1 now ...
18:40:48 <amrith> my concern with this change from the beginning was that the bug started to address one issue, then pivoted around and ended up somewhere totally different.
18:40:50 <peterstac> It's a lot of patchsets for a one-line commit message too
18:41:04 <trevormc> Yeah he needs to add the unit tests.. he also said he will update his commit message.
18:41:06 <amrith> and I have no idea what it is really intending to do
18:41:13 <amrith> that was one of my comments to him (or maybe more).
18:41:34 <trevormc> That's what i thought, if you have questions I can send them to him. Contacting him is tricky since he works in international times.
18:41:41 <amrith> see my comment August 26 at 1:15pm
18:42:01 <ShaikApsar> Hi
18:42:09 <trevormc> There he is!
18:42:10 <amrith> hi ShaikApsar
18:42:35 <amrith> and as peterstac says, a single line commit message leaves a lot to the reviewer to try and figure out
18:43:00 <ShaikApsar> i'm trying to to fix the  Client' object has no attribute 'tenants'
18:43:18 <ShaikApsar> i will update the commit with more details
18:44:06 <amrith> what would be great is to know how this impacts you, and what you have to do (or not do) to have this problem.
18:44:08 <ShaikApsar> amrith: you suggested few changes for the patch with respect context.auth_token
18:44:58 <trevormc> Amrith did you see my comment on the bug in launchpad? I had to enable the ceilometer plugin to get the error to appear.
18:46:04 <amrith> trevormc, no. I tuned out of this review a while ago with newton getting out of the door and it being clear that this wasn't in newton
18:48:15 <amrith> in any event ShaikApsar trevormc this review is now sitting with a WF-1. How about you respin it and then we see what it is about?
18:48:19 <amrith> does that make sense?
18:48:48 <ShaikApsar> yes
18:48:53 <amrith> ok, thx
18:48:57 <amrith> anything else ...
18:48:58 <trevormc> Yes amrith, just trying to get it on the radar again. I will be looking forward to the next patch.
18:49:17 <amrith> as soon as it has no WF -1's it will be on the radar ...
18:49:56 <amrith> motion to adjourn? ...
18:50:01 <amrith> ... anyone ...
18:50:31 <peterstac> seconded :)
18:50:36 <amrith> thanks peterstac
18:50:39 <amrith> #endmeeting