17:59:45 <amrith> #startmeeting trove
17:59:46 <openstack> Meeting started Wed Nov  2 17:59:45 2016 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:59:49 <openstack> The meeting name has been set to 'trove'
17:59:57 <amrith> anyone here for the trove meeting?
18:00:02 <spilla> o/
18:00:03 <aliadil> o/
18:00:13 <schang> o/
18:00:30 <amrith> hello ... let's give folks a couple of minutes to come on in
18:01:15 <peterstac> o/
18:01:27 <amrith> hi folks
18:01:37 <johnma> o/
18:02:20 <vgnbkr> o/
18:02:27 <mvandijk> ./
18:02:33 <amrith> let's get going
18:02:37 <amrith> we have a longish agenda
18:02:45 <amrith> #agenda https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:02:57 <amrith> #topic Update CONTRIBUTING.rst
18:03:06 <amrith> (yes, I skipped the review status)
18:03:21 <amrith> I'm updating the numbers in parallel and will get back to that.
18:04:22 <SlickNik> o/
18:04:28 <amrith> hi SlickNik
18:04:37 <amrith> so, one of the things from barcelona
18:04:39 <SlickNik> hi folks — sorry running a bit late this morning
18:04:47 <amrith> We had a discussion in Barcelona and I've summarized that as a change to CONTRIBUTING.rst. See https://review.openstack.org/#/c/392194/
18:05:04 <amrith> no worries SlickNik; i'm still running on barcelona time :) and I'm wondering why there's no wine.
18:05:14 <amrith> please take a minute to review https://review.openstack.org/#/c/392194/
18:05:47 <amrith> we've for a long time now been operating loosely on these principles
18:06:03 <amrith> but several projects are (like us) feeling the need to be more explicit about this.
18:06:16 <amrith> and I've proposed this language to contributing.rst as we discussed.
18:06:29 <amrith> I think the text is rather straightforward.
18:07:13 <amrith> but just in case anyone has concerns about it, let's discuss now.
18:08:15 <peterstac> WF+1'd, so I think we're good ;)
18:08:52 <amrith> thx peterstac
18:09:01 <SlickNik> Yes, it looks good to me — makes perfect sense.
18:09:09 <amrith> still, if there are concerns, we can always revisit.
18:09:27 <amrith> so without further ado, ... let's move to the previous item on the agenda
18:09:35 <amrith> #topic Review status
18:09:42 <amrith> #link https://docs.google.com/spreadsheets/d/1vJxNaoR3VVNS1Cpiz7U--1zyJRZ6ybMxzJoayrjdduo/edit?usp=sharing
18:10:19 <amrith> it is clear that we've had a steep decline in the #reviews
18:10:32 <amrith> and an increase in the number of outstanding change sets.
18:11:06 <amrith> we will have to do a couple of things. first, I've got to make sure I update these numbers weekly (working on automating that). the second is that we've all got to pick up the pace on reviews.
18:11:27 <amrith> nothing new or interesting here but I think the next two topics on the agenda may help.
18:12:20 <amrith> anyone have anything to add ...
18:12:51 <amrith> hearing none ...
18:12:53 <amrith> #topic Merge these changes as a priority
18:13:20 <amrith> OK, so this is one of two things that I'd like to start doing to help move things through in the areas that we have prioritized.
18:13:32 <amrith> each week, let's have a short list of things that we want to focus reviews on.
18:14:43 <amrith> in keeping with the projects that we thought we should get in for the ocata release, these are some of the reviews that we need to merge. some of them may have merged already, others may be on the way to merging (have already been verified). but this here is a starting point ... does anyone have questions about any of these, and how do we want to g about merging these
18:15:24 <amrith> 1 and 2 are already merged
18:15:41 <amrith> 7 is merged
18:15:58 <amrith> 8 is in merge conflict ... vgnbkr see https://review.openstack.org/#/c/382493
18:16:16 <amrith> the rest are in need of reviews
18:16:26 <vgnbkr> Yeah, F'ing jenkins.
18:17:25 <amrith> I updated the agenda
18:17:30 <amrith> please refresh your webpages
18:17:56 <amrith> the list now consists of the things that are in need of review (modulo the one that vgnbkr has merge conflicts on)
18:18:02 <SlickNik> The numbers correspond to the reviews here:
18:18:06 <SlickNik> #link https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:18:13 <amrith> yes
18:18:17 <amrith> now the reviews outstanding are:
18:18:25 <amrith> https://review.openstack.org/#/c/387528
18:18:29 <amrith> https://review.openstack.org/#/c/381241
18:18:34 <amrith> https://review.openstack.org/#/c/370971
18:18:39 <amrith> https://review.openstack.org/#/c/296667
18:18:44 <amrith> https://review.openstack.org/#/c/382493
18:18:49 <amrith> https://review.openstack.org/#/c/362338
18:18:54 <amrith> https://review.openstack.org/#/c/362341
18:18:58 <amrith> https://review.openstack.org/#/c/388100
18:19:10 <amrith> and here is what each of those is ...
18:19:11 <amrith> 387528 Change the way redstack figures the default network
18:19:11 <amrith> 381241 Fix RPC Versioning
18:19:11 <amrith> 370971 make trove-dashboard use upper-constraints
18:19:11 <amrith> 296667 Replace obsolete oslo-incubator apiclient
18:19:12 <amrith> 382493 Multi-Region Support (client side, server side has -1's not listed here)
18:19:13 <amrith> 362338 Cluster Upgrade (server side)
18:19:15 <amrith> 362341 Cluster Upgrade (client side)
18:19:17 <amrith> 388100 Guest-agent metadata (spec, code already proposed)
18:19:27 <amrith> We are required to finish 296667 for Ocata (goal across projects)
18:20:02 <amrith> the cluster upgrade and multi-region changes are things that we decided to do for Ocata (among other things)
18:20:30 <amrith> RPC versioning is going to be more important moving forward as we have upgrade now supported and may soon want to start actually versioning some of the API's
18:20:44 <amrith> 387528 is needed when we get to neutron (in the gate)
18:20:57 <amrith> though I just noticed that the description says redstack which is wrong
18:21:42 <johnma> for 296667, have we addressed the issues Ronald referred to in changeset 1?
18:22:26 <amrith> johnma, yes. I think they have to the best that we could
18:22:48 <johnma> ok sounds good.
18:22:53 <amrith> the common class approach that he refers to is something that must be done across projects and I've not seen anyone leap forward to do that.
18:23:04 <amrith> most people have taken the approach (an approach) similar to the one here.
18:23:18 <johnma> ok
18:23:29 <amrith> I think this is a stop-gap solution as we all think openstack client should be coming <cough><cough> soon
18:25:39 <amrith> any other thoughts on these ...
18:27:01 <peterstac> I'll see if I can take a look at it today ...
18:27:13 <amrith> thx peterstac
18:27:41 <SlickNik> I should be able to review quite a few of them today as well.
18:27:55 <SlickNik> Thanks for coming up with the list — this is helpful.
18:28:04 <amrith> np SlickNik
18:28:08 <amrith> I'm going to star them
18:28:14 <amrith> so it will pop up on the dashboard
18:29:06 <SlickNik> ++
18:29:19 <amrith> done
18:29:47 <SlickNik> I've edited the page to use ordered lists  — makes them a bit easier to talk about.
18:30:22 <amrith> cool thanks SlickNik
18:30:26 <amrith> yes, much better to read
18:30:46 <amrith> and for those who use the trove dashboard
18:30:55 <amrith> https://review.openstack.org/#/dashboard/?foreach=status%253Aopen++%2528project%253Aopenstack%252Ftrove+OR+project%253Aopenstack%252Ftrove%252Dintegration+OR+project%253Aopenstack%252Ftrove%252Dspecs+OR+project%253Aopenstack%252Fpython%252Dtroveclient+OR+project%253Aopenstack%252Ftrove%252Ddashboard%2529&title=Trove+Review+Dashboard&My+Patches+Requiring+Attention=owner%253Aself+%2528label%253AVerified%253C%253D%25
18:30:56 <amrith> 2D1%252Cjenkins+OR+label%253ACode%252DReview%253C%253D%252D1+OR+label%253AWorkflow%253C%253D%252D1+OR+NOT+is%253Amergeable%2529+%2528project%253Aopenstack%252Ftrove+OR+project%253Aopenstack%252Ftrove%252Dintegration+OR+project%253Aopenstack%252Ftrove%252Dspecs+OR+project%253Aopenstack%252Fpython%252Dtroveclient+OR+project%253Aopenstack%252Ftrove%252Ddashboard%2529&Patches+waiting+longer+than+14+days=label%253AVeri
18:30:57 <amrith> fied%253E%253D1%252Cjenkins+NOT+label%253AWorkflow%253C%253D%252D1+NOT+label%253ACode%252DReview%253C%253D%252D1+is%253Amergeable+age%253A14d&Patches+waiting+longer+than+7+days=label%253AVerified%253E%253D1%252Cjenkins+NOT+label%253AWorkflow%253C%253D%252D1+NOT+label%253ACode%252DReview%253C%253D%252D1+is%253Amergeable+age%253A7d+NOT+age%253A14d&Specs+requiring+review=project%253Aopenstack%252Ftrove%252Dspecs+NOT+
18:31:02 <amrith> label%253AWorkflow%253C%253D%252D1++NOT+label%253AVerified%253C%253D%252D1%252Cjenkins+NOT+label%253ACode%252DReview%253C%253D%252D2&Trove%253A+Priority+code+reviews=%2528starredby%253Aamrith+OR+starredby%253Aself%2529+%2528project%253Aopenstack%252Ftrove+OR+project%253Aopenstack%252Ftrove%252Dintegration%2529+NOT+label%253AWorkflow%253C%253D%252D1+is%253Amergeable+NOT+label%253AVerified%253C%253D%252D1%252Cjenkin
18:31:07 <amrith> s+NOT+label%253ACode%252DReview%253C%253D%252D2&Trove+Client+and+Dashboard%253A+Priority+code+reviews=%2528starredby%253Aamrith+OR+starredby%253Aself%2529+%2528project%253Aopenstack%252Fpython%252Dtroveclient+OR+project%253Aopenstack%252Ftrove%252Ddashboard%2529+NOT+label%253AWorkflow%253C%253D%252D1+is%253Amergeable++NOT+label%253AVerified%253C%253D%252D1%252Cjenkins+NOT+label%253ACode%252DReview%253C%253D%252D2&
18:31:12 <amrith> Changes+needing+Final+Approval=NOT+label%253AWorkflow%253E%253D1+NOT+label%253AWorkflow%253C%253D%252D1+label%253AVerified%253E%253D1%252Cjenkins+NOT+owner%253Aself+label%253ACode%252DReview%253E%253D2+NOT+label%253ACode%252DReview%252D1+is%253Amergeable&Changes+on+branches+other+than+master=NOT+branch%253Amaster&Needing+attention=%2528%2528%2528label%253AVerified%253C%253D%252D1%252Cjenkins%2529+NOT+label%253AWor
18:31:17 <amrith> kflow%253C%253D%252D1+NOT+label%253ACode%252DReview%253C%253D%252D2%2529+OR+NOT+is%253Amergeable%2529
18:31:20 <amrith> what a nice link :)
18:31:22 <amrith> there are two sections there
18:31:31 <amrith> trove priority code reviews and client and dashboard priority code reviews
18:31:44 <amrith> I'll work through some of them as well today
18:31:49 <amrith> hopefully we can get it done
18:31:58 <amrith> so unless there are other comments about this, ...
18:32:13 <amrith> #topic Abandon old reviews
18:32:20 <amrith> As we discussed at the work session, one of the things I want to do is abandon a number of old reviews that have not seen any action in weeks. If you would like any of these to be retained, please either be at the meeting, or update the agenda below. We will likely NOT go through each one at the meeting so updating the review will not suffice.
18:32:31 <amrith> Here's the list of reviews that I'm going to abandon
18:32:48 <amrith> 384298 Update .gitignore to ignore .idea of PyCharm
18:32:48 <amrith> 356270 trove-integration should use zuul user
18:32:48 <amrith> 347800 Reduce code duplication
18:32:48 <amrith> 367626 Handle Keystone V3 in module-list
18:32:48 <amrith> 373670 Updated the path of config files
18:32:49 <amrith> 353906 remove tenant_id from the injected guest_info file
18:32:50 <amrith> 347398 Reduce code duplication
18:32:52 <amrith> 370971 make trove-dashboard use upper-constraints
18:32:54 <amrith> 373236 Fix py34 jenkins gate errors
18:32:58 <amrith> 364608 Show flavor name instead of ID in show_instance
18:33:00 <amrith> 365412 Fix is_root_enabled to return True/False
18:33:02 <amrith> 369124 [install-guide]add Nova inject_partition configuration
18:33:04 <amrith> 356701 Create net/subnet for alt_demo tenant
18:33:06 <amrith> 303671 Make timeouts datastore specific
18:33:08 <amrith> 362416 [WIP] Cluster Upgrade for PXC
18:33:10 <amrith> 358693 Trove user page doesn't show allowed hosts AND databases
18:33:12 <amrith> 322826 Convert DIB elements from Fedora to CentOS7
18:33:14 <amrith> 288297 fix delete backup tenant_id error
18:33:16 <amrith> 315619 Superconductor Spec
18:33:18 <amrith> 348743 Add support for module ordering on apply
18:33:20 <amrith> 323590 Add support for Cassandra 2.2 and 3.x
18:33:22 <amrith> note that this list does NOT include #22 which trevormc clarified
18:33:24 <amrith> #337914 is pending waiting for a change to merge in oslo.
18:34:10 <amrith> so, if there are no concerns about these reviews, I intend to make them go away after this meeting with a message that they've been abandoned per discussion at the Trove meeting 11/2/2016 or something short like that
18:35:27 <mvandijk> wait
18:35:33 <mvandijk> you sue this is a good idea?
18:35:39 <spilla> Shortened the link: https://goo.gl/ytwZYL :)
18:35:42 <mvandijk> I see a number of them that aren't dead...
18:35:45 <mvandijk> just waiting for activity
18:36:27 <vgnbkr> 362416 is [WIP] because nobody is reviewing my other cluster upgrade changes.
18:38:32 <amrith> so how do we tell which is which?
18:38:53 <amrith> if you have reviews on the list that you'd like to not have abandoned, please update the list in the agenda with a note
18:38:58 <amrith> and I won't abandon those.
18:39:17 <amrith> or do you have a better solution to how we can get rid of the ones which are in fact dead, for all intents and purposes.
18:39:58 <SlickNik> Maybe we can put a note on the review this week. If folks reply to the note that they're still working on it, we keep the review. If there are no replies, we abandon the reviews next week.
18:40:07 <vgnbkr> Well as a first step, don't abandon things that are WIP without talking to the person.  Afterall, they're WIP.
18:40:37 <amrith> SlickNik, we talked about that some months ago and realized that putting that note in the review basically updated the review and it "appeared" active in the list :)
18:40:57 <amrith> hence the idea was to not update the reviews and instead discuss them at the meeting. not saying that's the best solution, just what we talked about.
18:41:47 <SlickNik> heh, yeah — we'd have to keep track of the reviews separately (like links off of that Meeting wiki) so we know which ones we're tracking (since we won't be able to use updated time as a metric for stale reviews anymore).
18:42:24 <amrith> vgnbkr, you are refering to 362416?
18:42:32 <vgnbkr> Yes
18:42:38 <vgnbkr> But in general, too.
18:43:26 <amrith> I don't know about the "in general" part. see https://review.openstack.org/373236
18:43:33 <amrith> what do you suggest?
18:43:42 <amrith> the thing has been comatose for a while
18:43:48 <vgnbkr> Somebody review the other changes that it is waiting on?
18:44:24 <amrith> yes, that's been the request all along. that people should review changes.
18:44:33 <amrith> but I'm asking about https://review.openstack.org/#/c/373236/
18:44:50 <amrith> what do you suggest? that we contact the submitter for this and each such thing with a WF-1?
18:47:22 <amrith> anyone have other ideas?
18:50:53 <amrith> .
18:51:03 <spilla> I like the idea of having the submitter respond
18:51:29 <spilla> But am trying to think of a way without updating the review that'll get their attention
18:51:58 <SlickNik> The only other way I can think of is emailing them, but that has a different set of disadvantages.
18:52:05 <amrith> mvandijk, which ones were you thinking were not really dead?
18:52:16 <mvandijk> the WIPs
18:52:19 <amrith> let's just take those off the list
18:52:25 <amrith> just take them off the list in the wiki
18:52:31 <amrith> I took vgnbkr's off
18:52:43 <amrith> I'm sure that there are plenty that aren't WIP
18:53:14 <mvandijk> ok, none of mine are on there so I can't really speak to the rest
18:53:28 <spilla> Could we flag the the with like [TBA] (to ba abandoned) to the review title and if no response to the review for 7 days they are abandoned
18:54:26 <SlickNik> ++ amrith: Let's do that — I'll make a separate list for the WIP ones on that page. And I'll track them and put a note in them. If I don't hear back in a week, we can abandon them.
18:54:47 <amrith> sounds good to me, let's just say we carry this list forward to the next meeting (1 week)
18:54:57 <johnma> do we want to try and review them in the next week or so and then do the following:
18:54:58 <johnma> 1) if they are good, merge
18:54:59 <amrith> and if they are still there we abandon them.
18:55:00 <johnma> 2) if it needs more work, update it accordingly with comments and then wait for activity/inactivity and then abandon at that point
18:55:02 <amrith> would that work?
18:55:11 <johnma> I think thats fair amrith
18:55:22 <SlickNik> amrith: ++ I think that's fair
18:55:33 <amrith> i'm fine with either johnma's proposal or SlickNik's proposal
18:55:47 <amrith> to johnma's proposal, we have a challenge getting review bandwidth
18:56:28 <amrith> do I *really* want to waste review bandwidth on https://review.openstack.org/#/c/384298? no ...
18:56:50 <amrith> nor 2, 3, 7, 9, ...
18:56:59 <amrith> but I'm fine with the approach
18:57:06 <amrith> let's pick one and move forward
18:57:09 <amrith> what do people feel?
18:57:27 <johnma> of course, the ones in the ocata review list definitely gets priority. the rest they either sit there for another week or as we get time we review
18:58:02 <amrith> like, I have this review https://review.openstack.org/#/c/370971; it is on the list to abandon. do I want it abandoned? no. but it needs to be reviewed and that hasn't happened. so I don't want it to just sit there forever.
18:58:07 <amrith> it should be a quick review
18:58:11 <amrith> but it hasn't happened ...
18:58:32 <amrith> and my concern is that the important ones are being lost in the noise
18:58:39 <amrith> anyway, we're 1m from #end of meeting
18:58:43 <amrith> so let's wrap up
18:58:49 <amrith> SlickNik, you'll make a list?
18:59:58 * SlickNik SlickNik to make a candidate list of reviews to abandon and put a note in them. We can track this list and abandon all of the reviews that have no movement in them in a weeks time.
19:00:07 <amrith> sounds good
19:00:12 <SlickNik> #action SlickNik to make a candidate list of reviews to abandon and put a note in them. We can track this list and abandon all of the reviews that have no movement in them in a weeks time.
19:00:19 <amrith> that's all we hav etime for today so let's call it a wrap
19:00:28 <amrith> and if there's anything more to talk about move to #openstack-trove
19:00:32 <amrith> #endmeeting