18:01:23 <amrith> #startmeeting trove
18:01:24 <openstack> Meeting started Wed Nov 30 18:01:23 2016 UTC and is due to finish in 60 minutes.  The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:27 <openstack> The meeting name has been set to 'trove'
18:01:32 <amrith> anyone here for the trove meeting?
18:01:33 <songjian> o/
18:01:36 <peterstac> o/
18:01:39 <amrith> hi songjian
18:01:39 <aliadil> o/
18:01:43 <amrith> #chair peterstac
18:01:43 <openstack> Current chairs: amrith peterstac
18:01:47 <songjian> hi amrith
18:01:47 <SlickNik> o/
18:01:58 <amrith> hi aliadil peterstac SlickNik
18:01:58 <peterstac> hi all
18:02:01 <amrith> #chair SlickNik
18:02:02 <openstack> Current chairs: SlickNik amrith peterstac
18:02:20 <aliadil> hi amrith
18:02:32 <amrith> #info I'm expecting a plumber to arrive any minute now so I may have to leave midway; if that happens peterstac has agreed to pick up the reins
18:02:35 <amrith> thx peterstac
18:02:46 <trevormc_> o/
18:02:46 <amrith> #agenda https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:03:08 <amrith> hi trevormc_ (nice work on the tempest thing this morning)
18:03:26 <peterstac> amrith, np
18:03:38 <amrith> just waiting a couple of minutes for johnma
18:04:17 <amrith> well, let's get started.
18:04:25 <trevormc_> thanks amrith, I knew how to fix that error haha :)
18:04:27 <dougshelley66> o/
18:04:32 <amrith> #topic Review status
18:04:45 <amrith> #link https://docs.google.com/spreadsheets/d/1vJxNaoR3VVNS1Cpiz7U--1zyJRZ6ybMxzJoayrjdduo/edit?usp=sharing
18:04:54 <amrith> as always, we could do with more reviews
18:05:02 <amrith> but we seem to be holding the line for now
18:05:17 <amrith> would be good if we could get the specs that are out there merged; we can talk about those later today
18:06:03 <amrith> the new patch cont is an abberation; several of us were pushing patches like crazy (esp peterstac, thanks much for that)
18:06:15 <amrith> 54 patch sets to get the neutron gate, for example.
18:06:36 <amrith> but the queue did grow a little, now have to haul that back in
18:06:50 <amrith> I've got nothing more to say about this ...
18:07:15 <amrith> .
18:07:24 <peterstac> it might be a good idea to get in as much as possible asap
18:07:27 <peterstac> :)
18:07:39 <amrith> before the gate breaks again you say?
18:07:44 <amrith> I'm working on that
18:07:45 <peterstac> yep :D
18:08:26 <peterstac> I'm trying to come up with a way to alleviate our troveclient pains - maybe push something up later this afternoon
18:08:40 <amrith> the running of the tempest job you mean?
18:08:54 <mvandijk_> ./
18:09:04 <pmalik> ./
18:09:25 <johnma> did we figure out why the client is running all those tempest tests
18:09:35 <amrith> hi mvandijk_ pmalik johnma
18:09:56 <peterstac> yes - looks like making the network shared (even temporarily) might not buy us as much time as I'd hoped
18:11:25 <amrith> peterstac, I think that's an answer to what the failure was. was johnma asking why we needed those tests there in the first place?
18:12:19 <peterstac> yeah, I don't know why we run those there
18:13:48 <amrith> #action figure out why we run the tempest tests in the client
18:14:12 <amrith> peterstac, johnma will one of you be looking into that?
18:15:00 <johnma> amrith: I can look at it
18:15:13 <amrith> #action (johnma) figure out why we run the tempest tests in the client
18:15:26 <amrith> anything else on the topic of review status...
18:15:37 <peterstac> I think only sahara does it as well
18:15:56 <peterstac> (well neutronclient does, but that's not unexpected)
18:18:26 <amrith> #topic  Code Reviews
18:18:42 <amrith> so, are there any specific code reviews that people would like to discuss?
18:20:35 <trevormc_> I think a rundown for the usage information for the module patches that peterstac have been putting out would be nice :)
18:20:53 <amrith> I don't follow
18:21:27 <peterstac> trevormc_, I was trying to find a link to a page that explains how the module stuff works, but haven't found it yet
18:22:14 <trevormc_> That's ok. It may be better to wait for the gates to be fixed.
18:22:30 <trevormc_> amrith: change 403287 is what I was talking about
18:24:12 <amrith> and you are looking for documentation on the module stuff?
18:24:46 <trevormc_> yes, but it can wait. Since we want to merge specs anyway
18:25:30 <amrith> which is a good transition to
18:25:32 <amrith> #topic 403287
18:25:44 <amrith> #topic Specs that are up for review (if any)
18:25:46 <amrith> that's better
18:26:00 <amrith> are there any specs that folks would like to discuss
18:26:11 <peterstac> trevormc_, here's an example of the module stuff, maybe it'll help - http://paste.openstack.org/show/590997/
18:27:03 <trevormc_> peterstac: thanks :)
18:27:17 <peterstac> trevormc_, np
18:28:06 <amrith> here is the list of specs that are up for review https://review.openstack.org/#/q/project:openstack/trove-specs+status:open
18:28:52 <amrith> the ones that are starred are the ones we're currently actively focusing on for ocata https://review.openstack.org/#/q/project:openstack/trove-specs+status:open+is:starred
18:29:34 <amrith> could all of you spend some time today reviewing these and providing feedback.
18:29:48 <amrith> it will help alleviate a logjam at the end of the release cycle
18:29:58 <johnma> will do
18:31:20 <amrith> thx all, anything further on specs
18:31:37 <amrith> ok
18:31:38 <peterstac> some of them are WIP or have -1's
18:31:47 <peterstac> I'll try and take a look too
18:31:48 <amrith> peterstac, that's the first list
18:31:58 <amrith> the one with the is:starred should be the one to look at
18:32:02 <amrith> or maybe that's only for me :(
18:32:09 <amrith> maybe you have to look on the dashboard
18:32:15 <peterstac> for me that list is empty :(
18:32:42 <trevormc_> you want review.openstack.org/#/q/starredby:amrith + status:open
18:32:55 <amrith> yes, that thing trevormc_ says :)
18:32:58 <amrith> https://review.openstack.org/#/q/project:openstack/trove-specs+status:open+starredby:amrith%2540tesora.com
18:33:20 <peterstac> ok, got it, thx
18:34:43 <amrith> #topic Ocata Release Schedule - Update
18:34:56 <amrith> #link https://releases.openstack.org/ocata/schedule.html
18:35:19 <amrith> so this week and the next are to get our specs and code merged, the next deadline is o-2
18:35:37 <amrith> what some of you may have already noticed is that we are now gating on the neutron based networking.
18:35:53 <amrith> and we will soon be gating on both trusty and xenial jobs
18:37:30 <amrith> a general observation about rechecks
18:38:01 <amrith> 1. please don't just recheck jobs without seeing why there was a failure; if you don't recognize the failure, it isn't a worthwhile effort to just recheck over and over and over and over and over again
18:38:11 <amrith> it will likely not pass and just make things harder for others.
18:38:35 <amrith> 2. please don't recheck other people changes without asking them. often someone is working on fixing something and a recheck is pointless.
18:38:53 <amrith> let's try and not make the gate more overloaded than it has to be; we have enough timeouts already
18:38:59 <amrith> </end-rant>
18:39:17 <amrith> and with that, I've come to the end of my notes ...
18:39:31 <amrith> so if no one has anything further on the release schedule
18:39:34 <amrith> we can switch to
18:39:37 <amrith> #topic open discussion
18:39:48 <amrith> and peter, my plumber is here ...
18:39:53 <amrith> would you take over please ...
18:39:55 <amrith> thanks all ...
18:40:09 <peterstac> amrith, sure np
18:41:20 <peterstac> so, any new business that needs to be discussed?
18:41:57 <trevormc_> I've introduced patchsets to the trove repository for adding hacking rules and stuff. I wanted to ask are there specific translation checks we want to check for? The list now is * check for tranlastion in logs * check for translation in exceptions * use translation hiints
18:42:40 <peterstac> trevormc_, I had a question about this - is there going to be a hacking rule enabled after these all land?
18:43:10 <trevormc_> from the hacking project, no. I took the custom rules from neutron-lib about translation.
18:43:40 <peterstac> well that's fine, as long as there is a rule enabled that enforces it once the work is done
18:44:20 <peterstac> otherwise the old style will immediately begin to creep back in ...
18:44:44 <trevormc_> I don't have config to turn these on or off it's just always on. Maybe that should be discussed here https://review.openstack.org/#/c/402780/
18:45:10 <trevormc_> If you checkout that code and run pep8 you will see errors about translation logs
18:46:06 <trevormc_> yeah the styling will NOT creep back in because it is covered by the tests that do static code analysis.
18:48:28 <peterstac> ah, ok - so this changereq should depend on all the other ones, and then merge last, right?
18:48:42 <trevormc_> right
18:48:43 <peterstac> #link https://review.openstack.org/#/c/402780/
18:49:01 <peterstac> ok, sounds good
18:49:30 <peterstac> Probably a good idea if there's any discussion on it to do it on the review
18:49:41 <peterstac> Anything else?
18:50:24 <peterstac> going once ...
18:50:38 <peterstac> going twice ...
18:50:46 <peterstac> Thanks everyone!
18:50:48 <peterstac> #endmeeting