18:00:05 <amrith> #startmeeting trove
18:00:06 <openstack> Meeting started Wed Jan 11 18:00:05 2017 UTC and is due to finish in 60 minutes. The chair is amrith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:09 <openstack> The meeting name has been set to 'trove'
18:00:14 <amrith> anyone here for the trove meeting
18:00:17 <trevormc> o/
18:00:19 <songjian> o/
18:00:32 <amrith> courtesy ping for peterstac johnma slicknik dougshelley66 pmalik vgnbkr mvandijk trevormc aliadil spilla songjian trevormc apsarshaik
18:00:40 <amrith> hi trevor songjian
18:00:40 <johnma> o/
18:00:45 <amrith> hi mariam
18:00:48 <peterstac-m> O/
18:01:02 <amrith> -m?
18:01:10 <pmalik> ./
18:01:14 <peterstac-m> Phone
18:01:17 <johnma> Hi Amrith. Happy New Year to everyone
18:01:18 <amrith> ah
18:01:20 <amrith> hi peter
18:01:23 <amrith> happy new year to all
18:01:26 <aliadil> o/
18:01:57 <peterstac-m> (I'm wandering around the office atm)
18:02:19 <amrith> so let's get started
18:02:32 <amrith> if one you guys in canada want to ping dougshelley66 that would be good
18:02:43 <amrith> I don't have anything specific for the agenda
18:05:01 <amrith> ah, I'm back
18:05:05 <amrith> sorry, we're having network issues here
18:05:12 <amrith> and I fell off the network for a bit
18:05:27 <amrith> I don't have anything specific for the agenda
18:05:37 <amrith> #agenda https://wiki.openstack.org/wiki/Meetings/TroveMeeting
18:06:01 <peterstac-m> dougshelley66 is here, just afk ;)
18:06:21 <dougshelley66> yes?
18:06:39 <amrith> sorry, lost IRC again
18:06:59 <amrith> #topic Review status
18:07:05 <amrith> I've not been able to update the table (sorry, bad internet)
18:07:19 <amrith> #topic code reviews
18:07:32 <amrith> Are there any code reviews that others would like to discuss; trevor, are you all set with the i18n changes
18:08:09 <amrith> trevormc, ^^
18:08:26 <trevormc> amrith, I'm all set with the changes but I don't think the gates are..
18:08:49 <amrith> there is that little detail trevor, thought I just saw something go into gate now (passed check)
18:09:06 <trevormc> I have rechecked the majority of the patches and some pass but most still show build failed
18:09:27 <amrith> are you sure the failures aren't real failures; i.e. not the gate being flakey
18:09:49 <peterstac-m> yeah the gate is still very unreliable
18:09:49 <trevormc> I look back at the jenkins of previous runs and its usually different gates failing
18:10:15 <trevormc> one run will fail mult-postgres and then i recheck, that passes but single-mysql fails
18:10:40 <trevormc> or some other variant
18:11:21 <amrith> ok, will take a look. let's wait for a quiet time and try and recheck then
18:11:30 <amrith> dougshelley66, when is that usually? late friday or early saturday?
18:11:53 <dougshelley66> saturday AM is usually good - likely <10 jobs in queue
18:11:59 <amrith> trevormc ^^
18:12:00 <trevormc> ok I'll wait for the Ok to do anymore rechecking.
18:12:11 <trevormc> so saturday AM it is
18:12:13 <dougshelley66> but it seems like there are other problems now
18:12:15 <amrith> let's check the gate results and make sure they are just flakiness
18:12:20 <amrith> and fix anything else that we can
18:12:25 <dougshelley66> we used to just have an issue when the gate was really busy
18:12:30 <amrith> then recehck them on saturday AM; I can do that by script
18:12:39 <amrith> CLI + cron :)
18:12:41 <dougshelley66> but now we seem to have issues because we sped things up and also it seems like random infra things fail now
18:12:59 <amrith> we could slow it down again; it is a trove change for that.
18:13:17 <dougshelley66> not certain if doing that makes sense either
18:13:35 <amrith> unfortunately we can't make it 'slightly faster', not all that fast :)
18:13:39 <amrith> it is qemu or kvm
18:13:43 <amrith> nothing in the middle
18:14:07 <dougshelley66> well if things are failing because of the new timing, we should fix them but that didn't seem to account for all the failures
18:14:15 <amrith> yes
18:14:26 <amrith> will start to take a look at trevor's changes
18:14:35 <amrith> any other changes that we should prioritize for reviewing?
18:15:12 <trevormc> reviewing this patch would be nice: https://review.openstack.org/#/c/400979/
18:15:51 <trevormc> I am about to push a rebased change.. I decided to remove the FakeResponse class as I ended up not using it.
18:16:26 <amrith> ok
18:16:30 <amrith> any other changes?
18:16:33 <amrith> going once ...
18:17:33 <amrith> twite
18:17:35 <amrith> twice
18:17:55 <amrith> #topic Specs that are up for review (if any)
18:18:01 <amrith> #link https://review.openstack.org/#/q/project:openstack/trove-specs+status:open
18:18:10 <amrith> There are no specs that are (now) active for ocata
18:18:20 <amrith> I approved the last one a couple of days back, it related to the openstack client
18:18:27 <amrith> trevormc has started working on that
18:18:41 <amrith> trevormc, have anything to add?
18:18:51 <trevormc> thank you! yes my progress is linked in an etherpad on the bp's whiteboard
18:19:05 <trevormc> #link https://etherpad.openstack.org/p/trove-support-python-openstackclient
18:19:27 <trevormc> I'm waiting for the requested review to merge so I can upload all of the list commands as they will be creating new files.
18:20:47 <johnma> trevormc: can you add these changesets to the meeting agenda page, so that its easy to reference from there. I will help with some reviews this week
18:21:05 <amrith> #link https://etherpad.openstack.org/p/trove-support-python-openstackclient
18:21:19 <trevormc> Currently there is only one changeset in review
18:21:20 <amrith> #link https://review.openstack.org/#/c/400979/
18:21:21 <trevormc> #link https://review.openstack.org/#/c/400979/
18:21:25 <amrith> beat ya!
18:21:26 <trevormc> oops
18:21:57 <amrith> yes, this is a non-trivial review
18:21:59 <amrith> will get to it today
18:22:48 <amrith> trevormc, anything else to add?
18:22:56 <trevormc> amrith, that's all. Thanks
18:23:01 <amrith> ok, thanks
18:23:22 <amrith> anyone has anything to add on topic of specs for review
18:23:35 <amrith> #topic Reviews for abandonment
18:23:46 <amrith> OK, last week I bumped off all of these reviews
18:23:55 <amrith> kept the list on the agenda for one more week so everyone knows about it
18:24:01 <amrith> #link https://etherpad.openstack.org/p/okipourVgv
18:24:09 <amrith> I'm going to do this periodically
18:24:18 <amrith> and abandon things that have been similarly inactive
18:24:28 <amrith> If people feel strongly about them, they can be restored.
18:24:53 <amrith> #topic Ocata Release Schedule - Update
18:24:59 <amrith> #link https://releases.openstack.org/ocata/schedule.html
18:25:18 <amrith> we have met our spec freeze deadline (this week)
18:25:22 <amrith> no milestones next week
18:25:42 <amrith> next major milestone is Jan 16th
18:25:57 <amrith> to be clear, we were late on the spec freeze deadline; that should have been a month ago
18:26:04 <amrith> but the last spec was just merged this past week
18:26:12 <amrith> next milestone for 1/16 is the client soft freeze
18:26:33 <amrith> if you have changes that have a client component (like OSC) let's get those highlighted on the agenda so we can focus review cycles on those.
18:26:53 <amrith> That's all I had on the topic, anyone have anything to add?
18:27:43 <amrith> #topic Open Discussion
18:27:53 <amrith> anyone have anything to discuss ...
18:27:54 <amrith> go for it
18:28:12 <trevormc> A wiki went up for hosting project etherpads for the PTG
18:28:15 <trevormc> #link https://wiki.openstack.org/wiki/PTG/Pike/Etherpads
18:28:41 <trevormc> Trove is missing there's.. we should probably add one.
18:28:42 <amrith> yup, we need to figure out the schedule for that
18:28:53 <amrith> #action figure out schedule for ptg sessions
18:29:28 <trevormc> that's all
18:29:33 <amrith> trevormc, do you want to setup the pages? and if anyone has things they'd like on the agenda they can add them to the wiki
18:29:42 <amrith> if you set it up, please broadcast the links
18:29:45 <amrith> like, to the ML
18:30:07 <trevormc> I suppose I could.. I need to learn
18:30:24 <trevormc> should be simple enough, I was just nervous on messing it up.
18:30:45 <amrith> thanks trevormc
18:31:34 <johnma> so does that mean Trove will be on Wednesday & Thursday only
18:32:04 <amrith> johnma, correct
18:32:16 <johnma> ok, sounds good.
18:32:50 <amrith> anyone have anything else to add
18:32:55 <songjian> Hi,all,I am work for this,https://review.openstack.org/#/c/368947/.I have a problem,is our test now is properly utf-8 encoded binary string?like this,https://github.com/openstack/trove/blob/master/trove/tests/unittests/common/test_stream_codecs.py#L35
18:34:04 <songjian> I try to decode('utf-8'),and error
18:35:04 <amrith> songjian, what's your question; how can we help?
18:36:06 <songjian> It seems that this patch needs repair test, I would like to ask the idea
18:37:22 <amrith> ok, do you have a new patch for review?
18:37:38 <amrith> one that addresses the review comments from the old patch
18:37:46 <songjian> My initial idea is to deserialize and serialize the results after same with Test Data, but this change will cause the data type is not the same situation
18:39:49 <amrith> ok, will check back once you have it working and there's something to review
18:39:52 <amrith> ok?
18:39:56 <songjian> Well, I will review a patch to show and then let us to discuss it,thx
18:40:11 <amrith> ok, anyone have anything else?
18:40:41 <amrith> going once
18:41:10 <amrith> going twice
18:41:37 <amrith> #endmeeting