14:00:12 <zhaochao> #startmeeting trove
14:00:13 <openstack> Meeting started Wed Jul 25 14:00:12 2018 UTC and is due to finish in 60 minutes. The chair is zhaochao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:17 <openstack> The meeting name has been set to 'trove'
14:00:24 <zhaochao> #topic roll call
14:02:09 <zhaochao> songjian1994: hi
14:02:33 <bzurkowski> Hello
14:02:37 <zhaochao> Courtesy ping fanzhang kumarmn maciejjozefczyk wangyao zhanggang
14:02:38 <Marcin> hi there
14:02:43 <zhaochao> bzurkowski: Marcin hi
14:03:12 <songjian1994> hi zhaochao
14:04:13 <zhaochao> songjian1994: :)
14:04:39 <zhaochao> OK, let's start
14:04:55 <zhaochao> #topic Rocky goal updates
14:05:14 <zhaochao> last week we have a few patches merged
14:05:57 <zhaochao> however I'm busy on other things, so we still have some active patches no get fully reviewed and merged
14:06:21 <zhaochao> I noticed some new patches of OSC client from wangyao
14:07:00 <zhaochao> and gang has also updated his patches about extended properties during cluster creating(currently only used for MongoDB)
14:08:11 <zhaochao> and it's milestone-3 deadline tomorrow
14:08:29 <zhaochao> so I think these patches cannot get merged before that
14:09:20 <zhaochao> I'll do the tagging tonight or early tomorrow morning
14:09:42 <songjian1994> Yes, time seems a bit urgent
14:10:06 <zhaochao> yes
14:11:04 <zhaochao> and we also have new contributors from Samsung R&D Center in Krakow, thanks for them to join us
14:11:10 <zhaochao> and the review and commits
14:11:24 <zhaochao> bzurkowski: :)
14:11:53 <bzurkowski> Yes, hello everyone
14:12:37 <zhaochao> bzurkowski: welcome
14:12:48 <bzurkowski> Me and also Marcin joined the community from Samsung R&D in Poland
14:12:56 <songjian1994> bzurkowski: welcome
14:13:25 <bzurkowski> We are slowly starting our activity
14:14:03 <Marcin> hello, nice to be here :)
14:14:11 <bzurkowski> So far we have made a couple of code reviews
14:14:30 <zhaochao> Marcin: welcome, I was just going to ask, thanks for reviews
14:14:52 <zhaochao> yes, thanks for helping
14:15:05 <bzurkowski> We passed approval process in our company so now are ready to start contributing our sources
14:15:07 <zhaochao> bzurkowski: I also read about the response in trove-tempest-plugin
14:15:26 <zhaochao> but still not response for that
14:15:31 <Marcin> my pleasure
14:16:16 <zhaochao> I think migrating the current integration tests to tempest plugin is really greate and valuable
14:17:00 <zhaochao> bzurkowski: great news!
14:17:29 <songjian1994> bzurkowski:It sounds exciting
14:17:58 <bzurkowski> zhaochao: Yes, rewriting integration tests into Tempest is very important
14:18:40 <bzurkowski> In this or the next week, we will push the first scenario: basic instance provisioning
14:19:21 <bzurkowski> This scenario will establish a framework for writing further tests
14:19:37 <zhaochao> bzurkowski: that's great, I'll try my best to help on that
14:20:09 <bzurkowski> There are a few changes on which we are currently dependent:
14:20:16 <bzurkowski> https://review.openstack.org/#/c/583252/
14:20:25 <bzurkowski> https://review.openstack.org/#/c/580763/
14:20:30 <bzurkowski> https://review.openstack.org/#/c/581114/
14:21:26 <bzurkowski> I would be grateful for review and submit
14:21:59 <zhaochao> yes, I did some first step reviews on those patches, and came up with a new zuul job for trove-tempest-plugin itself
14:22:12 <bzurkowski> I realize that milestone is approaching and there is not enough time so I just let you know
14:23:01 <zhaochao> bzurkowski: I'll also try my best to help all these migration happend, thanks for all the work you and your colleagues done
14:23:32 <zhaochao> for the milestone, I think it may not affect trove-tempest-plugin, as it's all about test cases
14:23:46 <zhaochao> we may still merge patches in this topic
14:24:09 <zhaochao> and as I stated in https://review.openstack.org/#/c/583252/
14:24:48 <zhaochao> we have to do some basic works for tempest plugin to really working, i.e. all new tempest cases should be tested
14:25:20 <bzurkowski> Right, this one is the most urgent one
14:26:22 <zhaochao> yes, we may need to rewrite some parts of the trove devstack plugin, and maybe new playbook roles
14:26:54 <zhaochao> to do the image building which previously done the the trovestack
14:27:24 <zhaochao> and upload them to glance, initialize datastores
14:27:56 <zhaochao> after that, the tempest plugin cases could run successfully
14:29:59 <zhaochao> we could also refactor the DIB elements part
14:30:41 <zhaochao> I think all these changes are in a good direction
14:31:19 <zhaochao> as the previous trove-integration subproject has been not well maintained for quite a while
14:31:54 <zhaochao> songjian1994: how do you think about these changes?
14:35:17 <zhaochao> bzurkowski: Marcin thanks for the work you have done, please help do more reviews
14:36:28 <zhaochao> recently we have some other import changes still not working
14:36:52 <zhaochao> the python3-first patches, the problems seem in the troveclient
14:36:54 <bzurkowski> zhaochao: If there are any reviews that require special care, you can put them on IRC and we will try to add our comments
14:37:15 <zhaochao> yes, ^
14:37:40 <Marcin> zhaochao: I will do my best
14:37:48 <zhaochao> Marcin: thanks
14:38:16 <zhaochao> python3-first patches are the first step patches to migrate python 3
14:38:37 <zhaochao> although we pass all unittests under python3 in the trove repo
14:39:14 <zhaochao> but the unittest coverage seems not very good
14:41:19 <zhaochao> #link https://review.openstack.org/#/q/topic:python3-first+status:open+project:openstack/trove
14:42:02 <zhaochao> when I have time, I'll also help on these patches
14:42:42 <zhaochao> another topic about project update is PTL election
14:42:56 <zhaochao> it's now election season again
14:43:19 <zhaochao> I was thinking about stepping down the PTL role
14:43:48 <zhaochao> and want to hear your opinions about self-nomination
14:44:30 <zhaochao> however it looks like the current active team members are still busy on other things and could not attend this meeting
14:45:01 <zhaochao> jiansong1994 may also be in a bad network condition today, :(
14:46:25 <zhaochao> bzurkowski: Marcin I also want to ask whether anyone from your team want to nominate him/herself as the Trove PTL
14:46:39 <bzurkowski> I was just going to ask
14:46:44 <Marcin> sure
14:47:17 <Marcin> I think Samsung R&D is ready for start as PTL member
14:47:48 <Marcin> we intend to increase our involvement in community
14:48:31 <zhaochao> Marcin: that's great, who're going to do the self-nominate?
14:49:27 <Marcin> we need to discuss it in your team
14:49:53 <Marcin> can we decide in a next meeting?
14:50:59 <Marcin> Darek and Przemek which are also in out team are absent now, we need to talk with them
14:51:00 <zhaochao> no, the deadline is Jul 31
14:51:11 <zhaochao> #link https://governance.openstack.org/election/
14:51:49 <zhaochao> then I think it's better discuss this on the ML
14:52:46 <Marcin> sorry, what do you mean by ML?
14:53:07 <zhaochao> O, sorry, the mailing list
14:53:30 <Marcin> sure :)
14:53:55 <Marcin> we will be in touch
14:54:03 <bzurkowski> We will discuss this internally and let you know before 31th.
14:54:10 <bzurkowski> For sure we are interested in self-nomination.
14:54:37 <zhaochao> OK, I'll start the conversation topic on the ML
14:56:19 <zhaochao> there's only one problem, I'm not sure about, that the nominee may need to have at least one patches merged in any of the Trove projects
14:57:01 <zhaochao> #action zhaochao start a conversation on the ML to discuss the PTL election
14:58:00 <bzurkowski> We currently have two patches in trove-tempest-plugin review, authored by me
14:58:46 <bzurkowski> I'll do my best to merge them
14:59:25 <zhaochao> bzurkowski: that's good, but I'm afraid we don't have enough time
14:59:31 <zhaochao> OK, time is up
14:59:41 <zhaochao> we'll discuss more on the ML
14:59:56 <zhaochao> thanks, everyone
15:00:04 <zhaochao> Good night!
15:00:15 <bzurkowski> Thanks and goodbye!
15:00:23 <Marcin> thanks, bye
15:00:23 <zhaochao> #endmeeting