14:01:39 <dkrol> #startmeeting trove
14:01:40 <openstack> Meeting started Wed Sep 26 14:01:39 2018 UTC and is due to finish in 60 minutes.  The chair is dkrol. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:44 <openstack> The meeting name has been set to 'trove'
14:01:50 <dkrol> Hello
14:01:58 <bzurkowski> Hello
14:02:16 <mpiwowarczy> hi
14:02:19 <dkrol> let's wait a few more minutes for others
14:02:23 <dkrol> mpiwowarczy: hi
14:03:16 <dkrol> #topic roll call
14:06:01 <dkrol> so only three of us today ? :)
14:06:24 <mpiwowarczy> still stable :)
14:06:54 <bzurkowski> I think we can start
14:06:59 <dkrol> great
14:07:18 <dkrol> #topic Core team members
14:07:35 <dkrol> bzurkowski: you added this topic to our discussion
14:07:40 <bzurkowski> Yes
14:08:09 <bzurkowski> I did the math and it turns out that we have only 4 active core members in this release
14:08:57 <bzurkowski> Marcin is with us for a longer time a does great job reviewing changes and commiting new fixes
14:09:14 <bzurkowski> I suggest adding him to the core team
14:09:42 <dkrol> hmm... but why do we need more core contributors ?
14:10:26 <bzurkowski> Because we need to facilitate the progress in the project
14:10:55 <bzurkowski> We have a lot of opened changes with many +1s or single +2s
14:11:06 <dkrol> do you think our current progress (I mean pace of merging) is too low ?
14:12:34 <mpiwowarczy> from my side I offer my work on review work
14:12:36 <bzurkowski> I have an impression that often a second core is missing that would approve the change
14:12:47 <mpiwowarczy> if it is needed I can help as core member :)
14:13:25 <dkrol> I get it
14:13:41 <dkrol> so we can vote but there are only two of us right now ?
14:13:57 <dkrol> it's not a lot :)
14:14:11 <mpiwowarczy> but I do not vote for nothing as it is about me :)
14:15:13 <dkrol> it seems we don't have quorum of core contributors right now
14:15:56 <dkrol> otherwise I agree with you, Marcin should be recognized as a core contributor
14:16:02 <bzurkowski> dkrol: You are right, but this is what we had for several past meetings...
14:16:40 <bzurkowski> I'm voting in favor of adding Marcin to the core team
14:17:40 <dkrol> shouldn't we try to contact them first ?
14:17:57 <dkrol> at least try to
14:18:43 <mpiwowarczy> can we do that on mailing list or somewhere?
14:19:24 <dkrol> we can get emails from gerrit and send them an invitation
14:19:33 <dkrol> and do the voting next week
14:19:51 <bzurkowski> dkrol: Yes, let's ask others about their opinion
14:19:56 <dkrol> will it be ok for you ?
14:20:37 <bzurkowski> dkrol: Sure
14:20:49 <dkrol> ok, thank you for understanding
14:21:12 <dkrol> #topic Recent changes and reviews
14:21:21 <dkrol> lets move to recent changes
14:21:53 <dkrol> from my side ...
14:22:04 <dkrol> I saw several python3-first changes
14:22:35 <dkrol> and I sent an email to stable branches mainteners
14:22:53 <dkrol> and I was asked a question: "is python3 support going to be backported to stable branches?"
14:23:11 <dkrol> and this seems to be a very good question
14:23:45 <dkrol> my first impression after reading https://docs.openstack.org/project-team-guide/stable-branches.html
14:23:48 <dkrol> #link https://docs.openstack.org/project-team-guide/stable-branches.html
14:24:13 <mpiwowarczy> how it is in other projects?
14:24:15 <dkrol> was that python3 should not be backported to stable branches
14:24:26 <dkrol> I didn't check it
14:24:51 <dkrol> but we should have our own opinion as well
14:25:05 <dkrol> before taking a look at other projects
14:26:10 <dkrol> what is your opinion ?
14:26:46 <mpiwowarczy> definitely you are right
14:27:08 <mpiwowarczy> but AIK only important changes are backported to stable branches
14:28:20 <mpiwowarczy> moreover python3-fists doeasnt have any functional changes, hence, what is a reason to backort them?
14:29:25 <mpiwowarczy> if anybody want to use trove trove in new python, will also use latest Trove version
14:29:45 <bzurkowski> I'm wondering why they are pushing python3-first changes so deep, up to ocata stable branch
14:29:50 <dkrol> I would think so too
14:30:14 <dkrol> maybe we could ask goal champions about it ? :)
14:30:16 <bzurkowski> Ocata and some subsequent branches will be dropped until Python 3 comes
14:30:29 <bzurkowski> The thing is that this is not happening by mistake, but defined explicitely in goal tools
14:30:33 <bzurkowski> #link https://github.com/openstack/goal-tools/blob/4125c31e74776a7dc6a15d2276ab51ff3e73cd16/goal_tools/python3_first/jobs.py#L54
14:30:48 <bzurkowski> dkrol: We should ask goal champions as you suggest
14:31:44 <dkrol> #action ask python3-first goal champions about supporting stable branches
14:32:13 <dkrol> ok
14:32:21 <mpiwowarczy> keep in mind, there is a lot of changes in python3-firsts tasks
14:32:28 <dkrol> besides this - do you have anything elso ?
14:32:43 <dkrol> else about recent changes ?
14:32:49 <mpiwowarczy> it is always a little risky to pull these changes to stable releases
14:33:06 <bzurkowski> dkrol: Nothing more from my side
14:33:37 <mpiwowarczy> im working on moving functional tests to python3 - https://review.openstack.org/#/c/604816/
14:33:48 <mpiwowarczy> but it is still in progress
14:34:20 <mpiwowarczy> want to use tox and wrap trovestack script in virtualenv to execute int_tests
14:34:41 <mpiwowarczy> that is all from my side
14:34:42 <dkrol> ok
14:34:52 <dkrol> from my side - I'm working on trovestack redesign but I didn't push anything yet
14:35:10 <dkrol> I think in the following week there will be something to report :)
14:35:26 <dkrol> #topic Trovestack redesign
14:36:05 <dkrol> we can change a topic now
14:36:26 <bzurkowski> One moment
14:36:27 <dkrol> so basically I was working on extracting minimal code to build mysql image
14:36:55 <bzurkowski> OK, continue
14:37:02 <dkrol> ok
14:37:15 <bzurkowski> I thought you were gonna skip trovestack redesign topic
14:37:43 <dkrol> it turned out trovestack is a bigger monolith I was thinking
14:38:22 <dkrol> it is not trivial to extract anything from it
14:38:52 <dkrol> there is a mix of functions in trovestack, functions and functions_qemu files
14:39:02 <dkrol> and they are tightly coupled :)
14:40:40 <dkrol> I'm at the moment where I have a seperate script for building minimal ubuntu mysql image which passes trovestack tests
14:41:24 <dkrol> I need to do some working on refactoring and verification but it should be ready for review in the follwoing week
14:41:38 <dkrol> how about you ? do you have anything on this topic ?
14:42:11 <bzurkowski> So finally you wrote image building script from scratch, right?
14:42:34 <bzurkowski> Based on existing code in trovestack
14:42:45 <dkrol> yes
14:43:00 <dkrol> and also trove registration script
14:43:19 <dkrol> once the image is built it has to be registered
14:44:51 <dkrol> ok, lets move on to the next topic
14:44:59 <dkrol> since we are running out of time
14:45:03 <dkrol> #topic Python 3 first support
14:45:17 <dkrol> mpiwowarczy: do you have any update about it ?
14:46:14 <mpiwowarczy> nothing more than functional test
14:46:32 <mpiwowarczy> we are still unable to update any point from https://etherpad.openstack.org/p/trove-python-3
14:46:40 <dkrol> :(
14:47:02 <dkrol> ok
14:47:09 <dkrol> lets move to the last topic
14:47:10 <mpiwowarczy> dont worry, work goes forward :)
14:47:15 <dkrol> #topic Building the community
14:47:24 <dkrol> bzurkowski: :)
14:47:52 <bzurkowski> dkrol: :)
14:48:11 <bzurkowski> I added this topic to talk about condition of Trove community
14:48:15 <dkrol> bzurkowski: the floor is yours
14:49:41 <bzurkowski> We all want to achieve great goals in this project by introducing advanced features and improvements
14:50:23 <dkrol> +1
14:50:40 <bzurkowski> However, we cannot make progress without the right number of people involved in the project
14:51:49 <bzurkowski> I looked at previous meetings from several years ago
14:52:32 <bzurkowski> There were 20 people instead of three during each weekly meeting
14:52:53 <bzurkowski> There were special meetings for discussing only blueprints
14:52:55 <bzurkowski> #link https://wiki.openstack.org/wiki/Meetings/TroveBPMeeting
14:53:19 <mpiwowarczy> maybe we sould consider add something like "quick start" to documentation
14:53:23 <bzurkowski> Let's collect ideas about how we could put life back into the project
14:53:34 <mpiwowarczy> it will make it easier start working with Trove
14:54:38 <dkrol> bzurkowski: do you have anything specific on mind ? or do you want to start  brainstorming about it ?
14:54:39 <mpiwowarczy> for now it isnt easy for newbies bring up trove with instances
14:54:46 <bzurkowski> The meeting is almost over so I suggest creating a pad for ideas
14:54:54 <bzurkowski> We could review it in the next week
14:55:08 <bzurkowski> dkrol: Rather start brainstorming
14:55:32 <dkrol> #link https://etherpad.openstack.org/p/trove-revitalization
14:55:33 <bzurkowski> Marcin's idea is a good start
14:55:40 <dkrol> how about it ? :)
14:56:11 <bzurkowski> dkrol: Thanks :)
14:56:29 <dkrol> ok, so let's have this discussion next week
14:56:39 <dkrol> thanks for coming today
14:57:15 <mpiwowarczy> bye
14:57:18 <dkrol> #endmeeting