15:15:18 <mpiwowarczy> #startmeeting trove
15:15:19 <openstack> Meeting started Wed Oct 31 15:15:18 2018 UTC and is due to finish in 60 minutes. The chair is mpiwowarczy. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:15:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:15:22 <openstack> The meeting name has been set to 'trove'
15:15:24 <mpiwowarczy> #topic roll call
15:15:34 <mpiwowarczy> hi folks!
15:15:42 <cezary_zukowski> hi
15:15:45 <bzurkowski> Hello everyone
15:16:03 <dkrol> hello :)
15:16:18 <mpiwowarczy> there was some confusion due to change local time, let's do meeting now
15:16:38 <mpiwowarczy> we have free room until 16:00 UTC
15:16:46 <dkrol> ok, I believe we don't need to wait for others as we already changed the meeting time :)
15:17:11 <mpiwowarczy> dkrol: you're right
15:17:15 <dkrol> #topic python3 support
15:17:16 <mpiwowarczy> lets start
15:17:30 <mpiwowarczy> #topic Python 3 first support
15:17:37 <dkrol> mpiwowarczy: can you give some update about it ?
15:17:57 <mpiwowarczy> yes
15:18:42 <mpiwowarczy> goals for trove are updated in etherpad
15:18:42 <mpiwowarczy> https://etherpad.openstack.org/p/trove-python-3
15:18:56 <dkrol> #link https://etherpad.openstack.org/p/trove-python-3
15:19:42 <bzurkowski> Looks promising
15:19:47 <bzurkowski> Great progress
15:19:55 <dkrol> mpiwowarczy: Looks great
15:19:57 <mpiwowarczy> there are few changes related to functional test goal which is last point (except wiki page update)
15:20:09 <dkrol> [ ] The wiki tracking page is up to date for the project. - this should be a quick one
15:20:51 <dkrol> I assume functional tests are block by my trovestack redesign task ?
15:21:23 <mpiwowarczy> they are not blocked
15:21:35 <bzurkowski> dkrol: Tempest is blocked
15:21:51 <mpiwowarczy> there is used old method of building images which is working fine
15:22:21 <dkrol> bzurkowski: I know but this is a different story :)
15:22:40 <dkrol> mpiwowarczy: so what do we need to check this one ?
15:22:47 <mpiwowarczy> summarizing - I hope in current or another week we will have all trove python3 goals closed
15:23:42 <cezary_zukowski> mpiwowarczy: how to interpret "[na]"? or just ignore?
15:23:51 <mpiwowarczy> I see two depended changes has beed reviowed by bzurkowski https://review.openstack.org/#/c/613756/ https://review.openstack.org/#/c/614196/
15:24:36 <mpiwowarczy> cezary_zukowski: ignore as it not exist for project
15:24:47 <cezary_zukowski> okay, thx
15:25:44 <mpiwowarczy> when these two changes will be merged, tests from trove changes should be passed https://review.openstack.org/#/c/604816/
15:26:06 <dkrol> ok, great
15:26:28 <dkrol> we still have about 2 weeks to openstack summit where it would be a nice success story
15:26:29 <mpiwowarczy> please for review once there will be +1 set by zuul
15:27:06 <mpiwowarczy> dkrol: I agree
15:28:34 <cezary_zukowski> yeah, a rewarding work, congrats
15:28:35 <mpiwowarczy> ok, that is all from me about python3-first goals
15:29:06 <mpiwowarczy> lets move on
15:29:21 <dkrol> yes, let's move on
15:29:46 <mpiwowarczy> #topic Trovestack redesign
15:30:23 <mpiwowarczy> any update on this matter?
15:30:29 <dkrol> regarding this task it is still on the same state as last week :/
15:30:55 <dkrol> however I have a working environment and I'm testing the code right now
15:31:29 <mpiwowarczy> dkrol: do you need any help or something? :)
15:31:59 <dkrol> I hope the change regarding instance/replica creating timeout will fix tests
15:32:28 <mpiwowarczy> fingers crossed :)
15:32:35 <dkrol> I just need a stable environment and time :)
15:32:46 <cezary_zukowski> yeah, crossed :)
15:33:07 <dkrol> I think we could upstream our Vagrantfile
15:33:16 <dkrol> for trove
15:33:37 <dkrol> mpiwowarczy: this is your work so you should do it
15:33:48 <dkrol> but this is a nice thing to have as a new developer
15:34:53 <mpiwowarczy> dkrol: for now it is very basic version
15:35:15 <mpiwowarczy> but having Vagrantfile for trove env is good idea
15:35:31 <dkrol> yes, but with a simple command 'vagrant up' you can have a working environment :)
15:35:40 <dkrol> for development
15:36:11 <dkrol> better to have something than nothing - just saying
15:36:16 <dkrol> please think about it
15:36:26 <dkrol> we will have a trove onboarding session
15:36:41 <dkrol> and this could be a nice element to talk about
15:36:46 <mpiwowarczy> dkrol: I will consider this
15:36:57 <cezary_zukowski> dkrol: hmm... okay, we can consider that
15:37:17 <mpiwowarczy> we would need to create any documentation aboud this additionally
15:37:35 <mpiwowarczy> but I will keep this in mind
15:38:04 <dkrol> please do :)
15:38:19 <dkrol> I think we can move on
15:39:04 <mpiwowarczy> #action Consider using Vagrant for trove development environment
15:39:22 <mpiwowarczy> #topic Documentation
15:40:17 <cezary_zukowski> ok, in this matter, I sent my work to dkrol via e-mail, do not know if anybody has time to examine it :)
15:40:18 <mpiwowarczy> cezary_zukowski: you worked on it, would you like to say something?
15:40:46 <mpiwowarczy> hmm
15:41:18 <mpiwowarczy> not yet
15:41:35 <cezary_zukowski> but okay, that's no urgent. Besides, I started writing my own guide: https://etherpad.openstack.org/p/trove-build-guest-images-from-scratch-guide - will fill step-by-step the content
15:43:00 <cezary_zukowski> it should start with DIB lesson definitely as building Trove Guest Images relies on it
15:43:41 <mpiwowarczy> yes, it is definitely one of most important parts of documentation
15:43:48 <cezary_zukowski> and next week I should finally obtain access and should push changes to official repo
15:44:25 <mpiwowarczy> sound great
15:44:48 <mpiwowarczy> one it will appear in gerrit we will be able to share ideas and suggestions
15:45:16 <cezary_zukowski> yeah, otherwise it's just work in progress :)
15:45:48 <mpiwowarczy> ok, thanks for an update :)
15:45:52 <cezary_zukowski> :)
15:47:14 <mpiwowarczy> ok, has someone any other topics for today?
15:47:34 <cezary_zukowski> don't thing so
15:47:37 <cezary_zukowski> think*
15:48:06 <dkrol> how about openstack summit preparation ?
15:48:14 <dkrol> are we on track with presentations and demo ?
15:49:01 <cezary_zukowski> in my case, I got some materials from bzurkowski, so I am on right track, but have to discuss with team next week
15:49:46 <bzurkowski> Presentation draft for main session is almost ready
15:49:53 <bzurkowski> Regarding demo... It's hell
15:50:27 <cezary_zukowski> Preparing live demo or overall?
15:50:31 <bzurkowski> Demo
15:50:42 <bzurkowski> Wrapping Devstack with all required services (Monasca, Vitrage, Trove etc.) is hard
15:50:50 <bzurkowski> Trying not to say "impossible"
15:51:29 <bzurkowski> Monasca creates most of the problems
15:51:35 <dkrol> understood
15:51:50 <bzurkowski> Now trying with Kolla
15:52:08 <mpiwowarczy> maybe we can touch Monasca team folks?
15:52:23 <bzurkowski> We could
15:52:26 <bzurkowski> If there are any
15:52:30 <dkrol> enable_plugin monasca doesn't work ?
15:52:55 <bzurkowski> dkrol: Brilliant! :D
15:53:14 <bzurkowski> It doesnt work as expected
15:53:42 <dkrol> no way :)
15:53:54 <bzurkowski> There are errors in Horizon
15:53:58 <bzurkowski> Not only from Monasca
15:54:04 <bzurkowski> Also Heat dashboard is broken
15:54:08 <dkrol> we should reach out on an irc channel
15:54:22 <dkrol> or maybe you could try rocky version ?
15:54:34 <bzurkowski> I tried upstream and rocky
15:54:36 <cezary_zukowski> #openstack-monasca
15:55:33 <bzurkowski> Let's catch Monasca folks during weekly
15:55:36 <bzurkowski> :)
15:56:45 <dkrol> ok
15:56:54 <dkrol> I believe we ran out of time
15:57:11 <mpiwowarczy> dkrol: yes
15:57:23 <mpiwowarczy> thanks for participating today
15:57:26 <bzurkowski> Thank you and bye
15:57:30 <mpiwowarczy> keep in mind in the next week we will start at 15:00 CST :)
15:57:36 <cezary_zukowski> yeah, many thanks for being here :)
15:57:41 <mpiwowarczy> o/
15:57:51 <mpiwowarczy> #endmeeting